k3b író

Fórum: 

A probléma a következő: immáron 64 bites linux mint 19 "tara" verzió fut a gépen és egy ismerősöm megkért, hogy írjak egy audio cd-t. Eddig mindig k3b progit használtam és már írtam is pont ugyanennek az ismerősömnek is gond nélkül. Most valami nem akar működni amikor írni akarok. Kérnék tippeket, tanácsokat, amit előre is köszönök. Képernyőkép mellékelve, hogy mit ír ki: https://ibb.co/3p7LX9S

kimarite képe

Device settings

Először a DVD vagy CD eszközt kell beállítani. Ez valahol ott van a menükben, és elég régen kellett ilyet, de a hibaüzenet ezt jelzi, nincs jogod az eszköz használatára (cdrecord has no permission to open the device > modify device settings in K3b to solve this problem).

Nincs most telepítve a k3b, ennyit tudok ... https://www.youtube.com/watch?v=qC4BIQWWnIA

Értékelés: 

0
Még nincs értékelve
kimarite képe

Device settings

#1 Én grafikus megoldásra emlékszem, de nézzük, mi a parancs kimenete:

ls -la /usr/bin/wodim

Azért nézz körül a garfikus beállításokban is. :-)

Értékelés: 

0
Még nincs értékelve

Device settings

#2 Ennyi:

ls -la /usr/bin/wodim
-rwxr-xr-x 1 root root 454376 ápr   21  2017

Értékelés: 

0
Még nincs értékelve
kimarite képe

Device settings

#3 Szia, először próbáld a K3b-t terminálban, így indítva írni

env $(dbus-launch) k3b

A parancsor kimenet kéne (a terminált ne zárd be), illetve nyomd meg a képen látható  „Show debugging output” elemet és mutasd a szöveget, illetve másolni jobb lenne ez is. Azaz a parancs kimenetet és a debug információkat másold be ide, válaszba.

Ha nem megy a fenti módszerrel (de az első teszt eredményét mindenképpen másold ide, mert azokból derül ki, mi a hiba pontosan!), zárd be a K3b-t és a terminált is, és futtasd ezt a parancssort:

sudo chown root:cdrom /usr/bin/wodim

Majd tesztelj. A szokásos, menüből történő indítással.

Értékelés: 

0
Még nincs értékelve

Device settings

#4 Show debugging output kimenet:

https://paste.ubuntu.com/p/wXswtsSkSD/

env $(dbus-launch) k3b re meg ezt adta a terminál:

https://paste.ubuntu.com/p/NsFPhbtkBp/

Értékelés: 

0
Még nincs értékelve

sudo chown root:cdrom /usr

sudo chown root:cdrom /usr/bin/wodim

futtattam, indítottam ahogy írtad grafikus módban a progit, az eredmény változatlan lett.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Device settings

#5 #6 Biztos üres a lemez, amit betettél?

(K3b::Device::DeviceManager) request for empty device!

Habár üresnek látszik:

found medium: ( "/dev/sr0" ) 
=====================================================
DiskInfo: 
Mediatype:        "CD-R" 
Current Profile:  "CD-R" 
Disk state:       empty 
Empty:            true 
Rewritable:       false 
Appendable:       false 
Sessions:         0 
Tracks:           0 
Layers:           1 
Capacity:         "79:57:71"  (LBA  359846 ) ( 736964608  Bytes) 
Remaining size:   "79:57:71"  (LBA  359846 ) ( 736964608  Bytes) 
Used Size:        "00:00:00"  (LBA  0 ) ( 0  Bytes) 

A teszthez használj újraírható lemezt, ha van, persze.

-----

A DBus indítás nem vált be...

Parancs kimenetek?

groups $USER
ls -la /usr/bin/wodim /usr/bin/cdrecord /usr/bin/genisoimage
ls -la /dev/sr0
wodim dev=/dev/sr0 --scanbus

Értékelés: 

0
Még nincs értékelve

Device settings

#7 Teljesen biztos, hogy üres, mielőtt betettem bontottam ki.

A többi kimenetek: https://paste.ubuntu.com/p/BnQbQJJmhq/

Értékelés: 

0
Még nincs értékelve

Nincs semmi kimenete a wodim

Nincs semmi kimenete a wodim parancsnak, nem tudom ez normális-e, mindenesetre futtattam, utána próbáltam, sajnos eredmény nélkül.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nincs semmi kimenete a wodim

#10 Normális, ha nincs kimenet. A kimenet hiba ilyen esetben.

Egy rendszer újraindítással még megpróbálkozhatunk.

Ha nem javul...

Mivel látatlanban próbálkozunk, kéne mutatnod egy hasonló fotót:
(https://www.kubuntuforums.net/showthread.php/72439-K3B-Won-t-Write-Permi...)
Az Imgur, imgBB, Mega, Dropbox, Google segítségével mutasd. Valamelyik. Link elegendő.

Settings->Configure K3b->Programs->Permissions

Illetve megkérlek arra is, hogy egy másik alkalmazással nézzünk rá az íróra most. Mert azzal is lehet gond.

XfBurn

sudo apt-get install xfburn

Próbálj adatot írni vele. Ha megy, akkor a K3b-t kell javítani, a DVD íróval nincs gond...

Értékelés: 

0
Még nincs értékelve

Nincs semmi kimenete a wodim

#11

https://ibb.co/1JWxZyv

Aztán:

xfburn felment, próbáltam .doc fájlt kiírni, ugyanaz az eredmény, vagyis hibajelzés. Viszont abból ítélve amit írtál, az íróval van valami gond? Mert alig egy héttel azelőtt, hogy 64 bitre frissítettem, írtam vele cd-t?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Zavar a mátrixban? Hang-CD vagy Új adat-összeállítás

#12 Az mp3 fájlokat szeretted vonal kiírni, most mi ez a dokumentum kiírási kísérlet? A dokumentum Új adat-összeállítás lenne. Ha az mp3 fájlokat nem zenei CD-ként írod, hanem mp3 fájlokként akkor is ezt kell választanod.

Az XfBurnben a zenei CD írásához válaszd a Hang-CD lehetőséget, másold be az mp3 fájlokat, majd lépj tovább az írásra. Itt mi a hibaüzenet?

Nem egy bonyolult ügy.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Zavar a mátrixban? Hang-CD vagy Új adat-összeállítás

#13 írjak egy audio cd-t. Eddig mindig k3b progit használtam és már írtam is pont ugyanennek az ismerősömnek is gond nélkül. Most valami nem akar működni amikor írni akarok. Kérnék tippeket, tanácsokat, amit előre is köszönök. Képernyőkép mellékelve, hogy mit ír ki

Oké, látom, hogy írtál ki audio CD-t, de a dokumentum kiírás más kategőria.

xfburn felment, próbáltam .doc fájlt kiírni, ugyanaz az eredmény, vagyis hibajelzés.

Hibajelzés sokféle lehet, ez pontosan mi volt?

Viszont abból ítélve amit írtál, az íróval van valami gond? Mert alig egy héttel azelőtt, hogy 64 bitre frissítettem, írtam vele cd-t?

Előfordulhat ez is.

Mit csináltál egészen pontosan? 64 bitre frssítettél? Talán inkább telepítettél egy 64 bites rendszert, Sajnos, nem emlékszem mindenre, ami egy-egy felhasználóval megtörtént és esetleg foglalkoztam is a témával.
https://linuxmint.hu/comment/35414#comment-35414

Tehát a K3b korábban, egy 32 bites rendszeren jó működött, de 64 bites rendszeren ez lett volna az első próba, és ez nem sikerült?

Értékelés: 

0
Még nincs értékelve

Zavar a mátrixban? Hang-CD vagy Új adat-összeállítás

#14 Bocsánat, igazad van, rosszul fejeztem ki magam, javítok: telepítettem 64 bites rendszert. Kérdésedre meg a válaszom, hogy igen, 64 biten ez volt az első próba, ami sikertelen lett. Másik felvetésre, hogy adat összeállítás, arra annyit tudok mondani, hogy azt sem először csináltam most, viszont elkövettem azt a hibát, hogy nem gondoltam arra, hogy másféle hibajelzés jöhet, mint azt megelőzően, így nem mentettem ki a hibajelzést, elnézést érte. Most már ezt nem is fogom megtenni, mivel az xfburn megírta a kívánt cd-t :) . Így ebben a felállásban szerintem megoldottnak tekinthetjük a problémát. Konklúzió részemről, hogy valami a k3b progival nem stimmelős, majd ha lesz időm próbálok mazsolázni leírásokban róla. De itt van az xfburn, amiről eddig nem tudtam, hogy létezik, viszont megoldotta nekem amit kellett. Maximális köszönetem a sok segítségért!

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezek adathordozó nélkül

#12 Mindent úgy kéne próbálni, hogy lemez nincs betéve. Vedd ki az adathordozót és utána indítsd a k3B-t.

https://ibb.co/1JWxZyv

Nyomj az Alkalmaz rádió gombra.
Mutasd, mi változott. És az is érdekes lehet, hogy jogot kapsz-e erre.

Nyomj az Alapértelmezések visszaállítása rádiógombra.
Mutasd, mi változott. És az is érdekes lehet, hogy jogot kapsz-e erre.

A growisofs sor fura, nincs használva. Régebben is ez a jelenség volt. Lehetséges, azért, mert a kép elkészítesekor be volt téve egy adathordozó, és úgy indítottad el az alkalmazást.

-----

Ez egy másféle próba

Amikor parancsot futtatsz, be kell zárnod a K3b-t. És minden más lemez író alkalmazást is. Az első parancs futtatása után az XfBurn vélhetően megjavul (visszaadjuk a root csoportnak), de most ne foglalkozz ezzel, lépj tovább  második parancsra.

sudo chown root:root /usr/bin/wodim
sudo chmod 0755 /usr/bin/growisofs /usr/bin/wodim /usr/bin/cdrdao

A parancs kimenet kéne (a parancsok futtaása után azonnal! Ne lépj tovább.):

ls -l /usr/bin/growisofs /usr/bin/wodim /usr/bin/cdrdao

Itt is kép kéne, mi változott, ehhez képest: https://ibb.co/1JWxZyv

És miután futtattad a parancsokat, nyisd meg a k3B-t (adathordozót még mindig ne tegyél be), a Permissions oszlopban vélhetően 0755 fog látszani mindhárom helyen, a New Permissions oszlopban előfordulhat más is. Nyomj az Alkalmaz rádió gombra, és esetleg a Refresh rádiógombra is, és mutasd képen, mi történt. A beállítás alkalmazásának hatására a New Permissions oszlopban is 0755-nek kéne látszódnia.

-----

Még az a kérdésem lenne, hogy az adathordozó CD vagy DVD?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezek adathordozó nélkül

#16 A Device fülön
https://ibb.co/1JWxZyv
rá lehet kerestetni a DVR-ROM-ra?

Értékelés: 

0
Még nincs értékelve

Mindezek adathordozó nélkül

#16 Sorba megyek azon, amit írtál.

1: simán alkalmazra nyomva nem történt semmi

2: alapértelmezések visszaállításra nyomva nem történt semmi.

3:

sudo chmod 0755 /usr/bin/growisofs /usr/bin/wodim /usr/bin/cdrdao futtatása utáni változás: semmi

4:

ls -l /usr/bin/growisofs /usr/bin/wodim /usr/bin/cdrdao kimenete: https://paste.ubuntu.com/p/pVpxkT3XFr/

5: végigmentem minden lépésen, volt alkalmaz és refresh gomb is nyomva, eredmény:

https://ibb.co/0V9jf4h

És kérdésedre válaszolva cd az amiről szó van, volt.

6: device fülön ezt adja:

 
https://ibb.co/M85zZdC

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezek adathordozó nélkül

#18 Tényleg semmi változás.

De jónak tűnik maga a beállítás. Telepítettem a K3b-t, és kicsit bővebben, de ugyanígy van:

0755 root:root | 4711 root:root

A growisofs mellett ugyanúgy nincs kijelölőnégyzet, és ez is ugyanaz:

0755 root:root | no change

A Programs fülön mindezek megtaláltnak jelölve.

A MIsc beállításoknál nézd meg, mi a Default Temporary Directory, majd nézzük meg a jogosultságokat arra a könyvtárra, ami nálad szerepel.

ls -la /ami/nálad/könyvtár

Az én beállításaimnál minden rendben (Videók), saját tulajdonban van minden:

ls -la /home/debkim/Videók
összesen 12
drwxr-xr-x  3 debkim debkim 4096 márc  31 23:17 .
drwxr-xr-x 22 debkim debkim 4096 ápr    2 10:48 ..
drwx------  2 debkim debkim 4096 márc  31 23:17 AnyDesk

Ez is ugyanaz (-rwxr-xr-x), mint nálad: https://paste.ubuntu.com/p/pVpxkT3XFr/

ls -l /usr/bin/growisofs /usr/bin/wodim /usr/bin/cdrdao
-rwxr-xr-x 1 root root 645352 júl   11  2018 /usr/bin/cdrdao
-rwxr-xr-x 1 root root 121840 dec   12  2018 /usr/bin/growisofs
-rwxr-xr-x 1 root root 443096 júl   22  2014 /usr/bin/wodim

Írni nem próbáltam.

A DVD_ROM felismerése itt is rendben lévőnek látszik: https://ibb.co/M85zZdC
A hivatkozásokat ne formázd meg, ha kérhetlek.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezek adathordozó nélkül

#19 Nekem csak újraírható lemezem van. Kiírtam pár mp3 fájlt.
A Simulate mód törölte - a nem üres - lemezt és hiba nélkül lefutott.
Élesben sikeres lemezírás, az AUDIO lemezt az Audacious lejátssza,

Devices
-----------------------
hp CDDVDW SU-208BB HH01 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7]

System
-----------------------
K3b Version: 18.8.1
KDE Version: 5.49.0
Qt Version:  5.11.3
Kernel:      4.19.0-8-amd64

Used versions
-----------------------
cdrecord: 1.1.11

cdrecord
-----------------------
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.11
SCSI buffer size: 64512
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.

...

Track 05: Total bytes read/written: 51720480/51720480 (21990 sectors).
Writing  time:  161.644s
Average write speed  10.0x.
Min drive buffer fill was 69%
Fixating...
Fixating time:   18.786s
/usr/bin/wodim: fifo had 3807 puts and 3807 gets.
/usr/bin/wodim: fifo was 0 times empty and 1770 times full, min fill was 97%.
BURN-Free was never needed.

cdrecord command:
-----------------------
/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=10 -sao driveropts=burnfree textfile=/tmp/k3b.iWuKIn -useinfo -audio /home/debkim/Videók/k3b_audio_0_01.inf /home/debkim/Videók/k3b_audio_0_02.inf /home/debkim/Videók/k3b_audio_0_03.inf /home/debkim/Videók/k3b_audio_0_04.inf /home/debkim/Videók/k3b_audio_0_05.inf

Értékelés: 

0
Még nincs értékelve
kimarite képe

New Data Projects | Show Debugging Output

#20 Most három fájlt írtam a lemezre: egy PDF, egy TXT, és egy CSS fájlt. Adat mód: New Data Projects .
Az alap beállításokon nem változtatttam. A kíírás sikerült. Persze, kicsit más az RW (újraírható), mint az R (egyszer írható) lemez. A Show Debugging Output (rövidítve, mint az előző is):

K3b::IsoImager
-----------------------
mkisofs print size result: 1535 (3143680 bytes)
...
Track 01: Total bytes read/written: 3143680/3143680 (1535 sectors).

Writing time: 7.257s
Average write speed 2.8x.
Min drive buffer fill was 99%
Fixating...
Fixating time: 32.657s
/usr/bin/wodim: fifo had 50 puts and 50 gets.
/usr/bin/wodim: fifo was 0 times empty and 0 times full, min fill was 100%.
BURN-Free was never needed.

cdrecord command:
-----------------------
/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=10 -tao driveropts=burnfree -multi -xa -tsize=1535s -

mkisofs
-----------------------
1535
I: -input-charset not specified, using utf-8 (detected in locale settings)
33.29% done, estimate finish Thu Apr 2 14:03:21 2020
65.60% done, estimate finish Thu Apr 2 14:03:21 2020
Total translation table size: 0
Total rockridge attributes bytes: 425
Total directory bytes: 642
Path table size(bytes): 10
Max brk space used 0
1535 extents written (2 MB)

mkisofs calculate size command:
-----------------------
/usr/bin/genisoimage -gui -graft-points -print-size -quiet -volid K3b data project -volset -appid K3B THE CD KREATOR (C) 1998-2017 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.ooxwbs -rational-rock -hide-list /tmp/k3b.RiVEGi -joliet -joliet-long -hide-joliet-list /tmp/k3b.BLYmWT -no-cache-inodes -full-iso9660-filenames -iso-level 3 -path-list /tmp/k3b.sXARIk

mkisofs command:
-----------------------
/usr/bin/genisoimage -gui -graft-points -volid K3b data project -volset -appid K3B THE CD KREATOR (C) 1998-2017 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.VXodZH -rational-rock -hide-list /tmp/k3b.hhyUSD -joliet -joliet-long -hide-joliet-list /tmp/k3b.gZKoNA -no-cache-inodes -full-iso9660-filenames -iso-level 3 -path-list /tmp/k3b.oRBBCU

Értékelés: 

0
Még nincs értékelve

Mindezek adathordozó nélkül

#19

https://ibb.co/R6kq0JV 

Remélem mindent jól csináltam: https://paste.ubuntu.com/p/XJ3NKtghv6/

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezek adathordozó nélkül

#22 Itt a gond!

A megoldás

Szépen átteszed ezt a „/tmp” beállítást saját könyvtárad alá, mondjuk, a „Publikus” könyvtárra.
Ja, nincs neked ilyen. Akkor csináld ezt:

cd
mkdir tmp

...ezzel, a saját könyvtárad alatt létrehozol egy tmp nevű könyvtárat.
Majd beállítod: a K3b alkalmazásban a MIsc beállításoknál, a Default Temporary Directory beállítása legyen ezen az elérési úton:

/home/kisscsalad/tmp

-----

Tájékoztatás

A beállítás most: /tmp
Ez egy rendszerkönyvtár! Jogod nincs hozzá úgy igazán.

Különben látnád is, ha nem rossz parancssort futtatnál (ami ez volt),

ls -la /home/kisscsalad

hanem, amit kértem, ami a képen (be is teszem, mert ez a probléma)

könyvtárként szerepel. És ez lett volna a kutakodás:

ls -la /tmp

Értékelés: 

0
Még nincs értékelve

Újratelepítettem az egész

Újratelepítettem az egész rendszert, mert zavart ez az állapot. Újra feltettem a k3b-t is és jött egy információs ablak amiben ez olvasható: https://paste.ubuntu.com/p/3K6XxQMdNF/

Mit kell tennem, mert ezek szerint a megoldás egyszerű (lenne, ha tudnám mi a csudát kell és hogyan telepítenem)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Újratelepítettem az egész

#25 Leírtam a megoldást, a most látható /tmp helyett mi kell.
Leírom még egyszer: a /tmp-ről
Ez egy rendszerkönyvtár, nem a saját könyvtáradban van.
Ez nem csak egy könyvtár, hanem a tmp könvtár és az elérési út egyben.
A / karakter a különbség. A / a gyökér könyvtár. Meg persze, más is... .
Ha a rendszerkönyvtár: /tmp
Ha a saját könyvtárad alatt van, elérési úttal, ahogy kell neked: /home/$USER/tmp
$USER = felhasználóneved
Nyisd meg a fájlkezelőt, és ott, ahol nyílik (saját könyvtárba szokott), hozz létre egy tmp nevű könyvtárat.

Példa

Ahogy most van beállítva a K3b, az elérési út a /tmp
(pwd parancs mutatja az ekérési utat)

debkim@debkim:~$ cd /
debkim@debkim:/$ pwd
/
debkim@debkim:/$ ls -l | grep tmp
drwxrwxrwt  20 root root  4096 ápr    2 17:05 tmp
debkim@debkim:/$

Tulajdonos: root (!)

-----

Ami kell neked, elérési út a /home/$USER/tmp:

debkim@debkim:/$ cd
debkim@debkim:~$ mkdir tmp # készítettem egy tmp könyvtárat
debkim@debkim:~$ pwd
/home/debkim # itt vagy, és benne a tmp könyvtár:
debkim@debkim:~$ ls -l | grep tmp
drwxr-xr-x 2 debkim debkim  4096 ápr    2 18:17 tmp 
debkim@debkim:~$

Tulajdonos te vagy, a felhasználó.

Olvasd el még egyszer a mai hozzászólásaim.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Újratelepítettem az egész

#27 -- megnyitod  fájlkezelőt
-- létrehozol egy tmp nevű könyvtárat
-- mindez így fog kinézni a K3b beállításokban

...felhasználónév más lesz. Nálad most ez lesz a beillesztendő sor

/home/kisscsalad/tmp

-- Alkalmaz > OK

-- teszteled az írást.

-----

#25 Vélhetően a GStreamer BAD csomagról van szó. Így telepíted:

sudo apt-get install gstreamer1.0-plugins-bad

Azért hiányozhat, mert a mostani telepítésnél kihagyhattad a külső féltől származó forrásokat, azok telepítését nem kérted a Linux Mint telepítőtől.

Értékelés: 

0
Még nincs értékelve

Újratelepítettem az egész

#28 Megcsináltam mindent, amit írtál, mutatom mire jutottam:

Létrehoztam a könyvtárat: https://ibb.co/gF6m5Kc

Megcsináltam a beállításokat: https://ibb.co/Lv42783

Megcsináltam a telepítést, ezt írta ki: https://paste.ubuntu.com/p/5W6ZKFXPcQ/

Az eredmény mégis ez írás próbánál: https://ibb.co/bFHxRkw

Mit tehetnék még?

 

Értékelés: 

0
Még nincs értékelve

Ubuntu fórumon böngészve

Ubuntu fórumon böngészve találtam, szoda nevű felhasználó írta:

Fontos, hogy a k3b-hez telepíteni kell a libk3b2-extracodecs és a libk3b3-extracodecs csomagot is, ha szeretnénk mp3-ból audio CD-t készíteni. Nem mondom, hogy gyakori funkció, de én már belefutottam egyszer, és elsőre nem is értettem, miért nem akarja tenni a dolgát, míg meg nem lett ez a csomag.

Nem tudom ez lehetne megoldás? Ha igen, kérnék instrukciót, hogy mit kell tennem.

Értékelés: 

0
Még nincs értékelve
kimarite képe

libk3b7-extracodecs

#29 És amikor kiválasztottad

/home/kisscsalad/tmp

utána megnyomtad az Alkalmaz és az OK elemeket?
Ellenőrzés: ha most megnyitod a beállításokat, maradandóan ott kell lennie:

/home/kisscsalad/tmp

#30 Megoldás lehet. Rákerestem a neten,
https://packages.ubuntu.com/search?suite=default&section=all&arch=any&ke...
újabb verzió telepíthető. Telepítsd, nem vesztesz ezzel semmit:

sudo apt-get install libk3b7-extracodecs

Ám, szerintem telepítve van, mert én is annyit csináltam,
(az alany: Debian)

sudo apt-get install k3b

és az Extra Kodekek telepítve. Nézz rá, semmi perc.

apt-cache policy libk3b7-extracodecs
libk3b7-extracodecs:
  Telepítve: 18.08.1-1
  Jelölt:    18.08.1-1
  Verziótáblázat:
 *** 18.08.1-1 500
        500 http://httpredir.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

KDE CD/DVD burning application library - extra decoders

De például a Mint saját kodek csomagja telepítve van-e? Nézzünk rá:

sudo apt-get install mint-meta-codecs

-----

Én értem ezt,

de nagy probléma lenne beszerezni egy-egy újraírható CD-RW és DVD-RW lemezt, és ezekkel is ránézni? Ki kéne próbálni.

-----

A BIOS-ban nem lett átállítva valami a közelmúltban?
Az író kábelei nem lazák? Ha beteszel egy adahordozót, azt és annak tartamát olvassa a Linux Mint 19?
Például beteszel lemezen valami zenét, filmet, és megpróbálod lejátszani: Audacious, VLC, SMPlayer, stb..

Értékelés: 

0
Még nincs értékelve
kimarite képe

libk3b7-extracodecs | az XfBurn jól működik (megoldva)

#31 ...csak, mert gyanús az író. Írod, XfBurn is hibára fut, pedig nem szokott.

Ha van régi RW-s CD lemez, aminek nem fontos a tartalma, így tudod törölni:

/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=4 -tao driveropts=burnfree blank=fast

Nálam sikerült így is.

----

#15 Mintha az lett volna, az Xfburn (is) hibára fut, visszakerestem és tényleg, volt olyan is.
A K3b a problémás még?

Egyszerre írtunk nagyjából, ezt a hozzászólást viszont nem láttam:

Bocsánat, igazad van, rosszul fejeztem ki magam, javítok: telepítettem 64 bites rendszert. Kérdésedre meg a válaszom, hogy igen, 64 biten ez volt az első próba, ami sikertelen lett. Másik felvetésre, hogy adat összeállítás, arra annyit tudok mondani, hogy azt sem először csináltam most, viszont elkövettem azt a hibát, hogy nem gondoltam arra, hogy másféle hibajelzés jöhet, mint azt megelőzően, így nem mentettem ki a hibajelzést, elnézést érte. Most már ezt nem is fogom megtenni, mivel az xfburn megírta a kívánt cd-t :) . Így ebben a felállásban szerintem megoldottnak tekinthetjük a problémát. Konklúzió részemről, hogy valami a k3b progival nem stimmelős, majd ha lesz időm próbálok mazsolázni leírásokban róla. De itt van az xfburn, amiről eddig nem tudtam, hogy létezik, viszont megoldotta nekem amit kellett.

Akkor ezt tudod használni írásra. :-)
És az íróval semmi gond. Probléma a K3b alkalmazással van. Nézz rá, amit az imént írtam, megmaradt-e a /home/$USER/tmp beállítás.

Értékelés: 

0
Még nincs értékelve

libk3b7-extracodecs

#31 Ismét sorban megyek:

Megnyomtam alkalmaz, ok gombokat és maradandóan van helyén.

Az első parancssorral telepítést végzett a terminál, ennek ellenére nem történt változás az írás próbájánál.

A második parancssorra a válasz: https://paste.ubuntu.com/p/nqR4H6Pkdh/

Elég nagy gond beszerezni itt újraírható lemezt a mostani felfokozott helyzetben, mert kis település, sokszor annak is örülök ha van egyáltalán lemez. Eljutni most nagyobb városba elég körülményes.

Bioshoz nem piszkáltam semmit.

Adathordozót többfélét is próbáltam, gond nélkül felismer mindent.

Adat: https://ibb.co/VvKkHtg

Hang: https://ibb.co/cwzyZ0R

DVD: https://ibb.co/0r6Tb4Q

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai

#33 Rendben.

Még valami: http://ubuntu.hu/node/25235#comment-266934

Futtasd a Súgó ▹ A rendszer ellenőrzése pontot.

Mit mond?

-----

Ilyen beállítás már nincs (nálam). Mert a KDE nem 4-es, hanem 5-ös, és itt máshogyan oldották meg.

A K3b rossz konfigurációja. Töröld a felhasználói beállításokat. (~/.kde4/share/apps/k3b könyvtár törlése és a ~/.kde4/share/config/k3brc fájl törlése.) Miután törölted, a K3b alapértelmezett beállításokkal fog indulni.

A k3brc jelenleg a kiemelt helyen van, amit átnevezhetsz a következő parancssor futtatásával, így alapra áll a K3b (ami be kell legyen zárva a futtatás idejére)

mv /home/kisscsalad/.config/k3brc /home/kisscsalad/.config/k3brc.ORIG

Ez egy próba lenne.

Az említett k3b könyvtár az /usr/share/apps/ elérési út alatt sem található meg. Megszűnt.

-----

A teljesen magyar menü:

sudo apt-get install k3b-i18n

Értékelés: 

0
Még nincs értékelve
kimarite képe

k3brc

#34 De meg is mutathatod, mi van benne (pasztázva).

/home/kisscsalad/.config/k3brc

Összehasonlítom az enyémmel.

Értékelés: 

0
Még nincs értékelve

Hiba okai

#34 rendszer ellenőrzése gombra semmit nem csinál (furcsa, de mintha nem is nyomkodnék neki semmit)

(~/.kde4/share/apps/k3b könyvtár törlése és a ~/.kde4/share/config/k3brc fájl törlése. Ezt hogy tudom megtenni?

mv /home/kisscsalad/.config/k3brc /home/kisscsalad/.config/k3brc.ORIG lefuttatva, eredmény nincs, illetve íráspróba esetén változatlan minden.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai

#36 Töltsd fel az Ubuntu Pastebinre a k3brc tartalmát.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai

#38 Fájlkezelő > megkeresed > megnyitod

Nem parancs, hanem elérési út, azért dőlt karakter.

Olvasása máshogyan (két módszer)

xdg-open /home/kisscsalad/.config/k3brc
cat /home/kisscsalad/.config/k3brc

(pasztázva)

-----

Ezeket kéne nézni (itt kellenek a kimenetek):

wodim -prcap
ulimit -l
ls -la /dev/sr0

A fájl tartalma kéne. Így nyitva:

xdg-open /etc/wodim.conf

...nézzük ezeket is:

file /usr/bin/cdrecord
ls -la /usr/bin/wodim /usr/bin/cdrecord /usr/bin/genisoimage

Csak azért, mert más az „elképzelés”, ezeket is...

Linux Mint 19 Tara (nálad: https://paste.ubuntu.com/p/BnQbQJJmhq/)

ls -la /usr/bin/wodim /usr/bin/cdrecord /usr/bin/genisoimage
lrwxrwxrwx 1 root root       5 ápr   21  2017 /usr/bin/cdrecord -> wodim
-rwxr-xr-x 1 root root  644856 ápr   21  2017 /usr/bin/genisoimage
-rwxr-xr-x 1 root cdrom 454376 ápr   21  2017 /usr/bin/wodim

Debian 10 (nálam):

ls -la /usr/bin/wodim /usr/bin/cdrecord /usr/bin/genisoimage
ls: '/usr/bin/cdrecord' nem érhető el: Nincs ilyen fájl vagy könyvtár
-rwxr-xr-x 1 root root 633864 júl   22  2014 /usr/bin/genisoimage
-rwxr-xr-x 1 root root 443096 júl   22  2014 /usr/bin/wodim

K3b error: Cdrecord has no permission to open the device”
Incidentally, k3b used to use cdrecord but now uses wodim; the error message is out-of-date (?)
https://help.ubuntu.com/community/K3b
Nem úgy tűnik, hogy minden egyben van.

-----

Jegyzet: https://bugs.launchpad.net/ubuntu/+source/cdrkit/+bug/1769848

Értékelés: 

0
Még nincs értékelve

Hiba okai

#39 Ok, megyek ismét sorban

xdg-open /home/kisscsalad/.config/k3brc : https://paste.ubuntu.com/p/SS5w53X5hJ/
cat /home/kisscsalad/.config/k3brc erre is kiadta ugyanazt, csak itt terminálban.

https://paste.ubuntu.com/p/yq3kk3Ws6w/

https://paste.ubuntu.com/p/TV2JWMMb3q/

https://paste.ubuntu.com/p/29vymnznvt/

https://paste.ubuntu.com/p/2HtR5hcsgb/

https://paste.ubuntu.com/p/X9gPXWVbFK/

https://paste.ubuntu.com/p/KMcQXPvV6B/

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai

#40 Köszi. Összesen egy kimenet kéne:

namei /usr/bin/cdrecord

Mert nem tudom, erre a szimbolikus linkre mi szükség.
És hogyan lehetne kiiktatni. Semmi szükség rá, a Wiki is azt írja nincs használva. Bonyolításnak tűnik.
(pop-rock kategória: https://www.youtube.com/watch?v=SGqYPN5aoK4 )

-----

Debian alatt nincs limit..

ulimit -l
unlimited

Linux Mint alatt van,

ulimit -l
16384

és ezt okozza.

wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
wodim: Resource temporarily unavailable. Cannot get mmap for 12587008 Bytes on /dev/zero.

Tehát két megoldandó probléma van.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai, megoldása

#41 Igazából az előző kérdésre adott válaszok fontosak, de lehet hanyagolni kéne a K3b használatát.

Összefoglalom, persze, más megoldás lehet.

1)

A limit nálam a JACK hangrendszer miatt unlimited.

Nézzük,

-- nálad milyen, olvassuk a fájl tartalmát

cat /etc/security/limits.d/audio.conf

-- esetleg, ha máshol van, akkor hol, listázzuk, mi van a könyvtárban

ls /etc/security/limits.d/

Könnyen megoldható, hogy nálad is unlimited legyen (csak, ha szeretnéd):

sudo apt-get install qjackctl

És a telepítés közben engedélyezed a realtime-ot, a valós idejű működés.
Ezt érdemes engedélyezni, mert a JACK-nek ez az egyik lényege!
Például az Ardour alkalmazásnak is szüksége van erre a beállításra.
Gyengébb gépen esetleg akadhat a hanglejátszás, de csak, ha nagyon sok alkalmazást használsz egyszerre, és csak a jó minőségű fájlok lejátszásánál (FLAC, OGG).

Eredmény (a kiemelt sor a parancssor) | a qjackctl és a valós idejű lejátszás

cat /etc/security/limits.d/audio.conf
# Provided by the jackd package.
#
# Changes to this file will be preserved.
#
# If you want to enable/disable realtime permissions, run
#
#    dpkg-reconfigure -p high jackd

@audio   -  rtprio     95
@audio   -  memlock    unlimited
#@audio   -  nice      -19

Ezzel megoldva ez a rész.  JACK hangrendszer csak akkor indul, ha te indítod, amúgy nem zavar.

2)

Megoldás lehet a CDRTools, PPA-ról:
https://www.kubuntuforums.net/showthread.php/73335-K3B-Can-t-burn-ISO-im...

3)

Valahogy kiiktatni a szimbólikus linket. Az előző kérdés kimeneteiből lehet a megoldásra következtetni.

4)

Ez nem megoldás!

A setuid biteket veszélyes változtatni (wodim, stb.). Így lehetne:

chmod 4755 file_name

De ezt NEM szabad, veszélyes!

Forrás (sok van): https://chmodcommand.com/chmod-4755/
https://en.wikipedia.org/wiki/Setuid
https://community.hpe.com/t5/System-Administration/rwsr-xr-x-gt-special-...
(https://blog.bitkorn.de/k3b-ubuntu-18-04-cdrecord-has-no-permission-to-o...)

5)

Hibát lehet jelenteni. K3b:

Súgó > Hibajelentés...

Itt be kell másolni a hibaüzeneteket, stb..
Fontos, hogy a te rendszered alól menjen, mert a rendszer információkat is elküldöd (nekem Debian-om van), azaz hogy Linux Mint 19 Tara, és, hogy 64 bites. Mást nem. Ránézhetsz úgy, hogy megnézed, mi van az URL-en, de nem küldesz be semmit. Aztán, ha gondolod, segítek.
De a Linux Mintben is van hibajelentés, mert előbbi nem a Linux Mint fejlesztőknek megy. Talán inkább ezt kéne próbálni.
Aztán megoldják.

-----

Talán nem maradt ki semmi.

Értékelés: 

0
Még nincs értékelve

Hiba okai

#41 https://paste.ubuntu.com/p/sgzSBKMkP8/

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai: sudo unlink /usr/bin/cdrecord

#43 Nincs benne az rendszer alternatives-ben szerencsére.

Próbáljuk megszüntetni:

sudo unlink /usr/bin/cdrecord

Majd nézzünk egy kimenetet, az eredményt:

ls -l /usr/bin/wodim /usr/bin/cdrecord /usr/bin/genisoimage

... ha nem találja, akkor sikerült.

Amit most csinálunk, visszafordítható.

És ezek után lehetne a K3b-t indítani. Lehet, a beállításokban ki kell venni a megfelelés jelet a cdrecordnál, de mutass inkább képet  először a parancsorok futtatása utáni állapotról.

Beállítások > Beállítóablak: K3b... > Alkalmazások > Jogosultságok

A Súgó menüből a Rendszer ellenőrzése funkciót is futtathatod, hátha most mutat valamit.

Értékelés: 

0
Még nincs értékelve

Hiba okai, megoldása

#42 Megyek sorban.

Három lépcső egyben mutatva: https://paste.ubuntu.com/p/44xHxnJVr5/

A 2-es pont alá amit írtál oldal, azokon végigmentem. Moun nevű programot nekem nem enged szofverközpontból feltenni, azt írja, hogy nem elérhető. Próbáltam sima sudo apt install paranccsal, ezt írta ki(ha ez érdekes):

https://paste.ubuntu.com/p/VCfyyjws4D/

Leadtam a hibajelzést az általad leírt módon. Nem volt piskóta olyannak, aki nem tud angolul... :) Meglátjuk mi lesz belőle, jelentkezem, ha valami alakul, és/vagy nem értem.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai, megoldása

#45 A qjackctl végül telepítve lett és beállítottad  realtime-ot? Megszakad ott a kimenet...
Talán a telepítése után jön létre az audio.conf (https://paste.ubuntu.com/p/44xHxnJVr5/)

ls /etc/security/limits.d/

-----

A linkeket ne nézd, az csak példa. Azokrbóle csinálj semmit. A Muon-t nem kell telepíteni. (https://paste.ubuntu.com/p/VCfyyjws4D/) A PPA-t máshogyan kell felvenni, nem kell hozzá Muon. Egyelőre ne vedd fel a PPA-t, és ne telepítsd a cdrtoolkit alkalmazást. Több módszer van, egyenként...

Leadtam a hibajelzést az általad leírt módon. Nem volt piskóta olyannak, aki nem tud angolul... :) Meglátjuk mi lesz belőle, jelentkezem, ha valami alakul, és/vagy nem értem.

Köszi, ügyes!
A hibaüzeneteket is be kell másolni. Gondolom, mert így nem jelentettem még.

-----

Az imént írtam még valamit: unlink. (fentebb)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai, megoldása

#46 Most csak az unlink -es módszert csináld, és nézzük, mi az eredménye.
https://linuxmint.hu/comment/35766#comment-35766

A felsorolás több (1-5), különböző módszer (azért „felsorolás”), egyszerre bele fogunk keveredni! :-)
Ha mégis megcsináltál a többiből valamit már, írd ide, hogy mit csináltál...
Írom én, mit kell csinálni. Egyelőre csak az unlink, semmi más.
A chmod-ot például nem szabad...

Értékelés: 

0
Még nincs értékelve

Hiba okai, megoldása

#47 Unlinkre nem ad semmilyen választ:

kisscsalad@kisscsalad:~$ sudo unlink /usr/bin/cdrecord
[sudo] kisscsalad jelszava:              
kisscsalad@kisscsalad:~$

A qjackctl végül telepítve lett és beállítottad  realtime-ot? Igen telepítettem, engedélyeztem amit kellett, beállítás, azt nem tudom.

kisscsalad@kisscsalad:~$ ls /etc/security/limits.d/
audio.conf
kisscsalad@kisscsalad:~$

A hibaüzenetet bemásoltam, igen, egyenlőre nem érkezett a megadott email címre válasz.

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hiba okai, megoldása

#48 Unlinkre nem ad semmilyen választ:

kisscsalad@kisscsalad:~$ sudo unlink /usr/bin/cdrecord
[sudo] kisscsalad jelszava:              
kisscsalad@kisscsalad:~$

Mert sikerült. Nincs ilyen, hogy „oks, minden rendben!”. :-)

-----

A qjackctl: telepítettem, engedélyeztem amit kellett, beállítás, azt nem tudom.

kisscsalad@kisscsalad:~$ ls /etc/security/limits.d/
audio.conf
kisscsalad@kisscsalad:~$

Vélhetően nincs limit most, a fájl ott.

-----

A hibaüzenetet bemásoltam, igen, egyenlőre nem érkezett a megadott email címre válasz.

Nem sietik el szerintem. Azt hiszem, a bug report oldalon fog megjelenni a hiba, de fejből nem tudom, lehet a KDE máshogy csinálja ezt is. Ránézünk később, nem igazán fontos a „várakozás”.
Két hibaüzenet volt, az, hogy nem tud hozzáférni az sr0-hoz a wodim | cdrecord, és a limit.

-----

Rendben, tehát akkor két dolgot csináltál,
-- unlink (cdrecord szimbolikus link megszűntetése)
-- és a qjackctl alkalmazás telepítése, beállítása.
Itt vagyok, de nem folyamatosan, ebédet készítek, takarítok.
Képet kéne mutatni a mostani állapotról. Az unlink javaslatnál leírtam melyik menü... . Jöhetett volna most is.

Értékelés: 

0
Még nincs értékelve

Hiba okai, megoldása

#49 Remélem erre gondoltál: https://ibb.co/BNNkxTS

Semmi gond, ha időnként azért csinálsz mást is, én is azt teszem :) Mondjuk az ebédet én készítem, de a takarítást másra hagyom :D , de közben szerelek, kertet rendezek, könyvet írok és rajzolok ha pihenni szeretnék, de két középiskolás mellett ez sem mindíg jön össze :) Csak azért írom mindezt, hogy jelezzem: maximális hálám, amiért tudásod egy számodra ismeretlen szolgálatába állítod, amiért csak köszönetet tudsz kapni.... Virtuális kalapemelésem és hálám neked és minden segítőnek!

Értékelés: 

0
Még nincs értékelve

Oldalak