Gufw és, vagy tűzfal hiba

Fórum: 

 

Sziasztok!

A GUFW konfiguráló programot szeretném használni, viszont egy hibába ütköztem, ebben kérném segítségetek.

Nemrég telepítettem a gufw és ufw programokat.

Rendszerindítás után automatikusan indul az ufw.
(sudo ufw status) lekérdezéskor aktív, de mikor indítom a gufw-t a pajzs ikon szürke és az állapotnál kikapcsoltat jelez. Miután bekapcsolom a gufw-t és lekérdezem az ufw statust az inaktív állapotot mutat.

Utána engedélyezem az ufw-t (sudo ufw enable), de a gufw-ben a már beállított szabályok nem látszanak.

A neten próbáltam utánanézni, találtam is ezzel a problémával küzdő embereket, de megoldást sehol sem találtam.

Köszi a segítséget, ötleteket!

Üdv.

p { margin-bottom: 0.25cm; line-height: 120%; }

szhf62 képe

Gufw és, vagy tűzfal hiba

@#0 Minden (!) Szoftverkezelőben megtalálod a "Firewall configuration" (Tűzfal beállítások) - ezt gufw keresőszóval, és az ufw keresőszóval ennek a "finomhangolóját" (Ha itt ez nem menne, a Synapticból is tudod telepíteni őket).
(A félreértések elkerülése végett a "(!)"-t azért írtam, mivel most Bionic Beavert használok, ma reggelre a rendszer nekem teljesen "kidobta" a tűzfal programot, és ezeknek az újratelepítésével kezdtem. Az "ufw" nem látszik, és nálam - jelenleg - nem indul el...)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Gufw és, vagy tűzfal hiba

@#0 Utána engedélyezem az ufw-t (sudo ufw enable), de a gufw-ben a már beállított szabályok nem látszanak.

Ezzel csak engedélyezed a tűzfalat, azaz indítod. A tűzfalszabályok (is) így kérdezhetőek le a terminálban:

sudo ufw status

A gufw vagy ufw telepítés után a rendszert egyszer újra kell indítani az automatikus indításához (ha engedélyezted), azonban a rendszerfolyamatok között nem fog látszani (pl. htop kimenet). Biztonsági okból.

Értékelés: 

0
Még nincs értékelve

Gufw és, vagy tűzfal hiba

#1 Szia!

A programok (gufw, ufw) telepítve vannak.

A két program együttműködésével van a probléma.

 

Értékelés: 

0
Még nincs értékelve

Gufw és, vagy tűzfal hiba

#2

Szia!

Megpróbálom máskét megfogalmazni.

Rendszerindítás után a sudo ufw status:

WARN: A(z) '/etc/ufw' a csoport által írható!
WARN: A(z) '/etc' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d' a csoport által írható!
WARN: A(z) '/lib' a csoport által írható!
WARN: A(z) '/etc/ufw/user.rules' a csoport által írható!
WARN: A(z) '/etc/default/ufw' a csoport által írható!
WARN: A(z) '/etc/default' a csoport által írható!
WARN: A(z) '/etc/ufw/ufw.conf' a csoport által írható!
WARN: A(z) '/etc/ufw/user6.rules' a csoport által írható!
WARN: A(z) '/usr' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d/cups' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d/samba' a csoport által írható!
Állapot: aktív

Címzett                    Művelet     Feladó
-------                    -------     ------
22/tcp                     ALLOW       Anywhere                 
22/tcp (v6)                ALLOW       Anywhere (v6)  

de mikor indítom a gufw-t az állapot kikapcsoltat jelez.

 

Miután bekapcsolom a gufw-t az állaptkapcsolóval és lekérdezem az ufw statust:

WARN: A(z) '/etc/ufw' a csoport által írható!
WARN: A(z) '/etc' a csoport által írható!
WARN: A(z) '/etc/ufw/ufw.conf' a csoport által írható!
WARN: A(z) '/lib' a csoport által írható!
WARN: A(z) '/etc/default/ufw' a csoport által írható!
WARN: A(z) '/etc/default' a csoport által írható!
WARN: A(z) '/etc/ufw/user6.rules' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d' a csoport által írható!
WARN: A(z) '/etc/ufw/user.rules' a csoport által írható!
WARN: A(z) '/usr' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d/cups' a csoport által írható!
WARN: A(z) '/etc/ufw/applications.d/samba' a csoport által írható!
Állapot: inaktív
 

Tehát szerintem a gufw kikapcsolja a tűtfalat.

Ha ezek után engedélyezem az ufw-t (sudo ufw enable), a gufw-ben a már eredetileg is beállított szabályok nem látszanak.

A két program nem működik együtt egymással.

 Üdv!

Értékelés: 

0
Még nincs értékelve
tothbela48 képe

Tűzfal működési hiba?

Engem idegesít a számtalan háttér forgalmazás, aminek okát, tartalmát nem ismerem.
Igyekszem az adatforgalamamat minimalizálni, elsősorban bigott mániából, hogy az irdatlan sok szemét előbb-utóbb bedugítja a világhálót. Másodsorban azért, mert olcsó szolgáltatói csomagokat használok, amiben figyelném és szabályoznám az adatforgalmamat, ha a háttérben nem történnének manipulációk. Harmadsorban sokszor van, hogy csak bámulom az oldalakat, a modem mégis felizzik. és lekapcsolja magát.
A forgalom figyelésére EtherApe programot telepítettem, amivel minden pillanatban láthatom, kivel történik mekkora adatforgalom.
A legtöbb sumák a Google-tól származik. Nem tudom, kívülről furakodik-e be, vagy a Linux Mint-be, vagy a modembe van beépítve valami meghívás.
A tapasztalatok alapján a tűzfalban az alábbi szabályokat állítottam be (én mezítlábas lévén a Gufw-t grafikusan használom)

Majdnem minden az elvárások szerint működik, de a 104.198.x.x cím a beállítás ellenére továbbra is befurakodik. Az EtherApe kimutaása szerint:

A 74.125.x.x tartományt ezen kép készítése után zártam ki, és az egyelőre működni látszik.
Mi mást tudok tenni a cél érdekében?
Üdvözlettel mindenkinek Béla

Értékelés: 

0
Még nincs értékelve
kimarite képe

Tűzfal működési hiba?

#5 Igy van tiltva a tartomány: All Interfaces?

No meg itt is tiltsd (a második képen látható csatoló): wo-in-f188.1e100.net

Értékelés: 

0
Még nincs értékelve
kimarite képe

Gufw és, vagy tűzfal hiba

#4 Ha ezek után engedélyezem az ufw-t (sudo ufw enable), a gufw-ben a már eredetileg is beállított szabályok nem látszanak.

A többi profilt nézted (gUFW)?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Tűzfal működési hiba?

#6 No meg: IPv4 és IPv6. Mindkettő engedélyezve a hálózati beállításokban? Ha az IPv6 mellőzve, akkor?

Értékelés: 

0
Még nincs értékelve