betöltésnél emergency mode kilépés

Fórum: 

Tanácsra, segítségre lenne szükségem.

Linux Mint Mate használok már közel egy éve, a 19.2 verzió van jelenleg a gépemen (minden felajánlott frissítéssel együtt), ez eddig minden gond nélkül, jól működött egészen a mai napig.

Jelenleg az LM betöltésnél ez a figyelmeztetés fogad:

"You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, . . ." ami egy hosszú listát generál, amit nem tudok értelmezni; a továbbiakban felkinál néhány tippet a folytatáshoz "systemctl reboot" és "systemctl default" vmint az "exit" lehetőségeket, viszont egyik sem oldja meg a betöltés folytatását ( mindegyiknél visszatér a fent említett figyelmeztetéshez.

Próbáltam a betöltési (grub)menüből az "advanced" menüből az előző mentésekből elindítani, de itt sem jártam eredménnyel(ua a figyelmeztetéssel).

Mielőtt ez az egész galiba megtörtént volna egy pendrájvot akartam láthatóvá tenni és a "Disk"-et indítottam el, talán itt állítodhatott el vmi tudtomon kivül.         

Előre is köszönök minden segítséget, tanácsot.

LXX felhasználó

tresor képe

Mi az amit azzal a

Mi az amit azzal a pendrájvval csinálni akartál? Kb. miket nyomkodtál? Nagyvonalakban. Biztos az a pendrájv volt kiválasztva?

Értékelés: 

0
Még nincs értékelve

Recovery módban tudsz indúlni

#1 Nem indul ott sem visszatér az emergency mode-ba felkinállásához

 

Értékelés: 

0
Még nincs értékelve

Mi az amit azzal a

#2 Csatoláskor a pendrive (ami tegnap még jó volt) nem látszott semelyik op. rendszeren sem. A Disk-nél vmi létezést jelzett, itt ki-be lehet kapcsolgatni a pen jelző ledjét, de kb. ennyi.

 

Értékelés: 

0
Még nincs értékelve
tresor képe

Mi az amit azzal a

#6 Gondolom most nincs bedugva az pendrájv és az első hibás bootolásnál sem volt, vagy igen?

Értékelés: 

0
Még nincs értékelve

Mi az amit azzal a

#7 Hát nagyon el vagyok szomorodva, mert fogalmam sincs, h oldjam meg.

Elolvastam a küldött linket és aként cselekedtem

beírva:

mount -a 

a válasz:

/mnt/usb-NAND_USB2DISK-0:0: mount point does not exist

ahol az usb-NAND . . . az a nyavalyás pen. Tehát olvasatomba a rossz penről akarna betöltödni.

 

 

LXX felhasználó

(zárójelben jegyezném meg, h csak sima linux felhasználó vagyok és az LXX az éveim számát jelenti).

 

Értékelés: 

0
Még nincs értékelve
tresor képe

Mi az amit azzal a

#8 Kérdeztem, hogy be van-e dugva most is vagy az első hibakor be volt-e dugva?

Értékelés: 

0
Még nincs értékelve
tresor képe

Be kéne bootolni egy live iso

Be kéne bootolni egy live iso-val, fájlkezelőben felcsatolni a rendszer partíciódat. Abban megnézni az /etc/fstab-ot. Szerintem egy ilyen sor van benne, azt kikéne kommentelni. De előtte mutasd meg. Csinálhatsz képeket és osztd meg. Jó minőségűek legyenek. Szólj ha bebootoltál a live cd-vel.

Értékelés: 

0
Még nincs értékelve

Próbáld meg live-ről chroot

#10 oké, megvan live cd a 19.0-ról. Bebootolok majd jelentkezem.

Értékelés: 

0
Még nincs értékelve

Ok itt vagyok a livecd-n

Ok itt vagyok a livecd-n keresztul.

Eleg szokatlan, printscreen-t mivel tudok csinalni? es persze mirol?

 

Értékelés: 

0
Még nincs értékelve
tresor képe

Ok itt vagyok a livecd-n

#12 Ó, vágod ezt nagyon. :-).

Ezt akartam mondani, hogy PrtScn gombbal lőhetsz képernyő képet. Azt feltöltöd, mondjuk a imgur-ra (imgur.com) és a kép linkjét meg ide válaszba.

1. Csatold fel a rendszer lemezed, amin a döglött rendszer van. Fájlkezelőben oldalt megleled. Ha megnyitottad, arról egy képet először.

Értékelés: 

0
Még nincs értékelve

fstab, mostani allapota

fstab, mostani allapota {kimasolva)

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=91cafab5-c4bc-4a29-9b50-5b343c1bcaf1 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
/dev/disk/by-id/usb-NAND_USB2DISK-0:0 /mnt/usb-NAND_USB2DISK-0:0 auto x-gvfs-show 0 0

Értékelés: 

0
Még nincs értékelve
tresor képe

fstab, mostani allapota

#14 Úgy kéne ide beilleszteni, hogy kijelölöd itt az egészet és ahol a "Normál"-t látod, azt ha lenyitod, benne a formázottat választod, akkor jobban olvasható az egész.

Értékelés: 

0
Még nincs értékelve
tresor képe

fstab, mostani allapota

#14 Vagy az ilyet az Ubuntu Pastebin-re is lehet.

https://paste.ubuntu.com/p/vt3mX4RyTy/

 

Értékelés: 

0
Még nincs értékelve
tresor képe

ok, az elozot hibasan kuldtem

#16 Abban az etc könyvtárban nyiss terminált (jobb klikk megnyitás terminálban).

sudo nano fstab

Az utolsó sor elejére ,( a pendrájvos sor) kell egy # jel. Ezzel kikommenteled.

Ctrl+O, enter, Ctrl+X  ezzel mented és kilépsz a nanoból. A gépet restartolod live cd nélkül.

Elvileg jó lessz.

Értékelés: 

0
Még nincs értékelve
tresor képe

Kellene még egy 

Kellene még egy 

sudo fdisk -l

kimenet is, ebben a felcsatolt állapotban.

Értékelés: 

0
Még nincs értékelve

Kellene még egy 

#19 már újraindítottam és problémamentesen betöltödött.

Most helyesen kilistázta,

csak ezzel a piros megjegyzéssel

"Partition 3 does not start on physical sector boundary."

amit nem tudok jó e v nem, volt e előtte is v nem,

 

 

Értékelés: 

0
Még nincs értékelve
tresor képe

Kellene még egy 

#20 Nincsenek jól illesztve a partíciók, a fizikai szektor határokra. HDD-nél nem annyira vészes, de SSD-nél gond a trimmelés miatt.

Örülök, hogy sikerűlt bebootolni a rendszert.

Értékelés: 

0
Még nincs értékelve

Kellene még egy 

#21 Mindenesetre hálásan köszönöm a segítségedet,

így nemcsak a linuxot, hanem a hitemet is visszanyertem.

 

Értékelés: 

0
Még nincs értékelve
tresor képe

Kellene még egy 

#22 Szívesen, máskor is.

HDD-n vagy SSD-n van a rendszered???????

Értékelés: 

0
Még nincs értékelve
tresor képe

Kellene még egy 

#22 No várjunk csak. Az fstab-ban csak a / partíció van. Az fdisk meg 3 partícióról nyavajog.

"Partition 3 does not start on physical sector boundary."

Csak másold már ide, de inkább pastebinre a

sudo fdisk -l

kimenetet.

Értékelés: 

0
Még nincs értékelve
kimarite képe

[off]

#24 Nálam ez volt a hiba:

Partition table entries are not in disk order.

Egy lemez van használatban (Linux), az sda.

Javítás:

sudo fdisk /dev/sda

Parancs (m = súgó): m
x   extra functionality (experts only)
Szakértői parancs (m = súgó): m
f   fix partitions order
r   return to main menu
Parancs (m = súgó): m
w   write table to disk and exit
You may get a warning that devices are in use and the new table will be used at the next boot. | a követketző indítás után lesz érvényes a javítás:

sudo systemctl reboot

-----

Vélhetően, mert a

v   verify the partition table

paramétert is használtam (sután követve egy rossz javaslato), az újraindítás után nem töltött be a rendszer (grub_rescue), így egy Live rendszer és a chroot segítségével újratelepítettem a GRUB-ot. A v paramétert nem kell használni. Megint itt. :-)

A kérdezőnek ez a megoldás nem jó, csak megmutattam, ha valakinek ugyanez a jelzés van (mint nálam, fentebb), akkor mit kell csinálni.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Partition 3 does not start on physical sector boundary.

#25 A kérdezőnek ez kell (a lemeze az sda):

sudo fdisk /dev/sda

Welcome to fdisk (util-linux 2.33.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Parancs (m = súgó): m
  • u   change display/entry units
Parancs (m = súgó): u

Changing display/entry units to cylinders (DEPRECATED!).

  • w   write table to disk and exit
Parancs (m = súgó): w

The partition table has been altered.
Syncing disks.

Rendszer újraindítás

sudo systemctl reboot

és ellenőrzés (a kimenet kéne):

sudo fdisk -l

Csak megjegyzem, mindezen javasolt tevékenység előtt meg is kéne a

sudo fdisk -l

parancssor kimenete, azért hogy megnézzük, a jelenlegi partícióstábla

Disklabel type: dos

vagy más. Én most újraindítom a rendszert, azaz a javaslat próbája jön.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Partition 3 does not start on physical sector boundary.

#26 Sikerült. :-)

Javítás

Itt (a w alkalmazása után)

  • w   write table to disk and exit
Parancs (m = súgó): w

The partition table has been altered.
Syncing disks.

lehagytam véletlenül a q paramétert, azaz nem léptem ki az fdisk alkalmazásból.
Utána lehet a rendszert újraindítani, majd tesztelni is.

A lényeg amúgy, hogy partíciók határainak korábbi beállítása a szektorok (units) szerint történt. Az új beállítás cilinderek (cylinders) szerint méretez.

Értékelés: 

0
Még nincs értékelve
kimarite képe

https://askubuntu.com

#28 Melyik pontosan a javaslatod? Mert több is van az oldalon, amit linkeltél..

Innen mondjuk és sorban írd, mi lenne a javaslat:
https://linuxmint.hu/comment/32761#comment-32761

(https://www.youtube.com/watch?v=21onW6HFPMQ )

Értékelés: 

0
Még nincs értékelve