dpkg

kimarite képe

A Frissítéskezelő és a Szoftverforrások alkalmazások működése, beállításai

A Linux Mint Frissítéskezelő alkalmazása felel a frissítések figyeléséért. Alapértelmezetten két órántként néz fel a tükrökre. A panelen látható ikon jelez (kék „i” karakter látható egy pajzson), ha bármely telepített csomagból újabb vagy másik verzió érhető el. Ez esetben lehetőséged van a frissítést alkalmazni, mondhatni, érdemes megtenned. A frissebb csomagok általában fejlesztéseket és hibajavításokat tartalmaznak, viszont olykor biztonsági okból adnak ki egy új csomagverziót. A Linux Mint biztonsági szinteket használ a frissítés szabályozására.

kimarite képe

A legújabb kernel telepítése: a dpkg segítségével

Azt gondolom, kíváncsi lehetsz a legújabb kernel fejlesztésekre, tehát szívesen kipróbálnád a legújabb kernelt, mielőtt az bekerülne támogatott csomagként az általad használt Linux Mint kiadásba. Szögezzük le, a saját felelősséged így telepíteni a kernelt, még akkor is,
-- ha hiba nem igazán szokott történni a legújabb kernel használatánál,
-- és bármikor visszatérhetsz a GRUB menüből a régebbi kernelre, ha mégis hibát tapasztalsz.

kimarite képe

A LibreOffice telepítése: a dpkg segítségével

Az alábbiakban a jelenleg legújabb LibreOffice telepítéséhez szeretnék segítséget nyújtani.
Telepítheted PPA-ról is, de most a dpkg segítségével telepítem az alkalmazást.
Ez a módszer a Debian-alapú LMDE kiadás alatt is használható.

kimarite képe

Csomagkezelés: DEB csomag készítése RPM csomagból az alien alkalmazással

Előfordulhat, hogy a rendszeredhez nem találsz DEB csomagot a csomagforrások között (tárolók = sources > apt-get, aptitude, apt, csomagkezelők), egyéb letöltési lehetőség sem érhető el a neten..., továbbá a forrás sem áll rendelkezésre a csomag forgatásához.
Ritka eset, ha ilyennel találkozol ..., jellemzően valamely nagyon egyedi alkalmazásról van szó, melynek a fejlesztését a fejlesztő valamiért nem folytatja, például, mert nem ér rá, más fontosabb dolga akadt, stb..

kimarite képe

Eltávolíthatatlan, rossz, következetlen állapotban lévő csomag törlése

Sajnos, belefutottam egy olyan jelenségbe, hogy az egyik számítógépemre nem telepíthető egy alkalmazás konzolos megoldása. És az eltávolítás is nehézségekbe ütközik: a csomag rossz, következetlen állapotban van - mondja a rendszer (a terminál, és a Synaptic). Tájékoztatás: a hiba a gépemben van, azaz a Telegram alkalmazáshoz (vélhetően, mert manapság mihez nem) szükséges a processzor SSE2 támogatása, és nálam ez nem teljesül.

Feliratkozás RSS - dpkg csatornájára