Melyik tárolót a legbiztonságosabb használni?

tothbela48 képe

Fórum: 

Előzmény: a Linux Mint 17.1-es változatában az internet böngészés lelassult (Firefox-al is és Operával is), a clamav nem talált vírust. Repositorinak a KFKI tárolóit használtam. Különböző kitérők után telepítettem a 18.2 változatot infotronik.hu és sze.hu tárolókból.

HP nyomtatók telepítése közben olyan hibaüzenetet kaptam, hogy bizonyos csomagok hiányoznak a helyes működéshez. A Synaptic nem találta a tárolókon azokat. Próbáltam tároló tükröt váltani. A felkapott neve matt először yandex-re, azt hivén, hogy "világméretű" jelenléte miatt jobban naprakészen tartja a szervereit. Valaki vagy valami nem engedte ezt a tükröt használni. Ezért visszaálltam a fent írott tükrökre. Biztonságból a HPLIP.hez tartozó csomagokat frissítettem.

Az egyik lib csomagot a Synaptik nem volt hajlandó letölteni, hogy a - ha jól emlékszem - SHA1 ranúsítvány túl gyenge. Pedig néhány nappal korábban feltelepítette.

Egy másik beszélgetés kapcsán kimarite segített, de hogy szervezettebb legyen a megjelenítés mások számára is, azért nyitottam tanácsára ezt a topikot. Odáig jutottunk, hogy a gépemből kérte megmutatni az alábbiakat:

energmester@toth-asztali ~ $ sudo apt-get update | tail -10

[sudo] energmester jelszava: 

Mellőz:1 http://mirror.infotronik.hu/mirrors/linuxmint/packages sonya InRelease

Találat:2 http://ubuntu.sth.sze.hu/ubuntu xenial InRelease

Találat:3 http://archive.canonical.com/ubuntu xenial InRelease

Találat:4 http://mirror.infotronik.hu/mirrors/linuxmint/packages sonya Release

Letöltés:5 http://ubuntu.sth.sze.hu/ubuntu xenial-updates InRelease [102 kB]

Letöltés:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]

Letöltés:8 http://ubuntu.sth.sze.hu/ubuntu xenial-backports InRelease [102 kB]

Letöltve 306 kB 1p 31mp alatt (3.365 B/s)

Csomaglisták olvasása...


 

Melyik tárolót a legbiztonságosabb használni?

@tothbela48 "legbiztonságosabb" ?
Az a biztonságos, amelyiket nem törték fel ... de ezt mi innen nem tudjuk megítélni.
Inkább a gyorsaságra, illetve a megbízhatóságra helyezném a hangsúlyt.
Van úgy, hogy frissítés közben közli hogy néhány csomagot nem tudott letölteni - helyettük a
régiek lesznek használva.
Ilyenkor az első dolgom az, hogy a "Szoftverforrások"-nál megkerestetem a leggyorsabb
tükörkiszolgálót (kat). Ha ez történetesen valamelyik magyar, - akkor nem biztos hogy ezt választom !
Mert a tapasztalatok (másokat is beleértve) azt mutatják, hogy a magyar tükörkiszolgálók nem a
megbízhatóság mintaképei.
Ha van hasonló sebességű külföldi, (osztrák, német, cseh, román) akkor inkább azt választom.
Egyébként, kb. 6 év Linux használat közben, 1 esetben kaptam a Chromium-on keresztül
(MP3-as audió fájlok letöltésekor ) trójai fertőzést - de nem tudta kifejteni a hatását, mert nem
erre a rendszerre (Linux) írták. Azért, Clamtk-val természetesen töröltem.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

@tothbela48 „Az egyik lib csomagot a Synaptik nem volt hajlandó letölteni, hogy a - ha jól emlékszem - SHA1 ranúsítvány túl gyenge. Pedig néhány nappal korábban feltelepítette.”
-- ki kéne 'találni', melyik csomag volt az. Azóta minden rendben vagy megint találkoztál hasonló problémával?

A Yandex Team
https://www.linuxmint.com/edition.php?id=238
vélhetően gyengélkedhetett, amikor próbáltad. Térképészetileg közelebi szervert kéne választani.

Amúgy nem tudom, miről beszélgettek lala-val, mert nem a szerver feltörésekről van szó (és nem is volt), hanem, hogy gyenge SHA jelszót használ az egyik tároló ... és nem tudjuk melyik. :-)
Vélhetőleg ez van, de kéne tapasztalnod megint, hogy lássuk, mi a probléma. Anélkül csak a találgatás megy, biztosat egyelőre nem tudunk.

Értékelés: 

0
Még nincs értékelve
tothbela48 képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

 A Synaptic-kal az alábbi képen bemutatott, összes HP-vel kapcsolatos csomagot újratelepítettem.

Most minden szó nélkül lefutott. Ennél többet sajnos nem tudok tenni a cél érdekében. A jövőben igyekszem minden hiba környezetét regisztrálni. Csak amikor sürgősen van szükség valamire, az ember siet a következő blindre, akkor nem eléggé körültekintő.

Megjegyzés: a Firefox már megint szörnyen lelassult. A javaslatai nem jöttek be. Az újraelepítéssel még nem próbálkoztam. De az Androidokkal is az a bajom, hogy a frissítések többsége újratelepítéssel, hatalmas adatforgalmazással történik.

Megjegyzésem ehhez a szövegszerkesztőhöz. Képet ide beszúrni nem igazán a hozzám hasonló laikusok képességeivel lehet. Értem én, hogy a szervereteket nem akarjátok teletömni mindenféle haszontalan képanyaggal. De akkor nem kell felajánlani a szolgáltatást. A Microsoft azért lépte le a Linuxot, mert gyorsabban, többet tett a laikusokhoz idomulás érdekében.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

#4 A Synaptic-kal az alábbi képen bemutatott, összes HP-vel kapcsolatos csomagot újratelepítettem.
Most minden szó nélkül lefutott.
-- az újratelepítéskor is kiderül, hogy a SHA hitelesítéssel minden rendben van-e.

A jövőben igyekszem minden hiba környezetét regisztrálni.
--érdemes lehet, én text (*.txt) fájlokba jegyzetelek, de pl. a megoldásokat mentheted a egy dokumentumba a LibreOffice-szal vagy az AbiWord-del.

Megjegyzés: a Firefox már megint szörnyen lelassult. A javaslatai nem jöttek be. Az újraelepítéssel még nem próbálkoztam. De az Androidokkal is az a bajom, hogy a frissítések többsége újratelepítéssel, hatalmas adatforgalmazással történik.
-- Linux alatt az újratelepítés egészen mást hoz, gyakorlatilag semmit, azaz nincs regisztrációs adatbázis, ami kavarodhat. Pl. egy kodek (másként függvény- alkalmazás könyvtár) csak egyszer települ és linkelve van mindenfelé, míg a Windows alatt többször települ, akár alkalmazásonként is. A Linux alatt az alkalmazások teljes eltávolítása tényleg töröl mindent, csak üres könyvtár(ak) vagy 'üres' szövegfájlok marad(hat)nak, melyet a rendszert már egyáltalán nem használ semmire.
A Firefox átmeneti időszaka ez ('át'alakulás), nálam csak az ESR változat lassult egy kicsit, a normál kiadás nem. Majd a következő frissítés itt megoldja. Reméljük, helyre lesz hozva a lassulás témaköre, jó böngésző.

Megjegyzésem ehhez a szövegszerkesztőhöz. Képet ide beszúrni nem igazán a hozzám hasonló laikusok képességeivel lehet. Értem én, hogy a szervereteket nem akarjátok teletömni mindenféle haszontalan képanyaggal. De akkor nem kell felajánlani a szolgáltatást. A Microsoft azért lépte le a Linuxot, mert gyorsabban, többet tett a laikusokhoz idomulás érdekében.
-- nem mi ajánljuk fel a szolgáltatást, hanem a használt WYSIWYG Drupal modul tartalmazza :). Beszélgettem az oldalunk sminkjének webmesterével anno, néztem a neten más modulokat, ez a legjobb modul, ami elérhető: fejleszteni lehetne jobbat (modul fejlesztés). És ne keverjük ide a MS-t, mert ez egy weboldal, Windows-zos weboldalon sem lehet egyszerűbben képet beilleszteni, azaz a PHP modulok sem egyszerűbbek (nem így tettél a témára említést, de tippelem), és még egy de ... a Drupal sem Linux, hanem web. Annyit tudnánk tenni, hogy kikapcsoljuk az Editor szerkesztés funkciók gombjait, de kétlem, hogy bárki is nagyon ért a HTML kódoláshoz a kezdő felhasználók között, így viszont a HTML szerkesztésre is lehetőség van, ha valaki azt szeretné (ha jól emlékszem -nem biztos- a helyesírás ellenőrzés HTML-nél működik) ;). Inkább a bőség zavarhat meg néhány embert, hogy be lehet állítani a kép egyéb jellemzőit, a méretet (mást nem igazán kell), azt is arányosan méretezi, az egyik méret (szélesség 400) elég. Hogy a kép eredeti méretben új oldalon nyíljon meg (_blank). Azonban ..., ahogy haladunk előre a Drupal oldalunk használatában, kezdek kissé egyetérteni a fejlesztőnkkel, tehát, hogy az oldal sminkje tipográfiát követ, létezik sorköz és sortörés. És ezzel kapcsolatban azt látom, hogy felnőtt emberek nehezen tudják alkalmazni az egy sorközt, többet 'ütnek' a hozzászólásaik szövegtömbjei közé, továbbá a hozzászólás végére is. Néha azt is látom, szóközök is 'leütődnek', tehát mondhatni 'túlszalad' az emberek keze. Mindeközben pedig a tipográfia (ugyan)azt az utat követi, amit az emberek már rég megszokhattak (bizonyos méretű sorköz) az irodai alkalmazásoknál, tekintve a LibreOffice- vagy az MS Office alkalmazást is. Ha ezekbe szöveget beillesztesz, akkor ugyanazt látod, mintha a WYSIWYG szerkesztőbe beillesztenéd ..., és ez talán túl sok lehetőség lenne, ez látszik is. De elküldés előtt lehet(ne) ellenőrizni a kinézetet (egyszerű rátekintéssel), és sokan láthatóan ezt nem teszik meg: és így lesz mondjuk 15 sorból 30 sor (felesleges sorközök). Képet nem kötelező beszúrni, linkelni is lehet, de ha valaki mégis ezt szeretné, szánjon 10 percet a kép beszúrásának (embed) egyszeri alkalommal történő megtanulására. Ennél többet nem tudok mondani erről. A videó beágyazása ezzel a kóddal történik:

[video:https://www.youtube.com/embed/PVuD5upHt2Q autoplay:0]

azaz ezt láthatod lentebb is: „[video:URL] segítségével videókat lehet beilleszteni.”
(itt a soron belül -és feljebb is- HTML kóddal szerkesztettem a szöveget,
máshogy, szövegszerkesztővel -jelenleg- nem is lehetne
Előbbi mondat és e mondat 'azaz ..'  tömbhöz kapcsolásához
a sorköz [Enter] helyett
a sortörést [Crtl + Enter] használtam)

Nézd, ez egy olyan oldal, ahol meg lehet tanulni a Linux-szot használni (ahogy a Windows-t sem magadtól tanultad, hanem beléd plántálták) és nem hiszem, hogy ilyen egyszerű feladatokra ne lenne energia mindenkiben. Nyilván az új ismeretek megtanulása 'fáj' egy kicsit (nehéz lehet), de amikről beszélünk, nem a nehéz kategória és nem is az a kategória, ami kötelező lenne.

(én a Geany-vel írtam [ezt] a hozzászólásom. Miután ide másoltam a szöveget, a Geany alkalmazással készített sorközöket itt újra elkészítettem: kettő Backspace és egy Enter ..., így a szöveg itt már jól ([helyesen, tipográfiát követve] fog megjelenni, és szerkesztésre megnyitáskor sem 'ugrik össze' [ami logikus, azonban nem fejteném ki]. De megírhattam volna itt is, csak én szeretem a Geany-t, azaz ez az én választásom, és tudom a határait és megoldásait)

Értékelés: 

0
Még nincs értékelve
tothbela48 képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

(Az MS felemlegetésekor a kezdeti óriás párharcra céloztam, nem a weboldalkészítésre. Ne haragudj, a szerkesztési pszichológiáról itt nem foglalom a helyet.)

A tanácsotokra válltoztattam tükröt. Úgy tudtam, a csehek precízebb emberek a magyaroknál. (A német közelségben megadjusztálódtak :-) )

A gyorsítótár frissítésre ki is írt tízegynéhány csomagot frissítendőnek. Persze megin óvatlan voltam, és nem mentettem le a listát. Nem gondolta, hogy ez következik:

Szerencsére véletlenül rátaláltam a részletes telepítési listára, a legalsó panel pajzs ikonjára jobb gombbal kattintva. Azt ide tudom másolni (de sokat kellett bűvölködnöm, hogy egysorosra sikerüljön):

 

 

 

 

10.10@12:57 ++ Launching mintUpdate
10.10@12:57 ++ Starting refresh
10.10@12:57 ++ Initial refresh will happen in 10 minutes, 0 hours and 0 days
10.10@12:57 ++ System is up to date
10.10@12:57 ++ Refresh finished
10.10@13:07 ++ MintUpdate is in tray mode, performing initial refresh
10.10@13:07 ++ Auto-refresh will happen in 0 minutes, 2 hours and 0 days
10.10@13:07 ++ Starting refresh (including refreshing the APT cache)
10.10@13:08 ++ Found 7 recommended software updates
10.10@13:08 ++ Refresh finished
10.10@13:11 ++ Install requested by user
10.10@13:11 ++ Will install binutils
10.10@13:11 ++ Will install libmpx0
10.10@13:11 ++ Will install libgcc-5-dev
10.10@13:11 ++ Will install cpp-5
10.10@13:11 ++ Will install libitm1
10.10@13:11 ++ Will install libcilkrts5
10.10@13:11 ++ Will install libasan2
10.10@13:11 ++ Will install libquadmath0
10.10@13:11 ++ Will install gcc-5-base
10.10@13:11 ++ Will install libtsan0
10.10@13:11 ++ Will install libubsan0
10.10@13:11 ++ Will install libgfortran3
10.10@13:11 ++ Will install gcc-5
10.10@13:11 ++ Will install liblsan0
10.10@13:11 ++ Will install libgomp1
10.10@13:11 ++ Will install libatomic1
10.10@13:11 ++ Will install libcc1-0
10.10@13:11 ++ Will install libstdc++6
10.10@13:11 ++ Will install intel-microcode
10.10@13:11 ++ Will install ntp
10.10@13:11 ++ Will install ntpdate
10.10@13:11 ++ Will install libpulsedsp
10.10@13:11 ++ Will install pulseaudio
10.10@13:11 ++ Will install libpulse0
10.10@13:11 ++ Will install libpulse-mainloop-glib0
10.10@13:11 ++ Will install pulseaudio-module-x11
10.10@13:11 ++ Will install pulseaudio-module-bluetooth
10.10@13:11 ++ Will install pulseaudio-utils
10.10@13:11 ++ Will install libpython3.5
10.10@13:11 ++ Will install python3.5
10.10@13:11 ++ Will install python3.5-minimal
10.10@13:11 ++ Will install libpython3.5-stdlib
10.10@13:11 ++ Will install libpython3.5-minimal
10.10@13:11 ++ Will install xfsprogs
10.10@13:12 ++ Ready to launch synaptic

(synaptic:2440): Gtk-CRITICAL **: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed
10.10@13:14 ++ Return code:0
10.10@13:14 ++ Install finished
10.10@13:14 ++ Starting refresh
10.10@13:15 ++ Error: The APT policy is incorrect!

Átálltam az osztrák sógorokra. Nem talált frissíteni valót. Hiba nélkül ment a gép újraindítva.

Innen úiratelepítettem a Firefox-ot. Gyorsabb, mint újkorában (az eredeti repositorik egyike amerikai volt, bocs, de nem kotorom elő a DVD-ről)

Értékelés: 

0
Még nincs értékelve
tothbela48 képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

Egy következő gépindításkor megint talált a frissítéskezelő jónéhány csomagot.

Ami akár normális  is lehetne, de telepítés közben megint értesített helyrehozhatatlan hibákról, amit helyettesített. Még a grubot, bootolást is átszerkesztette. Alább a lista. De a gép újraindítva zökkenőmentesen felállt. Minden reszketésem ellenére.

Véleményem szerint nincs értelme ezt már itt tovább ragozni.

10.11@14:26 ++ Launching mintUpdate 10.11@14:26 ++ Starting refresh 10.11@14:26 ++ Initial refresh will happen in 10 minutes, 0 hours and 0 days 10.11@14:26 ++ Found 4 recommended software updates 10.11@14:26 ++ Refresh finished 10.11@14:28 ++ Install requested by user 10.11@14:28 ++ Will install thunderbird-gnome-support 10.11@14:28 ++ Will install thunderbird-locale-en-us 10.11@14:28 ++ Will install thunderbird 10.11@14:28 ++ Will install thunderbird-locale-en 10.11@14:28 ++ Will install thunderbird-locale-hu 10.11@14:28 ++ Will install libcurl3 10.11@14:28 ++ Will install curl 10.11@14:28 ++ Will install libcurl3-gnutls 10.11@14:28 ++ Will install libxfont1 10.11@14:28 ++ Will install linux-libc-dev 10.11@14:28 ++ Ready to launch synaptic Error executing command as another user: Request dismissed10.11@14:28 ++ Return code:126 10.11@14:28 ++ Install failed 10.11@14:31 ++ Install requested by user 10.11@14:31 ++ Will install thunderbird-gnome-support 10.11@14:31 ++ Will install thunderbird-locale-en-us 10.11@14:31 ++ Will install thunderbird 10.11@14:31 ++ Will install thunderbird-locale-en 10.11@14:31 ++ Will install thunderbird-locale-hu 10.11@14:31 ++ Will install libcurl3 10.11@14:31 ++ Will install curl 10.11@14:31 ++ Will install libcurl3-gnutls 10.11@14:31 ++ Will install libxfont1 10.11@14:31 ++ Will install linux-headers-4.10.0-37 10.11@14:31 ++ Will install linux-headers-4.10.0-37-generic 10.11@14:31 ++ Will install linux-image-4.10.0-37-generic 10.11@14:31 ++ Will install linux-image-extra-4.10.0-37-generic 10.11@14:31 ++ Will install linux-libc-dev 10.11@14:31 ++ Will install libgles2-mesa 10.11@14:31 ++ Will install libglapi-mesa 10.11@14:31 ++ Will install libxatracker2 10.11@14:31 ++ Will install libegl1-mesa 10.11@14:31 ++ Will install libgbm1 10.11@14:31 ++ Will install libwayland-egl1-mesa 10.11@14:31 ++ Will install libgl1-mesa-dri 10.11@14:31 ++ Will install libgl1-mesa-glx 10.11@14:31 ++ Ready to launch synaptic 10.11@14:36 ++ The mintUpdate window is open, skipping initial refresh 10.11@14:36 ++ Auto-refresh will happen in 0 minutes, 2 hours and 0 days  (synaptic:1815): Gtk-CRITICAL **: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed ** (synaptic:1815): WARNING **: no statusfd changes/content updates in terminal for 120 seconds ** (synaptic:1815): WARNING **: TerminalTimeout in step: linux-headers-4.10.0-37-generic (amd64) konfigurálása10.11@14:57 ++ Return code:0 10.11@14:57 ++ Install finished 10.11@14:57 ++ Starting refresh 10.11@14:58 ++ System is up to date 10.11@14:58 ++ Refresh finished 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

#7 A MintUpdate csomag települt, ez látszik itt. És a rendszermag (++ Will install linux-image-4.10.0-37-generic), ha átszerkesztette a boot listát. A múltkor a 'sudo apt-get update' semmi rosszat nem mutatott. De nézzünk egy ilyet:

inxi -Sr

Nem mindig a legújabb rendszermag jó egy géphez ;). A 4.10.x amúgy 4-es biztonsági besorolású.
Ha valami meghibásodni látszik, nálad például APT cache (átmeneti tár), akkor -az előbbit- egy 'update' gomb vagy parancs helyrehozza.

Értékelés: 

0
Még nincs értékelve
tothbela48 képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

 Ez már nekem kínai, de a közösség kedvéért teszem, amit mondasz.

energmester@toth-asztali ~ $ inxi -Sr
System:    Host: toth-asztali Kernel: 4.10.0-37-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.4.6  Distro: Linux Mint 18.2 Sonya
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirror.inode.at/linuxmint/packages sonya main upstream import backport
           deb http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial main restricted universe multiverse
           deb http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial-updates main restricted universe multiverse
           deb http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Melyik tárolót a legbiztonságosabb használni? Akármelyiket!

#9 Nincs semmi gond a tárolókkal, osztrák szerver. Ha megint lesz valami, szólj. Szerintem a rendszereddel semmi baj. :-)

A kimenet formázása tökéletes, de hosszú egy-egy sor, így önmagában ugrik egy sorral lejjebb a szöveg, mintha sortörés lenne, de nem az.

Értékelés: 

0
Még nincs értékelve