[ Megoldva ] Program telepítési feltelek ellenőrzése.

Fórum: 

Sziasztok,
szeretnék külső forrásból telepíteni egy programot (www.activestate.com/komodo-ide), aminek vannak előfeltételei (installation prerequisites):

    GTK+ 2.24 (or higher)
    Glib 2.22 (or higher)
    Pango 1.14 (or higher)
    X.Org 1.0 (or higher)
    Libstdc++6
    gdk-pixbuf (required on come platforms like Centos 6)
    Gnome libraries (libgnome, libgnomeui)

Pontosan hogyan tudnám megállapítani, hogy minek felelek meg és minek nem, valamint ami hiányzik, azt hogyan tudom a legjobb módszerrel pótolni, mielőtt nekikezdenék a telepítésnek. Van már Systemback mentésem, de a gtk-nál máris elkadtam.

Synaptic csomagkezelő?

Synaptic csomagkezelő?
Mármint ha azzal telepíted, az elvileg figyeli, hogy milyen csomagfüggőségek vannak meg ilyesmi, szóval, hogy kell hozzá.

Értékelés: 

0
Még nincs értékelve

Synaptic csomagkezelő?

#1 Amint írtam, ez egy külső forrásból származó program, tehát van saját könyvtárstruktúrája, azon belül saját install.sh-ja, ami leáll, ha nem felel meg a környezet.  A synaptic-al itt nem tudok mit kezdeni, legalább is azt hiszem.

Értékelés: 

0
Még nincs értékelve

Synaptic csomagkezelő?

...kinyitod a programot és nyitsz benne terminalt-beirod ./configure...utana kiirja a hianyzo fuggosegeket...vagyis addig forgatod meg jo nem lessz...

...valahol kimarite mar leirta nekem,amikor kinlodtam... 

Értékelés: 

0
Még nincs értékelve
tresor képe

Nem ártott volna, ha legalább

#4 El vagy egy kicsit tévedve. Forrásból akar telepíteni, nem bináris csomagból!!!!

Értékelés: 

0
Még nincs értékelve

Sikerült a telepítés, mivel a

Sikerült a telepítés, mivel a telepítő kizárólag a gtk-t hiányolta:

install: warning: It appears that either your system does not have gtk-2.0 installed, or your system's version of gtk-2.0 is not up to date.
Komodo requires version 2.24 or greater. Please update gtk-2.0. While Komodo will still install correctly, it may not run.
This diagnostic is not fool-proof. If you are sure the package is installed and up to date, you may safely ignore this warning.
Proceed? [y/N]

A synaptic-ban ellenőriztem a gtk verziószámot (libgtk-3 -ra kerestem rá) és mivel maga a telepítő is azt írta, hogy nem teljesen fool-proof a detektálása, nálam meg megvolt a gtk-3, hittem neki és bátran továbbléptem és feltelepült és fut rendesen.

@aperten: az oprendszerem szerepel az aláírásomban, ha külön megírnám, akkor meg az lenne a gond, hogy mindent kétszer mond mindent kétszer mond :-) Amúgy az apt-policy-ért viszont köszi, elfelejtettem, de pont ide illett a használata.

 

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Sikerült a telepítés, mivel a

#6 Pedig a GTK+ 2-es verzióját is telepíthetted volna,

your system does not have gtk-2.0 installed

mert akkor az alkalmazás ezekkel is hibamentesen fut. Például egy csak GTK+ 2 alkalmazásokhoz való témával. Sok helyet nem foglal.

Értékelés: 

0
Még nincs értékelve