Libre Office elmosódott betűk

Fórum: 

Az LO Writer borzasztóan jeleníti meg a betűket, ez független a beállított betűméret és típustól. Némelyik halvány, másik elmosódott, alig olvasható, összefolyik.
Ugyanez a fájl Win alatt LO. vagy Open Officevel tökéletes. Egyszerű szöveges fájlt nyitva, a LO. borzasztó, Kate, Okular, Notepad jó. 
https://www.dropbox.com/s/uuejgdvbkii2bj1/libreelmosodott.png?dl=0
Van erre valami megoldás? A képen sokkal jobb mint eredetibe, alig olvasható.

keraform képe

Hinting

Leírom, hogy nálam milyen beállítások vannak. Jegyezd fel a mostani beállításaidat.

A LibreOffice > Beállítások (Alt+F12) > LibreOffice > Nézet
Betűk élsimítása a képernyőn ettől: 8 képpont
Élsimítás használata (Igen)
OpenGL használata mindenhez (Nem)
O.K. és ha kell, újraindítod az LO-t.

De szerintem itt van a kutya elásva:
Alt+F2: cinnamon-settings fonts
Ha nem Cinnamon, akkor Menü > Beállítások > Betűtípusok
Hinting: Nincs
Élsimítás Rgba
RGBA: RGB

Ha itt változtatsz, az rögtön látszik a monitoron.
Nyisd meg azt a rosszul látszódó szöveges fájlt, és úgy állítgass a beállításokon.
Nem biztos, hogy nálad az én beállításaim lesznek jók.
 

Értékelés: 

0
Még nincs értékelve

Hinting

#1
Ugyanezek a beállításaim, viszont: a LO,
Eszközök-->Beállítások  és itt  maga a beállítóablak is ugyanilyen mosott, életlen. 
KDE alatt nincs se hinting se élsimítás csak anti-aliasing van. Azt állítgattam, eredmény nélkül.

Minden más jól jelenik meg, az egész felület, a menük, ablakok feliratai stb. csak a LO. ilyen elmosódott.

Értékelés: 

0
Még nincs értékelve
keraform képe

Hinting

#2 http://www.ubuntubuzz.com/2016/03/how-to-fix-ugly-libreoffice-font-rende...

Értékelés: 

0
Még nincs értékelve

Hinting

#3
Eredménytelen. Több beállítást is kipróbáltam. Talán valamivel élesebb de szerintem a bebeszélés határán van.
Mindegy, használom a Wine beépített Word Padot, azzal borotvaélesek a betúk.

Amúgy is lassan megy a Manjaro a levesbe, megpróbálkozok egy tiszta Vanilla Arch telepítéssel a nulláról mert ez több sebből vérzik már.

Köszönöm a segítséget.

Értékelés: 

0
Még nincs értékelve

Jelentem megoldva de hosszú

Jelentem megoldva de hosszú lesz, ha valakit érdekel olvassa végig.

A pc-m, ami egy mini pc, 

Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor 
  x5-E8000/J3xxx/N3xxx Integrated Graphics 
 
az első Linux próbálkozásaim óta valami videodriver gonddal küszködik mert ha minden driver fennt van akkor az alábbi linken látható egérkurzor megbolondulást produkálja:
https://www.dropbox.com/s/n7lxarw071swfo0/villog.mp4?dl=0
Ezt csinálta Mint18, 19 és Manjaro alatt is. Mivel így egyszerűen használhatatlan, és ha elkezdi csak a reboot segít, elkezdtem a videodriver környékén kutakodni. A mostani Manjaro KDE alatt ez egy régebbi kenellel és a nyílt driverrel jó de néha így is megbolondul a kurzor, ha felváltva webes videókat (pl. Youtube) és helyi filmeket (SM Player) nézek akkor garantáltan 15-20 perc után restartolhatom a pc-t. Mivel ez is eléggé idegesítő, kutakodtam tovább.
Namost. Arra rájöttem hogy ha kikapcsolom az Összeállítót vagyis a kompozitort, akkor atomstabil lesz a kurzor, soha nem produlálta így a hibát.
Viszont így meg sajnos elestem egy rakás nagyon szép és hasznos KDE animációtól, nemcsak a csicsára gondolok hanem pl. az Alt+Tabos feladatváltó nézetektől stb.
És ekkor jött az Open Office elmosódott, alig olvasható kinézete. Na mondom hajrá tovább, tuti hogy ennek is köze van a videodriverhez valamilyen szinten.
Mivel a kernelek, videodriverek, kompozitor ki-be kapcsolásának és az élsimítás beállításainak kb. 30 variációját próbáltam végig, megfejelve a hardveres gyorsítás ki-be kapcsolgatásával ezért ezzel nem untatnám a T. közönséget.

A végeredmény, borotvaéles LO, stabil egérkurzor, és a médiaplayerem (SM Player) minimális procihasználata FHD videó lejátszása alatt is. 
Ami sajnos nincs az a kompozitor mert ha azt bekapcsolom akkor reszeltek az egérkurzornak.

Beállítások:
LO: font Noto Sans Mono vagy Noto Mono, a Beállítások-->Nézet fülön Hardveres gyorsítás és Élsimítás használata, Open GL kikapcsolva.
SM Player: video kimeneti meghajtó XV.  Szoftveres videó kiegyenlítő használata, Hardveres gyorsítás, Dupla bufferelés
a Teljesítmény fülön H264 dekódolási szálak:4, Hardveres dekódolás:vaapi (ez az Intel soc-hoz ajánlott és tökéletes).
Rendszerbeállítások-->Betűkészletek -->Betűtípusok(Configure fonts):  Anti-aliasing-enable  Sub-pixel rendering-RGB, Hinting-közepes.
Kernel, a legújabb.
Videodriver: ez nálam érdekes, az itt linkelt beállítással jó:   https://www.dropbox.com/s/ccy0jeyjh5x6kn1/videodriverjo.png?dl=0

A kísérletezés közben volt ilyen is, a képtartalom bal oldala 4-5 centit átcsúszott a jobb oldalra, érdekes volt:   https://www.dropbox.com/s/t6mzln20caeqd4l/atcsuszva01.jpg?dl=0

Sajnos a kompozitor nem használható. De ezen kívül minden tökéletes. Ráment a mai délutánom de egye fene ha egészen  használható lett a végeredmény.

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jelentem megoldva de hosszú

#5 A fájl

~/.config/fontconfig/fonts.conf

tartalma nálam ez.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintnone</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>none</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>false</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcdnone</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
</fontconfig>

Azt írják, legyen még benne ez is (kiemeltem):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintnone</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>none</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>false</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcdnone</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
        <edit name="embeddedbitmap" mode="assign">
            <bool>false</bool>
        </edit>
        </match>
</fontconfig>

Forrás: https://askubuntu.com/questions/369705/ugly-libreoffice-font/849182#849182

Ugyanezen szálban az OPenGL kikapcsolását is javasolják: https://askubuntu.com/questions/369705/ugly-libreoffice-font/369894#369894

Miután ez megvan frissíteni kell a font cachet:

sudo fc-cache -vf

-----

Egy másik javaslat szerint, az Antialiasing lehet true vagy false.

Mármint itt:

/etc/fonts/conf.avail/10-antialias.conf

De ezt ennek a fájlnak a változtatását nem mindenhol javasolják.

Nálam ez van a fájlban (bekapcsolt állapot):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!--  Use the Antialiasing -->
  <match target="pattern">
    <edit name="antialias" mode="append"><bool>true</bool></edit>
  </match>
</fontconfig>

Meg kell nézni, a KDE beállítás hatással van-e a fájl beálításra. Ez az egyik. Ha nem, az megint más dolog, de akor lehet, a KDE ezt a beállítást amúgy sem veszi figyelembe.

Ha itt (a fájlban) változtatnál mégis, akkor kell a font cache frissítése:

sudo fc-cache -vf

-----

Írod

Eszközök-->Beállítások  és itt  maga a beállítóablak is ugyanilyen mosott, életlen. 

hogy a LibreOffice menüi is elmosódottak. Igen: https://www.dropbox.com/s/uuejgdvbkii2bj1/libreelmosodott.png?dl=0

A dmesg és a Xorg.0.log mutatná meg, mi a probléma a Libreoffice-szal (annak indítása után futtatva), de a monitor csúszást (https://www.dropbox.com/s/t6mzln20caeqd4l/atcsuszva01.jpg?dl=0) biztosan. Ilyen egér késleltetés problémáról (https://www.dropbox.com/s/n7lxarw071swfo0/villog.mp4?dl=0) is volt szó itt a fórumon. Te tetted fel a kérdést (https://linuxmint.hu/forum/egerkurzor-megbolondul), de újratelepítéssel „oldódott meg”. Mindez kompozitor és videó driver gond lehet. Utána lehetne járni. A megoldásokat én is keresem.

A LibreOffice KDE integrációs csomag telepítve van (libreffice-kde*)? KDE 5 verzióra nem látok elérhetőt, ... de amúgy ez más téma, a menübe, a MIME csatolásokhoz való beépülést segíti és nem a fontok megjelenését.
Ugye állítható a KDE (Plasma) és  Libreoffice font külön: https://www.dedoimedo.com/computers/libreoffice-plasma-kde-fonts.html
Mondjuk, érdekes dolog, hogy nálam (Xfce) OpenGL beállítás nincs, nem látható. Hm. Nyilván videó kártya függő. Telepítettem a i965-va-driver-shaders alkalmazást most a i965-va-driver helyett. Bekapcsoltam az OpenCL-t. Így sem látszik. Ja, mert nincs meg a minimum 3.3-as verzió:
https://wiki.documentfoundation.org/OpenGL

glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL core profile version string: 4.2 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

OpenGL hiba lehet: https://askubuntu.com/questions/848570/cant-enable-opengl-in-libreoffice...

A dmesg és a Xorg.0.log naplókat érdemes lenne megmutatni, még így is, a probléma megoldás után. Bár nem megoldás a kikapcsolt kompozitálás. Bekapcsolt kompozitálás után kéne megmutatni!

Nincs KDE-em. Neked a inux Mint 18.3 van telepítve? A 19.x kiadásoknál ne érhető el alapértelmezetten a KDE asztali környezet.

Értékelés: 

0
Még nincs értékelve
kimarite képe

~/.config/libreoffice

#6 Megpróbáltatod ezt is:

mv ~/.config/libreoffice ~/.config/libreoffice.ORIG

Majd elindítod a LibreOfficet.

Forrás: https://askubuntu.com/questions/1128980/kubuntu-18-04-issues-with-font-r...

Értékelés: 

0
Még nincs értékelve
kimarite képe

OOO_FORCE_DESKTOP="kde4" libreoffice

#7 Vagy így indítani:

OOO_FORCE_DESKTOP="kde4" libreoffice

Forrás: https://en.opensuse.org/SDB:KDE_Plasma_5

Értékelés: 

0
Még nincs értékelve
kimarite képe

SAL_USE_VCLPLUGIN=* libreoffice

#8 További környezeti változók:
https://wiki.archlinux.org/index.php/LibreOffice#Theme

SAL_USE_VCLPLUGIN=gen libreoffice
SAL_USE_VCLPLUGIN=kde4 libreoffice
SAL_USE_VCLPLUGIN=gtk libreoffice
SAL_USE_VCLPLUGIN=gtk3 libreoffice

Vagy más lehetőségek

SAL_USE_VCLPLUGIN=qt5 libreoffice
SAL_USE_VCLPLUGIN=gtk3_kde5 libreoffice

Innen: https://community.chakralinux.org/t/libreoffice-gets-qt5-and-plasma-inte...

További teszt: az Oxygen témát beállítása a Breeze helyett.

sudo apt-get install libreoffice-style-oxygen

Habár a Breeze is KDE téma.
https://forums.gentoo.org/viewtopic-p-8111074.html
https://kdeonlinux.wordpress.com/2015/03/25/breeze-love-libre-office/
https://tentangopensource.wordpress.com/category/kde/

-----

Bogár: https://bugs.documentfoundation.org/show_bug.cgi?id=124044

-----

Lehetőség:

sudo apt-get install libreoffice-gtk3

Forrás: https://www.linuxslaves.com/2018/09/fix-libreoffice-looks-awful-kde-plas...
http://www.ubuntubuzz.com/2017/06/fix-libreoffice-gtk-looks-ugly-on-kde-...

Valamelyik „megoldás” lehet.

Értékelés: 

0
Még nincs értékelve
kimarite képe

dmesg, Xorg.0.log

#6 A dmesg egy parancs, a Xorg.0.log

locate Xorg.0.log

itt:

/var/log/Xorg.0.log
/var/log/Xorg.0.log.old

Értékelés: 

0
Még nincs értékelve