Kernel frissítés után nem indul többé a Cinnamon (NAS)

Fórum: 

Mint 18.1

Ma újraindítottam a gépemet egy hétnyi frissítéssel. Utoljára kb 10 napja volt újraindítva a gép. A váltás, amire emlékszem: a 4.4.0.64-es kernelről a 4.4.0.66-osra.

Tünet: nem lép tovább a splash screenről. Ha GRUB beálításoknál kiveszem a "quite splash" részt, akkor szépen látom, hogy végigfut minden (mindenhol "OK"), és megáll amikor már csak a GUI jönne. Hálózat megy, minden fel van mountolva, SSH-n belépve a gépre tudtam indítani az X-et rootként (sudo startx), de sehogy máshogy nem nyekken meg a grafikus felület. Fórumokban bóklászva elég sokmindent újratelepítettem (mdm, xserver-xorg, stb), sőt még a gdm-et is felraktam átmenetileg, de azzal sem működött semmi.

Hardver: Asrock J3710 ITX.

Bármilyen segítségnek nagyon örülnék, tanácstalan vagyok. Az én gépemen lett elcsűrve valami, vagy a frissítésekkel jött valami bug vagy config változás?

RE:RE: frissítés után nem indul többé a Cinnamon

#1

startx

xauth:  file /home/nas/.Xauthority does not exist

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux NAS 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-66-generic root=UUID=b5d0ad4a-bf8a-453c-a6cf-97f3c46141db ro
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support (link is external))
Current version of pixman: 0.33.6
    Before reporting problems, check http://wiki.x.org (link is external)
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/nas/.local/share/xorg/Xorg.0.log", Time: Tue Mar 14 01:04:04 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
(EE)
(EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org (link is external)
 for help.
(EE) Please also check the log file at "/home/nas/.local/share/xorg/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn't get a file descriptor referring to the console

cat ~/.local/share/xorg/Xorg.0.log

[  4329.291]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[  4329.291] X Protocol Version 11, Revision 0
[  4329.291] Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
[  4329.291] Current Operating System: Linux NAS 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64
[  4329.291] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-66-generic root=UUID=b5d0ad4a-bf8a-453c-a6cf-97f3c46141db ro
[  4329.291] Build Date: 02 November 2016  10:06:10PM
[  4329.291] xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support)
[  4329.291] Current version of pixman: 0.33.6
[  4329.291]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  4329.291] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4329.291] (==) Log file: "/home/nas/.local/share/xorg/Xorg.0.log", Time: Tue Mar 14 01:04:04 2017
[  4329.295] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4329.298] (==) No Layout section.  Using the first Screen section.
[  4329.298] (==) No screen section available. Using defaults.
[  4329.298] (**) |-->Screen "Default Screen Section" (0)
[  4329.298] (**) |   |-->Monitor "<default monitor>"
[  4329.299] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[  4329.299] (==) Automatically adding devices
[  4329.299] (==) Automatically enabling devices
[  4329.299] (==) Automatically adding GPU devices
[  4329.299] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  4329.301] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  4329.301]     Entry deleted from font path.
[  4329.301] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  4329.301]     Entry deleted from font path.
[  4329.301] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  4329.301]     Entry deleted from font path.
[  4329.302] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  4329.302]     Entry deleted from font path.
[  4329.302] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  4329.302]     Entry deleted from font path.
[  4329.302] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[  4329.302] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[  4329.302] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4329.303] (II) Loader magic: 0x55c1c6ad2dc0
[  4329.303] (II) Module ABI versions:
[  4329.303]     X.Org ANSI C Emulation: 0.4
[  4329.303]     X.Org Video Driver: 20.0
[  4329.303]     X.Org XInput driver : 22.1
[  4329.303]     X.Org Server Extension : 9.0
[  4329.315] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_34
[  4329.316] (II) xfree86: Adding drm device (/dev/dri/card0)
[  4329.318] (EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted
[  4329.318] (II) config/udev: Ignoring already known drm device (/dev/dri/card0)
[  4329.320] (--) PCI:*(0:0:2:0) 8086:22b1:1849:22b1 rev 53, Mem @ 0x90000000/16777216, 0x80000000/268435456, I/O @ 0x0000f000/64
[  4329.320] (II) LoadModule: "glx"
[  4329.328] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  4329.338] (II) Module glx: vendor="X.Org Foundation"
[  4329.338]     compiled for 1.18.4, module version = 1.0.0
[  4329.338]     ABI class: X.Org Server Extension, version 9.0
[  4329.338] (==) AIGLX enabled
[  4329.338] (==) Matched intel as autoconfigured driver 0
[  4329.338] (==) Matched modesetting as autoconfigured driver 1
[  4329.338] (==) Matched fbdev as autoconfigured driver 2
[  4329.338] (==) Matched vesa as autoconfigured driver 3
[  4329.338] (==) Assigned the driver to the xf86ConfigLayout
[  4329.338] (II) LoadModule: "intel"
[  4329.338] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  4329.341] (II) Module intel: vendor="X.Org Foundation"
[  4329.341]     compiled for 1.18.4, module version = 2.99.917
[  4329.341]     Module class: X.Org Video Driver
[  4329.341]     ABI class: X.Org Video Driver, version 20.0
[  4329.341] (II) LoadModule: "modesetting"
[  4329.342] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  4329.343] (II) Module modesetting: vendor="X.Org Foundation"
[  4329.343]     compiled for 1.18.4, module version = 1.18.4
[  4329.343]     Module class: X.Org Video Driver
[  4329.343]     ABI class: X.Org Video Driver, version 20.0
[  4329.343] (II) LoadModule: "fbdev"
[  4329.343] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  4329.343] (II) Module fbdev: vendor="X.Org Foundation"
[  4329.343]     compiled for 1.18.1, module version = 0.4.4
[  4329.343]     Module class: X.Org Video Driver
[  4329.343]     ABI class: X.Org Video Driver, version 20.0
[  4329.343] (II) LoadModule: "vesa"
[  4329.344] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  4329.344] (II) Module vesa: vendor="X.Org Foundation"
[  4329.344]     compiled for 1.18.1, module version = 2.3.4
[  4329.344]     Module class: X.Org Video Driver
[  4329.344]     ABI class: X.Org Video Driver, version 20.0
[  4329.344] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  4329.345] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[  4329.345] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[  4329.345] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[  4329.345] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  4329.345] (II) FBDEV: driver for framebuffer: fbdev
[  4329.345] (II) VESA: driver for VESA chipsets: vesa
[  4329.345] (EE)
Fatal server error:
[  4329.345] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
[  4329.345] (EE)
[  4329.345] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
[  4329.345] (EE) Please also check the log file at "/home/nas/.local/share/xorg/Xorg.0.log" for additional information.
[  4329.345] (EE)
 

A videó driverhez nem nyúltam, nem kellett bajlódni a telepítésével külön (Intel).

Van heti mentésem a rendszerről: ha van arra ötlet, hogy milyen config fájlokat hasonlítsak össze, már az is segítség.

Értékelés: 

0
Még nincs értékelve

RE: Frissítés után nem indul többé a Cinnamon

#2
xauth:  file /home/nas/.Xauthority does not exist

Automatikus bejelentkezésre van állítva a rendszer?
Nem lehet, hogy sudo-val indítottál grafikus felületen futó alkalmazást és az .Xauthority a root tulajdonába került?
Ha ez a helyzet, akkor egy

sudo chown -R $USER:$USER /home/$USER

segíthet a dolgon.

Értékelés: 

0
Még nincs értékelve

RE:RE: Frissítés után nem indul többé a Cinnamon

#3

Nincs engedélyezve az automatikus bejelentkezés.

Egyszer egy hasonló dolgot sikerült azzal megoldani, hogy a ".ICEauthority" és a ".Xauthority" fájloknak visszaállítottam a jogosultságát ahogy írtad, de most ez nem működött. A legutolsó próbálkozásnál simán töröltem ezeket a fájlokat, és újrakreálta őket az X, ez látszik a logon. (Tehát a mostani ".Xauthority" fájl a $USER:$USER tulajdonában van 600 jogosultsággal.)

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE: frissítés után nem indul többé a Cinnamon

#2 Ez egy szerver? Mit lehet tudni a gépről, rendszerről 'amúgy'? Van rákötve amúgy monitor? És billentyűzet vagy egér?
SSH nélkül, inkább konzolra átlépve (pl. Ctrl + Alt + F2) kéne megpróbálni a startx parancsot. Amúgy rég nem a startx indítja a rendszert, ha mégis, akkor az pl. a .xinitrc fájlban lehet rögzítve. Van neked .xinitrc fájlod?

Az alábbi -egyetlen- parancs futtatása

sudo udevadm hwdb --update 2>&1 | tee -a testXlogin_01.txt ; echo ----- 2>&1 | tee -a testXlogin_01.txt ; xrandr 2>&1 | tee -a testXlogin_01.txt ; echo ----- 2>&1 | tee -a testXlogin_01.txt ; loginctl 2>&1 | tee -a testXlogin_01.txt ; echo ----- 2>&1 | tee -a testXlogin_01.txt ; echo ----- 2>&1 | tee -a testXlogin_01.txt ; inxi -F 2>&1 | tee -a testXlogin_01.txt ; echo ----- 2>&1 | tee -a testXlogin_01.txt ; systemd-cgls --no-pager 2>&1 | tee -a testXlogin_01.txt

után a kimenet szövegfájlt (testXlogin_01.txt) megnyitva, annak tartalmát töltsd fel a https://paste.ubuntu.com/ oldalra, és mentés után az URL kéne ide. Hosszú szövegfájloknál máskor is az előbb említett oldalt használd megosztásra.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE: frissítés után nem indul többé a Cinnamon

#5

Ez egy NAS, vagyis fájlmegosztásra (sshfs) és tartalomlejátszásra használom. Van rákötve egy TV, billentyűzet és egér. (A fájlmegosztás működik jelenleg is értelemszerűen.)

Konzolra nem tudok átlépni, Ctrl+Alt+F2-re csak egy villogó kurzort kapok a bal felső sarokban, Ctrl+Alt+F1-gyel vissza tudok lépni a rendszerüzenetekhez.

Saját ".xinitrc" fájlja nincs a felhasználónak, a rendszeren itt van ez a fájl: "/etc/X11/xinit/xinitrc"

Király ez a paste.ubuntu.com oldal! Íme a kimenet (SSH-val): https://paste.ubuntu.com/24178025/

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE: frissítés után nem indul többé a Cinnamon

#2 A mostani kimenetekben -túl sok- új nem látható / található sajnos.
Az nvidia kártyára írnak érdekességeket a kernellel kapcsolatosan, legalábbis arra találtam.

Emiatt viszont

(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

kéne a következő kimenet:

ls -la /usr/bin/Xorg

Nálam az alábbi:

-rwxr-xr-x 1 root root 2564976 febr  11  2015 /usr/bin/Xorg

Forrás:
https://bbs.archlinux.org/viewtopic.php?id=35143

::::

Mellékesen:

-- mi van ebben a fájlban?

more /etc/X11/Xwrapper.config

-- telepítve van az alábbi csomag?

dpkg -l xserver-xorg-legacy

Habár utóbbiakból egy másik hibára lehet következtetni, azért megkérdezem.
(ezeken az oldalakon szó van erről a témáról
https://bugs.launchpad.net/ubuntu/+source/xinit/+bug/1562219
https://ubuntuforums.org/showthread.php?t=2328593
de vélelmezem, talán az első kérdésemre itt
https://bbs.archlinux.org/viewtopic.php?id=35143
a már linken fórumról érkezhet a jó válasz:

chmod u+s /usr/bin/Xorg

persze, csak, ha nagyon más a Xorg tulajdonosa, mint a nálam látható ...
Jó lenne az a kimenetet is látni, mielőtt a parancs 'lefut'.)

Értékelés: 

5
Átlag: 5 (1 szavazat)

RE:RE:RE:RE: frissítés után nem indul többé a Cinnamon

#7

ls -la /usr/bin/Xorg
-rwxr-xr-x 1 root root 274 Nov  3 00:12 /usr/bin/Xorg
more /etc/X11/Xwrapper.config
more: stat of /etc/X11/Xwrapper.config failed: No such file or directory
dpkg -l xserver-xorg-legacy
dpkg-query: no packages found matching xserver-xorg-legacy

Feltettem az xserver-xorg-legacy csomagot, éééés MŰKÖDIK! Lógok eggyel, hálám üldözni fog! :) Már csak azt nem értem, hogy az a csomag hogy tűnt el, de most nem érdekel. :)

KÖSZÖNÖM!!

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE:RE: frissítés után nem indul többé a Cinnamon

#8 Előfordulhat, hogy a rendszer által létrehozott, újonnan létrejött '.Xauthority' nem tartalmazott elég információt a 'nas' nevű felhasználóhoz.
https://wiki.archlinux.org/index.php/Systemd/User#DISPLAY_and_XAUTHORITY
Mindenesetre a /etc/X11/Xwrapper.config alapvetően már nem létezik (a Linux Mint 18-tól)
https://github.com/dnschneid/crouton/issues/2185
a Debian SID-ben. Így az előbbire (SID) épülő Ubuntu 16.04-ben sem, melyből a Linux Mint 18 változata készül. Nálam még igen, de én a Debian Jessie kiadását használom. Mindezen változást a systemd 'hozta'.
Azt nem tudom, még mi okozhatta a jelenséget, lehetséges, a 'sudo' nem megfelelő használata.
Az Xwrapper.config épp ilyen beállításokra jó,
http://manpages.ubuntu.com/manpages/trusty/man5/Xwrapper.config.5.html
de az xserver-xorg-legacy csomag leírása is a jogokkal függ össze.
https://www.reddit.com/r/debian/comments/3nz0vz/psa_x_server_is_now_runn...
Ez egy wrapper, a setuid root állítgatására (ez állítódhatott el valahogy), továbbá írják fentebb, hogy zárt forráskódú drivereknél előnyös, ha telepítve van, ezt én nem tudom.

A fenti beállítófájl hiányában így is állíthatóak a jellemzők.
(de nyilván neked felesleges, mert nálad éppen megfelelőek a telepítéskori beállítások)

A kép csak szemléltetés. Az indító parancsa:

sudo dpkg-reconfigure x11-common

Forrás:
https://www.raspberrypi.org/forums/viewtopic.php?p=344408

Örülök, hogy helyrejött a rendszered. :-)

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE: frissítés után nem indul többé a Cinnamon

#9

Köszi a magyarázatot, így már nagyjából értem, hogy mi is történt. Szörnyű ingoványos vidék ez az Xserver... :)

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE:RE: frissítés után nem indul többé a Cinnamon

#10 Egy újraindításig működött, azóta megint nem. A tünet ugyanaz. Keresgélek még egy kicsit, de valószínűleg okosabb lesz visszaállítani a gépet hónap eleji állapotra.

Értékelés: 

0
Még nincs értékelve
kimarite képe

*RE: frissítés után nem indul többé a Cinnamon

#12 Az 'egy újraindításig működött' jelzésedre a válaszomhoz tudni kéne, mit csináltál pontosan. Tehát, a *-legacy csomagot telepítetted, és egyszer újraindítva a rendszert, működött rendesen, de másodszorra már nem. Ezen kívül állítottál mást is, mit csináltál még?

Értékelés: 

0
Még nincs értékelve

RE:*RE: frissítés után nem indul többé a Cinnamon

#13 Igen, követtem az utasításokat a *-legacy csomag telepítéséig, kipróbáltam azon a ponton (is), és újraindítva működött minden. Ekkor hagytam a NAS-t napokig ahogy szoktam, nem változtattam semmin közben, csak szokásos módon telepítettem a frissítéseket, de nem volt a napokban xorg, kernel vagy hasonló frissítés. Mivel sokáig bekapcsolva hagyva a gépet egy idő után eltűnik a kimeneti hang opciók közül a HDMI (amit egy újraindítás mindig orvosol, ez így van mióta telepítettem a gépet hónapokkal ezelőtt), ezért újraindítottam a gépet, hogy a kiszemelt film megnézése közben még hang is legyen. Az újraindítás nem sikerült, ugyanott döglik meg a gép. Se grafikus felület, se terminál, csak SSH.

De na bajlódj ezzel, most van egy kis időm, így visszarakom a hónap eleji mentett rendszert.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:*RE: frissítés után nem indul többé a Cinnamon

#14 Ha ezt indítod, melyik beállításon áll?

sudo dpkg-reconfigure x11-common

Ha nem a 'Csak konzol felhasználók'-on van, próbáld azt. Ha azon, akkor nyomj OK-t. Ha nem változtatnál, nyomj Esc-t.

Értékelés: 

0
Még nincs értékelve

RE:RE:*RE: frissítés után nem indul többé a Cinnamon

#14

Szívás van. A backupot feltéve ez az üzenet fogadott:

Could not start the X server (your graphical environment) due to some internal error.
Please contact your system administrator  or check your syslog to diagnose.
In the meantime this display  will be disabled. Please restart MDM when the problem is corrected.

Többet ezt sem írta ki, de most már legalább a hálózat és a macerás mountok is haza vannak vágva. :( Magyarul reinstall lesz annak minden szívásával ha nem akarok live diskről chrootolgatni, hogy megjavítsam a fogalmam sincs micsodát.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:*RE: frissítés után nem indul többé a Cinnamon

#16 A chroot jó :-)

or check your syslog to diagnose.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:*RE: frissítés után nem indul többé a Cinnamon

#17 Na, a konokságom győzött, kipofoztam a backupot, az X más miatt nem működött (read-only mount) a backupnál.

Szóval most áll a rendszer, működik az X, minden oké, többször teszteltem az újraindítást, stb.

Ezek a frissítések sorakoztak fel azóta, valamelyik ezek közül szedte szét a rendszeremet. Most nyilván nem merem felrakni őket, majd jövő héten jobban megnézem a listát.

Értékelés: 

0
Még nincs értékelve