E-személyi kliens telepítése

Laci képe

Fórum: 

 Üdv.

Letöltöttem a honlapról : eszemelyi.hu/letoltesek de nem lehet telepíteni.

 laci@laci-desktop ~ $ sudo dpkg -i eSzemelyi_Kliens_x86_1_2_8.deb

[sudo] laci jelszava: 

A korábban ki nem választott eszemelyi-kliens csomag kiválasztása.(Adatbázis olvasása ... 442940 fájl és könyvtár van jelenleg telepítve.)Kibontás előkészítése: eSzemelyi_Kliens_x86_1_2_8.deb ...Kibontás: eszemelyi-kliens (1.2.8) ...dpkg-deb (alfolyamat): nem lehet másolni az archívumtagot innen: „eSzemelyi_Kliens_x86_1_2_8.deb” a kibontó csőbe: váratlan fájl vagy folyam végdpkg-deb (alfolyamat): archívumtag kibontása: lzma hiba: váratlan bemenetvégdpkg-deb: hiba: <kibontás> alfolyamat 2 hibakóddal kilépettdpkg: hiba az archívum feldolgozásakor: eSzemelyi_Kliens_x86_1_2_8.deb (--install): nem másolhatók a kibontott adatok ehhez: „./usr/lib/KEKKH/Qt5/libQt5Core.so.5.5.1” ide: „/usr/lib/KEKKH/Qt5/libQt5Core.so.5.5.1.dpkg-new”: váratlan fájl vagy folyam végAktiválók feldolgozása: desktop-file-utils (0.22+linuxmint1) ...Aktiválók feldolgozása: mime-support (3.59ubuntu1) ...Hibák történtek a feldolgozáskor: eSzemelyi_Kliens_x86_1_2_8.deb laci@laci-desktop ~ $  Valami ötlet??Laci.

Laci képe

 Kormányzat. Bővebben:

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Kormányzat. Bővebben:

#2 Az lzma egy tömörítő alkalmazás, és nem tudja kibontani.

Unpacking eszemelyi-kliens (1.2.8) ...
dpkg-deb (alfolyamat): cannot copy archive member from 'eSzemelyi_Kliens_x86_1_2_8.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (alfolyamat): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: <decompress> alfolyamat 2 hibakóddal kilépett

A kibontás nem lehetséges, így a későbbi folyamatok sem futtathatóak.

dpkg: error processing archive eSzemelyi_Kliens_x86_1_2_8.deb (--install):
 cannot copy extracted data for './usr/lib/KEKKH/Qt5/libQt5Core.so.5.5.1' to '/usr/lib/KEKKH/Qt5/libQt5Core.so.5.5.1.dpkg-new': unexpected end of file or stream
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Hibák történtek a feldolgozáskor:
 eSzemelyi_Kliens_x86_1_2_8.deb

Próbáld az Archívumkezelővel, de az sem tudja kibontani: a 'data.tar.xz' fájl sérült ..., de még ránézek máshogy.

A gdebi ezt a hibát dobja:

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Kormányzat. Bővebben:

#3 További hibák

dpkg -x eSzemelyi_Kliens_x86_1_2_8.deb tmp/
dpkg-deb (alfolyamat): cannot copy archive member from 'eSzemelyi_Kliens_x86_1_2_8.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (alfolyamat): decompressing archive member: lzma error: unexpected end of input
tar: Váratlan fájlvége jel az archívumban
tar: Váratlan fájlvége jel az archívumban
tar: Error is not recoverable: exiting now
dpkg-deb: error: tar alfolyamat 2 hibakóddal kilépett
ar vx eSzemelyi_Kliens_x86_1_2_8.deb 
x - debian-binary
x - control.tar.gz
x - data.tar.xz
ar: eSzemelyi_Kliens_x86_1_2_8.deb is not a valid archive
dpkg-deb -I eSzemelyi_Kliens_x86_1_2_8.deb
 new debian package, version 2.0.
 size 9532870 bytes: control archive=307 bytes.
     267 bytes,     7 lines   *  control             
 package: eszemelyi-kliens
 version: 1.2.8
 architecture: i386
 maintainer: ID&Trust Kft. <support@idandtrust.com>
 description: eSzemelyi Kliens Installer
              Installer of the eSzemelyi Kliens software package for the Hungarian eSzig card.
 installed-size: 26823
dpkg-deb -W eSzemelyi_Kliens_x86_1_2_8.deb
eszemelyi-kliens    1.2.8
dpkg-deb -x eSzemelyi_Kliens_x86_1_2_8.deb tmp/
dpkg-deb (alfolyamat): cannot copy archive member from 'eSzemelyi_Kliens_x86_1_2_8.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (alfolyamat): decompressing archive member: lzma error: unexpected end of input
tar: Váratlan fájlvége jel az archívumban
tar: Váratlan fájlvége jel az archívumban
tar: Error is not recoverable: exiting now
dpkg-deb: error: tar alfolyamat 2 hibakóddal kilépett
dpkg -c eSzemelyi_Kliens_x86_1_2_8.deb
drwxr-xr-x root/root         0 2017-05-10 14:28 ./
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/bin/
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/share/
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/share/applications/
-rw-r--r-- root/root       204 2017-05-10 14:28 ./usr/share/applications/eszig-cmu.desktop
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/KEKKH/
-rwxrwxr-x root/root     14504 2017-05-10 14:28 ./usr/lib/KEKKH/release-notes.txt
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/KEKKH/node_modules/
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/KEKKH/platforms/
-rwxr-xr-x root/root      9908 2017-05-10 14:28 ./usr/lib/KEKKH/platforms/libqxcb.so
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/KEKKH/imageformats/
-rwxr-xr-x root/root     26520 2017-05-10 14:28 ./usr/lib/KEKKH/imageformats/libqico.so
-rwxrwxr-x root/root  13432499 2017-05-10 14:28 ./usr/lib/KEKKH/libjx.so
-rwxrwxr-x root/root   1990847 2017-05-10 14:28 ./usr/lib/KEKKH/eszig-pkcs11.so.1.1.2
drwxr-xr-x root/root         0 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/
-rwxr-xr-x root/root   6506888 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5Widgets.so.5.5.1
-rwxr-xr-x root/root    523140 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5DBus.so.5.5.1
-rwxr-xr-x root/root   1887208 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5XcbQpa.so.5.5.1
-rwxr-xr-x root/root   5104700 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5Gui.so.5.5.1
-rwxr-xr-x root/root   1425500 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5Network.so.5.5.1
-rwxr-xr-x root/root   5988420 2017-05-10 14:28 ./usr/lib/KEKKH/Qt5/libQt5Core.so.5.5.1
dpkg-deb (alfolyamat): cannot copy archive member from 'eSzemelyi_Kliens_x86_1_2_8.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (alfolyamat): decompressing archive member: lzma error: unexpected end of input
tar: Váratlan fájlvége jel az archívumban
tar: Error is not recoverable: exiting now
dpkg-deb: error: tar alfolyamat 2 hibakóddal kilépett

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: E-személyi kliens telepítése

@Laci Nálad: Linux Mint 17+ vagy 18+ ?
Írtam nekik. ... vasárnap van, de jött egy előzetes:

Tisztelt Ügyfelünk!
Köszönjük, hogy elektronikus levelével a Kormányzati Ügyfélvonalhoz fordult.
Válaszunkig szíves türelmét kérjük.
Tisztelettel:
Kormányzati Ügyfélvonal

Dear Sir or Madam,
Thank you for contacting the Governmental Information Center.
We kindly ask your patience until we reply.
Yours sincerely,
Governmental Information Center

A válasz címe a következő:

Automatikus válasz: ***SPAM*** eSzemelyi_Kliens - Linux DEB telepítő hiba (32 bit)

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: E-személyi kliens telepítése

#5 Csak azért kérdezem, mit használsz, mert ezekre írják, hogy támogatott:
https://eszemelyi.hu/dok/eSzemelyi_Kliens_Telepitesi_Utmutato_v5.2.pdf

Linux disztribúciók: CentOS 7, Debian 8, SuSe 13.2, Ubuntu 14.04.5 LTS
Megjegyzés: A Gnome X11-es felület csak a 3.4-es verziótól támogatott, a következő
extension telepítése után: https://extensions.gnome.org/extension/495/topicons/
A Linux disztribúciók jelenleg nem támogatják a ReinerSCT cyberJack RFID standard
olvasóját.

Persze, az egy érdekes kérdés, hogy a Qt5 mennyire támogatott már ezeken a rendszereken.

Értékelés: 

0
Még nincs értékelve
Laci képe

RE: E-személyi kliens telepítése

Linux Mint 18 Sonya 32-bit,

Találtam egy másikat, eszemelyi.hu/app/eSzemelyi_Kliens_x86_1_2_8.rpm , ezt átkevertem aliennel, így telepíthető lett.

De ez nekem nem lett jó, mert érintés nélküli leolvasót és kártyát kíván, nekem pedig csipes van. Hogy ezt miért nem írták a honlapjukon?? A leolvasót mellesleg felismeri, de a kártyával már nem hajlandó kommunikálni.

Találtam egy másikat, ez állítólag csippeshez való, hiteles.gov.hu/letoltes/167/Classic_Client_Ubuntu_32bit_7.0.0-b08.deb de ennek meg mindenféle nyűgje van telepítéskor. ::.libssl0.9.8 (>= 0.9.8m-1)::: .....nem fogok káromkodni.... ... ...

Laci

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: E-személyi kliens telepítése

#7 A függőségekből (control fájl)

Package: libclassicclient
Version: 7.0.0-b08
Architecture: i386
Maintainer: Gemalto <hotline@gemalto.com>
Installed-Size: 16690
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.8.0), libncurses5 (>= 5.5-5~), libpango-1.0-0 (>= 1.14.0), libpcsclite1 (>= 1.3.3), libqt5core5a (>= 5.0.2), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5widgets5 (>= 5.0.2), libssl0.9.8 (>= 0.9.8m-1), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.6), libtinfo5, libusb-0.1-4 (>= 2:0.1.12), pcscd
Section: libs
Priority: optional
Description: Gemalto Classic Client for Linux
 This package provides a PKCS#11 token for Classic cards
 .
 The PKCS#11 token filename is /usr/lib/pkcs11/libgclib.so

két fájl nem elérhető, a libssl -ek (ez egy Debian kimenet, de nálad is a Trusty kiadás csomaga
https://packages.ubuntu.com/search?arch=i386&keywords=libssl0.9.8
is túl új)

apt-cache policy libgcc1 libatk1.0-0 libc6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libncurses5 libpango-1.0-0 libpcsclite1 libqt5core5a libqt5gui5 libqt5gui5-gles libqt5widgets5 libssl0.9.8 libssl1.0.0 libstdc++6 libtinfo5 libusb-0.1-4 pcscd
libgcc1:
  Telepítve: 1:6.3.0-18
  Jelölt:    1:6.3.0-18
  Verziótáblázat:
 *** 1:6.3.0-18 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libatk1.0-0:
  Telepítve: 2.22.0-1
  Jelölt:    2.22.0-1
  Verziótáblázat:
 *** 2.22.0-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libc6:
  Telepítve: 2.24-11+deb9u1
  Jelölt:    2.24-11+deb9u1
  Verziótáblázat:
 *** 2.24-11+deb9u1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        500 http://security.debian.org stable/updates/main i386 Packages
        100 /var/lib/dpkg/status
libgdk-pixbuf2.0-0:
  Telepítve: 2.36.5-2
  Jelölt:    2.36.5-2
  Verziótáblázat:
 *** 2.36.5-2 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libglib2.0-0:
  Telepítve: 2.50.3-2
  Jelölt:    2.50.3-2
  Verziótáblázat:
 *** 2.50.3-2 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libgtk2.0-0:
  Telepítve: 2.24.31-2
  Jelölt:    2.24.31-2
  Verziótáblázat:
 *** 2.24.31-2 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libncurses5:
  Telepítve: 6.0+20161126-1
  Jelölt:    6.0+20161126-1
  Verziótáblázat:
 *** 6.0+20161126-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libpango-1.0-0:
  Telepítve: 1.40.5-1
  Jelölt:    1.40.5-1
  Verziótáblázat:
 *** 1.40.5-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libpcsclite1:
  Telepítve: 1.8.20-1
  Jelölt:    1.8.20-1
  Verziótáblázat:
 *** 1.8.20-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libqt5core5a:
  Telepítve: 5.7.1+dfsg-3+b1
  Jelölt:    5.7.1+dfsg-3+b1
  Verziótáblázat:
 *** 5.7.1+dfsg-3+b1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libqt5gui5:
  Telepítve: 5.7.1+dfsg-3+b1
  Jelölt:    5.7.1+dfsg-3+b1
  Verziótáblázat:
 *** 5.7.1+dfsg-3+b1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libqt5gui5-gles:
  Telepítve: (nincs)
  Jelölt:    (nincs)
  Verziótáblázat:
libqt5widgets5:
  Telepítve: 5.7.1+dfsg-3+b1
  Jelölt:    5.7.1+dfsg-3+b1
  Verziótáblázat:
 *** 5.7.1+dfsg-3+b1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libssl0.9.8:
  Telepítve: (nincs)
  Jelölt:    (nincs)
  Verziótáblázat:
libssl1.0.0:
  Telepítve: (nincs)
  Jelölt:    (nincs)
  Verziótáblázat:
libstdc++6:
  Telepítve: 6.3.0-18
  Jelölt:    6.3.0-18
  Verziótáblázat:
 *** 6.3.0-18 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libtinfo5:
  Telepítve: 6.0+20161126-1
  Jelölt:    6.0+20161126-1
  Verziótáblázat:
 *** 6.0+20161126-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
libusb-0.1-4:
  Telepítve: 2:0.1.12-30
  Jelölt:    2:0.1.12-30
  Verziótáblázat:
 *** 2:0.1.12-30 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages
        100 /var/lib/dpkg/status
pcscd:
  Telepítve: (nincs)
  Jelölt:    1.8.20-1
  Verziótáblázat:
     1.8.20-1 500
        500 http://ftp.cz.debian.org/debian stable/main i386 Packages

Mivel ez egy security csomag, talán érdemes lehet újraforgatni a *-dev fájl felhasználásával a csomagot.
https://packages.ubuntu.com/search?suite=default&section=all&arch=i386&k...
A control fájlból nem igazán vehetem ki, pont a security volta miatt.

:::::

Na de mégis. Készítettem két fájlt, ezekkel próbáld:

-- Linux Mint 18+ (Ubuntu 16.04)
https://send.firefox.com/download/4f7989fdfe/#UVn4QG74zVzjwaWf2jr7wA

-- Debian Stretch (az érdekesség kedvéért)
https://send.firefox.com/download/0a23ea2c78/#av1njiutpRlEF32sNSfW_Q

!https://linuxmint.hu/hir/2017/08/firefox-send-a-mozilla-bemutatta-a-legj...
Megkérnék mindenkit, hogy ne töltse le, mert egyszeri letöltés lehetséges, úgy azt a kérdező tehesse meg.

Forrás (source) sajnos nem elérhető:
https://hiteles.gov.hu/cikk/53/classic_client_ubuntu_linuxhoz

Az újrakonfigurált DEB -et nem telepítettem, de lehetséges lenne.

A módszer -a control fájl megváltoztatása miatt- most ez volt:
https://gist.github.com/shamil/3140558

Use folowing steps to repackage dep package:

1: Extract deb package

dpkg-deb -x <package.deb> <dir>

2: Extract control-information from a package

dpkg-deb -e <package.deb> <dir/DEBIAN>

3. After completed to make changes to the package, repack the deb

dpkg-deb -b <dir> <new-package.deb>

-----

A <dir> nálam = debian.

-- először létrehozod

mkdir debian

-- majd (Példa):

dpkg-deb -x Classic_Client_Ubuntu_32bit_7.0.0-b08.deb debian/
dpkg-deb -e Classic_Client_Ubuntu_32bit_7.0.0-b08.deb debian/DEBIAN

-- a control fájl szerkesztése után újracsomagolod

dpkg-deb -b debian/ Classic_Client_Ubuntu_32bit_7.0.0-b08_lm18_ub16.04.deb

A 'control' fáljban a függőségek közül kivettem (töröltem) ezt a függőséget (mondván, az újabb is jó lesz, ami mellette látható)

libssl0.9.8 (>= 0.9.8m-1)

és ennek a csomag függőségnek

libssl1.0.0 (>= 1.0.0)

a verziószámát változtattam arra a minimumra, amely -az aktuális- Linux Mint alatt vagy a Debian alatt elérhető.

Így nézed meg, mi a legnagyobb verziószámú, a control fájban megkívánt csomaghoz hasonló nevű csomag:

apt-cache policy libssl*

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: E-személyi kliens telepítése

#8 A control fájl tartalma - ha valaki mégis előtted letöltötte volna a DEB -et:

-- Linux Mint 18+

Package: libclassicclient
Version: 7.0.0-b08
Architecture: i386
Maintainer: Gemalto <hotline@gemalto.com>
Installed-Size: 16690
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.8.0), libncurses5 (>= 5.5-5~), libpango-1.0-0 (>= 1.14.0), libpcsclite1 (>= 1.3.3), libqt5core5a (>= 5.0.2), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5widgets5 (>= 5.0.2), libssl1.0 (>= 1.0), libstdc++6 (>= 4.6), libtinfo5, libusb-0.1-4 (>= 2:0.1.12), pcscd
Section: libs
Priority: optional
Description: Gemalto Classic Client for Linux
 This package provides a PKCS#11 token for Classic cards
 .
 The PKCS#11 token filename is /usr/lib/pkcs11/libgclib.so

-- Debian Stretch

Package: libclassicclient
Version: 7.0.0-b08
Architecture: i386
Maintainer: Gemalto <hotline@gemalto.com>
Installed-Size: 16690
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.8.0), libncurses5 (>= 5.5-5~), libpango-1.0-0 (>= 1.14.0), libpcsclite1 (>= 1.3.3), libqt5core5a (>= 5.0.2), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5widgets5 (>= 5.0.2), libssl1.1 (>= 1.1), libstdc++6 (>= 4.6), libtinfo5, libusb-0.1-4 (>= 2:0.1.12), pcscd
Section: libs
Priority: optional
Description: Gemalto Classic Client for Linux
 This package provides a PKCS#11 token for Classic cards
 .
 The PKCS#11 token filename is /usr/lib/pkcs11/libgclib.so

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: E-személyi kliens telepítése

#5 A válasz ma megérkezett. A beszélgetés szereplőit kommenteltem:

Tisztelt X Y!

Köszönjük, hogy kérdésével a Kormányzati Ügyfélvonalhoz fordult!

Kérdését továbbítottuk a fejlesztők részére, visszajelzésükig szíves türelmét kérjük.

Amennyiben további kérdése van vagy információra lenne szüksége, forduljon továbbra is bizalommal hozzánk!

Tisztelettel:

Y X

Kormányzati Ügyfélvonal

Értékelés: 

0
Még nincs értékelve