20.2-re frissítés

Fórum: 

Néhány perccel ezelőtt frissült a Frissítéskezelő. Azzal járt, hogy -> "Szerkesztés" - megjelent benne a 20.2-re történő frissítés lehetősége. https://ibb.co/st2q4Q7 Ma már nem, de holnap elindítom - miután csináltam egy friss rendszer-visszaállítási pontot.

20.2-re frissítés

#2 Én is frissítettem, még tegnap. Frissítés előtt a szoftverforrásokat alapértelmezettre kellett állítani, mert különben nem jelent meg a frissítési lehetőség.
Az update elég gyorsan lefutott. Két dolgot figyeltem meg: a Thunar ikonja megváltozott (bizonyára több alkalmazásé is) és az oldal-és alsó panel (Xfce-n) tovább marad a képernyőn, mint eddig (nálam ugyanis rejtve vannak). Hol lehet ezt az időt állítani?
Amit még a mai napig nem tudtam elérni, hogy az NVIDIA X Server Settings megfelelően működjön, mert most csak a processzor grafikája dolgozik, az NVIDIA dedikált chipje nem választható, bármit is állítok be az Illesztőprogram-kezelőben. Régebben volt már erről szó, de megoldás akkor sem született. Jelenleg az nvidia-driver-465 az aktuális. Ezt a problémát a 20.2-es verzió sem oldotta meg.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#3 20-ról 20.2-re történő frissítés után, egyelőre csak annyit vettem észre, hogy
felfüggesztésből szinte azonnal automatikusan "felébred". :(

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#4 Nálam (Xfce) jó a felfüggesztés az Umán. Cinnamon probléma lehet?

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#5 Cinnamon felületet használok - több mint valószínű hogy ez a felfüggesztési probléma
a 20.2-re frissítéssel jött be - mert a gépem hardware összetétele nem változott.
A 20-on jó volt - ritkán használtam - úgy-hogy különösebb problémát nem okoz. :)

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#6 Új gépekre "Edge" (?) https://linuxmint-user-guide.readthedocs.io/en/latest/edge.html

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés

#3 Jelenleg az nvidia-driver-465 az aktuális.

Ez jelenleg a legújabb, de az eszközhöz ez az ajánlott (recommended) is?

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#8 Így néz ki az Illesztőprogram-kezelő: https://ibb.co/94g0Pqb
Ajánlottat nem látok. Az xserver-xorg-video-nouveau beállításával sem jó.
Az NVIDIA X Server Settings elindítása ezzel az eredménnyel zárul: https://ibb.co/8xrSrXZ
A videochip ez: NVIDIA GeForce 940M (2GB VRAM).

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés

#9 Kimenet?

ubuntu-drivers devices ; inxi -r

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#10 Közben átállítottam xserver-xorg-video-nouveau-ra, de ezzel se jó.

lajos@lajos-Aspire-E5-772G:~$ ubuntu-drivers devices ; inxi -r
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:1c.4/0000:04:00.0 ==
modalias : pci:v000010DEd00001347sv00001025sd00000974bc03sc02i00
vendor   : NVIDIA Corporation
model    : GM108M [GeForce 940M]
driver   : nvidia-driver-465 - third-party non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-460 - third-party non-free recommended
driver   : nvidia-driver-390 - third-party non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/audio-recorder-ppa-focal.list 
  1: deb http://ppa.launchpad.net/audio-recorder/ppa/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/gezakovacs-ppa-focal.list 
  1: deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/google-earth-pro.list 
  1: deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-focal.list 
  1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/megasync.list 
  1: deb https://mega.nz/linux/MEGAsync/xUbuntu_20.04/ ./
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com uma main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/snappy-dev-tools-focal.list 
  1: deb http://ppa.launchpad.net/snappy-dev/tools/ubuntu focal main

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés

#11 Ezt kéne telepíteni (recommended, azaz, magyarul ajánlott):

 driver   : nvidia-driver-460 - third-party non-free recommended

A jelenleg használtat és annak beállításat el kell távolítani.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés

#12 A driverek eltávolításához és telepítéséhez segítséget kérnék, nem vagyok jártas az ilyenekben.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | PPA kikapcsolása

#13 Mutatnál kimenetet?

apt-cache policy nvidia-driver-460 nvidia-driver-465

A Proprietary GPU Drivers PPA ( https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa ) nélkül is próbáltad a telepítést korábban, ha igen, melyik driver verzióval? Mert az is egy módszer lenne, hogy kikapcsolod a PPA-t (Szoftverforrások vagy Synaptic), és persze ehhez kell a változtatás érvényesítése, elemmel vagy terminálban ( sudo apt-get update ), majd megnézed a parancssor kimenetét:

ubuntu-drivers devices

Ha továbbra is recommended/ajánlott a 460-as, akkor az telepíted.
És itt jön a következő...

Az eltávolításnak több módszere van:
-- a képen látott Illesztőprogramkezelőben kiválasztod a 460-as drivert (ez az ajánlott),
-- esetleg a Synaptic csomagkezelőben megkeresed a telepített drivert és a Teljes eltávolítását választod, majd telepíted a 46-ast.

Jelenleg a 460/465 verziójú driverekből kettő érhető el, és az újabb fog települni, amíg a PPA be van kapcsolva. Nem tudjuk, melyik a jobb, a rendszer tükörről származó vagy a PPA-s. Az biztos, egyedi eszközöd van, és előfordulhat, ha bármelyik driver is jó, tovább kell kutatni a megoldást valamilyen környezeti változóval vagy szöveges beállítással.

-----

Az most is jelentkező problémádról,

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:1904): GLib-GObject-CRITICAL **: 18:25:15.150: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 18:25:15.154: PRIME: No offloading required. Abort
** Message: 18:25:15.154: PRIME: is it supported? no

itt volt szó:
https://linuxmint.hu/forum/nvidia-x-server-settings

Írod, a Debian-alapú MX Linuxon nincs baj a működéssel.
Melyik driver verzió van telepítve?
A parancs kimenettel (pastebin megosztás kéne),

dpkg -l | grep nvidia*

nézzünk rá honnan, melyik tükörről jön az MX driver.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | PPA kikapcsolása

#14  lajos@lajos-Aspire-E5-772G:~$ apt-cache policy nvidia-driver-460 nvidia-driver-465
nvidia-driver-460:
  Telepítve: (nincs)
  Jelölt:    460.84-0ubuntu0.20.04.1
  Verziótáblázat:
     460.84-0ubuntu0.20.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal/main amd64 Packages
     460.80-0ubuntu0.20.04.2 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages
        500 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
nvidia-driver-465:
  Telepítve: (nincs)
  Jelölt:    465.31-0ubuntu0.20.04.1
  Verziótáblázat:
     465.31-0ubuntu0.20.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal/main amd64 Packages
     465.27-0ubuntu0.20.04.2 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages
        500 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
 

Várni kell kb. 2 órát, mert dolgozik a gép.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | PPA kikapcsolása

#16 Várunk...
Synaptic mutat telepített csomagot, és milyen néven?
Itt ezt látom mindkét helyen: Telepítve: (nincs)

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | PPA kikapcsolása

#18 Ez Live rendszer, vagy telepített Linux Mint?
Egy nvidia driver sincs telepítve. Felesleges itt is megnézni, az apt-cache ugyanezt mutatta. Átálltál a nyílt forráskódú nouveau driverre?

Közben átállítottam xserver-xorg-video-nouveau-ra, de ezzel se jó.

Szerk.: Igen.
De ezzel települ a rendszer, ott már látod, jó-e vagy nem.
Nem változott a javaslatom (fentebb). Röviden: ubuntu-drivers devices kimenetet nézni PPA nélkül, stb.. Az előre mutató dolgokat kéne vinni, felesleges többféleképpen megnézni, mi nincs telepítve. Tehát egyik driver sem működik jól, de ez három driver, illetve öt, mert van a 460 és 465 (ebből van kettő-kettő: saját és PPA) és a nouveau. És ezt a témát akkor elengedjük egy időre...

Ami fontos most, vizsgálni kéne: az MX Linux-ra vonatkozó kérdésem.
Ott működik, tehát kérdés a: driver verzió, melyik tükörről jön, beállításai (utóbbit majd később)? És melyik MX kiadás? Amikor szabad a gép, akkor válaszolsz.

Ui.: képeket képfeltöltő oldalra (pl. imgBB vagy Imgur) regisztráció és belépés után érdemes. Mert később könnyen megtalálod a fiókodban ..., és hasonló probléma esetén megoldás is lehet maga a kép. A vendégként feltöltött kép nem igazán található meg (másnak is mondom).

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | PPA kikapcsolása

#19 A rendszer a valós 20.2-es Linux Mint, és az Illesztőprogram-kezelővel átálltam a xserver-xorg-video-nouveau-ra.
A Szoftverforrásokban kikapcsoltam a graphics-drivers PPA-t, és ez az erdmény:

lajos@lajos-Aspire-E5-772G:~$ ubuntu-drivers devices
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:1c.4/0000:04:00.0 ==
modalias : pci:v000010DEd00001347sv00001025sd00000974bc03sc02i00
vendor   : NVIDIA Corporation
model    : GM108M [GeForce 940M]
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-465 - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-460 - distro non-free recommended
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Most indítom az MX-Linuxot.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | PPA kikapcsolása

#19 Egy gyors rendszerinformáció az MX-Linuxról:

Snapshot created on: 20200523_1117
System:    Host: <filter> Kernel: 4.19.0-6-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19.0-6-amd64 
           root=UUID=<filter> ro quiet splash 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0 
           Distro: MX-19.4_x64 patito feo February 15  2020 base: Debian GNU/Linux 10 (buster) 
Machine:   Type: Laptop System: Acer product: Aspire E5-772G v: V1.10 serial: <filter> 
           Mobo: Acer model: Aspire E5-772G v: V1.10 serial: <filter> UEFI [Legacy]: Insyde 
           v: 1.10 date: 10/27/2015 
Battery:   ID-1: BAT0 charge: 26.5 Wh condition: 26.5/37.0 Wh (72%) volts: 17.3/14.8 
           model: SANYO AL15A32 type: Li-ion serial: <filter> status: Not charging 
CPU:       Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell 
           family: 6 model-id: 3D (61) stepping: 4 microcode: 2F L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17559 
           Speed: 799 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 801 2: 798 3: 798 4: 798 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:1616 
           Device-2: NVIDIA GM108M [GeForce 940M] driver: N/A bus ID: 04:00.0 chip ID: 10de:1347 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.6 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Sound Server: ALSA v: k4.19.0-6-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
           chip ID: 10ec:8168 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: 4000 bus ID: 03:00.0 
           chip ID: 8086:3165 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.25 TiB used: 12.63 GiB (1.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0 size: 931.51 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1A01 scheme: MBR 
           ID-2: /dev/sdb vendor: LITE-ON IT model: L8T-128L9G size: 119.24 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 202 scheme: MBR 
           ID-3: /dev/sdc type: USB vendor: Samsung model: SP2514N size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 0000 scheme: MBR 
Partition: ID-1: / raw size: 21.10 GiB size: 20.64 GiB (97.84%) used: 12.63 GiB (61.2%) fs: ext4 
           dev: /dev/sdc1 
Sensors:   System Temperatures: cpu: 57.0 C mobo: 42.0 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://deb.debian.org/debian buster-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://deb.debian.org/debian buster main contrib non-free
           2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/estmob-sendanywhere.list 
           1: deb [arch=amd64,i386] http://update.send-anywhere.com/linux/debian/ stable main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb https://quantum-mirror.hu/mirrors/pub/mx-linux/packages/mx/repo/ buster main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 228 Uptime: 8m Memory: 7.71 GiB used: 894.9 MiB (11.3%) Init: SysVinit 
           v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: quick-system-in 
           running in: quick-system-in inxi: 3.0.36

 

$ dpkg -l | grep nvidia*
ii  bumblebee-nvidia                      3.2.1-20                                amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  glx-alternative-nvidia                1.1.0~mx19+1                            amd64        allows the selection of NVIDIA as GLX provider
ii  libegl-nvidia0:amd64                  440.59-0.1~mx19+1                       amd64        NVIDIA binary EGL library
ii  libegl-nvidia0:i386                   440.59-0.1~mx19+1                       i386         NVIDIA binary EGL library
ii  libgl1-nvidia-glvnd-glx:amd64         440.59-0.1~mx19+1                       amd64        NVIDIA binary OpenGL/GLX library (GLVND variant)
ii  libgl1-nvidia-glvnd-glx:i386          440.59-0.1~mx19+1                       i386         NVIDIA binary OpenGL/GLX library (GLVND variant)
ii  libgles-nvidia1:amd64                 440.59-0.1~mx19+1                       amd64        NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia1:i386                  440.59-0.1~mx19+1                       i386         NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia2:amd64                 440.59-0.1~mx19+1                       amd64        NVIDIA binary OpenGL|ES 2.x library
ii  libgles-nvidia2:i386                  440.59-0.1~mx19+1                       i386         NVIDIA binary OpenGL|ES 2.x library
ii  libglx-nvidia0:amd64                  440.59-0.1~mx19+1                       amd64        NVIDIA binary GLX library
ii  libglx-nvidia0:i386                   440.59-0.1~mx19+1                       i386         NVIDIA binary GLX library
ii  libnvidia-cbl:amd64                   440.59-0.1~mx19+1                       amd64        NVIDIA binary Vulkan ray tracing (cbl) library
ii  libnvidia-cfg1:amd64                  440.59-0.1~mx19+1                       amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-eglcore:amd64               440.59-0.1~mx19+1                       amd64        NVIDIA binary EGL core libraries
ii  libnvidia-eglcore:i386                440.59-0.1~mx19+1                       i386         NVIDIA binary EGL core libraries
ii  libnvidia-fatbinaryloader:amd64       440.59-0.1~mx19+1                       amd64        NVIDIA FAT binary loader
ii  libnvidia-glcore:amd64                440.59-0.1~mx19+1                       amd64        NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-glcore:i386                 440.59-0.1~mx19+1                       i386         NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-glvkspirv:amd64             440.59-0.1~mx19+1                       amd64        NVIDIA binary Vulkan Spir-V compiler library
ii  libnvidia-glvkspirv:i386              440.59-0.1~mx19+1                       i386         NVIDIA binary Vulkan Spir-V compiler library
ii  libnvidia-ml1:amd64                   440.59-0.1~mx19+1                       amd64        NVIDIA Management Library (NVML) runtime library
ii  libnvidia-ptxjitcompiler1:amd64       440.59-0.1~mx19+1                       amd64        NVIDIA PTX JIT Compiler
ii  libnvidia-rtcore:amd64                440.59-0.1~mx19+1                       amd64        NVIDIA binary Vulkan ray tracing (rtcore) library
ii  nvidia-alternative                    440.59-0.1~mx19+1                       amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-detect                         440.59-0.1~mx19+1                       amd64        NVIDIA GPU detection utility
ii  nvidia-driver                         440.59-0.1~mx19+1                       amd64        NVIDIA metapackage
ii  nvidia-driver-bin                     440.59-0.1~mx19+1                       amd64        NVIDIA driver support binaries
ii  nvidia-driver-libs:amd64              440.59-0.1~mx19+1                       amd64        NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-driver-libs:i386               440.59-0.1~mx19+1                       i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-driver-libs-i386:i386          440.59-0.1~mx19+1                       i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries)
ii  nvidia-egl-common                     440.59-0.1~mx19+1                       amd64        NVIDIA binary EGL driver - common files
ii  nvidia-egl-icd:amd64                  440.59-0.1~mx19+1                       amd64        NVIDIA EGL installable client driver (ICD)
ii  nvidia-egl-icd:i386                   440.59-0.1~mx19+1                       i386         NVIDIA EGL installable client driver (ICD)
ii  nvidia-installer-cleanup              20151021+9                              amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                  20151021+9                              amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                    440.59-0.1~mx19+1                       amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-support                 440.59-0.1~mx19+1                       amd64        NVIDIA binary kernel module support files
ii  nvidia-legacy-check                   440.59-0.1~mx19+1                       amd64        check for NVIDIA GPUs requiring a legacy driver
ii  nvidia-modprobe                       418.56-1                                amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-settings                       440.36-0.1~mx19+1                       amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-support                        20151021+9                              amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64             440.59-0.1~mx19+1                       amd64        Video Decode and Presentation API for Unix - NVIDIA driver
ii  nvidia-vulkan-common                  440.59-0.1~mx19+1                       amd64        NVIDIA Vulkan driver - common files
ii  nvidia-vulkan-icd:amd64               440.59-0.1~mx19+1                       amd64        NVIDIA Vulkan installable client driver (ICD)
ii  nvidia-vulkan-icd:i386                440.59-0.1~mx19+1                       i386         NVIDIA Vulkan installable client driver (ICD)
ii  xserver-xorg-video-nvidia             440.59-0.1~mx19+1                       amd64        NVIDIA binary Xorg driver
 

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | MX driver: nvidia 440.59

#20 A saját tükör a 440-es drivert 450-esnek, a 430-as 440-esnek jelzi a csomagnevekben. Kicsit fura.
https://packages.ubuntu.com/search?keywords=nvidia&searchon=names&suite=all&section=all
Ha a logika az, hogy a csomagnevet veszem alapnak, akkor a PPA nélkül a 430-as driver jó lehet. De a Synapticban - remélhetőleg - meg tudod nézni az eszközök támogatását (csomag tulajdonságok), amiből más következtetésre is juthatsz.

A PPA felvételével tudod telepíteni a 440.100-as verziót:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa?field.series_filter=focal

A 440.59-es verzió, amit az MX Linux is használ, itt érhető el (letöltésre):
https://www.nvidia.com/download/driverResults.aspx/156772/en-us

Persze, a tesztelések előtt kell a rendszer visszaállítási pont (Timeshift, Systemback), és szükséges, tudd a módszert arra, hogy akár kép nélkül vissza tudj állni a korábbi állapotra. A fórum kereső segít a neked megfelelő alkalmazás kiválasztásában, vagyis, az említett két alkalmazás tekintetében a módszer már le van írva.

A másik rendszeren ez nem kavar be?

Graphics:  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:1616 
           Device-2: NVIDIA GM108M [GeForce 940M] driver: N/A bus ID: 04:00.0 chip ID: 10de:1347 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.6 
           compat-v: 3.0 direct render: Yes 

Megkérlek, használd a pastebin oldalt a szöveg megosztásra. Előfordulhat az, hogy nem válaszolunk, ha nem teszed meg. A módszer: A honlap működése 7. rész: Ubuntu Pastebin | szöveg megosztása

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | MX driver: nvidia 440.59

#22 Fölvettem a PPA-t, update-eltem, de aztán hogyan tovább?
A Synapticból kijelöltem a 440-est, mégis a 460-ast telepítette. Továbbra se működik a NVIDIA-chip. Ideje föladnom, ezen már csak a teljes rendszer újratelepítése segíthet (amit nemigen akarok elvégezni). Bizonyára a home-partíción megmaradtak a régi beállítások, és az istennek sem akarja kijavítani magát.
Azért illesztettem ide a listákat, mert így jobban olvasható, és amúgy se voltak olyan túlzottan hosszúak. Tudom, hogyan kell használni a Pastebint.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#23 Fölvettem a PPA-t, update-eltem, de aztán hogyan tovább?

Említettem, PPA nélkül is meg kéne próbálni. És lentebb írom, mit említettem még.

A Synapticból kijelöltem a 440-est, mégis a 460-ast telepítette.

Igen, és mert vélhetően így van jól. Én is ránéztem, mi települ.
Az Illesztőprogramkezelő a másik út ... a 460-ast ajánlja, vélhetően ez a magyarázata ennek.
Figyi, helyetted nem fogjuk megcsinálni, ezt mégis, hogyan képzeled: ha említettem három utat, amiből egyet megcsináltál, akkor mi végre a kérdés, „hogyan tovább”?
Ha telepítetted a 460-as drivert és bejön így is a grafikus felület, akkor a dmesg kimenetben lehet nézelődni, mi lehet még feladat megjavítani.

Továbbra se működik a NVIDIA-chip. Ideje föladnom, ezen már csak a teljes rendszer újratelepítése segíthet (amit nemigen akarok elvégezni). Bizonyára a home-partíción megmaradtak a régi beállítások, és az istennek sem akarja kijavítani magát.

Nem látunk bele, de többen említettük már - az évek folyamán - nagyon régi home megtartása nem jó... . Kijavítani nem fogja magát, jó lenne, de ott még nem tartunk, másrészt nem is igazán lenne értelme azon kívül, hogy százból néhány felhasználónak ez igénye.
Az Nvidia az MX Linuxon sem működik :), láthatod N/A a driver, azaz nincs használva (inxi)! Az Intel iGP-t használja az MX és a MESA-t.
A Linux Mint telepíthető Nvidia driver módban. Érdemes lenne kipróbálnod. Vagy küzdesz a „múlt árnyékaival”, de ez a te dolgod kizárólag.

Azért illesztettem ide a listákat, mert így jobban olvasható, és amúgy se voltak olyan túlzottan hosszúak. Tudom, hogyan kell használni a Pastebint.

A világban minden fórumon 10 sor a legtöbb, ami szövegesen elbír egy fórum, linkeltem leírást, abban minden ugyanígy le van írva. Az, hogy értetlenkedsz ezen, nem érdekel senkit sem. Ha tudod használni, élj a lehetőséggel, ami itt kérés volt, mégpedig az, hogy tartsd be a játékszabályokat.

Azt írják, ez működik: nvidia-driver-418
https://forums.developer.nvidia.com/t/all-drivers-not-working-geforce-940m-ubuntu-20-04-kernel-5-4-0-51-lenovo-ideapad/157180
PPA-ról nem szólnak.
Nehezen kezelhető kártyád van, mondjuk ki. Ahol a megoldás rákeresés hasonló problémákra, illetve naplók nézegetése. Rákerestem, és az is rendben van, hogy a driver elérhető a rendszer tükrökről: https://packages.ubuntu.com/search?suite=all&section=all&arch=any&keywords=+nvidia-driver-418&searchon=names

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#24 A telepítés így néz ki (teszt): https://paste.ubuntu.com/p/SyHH7mk8fB/

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#26 Siker az nincs, továbbra is csőd. Marad az Intel® HD Graphics 5500. Amúcs sincs értelme az NVIDIA chipjét használni, mert nem ismeri a hardveres enkódolást, míg az Intelé igen.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#27 Gondolkodnék egy friss telepítésen, de te tudod.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#28 Túl nagy macerával járna a programok újrabeszerzése és konfigurálásuk - maga a rendszertelepítés nem probléma. Azért választottam a frissítést, mert a beállítások megmaradtak a home-on - igaz a hibások is.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#29 Túl nagy macerával járna a programok újrabeszerzése és konfigurálásuk...

Rá kell fordítani egy kis időt a beszerzésre, a beállításokat szövegfájlba is lehet elmenteni.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#30 Sikerült: https://ibb.co/7nDGVbK
Örülni azért nem kell, mert tiszta 20.2-es telepítéssel sikerült. Feláldoztam a külső HDD-re telepített Debiant.
Telepítés után a Hibajelentő felajánlotta az illesztőprogram installálását (a 460-as az ajánlott). Ezután frissítettem a rendszert, és most már választható a két grafikus mód.
Valamit ki lehetne deríteni erről a rendszerről, hogy az SSD-re telepített fő Linux Mintet kijavítsuk?

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#31 Sikerült...

Szuper!

Örülni azért nem kell, mert tiszta 20.2-es telepítéssel sikerült. Feláldoztam a külső HDD-re telepített Debiant.
Telepítés után a Hibajelentő felajánlotta az illesztőprogram installálását (a 460-as az ajánlott). Ezután frissítettem a rendszert, és most már választható a két grafikus mód.

Ez  jó dolog.

Valamit ki lehetne deríteni erről a rendszerről, hogy az SSD-re telepített fő Linux Mintet kijavítsuk?

A javításra most nem tudok biztosat mondani, de megpróbáljuk.

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#31 Telepítsd:
sudo apt install vainfo
Mit mutat a:
vainfo
kimenete ?
https://en.wikipedia.org/wiki/Video_Acceleration_API

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#33  lajos@lajos-Aspire-E5-772G:~$ vainfo
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.1.1 ()
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :    VAEntrypointVLD
      VAProfileMPEG2Main              :    VAEntrypointVLD
      VAProfileH264Main               :    VAEntrypointVLD
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileJPEGBaseline           :    VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
      VAProfileVP8Version0_3          :    VAEntrypointVLD

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#34 Nálam ezt mutatja:
vainfo
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.1.1 ()
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSliceLP
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSliceLP
VAProfileJPEGBaseline : VAEntrypointVLD
VAProfileJPEGBaseline : VAEntrypointEncPicture
VAProfileH264ConstrainedBaseline: VAEntrypointVLD
VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
VAProfileVP8Version0_3 : VAEntrypointVLD
VAProfileHEVCMain : VAEntrypointVLD
VAProfileHEVCMain10 : VAEntrypointVLD
VAProfileVP9Profile0 : VAEntrypointVLD
VAProfileVP9Profile2 : VAEntrypointVLD

I5-8600 IGP

Most nézegettem a synaptcban alapértelmezetten az: "intel-media-va-driver" van telepítve.
De van ott egy: "intel-media-va-driver-non-free" is amelyik nincs telepítve.
A 2 kizárja egymást - vagy az egyik, vagy a másik telepíthető.
Valószínű lecserélem a "non-free"-re - még ha ideiglenesen is - hogy észlelek-e különbséget.

A 2 közti különbségről itt esik (kevés) szó: https://github.com/intel/media-driver

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#35 A "non-free" csomagra történő váltás után:
vainfo
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.1.1 ()
vainfo: Supported profile and entrypoints
VAProfileNone : VAEntrypointVideoProc
VAProfileNone : VAEntrypointStats
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Simple : VAEntrypointEncSlice
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointFEI
VAProfileH264Main : VAEntrypointEncSliceLP
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSlice
VAProfileH264High : VAEntrypointFEI
VAProfileH264High : VAEntrypointEncSliceLP
VAProfileVC1Simple : VAEntrypointVLD
VAProfileVC1Main : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD
VAProfileJPEGBaseline : VAEntrypointVLD
VAProfileJPEGBaseline : VAEntrypointEncPicture
VAProfileH264ConstrainedBaseline: VAEntrypointVLD
VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
VAProfileH264ConstrainedBaseline: VAEntrypointFEI
VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
VAProfileVP8Version0_3 : VAEntrypointVLD
VAProfileVP8Version0_3 : VAEntrypointEncSlice
VAProfileHEVCMain : VAEntrypointVLD
VAProfileHEVCMain : VAEntrypointEncSlice
VAProfileHEVCMain : VAEntrypointFEI
VAProfileHEVCMain10 : VAEntrypointVLD
VAProfileHEVCMain10 : VAEntrypointEncSlice
VAProfileVP9Profile0 : VAEntrypointVLD
VAProfileVP9Profile2 : VAEntrypointVLD

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418

#33 Az Nvidiához meg a VDPAU kéne.

Első vagy a második parancs(sor) ..., ha az első hibát dob (de a hiba is fontos, hogy mi):

vdpauinfo
VDPAU_DRIVER=va_gl vdpauinfo

https://en.wikipedia.org/wiki/VDPAU

sudo apt-get install vdpauinfo

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#37  lajos@lajos-Aspire-E5-772G:~$ VDPAU_DRIVER=va_gl vdpauinfo
display: :0.0   screen: 0
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418

#38 Előtte talán telepíteni kéne a vdpauinfo-t.
A synaptic nálam ezt mutatja a vdpau keresésre: https://ibb.co/vvbxdq0
Úgy tűnik, itt is lehetne még mit telepíteni.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418 | libvdpau_va_gl.so

#38 Keresés

apt-file search libvdpau_va_gl.so

és találat (telepítsd a kiemelt csomagot, majd vdpauinfo újra):

libvdpau-va-gl1: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_va_gl.so
libvdpau-va-gl1: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_va_gl.so.1

Azaz:

sudo apt-get install libvdpau-va-gl1

#40 A képen az látható, hogy nincs telepítve az itt említett csomag.

-----

Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory

Meghiúsult a VDPAU háttér libvdpau_va_gl.so megnyitása: nem nyitható meg a megosztott cél fájl: Nincs ilyen fájl vagy könyvtár.

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2-re frissítés | nvidia-driver-418 | vdpauinfo

#38 És erre mi a kimenet?

vdpauinfo

Értékelés: 

0
Még nincs értékelve

20.2-re frissítés | nvidia-driver-418 | libvdpau_va_gl.so

#41   #42  https://paste.ubuntu.com/p/jXp34tSHGh/

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2 kiadásra frissítés után a telepített rendszer javítása (nvi

#43 Teljesen normális kimenet.

Csak jelzem, hogy ez a tényállás,

#27 Marad az Intel® HD Graphics 5500. Amúcs sincs értelme az NVIDIA chipjét használni, mert nem ismeri a hardveres enkódolást, míg az Intelé igen.

és az a cél egyedül,

#31 hogy az SSD-re telepített fő Linux Mintet kijavítsuk

És ehhez képest a vainfo, a vdpauinfo hogy jön ide, nem is értem....

Értékelés: 

0
Még nincs értékelve
kimarite képe

20.2 kiadásra frissítés után a telepített rendszer javítása (nvi

#44 Hasonlóságokat kéne keresni. Elsőre a telepített csomagokat megnézni, legyen ugyanaz.

Értékelés: 

0
Még nincs értékelve

A fő tükörgiszolgáló

A fő tükörgiszolgáló lekérdezése sikertelen, váltson egy közelebbi kiszolgálóra.  Eddig nem volt ilyen hiba.

Értékelés: 

0
Még nincs értékelve

A fő tükörgiszolgáló

#46 Ez nálam is kijött, nem is értettem. Aztán nézelődtem a WIFI ment el. Újrainditás megoldotta.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fő tükörkiszolgáló

#46 #47 És megjavult? Nálam csak hasonló hiba volt, mert nem kapcsoltam ki egy külső tükröt a frissítés előtt. Nem emlékszem most, mi volt a jelzés, de nem is a hivatalos úton frissítettem.

Azt hiszem, kijavítottam, ... a terminálban ment minden.

Értékelés: 

0
Még nincs értékelve

A fő tükörkiszolgáló

#48 Nem javult meg. Minden alkalommal a frissítésre kattintok, így keresem meg az új csomagokat.

Értékelés: 

0
Még nincs értékelve

Oldalak