Xnview gond.

Fórum: 

 Nagyon szeretem használni képek egyszerűbb szerkesztésére, és még simán azok rendezésére, áttekintésére is az Xnview nevű multiplatformos programot. tegnap délután az Xnview frissítésre figyelmeztetett és amikor elfogadtam, a lehetőséget szokás szerint akiadó oldalára irányított. A letöltés és telepítés után azonban azt írta ki a csomagkezelő, hogy már telepítve van a program ezen verziója.  Igazság szerint meg sem néztem, hogy milyen frissítést ajánlott, még sosem volt gond vele. Ma reggel meg azt tapasztalom, hogy nem indul el a program. 

-Linux Mint 19 Tara 64bit.
AMD FX8120 8Core, 16GB DDR3 1660Mhz. Radeon HD 6850.

kimarite képe

Xnview gond.

@Attys EXE + Wine telepítést használtál az XnView-nél, vagy ezt a PPA-t?
https://launchpad.net/~dhor/+archive/ubuntu/myway

Szerk.: Azért kérdezem, mert meg kéne keresni az indítót és teljes elérési úttal (ahol/van/xnview.exe) terminálban indítani, hátha jön egy „ez a bajom, figyu” sóhaj, amiből kitaláljuk az okot.

Esetleg távolítsd el teljesen és telepítsd újra az újat. Talán ez a javaslat le van írva a készítő oldalán, nem tudom.

Értékelés: 

0
Még nincs értékelve

 Nem exe, mert multiplatform,

 Nem exe, mert multiplatform, deb fájl van fent a gyártó oldalán is. Azt már nem tudom, hogyhonnan volt telepítve, gyártó oldaláról letöltve, vagy szoftverkezelő, de az utóbbiban, hiába uninstallálom, és telepítem újra, nem történik semmi. 

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Nem exe, mert multiplatform,

#3 Tehát ezek:
64bit: https://download.xnview.com/XnViewMP-linux-x64.deb
32bit: https://download.xnview.com/XnViewMP-linux.deb
Honlap: https://www.xnview.com/en/xnviewmp/#downloads

Mit mutatnak ezek a parancsok?

which xnview
apt-cache policy xnview
dpkg -l xnview
dpkg -L xnview

32bit-es vagy 64bit-es a rendszered?
Szerk.: ja látom > -Linux Mint 19 Tara 64bit.

Itt kéne lenni az indítónak,
(a csomagkezelő a GDebi)

és akkor a terminál teszt ez lesz.

/usr/bin/xnview

Mi a kimenet?

Értékelés: 

0
Még nincs értékelve

A letöltés és telepítés után

A letöltés és telepítés után azonban azt írta ki a csomagkezelő, hogy már telepítve van a program ezen verziója.

Minden telepítés után ezt írja. ;-)

Ma reggel meg azt tapasztalom, hogy nem indul el a program.

Fel kell még tenni két csomagot, oszt működni fog:

libva-drm1 (1.7.0-1ubuntu0.1) (http://launchpadlibrarian.net/335339357/libva-drm1_1.7.0-1ubuntu0.1_amd6...)

libva-x11-1 (1.7.0-1ubuntu0.1) (http://launchpadlibrarian.net/335339363/libva-x11-1_1.7.0-1ubuntu0.1_amd...)

Forrás: https://launchpad.net/ubuntu/+source/libva/1.7.0-1ubuntu0.1/+build/13319313

(Az más tészta, hogy az xnviewMP telepítője ezen függőségeket miért nem hiányolja?)

Értékelés: 

0
Még nincs értékelve
kimarite képe

A letöltés és telepítés után

#5 Mert a control fájlba a fejlesztő nem írta bele a szükséges függőségeket, illetve a minimum elvárásokat sem. Semmilyen függőséget nem írt a beállító fájlba:

dpkg-deb -I XnViewMP-linux-x64.deb
 new debian package, version 2.0.
 size 44215802 bytes: control archive=378 bytes.
     220 bytes,     9 lines      control             
      75 bytes,     4 lines   *  postinst             #!/bin/sh
 Package: xnview
 Version: 0.91
 Architecture: amd64
 Installed-Size: 16
 Section: graphics
 Priority: optional
 Maintainer: None <none@none.com>
 Homepage: http://www.xnview.com
 Description: Graphic viewer, browser, converter.
dpkg -I XnViewMP-linux-x64.deb
 new debian package, version 2.0.
 size 44215802 bytes: control archive=378 bytes.
     220 bytes,     9 lines      control             
      75 bytes,     4 lines   *  postinst             #!/bin/sh
 Package: xnview
 Version: 0.91
 Architecture: amd64
 Installed-Size: 16
 Section: graphics
 Priority: optional
 Maintainer: None <none@none.com>
 Homepage: http://www.xnview.com
 Description: Graphic viewer, browser, converter.

Mert például egy innen
https://packages.ubuntu.com/bionic/geany
„sk” letöltött telepítőnek vannak beállított függőségei, azaz a „Depends” a control fájlban résztezve van (csak a példa kedvéért mutatom):

dpkg -I geany_1.32-2_amd64.deb
 new debian package, version 2.0.
 size 1032704 bytes: control archive=1668 bytes.
    1300 bytes,    28 lines      control             
    1266 bytes,    18 lines      md5sums             
      17 bytes,     1 lines      shlibs              
      70 bytes,     2 lines      triggers            
 Package: geany
 Version: 1.32-2
 Architecture: amd64
 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
 Original-Maintainer: Geany Packaging Team <pkg-geany-team@lists.alioth.debian.org>
 Installed-Size: 3016
 Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.15), libcairo2 (>= 1.8.0), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1), libgtk-3-0 (>= 3.21.5), libpango-1.0-0 (>= 1.20.0), libpangocairo-1.0-0 (>= 1.14.0), libstdc++6 (>= 5.2), geany-common (= 1.32-2)
 Suggests: libvte9, doc-base
 Breaks: geany-plugins-common (<< 0.21)
 Provides: geany-abi-18176, geany-api-235
 Section: devel
 Priority: optional
 Homepage: http://www.geany.org
 Description: fast and lightweight IDE
  Geany is a small and lightweight integrated development environment.
  It was developed to provide a small and fast IDE, which has only a
  few dependencies from other packages. It is using only the GTK2 toolkit
  and therefore you need only the GTK2 runtime libraries to run Geany.
  .
  The basic features of Geany are:
   - syntax highlighting
   - code completion
   - auto completion of constructs like if, for and while, XML and HTML
   - call tips
   - folding
   - many supported filetypes like C, Java, PHP, HTML, Python, Perl, Pascal
   - symbol lists
   - embedded terminal emulation

Értékelés: 

0
Még nincs értékelve
kimarite képe

libva-drm[1-2] és libva-x11-[1-2], mint XnView függőségek

#5 A tükrökről is elérhetőek a csomagok, ..., mutatok inkább mást, jobb módszert:
https://packages.ubuntu.com/search?keywords=libva+drm&searchon=names
https://packages.ubuntu.com/search?suite=default&section=all&arch=any&ke...

Akkor a letöltés helyett

-- a Linux Mint 17.x és a Linux Mint 18.x alatt ez

sudo apt-get install libva-drm1 libva-x11-1

-- Linux Mint 19 alatt ez

sudo apt-get install libva-drm2 libva-x11-2

a telepítési parancs használandó.

A javaslatot köszönjük.

Értékelés: 

0
Még nincs értékelve

Linux Mint 19 alatt ez

"Linux Mint 19 alatt ez..."

Na, ez eddig szép és jó, csakhogy az xnviewMP-nek a "-1"-es végű csomagok kellenek, nem a "-2"-ek.

...és ha jól emlékszem a "-2"-es végűek egyébként is alapból telepítve vannak, de azokkal nem indul el.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Linux Mint 19 alatt alapból telepítve ...

#8 Alapból telepítve? Igen.

dpkg -l libva*
Kért=ismeretlen(u)/telepítés(i)/eltávolítás(r)/törlés(p)/tartás(h)
| Állapot=nem(n)/telepített(i)/ütköző-fájlok(c)/kibontatlan(u)/félig-
|     ütköző(f)/félig-telepített(h)/aktiválóra-vár(w)/aktiváló-függőben(t)
|/ Hiba?=(nem)/újratelepítés-szükséges(r) (Állapot,Hiba: nagybetű=rossz)
||/ Név                                  Verzió                  Architektúra            Leírás
+++-====================================-=======================-=======================-=============================================================================
un  libva-driver-abi-1.0                 <nincs>                 <nincs>                 (nincs leírás)
un  libva-driver-abi-1.1                 <nincs>                 <nincs>                 (nincs leírás)
ii  libva-drm2:amd64                     2.1.0-3                 amd64                   Video Acceleration (VA) API for Linux -- DRM runtime
ii  libva-wayland2:amd64                 2.1.0-3                 amd64                   Video Acceleration (VA) API for Linux -- Wayland runtime
ii  libva-x11-2:amd64                    2.1.0-3                 amd64                   Video Acceleration (VA) API for Linux -- X11 runtime
ii  libva2:amd64                         2.1.0-3                 amd64                   Video Acceleration (VA) API for Linux -- runtime

De nem tudhatom, hogy az XnView mit kíván. Nem linkelted a tudás-forrásod, én meg nem Mint alatt osztom a tanácsot így Virtualbox alatt megnéztem. :-)

Értékelés: 

0
Még nincs értékelve