Verzió váltás

Fórum: 

Sziasztok!

Jelenleg Linux Mint 18.3-as verzió fut a gépen. Mivel az 16.04-s Ubuntu alapokon fut egy két ppa tárolót már nem frissítenek. Valahogy lehet frissíteni 19-es verzióra újratelepítés nélkül "halandó nem informatikus" felhasználói szinten lévő embernek? 

Az egyik ok a Rawtherapee program lenne. PPA-ból telepítettem a honlapja szerint (ppa:dhor/myway).  

De itt már Ubuntu 16.04-re nem frissítik a legújabb 5.5-ös verziót. A honlapon van még egy leírás ott van rá valamilyen megoldás de nem tudom, hogy ilyenkor el kell-e távolítanom a ppa tárolót. Ha jól emlékszem más program is frissült már onnan ezért nem merem eltávolítani. 

A honlap leírása a következő (https://rawtherapee.com/downloads) (Ubuntu 64bit stabil verzió):

 

Repositories

A repository is a source of packages which you can install using a package manager. When you install a program from a repository you will get notified when updates become available.

Repository 1 - PPA

This repository is kindly run by Dariusz Duma, and all questions should be directed to him.

To install RawTherapee follow these simple steps:

  1. Open the terminal and paste this code into it:
    sudo add-apt-repository ppa:dhor/myway
    sudo apt-get update
    sudo apt-get install rawtherapee

    If you want a development version:

    sudo apt-get install rawtherapee-unstable

RawTherapee should now be installed and ready for use.

Repository 2 - Open Build Service

This repository is kindly run by Marcin Bajor, and all questions should be directed to him.

To install RawTherapee follow these simple steps:

  1. Open the terminal
  2. Add the correct repository for your version of Ubuntu:
    • For Ubuntu 17.10:
      sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_17.10/ /' > /etc/apt/sources.list.d/rawtherapee.list"
    • For Ubuntu 17.04:
      sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_17.04/ /' > /etc/apt/sources.list.d/rawtherapee.list"
    • For Ubuntu 16.10:
      sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_16.10/ /' > /etc/apt/sources.list.d/rawtherapee.list"
    • For Ubuntu 16.04:
      sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/rawtherapee.list"
  3. Add the repository key to apt. Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information).
    • To add the key, first download it:
      • For Ubuntu 17.10:
        wget -r http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_17.10/Release.key
      • For Ubuntu 17.04:
        wget -r http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_17.04/Release.key
      • For Ubuntu 16.10:
        wget -r http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_16.10/Release.key
      • For Ubuntu 16.04:
        wget -r http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_16.04/Release.key
    • Then install it:
      sudo apt-key add - < Release.key
      sudo apt-get update
  4. Install RawTherapee:
    sudo apt-get update
    sudo apt-get install <rawtherapee-type>

    where <rawtherapee-type> is one of the following:

    • rawtherapee - the latest stable release. Uses GTK3. This is the recommended option.
    • rawtherapee-nosse - as above, but only for people with very old i586 CPUs which don't support SSE2 optimization, making them much slower.
    • rawtherapee-unstable - the latest development release.
    • rawtherapee-unstable-nosse - as above, but without SSE2 optimization.
    • rawtherapee-gtk2 - RawTherapee-5.0-r1 using GTK2. The GTK2 branch is dead and unsupported, we will not release a new RawTherapee version for GTK2.
    • rawtherapee-gtk2-nosse - as above, but without SSE2 optimization.

RawTherapee should now be installed and ready for use.

 

Segítséget előre is köszönöm!

 

 

kimarite képe

Előszöt is ...

Timeshift mentés és a fontos adatokról másolat.

Majd valami ilyesmi:

sudo apt-get update
sudo apt-get install mintupgrade mintupgrade-info
mintupgrade download
mintupgrade upgrade

Grafikusan is: https://linuxmint.hu/hir/2018/07/elerheto-a-frissites-a-19-es-tara-linux...

Ám a legjobb a friss telepítés. Sokkal rövidebb például.

Értékelés: 

0
Még nincs értékelve

Köszi a gyors választ!

Köszi a gyors választ!

Grafikusannál említett szerkesztés menüben nem jelent meg újabb verzió. Ezt vártam én is.

Ha ezt a 4 parancsot kiadom melyik verzióra frissíti, 19.1-re? 

Utána a ppa tárolókat törölnöm kell és újakat kell felvennem a Ubuntu 18.04-nek megfelelően? A programokkal -amiket a régi verzión raktam fel- ezután mi lesz ha ezt végrehajtottam? Menni fognak?

Most gondolok csak bele, hogy ez mivel jár!

Előre is köszi!

 

Értékelés: 

0
Még nincs értékelve
keraform képe

Verzió váltás - biztosan?

A verzióváltás témához csak érintőlegesen akarok hozzászólni, és csak a véleményemet mondom el.

Én sohasem frissítek az új Linux verzióra, én a tiszta telepítés híve vagyok. Magyarázatot nem adok, mert azzal vitatkozni lehet.
Minden adatot menteni, ami hiányozna, ha elveszne. Egy lista a jelenleg használt programokról, és 30 perc telepítés.

RawTherapee
Nekem Linux Mint 18.3 Cinnamon rendszerem van, és most kipróbáltam a RawTherapee 5.5-ös verziót.

Igaz, nem telepítettem semmit, egyszerűen letöltöttem a https://rawtherapee.com/downloads oldalról az "RT 5.5 for Linux AppImage 64-bit - fast" appimage fájlt, megjelöltem futtathatónak, készítettem hozzá egy desktop fájlt, amire a program indítója szépen beépült a Menü > Grafika almenübe.

Ez az egész nem tartott két percnél tovább. Emiatt én biztosan nem telepíteném újra a jól működő rendszeremet egy vitatható állapotú új disztróra.

Viszont, írhatnál egy blogot "Az első lépések RawTherapee-val" címmel.

Értékelés: 

0
Még nincs értékelve

"Én sohasem frissítek az új

"Én sohasem frissítek az új Linux verzióra, én a tiszta telepítés híve vagyok."

Tökéletesen egyetértek.

Értékelés: 

0
Még nincs értékelve

"Én sohasem frissítek az új

#4 Szerintem a verzión belüli (PL.: 19 -> 19.1 -> 19.2 ...) frissítés nem annyira veszélyes.
Persze, előtte egy rendszer-visszaállítási pont létrehozása (számomra ) kötelező.
A fő verzió frissítése már jóval rizikósabb - szerintem is jobb a friss telepítés !

Értékelés: 

0
Még nincs értékelve
keraform képe

Én sohasem frissítek az új verzióra

#5 #4
Ennek a módszernek az az áldásos mellékhatása is megvan, hogy olyankor az ember átnézi, rendszerezi a dolgait, és a telepítéssel megszabadul egy csomó kolonctól. Persze van hátulütője is, hogy a programokat újra fel kell telepíteni, és be kell állítani. De ilyenkor legalább az ember végignyálazza a beállításokat, és rájön, hogy már több verzió óta van egy új menüpont, amiről eddig nem is tudott.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Másodszor ...

#1 A külső forrásokat ki kell kapcsolni a verzió frissítés alkalmával, az előtt. Miután a verzió frissítés megvolt, az új PPA-t használva, azt bekapcsolva újratelepíted az alkalmazást. A egyéni módszerrel telepített alkalmazásaidat vélhetően újra kell telepítened majd.

sudo apt-get install --reinstall pkg

pkg = például rawtherapy --> package

vagy

sudo apt install pkg

Alverzió frissítéskor mindez nem szükséges, mármint a PPA-k tekintetében. A PPA a fő verzióra készül, mármint az Ubuntu Linux fő verziójára, és a Linux Mint fő verziója ezt követi, ugyanúgy, mint az Ubuntu Linux fő verziói is. Megfordítom a kijelentésem: a PPA fejlesztője készíti el a fő verziókra az alkalmazásokat, és a változásokat (újabb és újabb alverziók) ő követi a fejlesztéssel (ha ez szükséges).

Értékelés: 

0
Még nincs értékelve

Verzió váltás - biztosan?

#3

Először köszönöm mindenkinek a jótanácsokat. Akkor marad addig, amig be nem ruházok egy SSD-t.

(Milyet javasoltok ezek közül (vagy másikat):

https://www.aqua.hu/120gb-crucial-ssd-25-sata-iii-bx500-meghajto-ct120bx...

https://www.aqua.hu/128gb-adata-ssd-sataiii-25-meghajto-su800-series-asu...

https://ipon.hu/shop/termek/adata-120gb-ultimate-su650-sata-3-25-asu650s...

https://ipon.hu/shop/termek/transcend-120gb-ssd220-sata-3-25-ts120gssd22...)

 

"Igaz, nem telepítettem semmit, egyszerűen letöltöttem a https://rawtherapee.com/downloads oldalról az "RT 5.5 for Linux AppImage 64-bit - fast" appimage fájlt, megjelöltem futtathatónak, készítettem hozzá egy desktop fájlt, amire a program indítója szépen beépült a Menü > Grafika almenübe."

Ez azt jelenti, hogy valahova letöltötted a fájlt és utána hogyan teszed futtathatóvá? Fájlkezelőben ilyet nem hoz fel jobb klikkre. A leírásánál a letöltés után van még két pont. Ezket kell beírni a terminálba? (a kiemeltet?)

  1. Make it executable: chmod +x RawTherapee.AppImage
  2. Run: ./RawTherapee.AppImage

 

Én ez alapján tanulom a rawtherapee-t még most is: 

http://www.bykyny.hu/rawtherapee.shtml

A válaszokat előre is köszönöm!

Értékelés: 

0
Még nincs értékelve
keraform képe

AppImage "telepítés"

#8 Igen, letöltöttem az rawtherapee.appimage fájlt a Letöltések mappába. De nem hagytam ott, az amúgy is egy zavaros mappa.
Áthelyeztem egy a /home-tól független, Adattár nevű partíción lévő AppImages mappába.
Ez nem a legszerencsésebb megoldás, mert így nem az SSD-re került, hanem egy HDD-re, de nálam ez csak tesztelés céljából került fel. Nyugodtan létrehozhatsz a saját mappádban egy AppImages mappát: /home/valaki/AppImages.
Ide áthelyezed a letöltött fájlt. (Ha több ilyen fájlt töltesz le, azok is mehetnek majd oda)
A továbbiakról az egyszerűbb, barátibb megoldást írom le, de amit te írtál az is jó, csak az én megoldásomat könnyebb megjegyezni, és nem fenyeget az a veszély, hogy valamit elrontok.
Nem tudom például, hogy a 2-vel jelzett sort te hogy gondolod beírni? Mert azt, hogy Run nem kell, és a többinél se mindegy, hogy hol nyitottad meg a terminált. Az ilyen terminálos leírásokkal óvatosan kell bánni, csak akkor kövesd, ha biztosan tudod, hogy az megegyezik a te eseteddel.
Tehát a letöltött, és áthelyezett fájlra jobb klikk, Tulajdonságok, Jogosultságok, Fájl végrehajtásának engedélyezése programként: pipa.
Ablak bezár, majd duplakatt a fájlra.
Ekkor valami olyasmit fog kérdezni, külföldiül, hogy akarod-e, hogy beépüljön a rendszerbe. Ha akarod, (Yes) készít egy bejegyzést a Menü > Grafika almenübe.
A bejegyzés elkészül ugyan, de ikon nélkül, ami egy kis szépséghiba.
Letöltöttem ezt a képet: https://www.google.com/imgres?imgurl=https%3A%2F%2Fwww.techspot.com%2Fim...
Ez lesz az ikon.
Jobb klikk a Menün > Beállítások > Menüszerkesztő megnyitása. (A Menün a panelon lévő főmenüt értem)
Katt a Grafika elemre a bal oldalon, majd a RawTherapee elemre a jobb oldalon.
Tulajdonságok > katt az ikonra > majd a az imént letöltött ikon betallózása után OK, OK, Bezárás, X.
(Én az összes saját ikont egy .../Linux/Ikonok  mappában tárolom, ami olyan helyen van, ami túléli az újratelepítést)

Köszi a linket.
 

Értékelés: 

0
Még nincs értékelve

AppImage "telepítés"

#9 Sikerült fut a program, köszönöm mégegyszer mindenkinek a segítséget. SSD-s tanácsokat ha még írnátok az nagy segítségemre lenne. Nem tudom, hogy a 2012-2013-aqs tanácsok amikat olvastam mennyire aktuálisak még.

Értékelés: 

0
Még nincs értékelve
kimarite képe

SSD

#10 Linkelhetnéd a tanácsokat. :-)

Nem értek túlzottan a témához. Ezt nézném, ha vennék:

garancia (hány év), írási-olvasási sebesség, a gyártó mióta létezik,  ... és nem tudom, még mit. Ja de,  teszteket.

Itt is körbenézhetsz:

https://www.pcx.hu/ | http://www.zonacomputers.hu/

Az általad linkelt egyik weboldalon láttam HP terméket. Az is jó választás lehet. Nekem a Toshiba szimpatikus még, és a Hitachi,  bár utóbbi manapság WD név alatt jelenik meg.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Rawtherapee

A tükrökről ez a verzió érhető el,

apt-cache policy rawtherapee
rawtherapee:
  Telepítve: (nincs)
  Jelölt:    5.3-1
  Verziótáblázat:
     5.3-1 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages

és a PPA-t érdemes használni, mert ott az 5.5.1-es verzió van, ami -úgy vélem- ugyanaz, mint az AppImage verzió.
https://launchpad.net/%7Edhor/+archive/ubuntu/myway/+index?batch=75&dire...
Másrészt a PPA-s verzió frissül, és ... én bízom Dariusz Duma-ban, „régi motoros”, azaz nem fogja abbahagyni egyhamar a frissítések elkészítését.

Tehát felveszem a PPA-t (Linux Mint 19.1),

sudo add-apt-repository ppa:dhor/myway
sudo apt-get update

majd telepítem a stabil verziót.

sudo apt-get install rawtherapee

Lehetne a Git, napi frissítésűt is (unstable), az most ekkori: 2019. 02. 14.,

sudo apt-get install rawtherapee-unstable

de ezzel eltávolítod a stabil verziót (kimenet).

Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
Az alábbi csomagok el lesznek TÁVOLÍTVA:
  rawtherapee
Az alábbi ÚJ csomagok lesznek telepítve:
  rawtherapee-unstable
0 frissített, 1 újonnan telepített, 1 eltávolítandó és 46 nem frissített.
Remv rawtherapee [5.5-1dhor~bionic]
Inst rawtherapee-unstable (1:5.5-git20190214-1372~ubuntu18.04.1 Highly explosive!:18.04/bionic [amd64])
Conf rawtherapee-unstable (1:5.5-git20190214-1372~ubuntu18.04.1 Highly explosive!:18.04/bionic [amd64])

-----

Jelenleg ezek a verziók érhetőek el (telepítésre):

apt-cache policy rawtherapee*
rawtherapee-fresh:
  Telepítve: (nincs)
  Jelölt:    (nincs)
  Verziótáblázat:
rawtherapee-unstable:
  Telepítve: (nincs)
  Jelölt:    1:5.5-git20190214-1372~ubuntu18.04.1
  Verziótáblázat:
     1:5.5-git20190214-1372~ubuntu18.04.1 500
        500 http://ppa.launchpad.net/dhor/myway/ubuntu bionic/main amd64 Packages
rawtherapee-default:
  Telepítve: (nincs)
  Jelölt:    (nincs)
  Verziótáblázat:
rawtherapee-data:
  Telepítve: (nincs)
  Jelölt:    5.3-1
  Verziótáblázat:
     5.3-1 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe i386 Packages
rawtherapee:
  Telepítve: 5.5-1dhor~bionic
  Jelölt:    5.5-1dhor~bionic
  Verziótáblázat:
 *** 5.5-1dhor~bionic 500
        500 http://ppa.launchpad.net/dhor/myway/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     5.3-1 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages

Értékelés: 

0
Még nincs értékelve

Szia!

Szia!

Azt néztem, hogy a Ubuntu 18.04-re van 5.5, de a régire a 16.04-re én nem láttam csak talán az 5.4-s verziót. Az AppImage-s verzió, most fut a gépen, de képet még időhiány miatt nem dolgoztam meg vele.

Köszi!

Értékelés: 

0
Még nincs értékelve
kimarite képe

rawtherapee-unstable | 5.5-git20190218-1376~ubuntu16.04.1

#13 Hát Linux Mint 18.x alatt csak az 5.4 érhető el tényleg:
https://launchpad.net/%7Edhor/+archive/ubuntu/myway/+index?field.series_...
Azaz nem, mert éppen 47 perce készült el az unstable verzió:

rawtherapee-unstable 1:5.5-git20190218-1376~ubuntu16.04.1 (47 minutes ago)

Esetleg -a PPA felvétele után- kipróbálhatod ezt a verziót is,

sudo apt-get install rawtherapee-unstable

hátha nincs sok gond vele. Az Appimage verzió mellett elfér ez is, nem vesznek össze.
Én még ezt hiányolom: egyszerre lehetne használni, telepíteni mindkettőt, mármint a PPA-ról.

-----

Az SSD teszt oldalak linkelésével még adós vagy. :-)

Értékelés: 

0
Még nincs értékelve

rawtherapee-unstable | 5.5-git20190218-1376~ubuntu16.04.1

#14

Köszi szépen!

 

Igazából nem tesztek érdekelnek -hacsak nem tartóssági tesztek-, mert igazából az érdekelne, hogy melyiket lehet használni egyszerűen linux alatt, melyik tartós, kinek milyene volt és mik a tapasztalatok vele. Nem játék a lényeg ahol 0,0000001 sec-s gyorsulásért  valaki hajlandó százezreket fizetni. 10000-15000 Ft-ból hozzam ki a legjobbat. Csaka a rendszer lenne rajta. minden adat maradna a HDD-n. Eza alapján szerintem 120-128 GB-os bőven elég lenne.

 

Előre is köszi!

Értékelés: 

0
Még nincs értékelve
kimarite képe

rawtherapee-unstable | 5.5-git20190218-1376~ubuntu16.04.1

#15 Értem. Amit tudok a témáról, korábban leírtam. Én is teszteket néznék. :-)

A Rawthrerapee unstable változata, telepítetted? Tapasztalat?

Értékelés: 

0
Még nincs értékelve

PG78 ha SSD-t akarsz

PG78 ha SSD-t akarsz vásárolni erről van tapasztalatom. https://www.adata.com/us/feature/503 Januárban vettem kettőt a Windows alá egy újabb  és a LinuxMint alá kicsivel régebbi gépembe. https://ssd-meghajto.arukereso.hu/adata/ultimate-su650-2-5-240gb-sata3-a... Kifogástalanul működik mindkettő, melllettük egy egy TB-os winchesterrel. Sokkal gyorsabb a renszer igazán jó vásárlás volt csak ajánlani tusom. (120 GB azért szűk a rendszernek ezen ne spórolj, hiszen hosszú távra kell )

Értékelés: 

0
Még nincs értékelve

PG78 ha SSD-t akarsz

#17 Miért kevés a 120GB?

Az enyém ennyi:

https://ibb.co/qmvxJHP

Értékelés: 

0
Még nincs értékelve

Köszönöm a válaszokat!

Köszönöm a válaszokat!

A Rawthrerapee unstable változatát még nem telepítettem időhiány miatt. Lehet, hogy mire odáig jutok már a stabil is meglesz.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Köszönöm a válaszokat!

#20 Kb. 5 perc a telepítés. Se. :-)
Persze, törli a stable verziót. Ha az DEB.

Értékelés: 

0
Még nincs értékelve

Köszi, jó hogy leírtad a

Köszi, jó hogy leírtad a második mondatot, mert kerestem volna egy ideig. Azt hiszem mivel nem vagyok egy nagy mágus megvárom a stabilat.

Értékelés: 

0
Még nincs értékelve

A régi 5.4 is fennt van,

A régi 5.4 is fennt van, hátha frissül közben. Jobban bízok a valaki által karbantartott kiadásban nem tudom miért. Egyébként van eltérés a két verzió között kódban (ppa és appimage)? Nem tudom mit jelent a valójában a "csomagos" verzió és appimage. (Az appimage az olyan lehet mint az .exe az ablakos világban? A ppa-nál meg nézik az esetleges futási hibákat az adott verzióra és esetleg belenyúlnak a kódba?)

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fórumon is találsz leírásokat, ...

#24 de:
Appimage: https://appimage.org/ (egy, az egyben)
DEB: https://en.wikipedia.org/wiki/Deb_%28file_format%29 („olyan, mint az EXE”)
PPA: https://wiki.ubuntuusers.de/Paketquellen_freischalten/PPA/ (külső forrás)

Értékelés: 

0
Még nincs értékelve

A régi 5.4 is fennt van,

#24 Az "appimage" olyasmi mint a Win.-ben a portable app. (Telepítés nélkül indítható.)

Értékelés: 

0
Még nincs értékelve

Frissítés

Sziasztok!

Egy kis problémáról szeretném kikérni a véleményeteket. A mai napon frisítettem a linux mint serenámat, sylviára. Ezzel nincs is semmi probléma, de mikor kicsivel később letöltöttem [közben videót néztem, egyszer csak el kezdtem lagolni, hosszabb időkre lefagyni. Meglepett mert ilyen még nem volt. Többnyire nem okoz gondot neki ha egyszerre csinálok 2-3 dolgot. Mindegy, újraindítottam a gépet ez megoldotta a problémát és felttem egy CPU figyelőt majd ismét neki gyűrkőztem. A CPU a letöltés alatt 90 és 100% között pörgött a rMemória meg a Swap pedig lassan megtelt. A letöltés végére bár a gép nem fagyott le, de nagyon lassú volt és hiába zártam be a böngészőt se a ram, se a Swap nem űrűlt ki. Amit megint csak furcsáltam mert megszoktam, hogy nagyon gyorsan észhez tér bármit is csinálok. Próba képpen elindítottam egy programot amiről tudtam, hogy sokat zabál. Hát végül nem vártam meg amíg betölt. Az újraindítás persze most is kisöpört mindent, de ennek nem ígykéne működnie.

A lényeg, mi változott meg? Illetve mit csinálhatok? Térjek vissza Serenához?

Értékelés: 

0
Még nincs értékelve

Frissítés

#30 Szia !
Nézd meg hogy melyik program vagy folyamat zabálja a RAM -ot.

top
vagy:
 ps -A --sort -rss -o comm,pmem | head -n 11
parancsokkal.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Frissítés

#30 Copy pasteld be ide
https://paste.ubuntu.com/
a

dmesg

parancs kimenetét (az egészet)

és (az így olvasásra megnyitott)

xdg-open /var/log/syslog

syslog napló szöveges tartalmát.
Szólj, ha a Libreoffice nyitná meg a szövegfájlt, mert ezt a viselkedést meg kell először változtatni.

A bemásolás és mentés után az URL kell ide, a válaszba.

És ez a kimenet is kéne (pasztázva):

inxi -Fz

A frissítésnél a biztonsági szintek beállítása enged 2-es szintnél magasabb csomagokat?

Értékelés: 

0
Még nincs értékelve