Swapfile létrehozása másik meghajtón

Fórum: 

A címben leírt megoldást keresném, a rendszer ssd-n az sda4 partíción létre tudom hozni, használja is (hibernáláshoz kéne, de 8G ramom van és ennyit nem tudok neki adni mert kicsike a / partíció).
Az ssd-n kívül van egy 1Tb hdd, fixen, sata porton, rajta 4 partíció, fstab-ba bedrótozva. 
Az sdb4 az EXT4, 100Gb, használja is a rendszer, azon vannak a virtualbox meg a Qemu képfájlok és a Timeshift is erre menteget. 
(Timeshift ügyben is majd kérdezek másik topikba mert néhány dolog nem érthető számomra)
Ezen a hdd-n lévő 100 gigás partíción szeretném létrehozni a swap filét de nem találok erre leírást.
Lehetséges egyáltalán?
Az 1T hdd az igaz hogy GPT vagyis simán elférne rajta még pár  partíció  de jelenleg az egész terület már fel van darabolva és nem akarnám átpartícionálni, az ezzel járó 100 gigák mentése majd visszaírása nem akaródzik.

Lehet esetleg lassú lenne a hdd, de csak hibenálni kéne  a terület, most sincs cserehelyem, a swappinest leveszem majd nullára ha sikerül létrehozni.
 

kimarite képe

fallocate vagy dd ...

A fallocate biztonságosabb, mint a dd. Utóbbival gondot okozhatsz, ha nem figyelsz a parancssornál.

https://linuxize.com/post/how-to-add-swap-space-on-debian-9/
https://www.digitalocean.com/community/tutorials/how-to-add-swap-space-o...
https://devconnected.com/how-to-add-swap-space-on-debian-10-buster/

https://wiki.debian.org/Swap

Be kell lépni a másik meghajtó egyik könyvtárába vagy közvetlenül a befűzés helye alá, ha másik meghajtóra szánod a swap fájlt.

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#1 Eddig oké, ezt már lefordítóztam magamnak de hogy kell azt hogy ne a / alatt jöjjön létre a swapfile?
Hanem az sdb4 linuxsave  partíció gyökerébe?
Vagy uuid, 69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505/swapfile ?

Miközben írtam, kimarite válaszolt.
Csinálom is ahogy mondta.

Értékelés: 

0
Még nincs értékelve

SWAP partíció

Annak a 100 GB-os partíciónak a végéből nem lehetne lecsípni 8-10 GB-ot?
És ezt megformázni cserehelynek - majd az UUID-jét beszerkeszteni az /etc/fstab-ba.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#3 Fájlkezelőben belépsz a kívánt külső partíció legfelsőbb szintű könyvtárába (annak gyökerébe, ami a befűzés helye is).
Majd egér jobb gombos menü: Megnyitás terminálban vagy Terminál nyitása itt.
A megnyitni kívánt könyvtárat jelöld ki, és utána egér jobb gombos menü...
Vagy megnyitod, és az ablakban: egér jobb gombos menü... (ha elférsz)

A pwd parancs mutatja az elérési utját a könyvtárnak, ahol vagy:

pwd

Ha egy könyvtárral mélyebben vagy, akkor a cd parancs segítségével lépsz egy könyvtárral feljebb, a megfelelő helyre:

cd ..

Ha mélyebbre lépnél, akkor (listázás)

ls

... listázod, mi van abban a könyvtába, ahol vagy, majd (ez csak az eleje, amit be kell írnod)

cd

... utána szóköz és beírod azt a könyvtárnevet (vagy elérési utat),ahová el szeretnél jutni. A név kiegészítésekhez Nyomd meg a TAB billentyűt. A nevet el kell kezdened begépelni, a TAB nem találja ki enélkül a kiegészítését.

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#5 Így csináltam.
Minden lefutott hiba nélkül a konzolba de a fájlkezelőbe se és dir se listázza ki hogy történt volna valami. Nem találom a swapfájlt.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#6 Több lépéses a folyamat, linkeltem 4 leírást is:
https://linuxmint.hu/comment/37386#comment-37386

Ugye a fallocate vagy dd elkészítette a fájlt (ha elkészítette), de jogosultságot kell adni, meg kell formázni, és be kell kapcsolni. Ennek elmélete (másoltam):

sudo chmod 600 /PATH/FILENAME
sudo mkswap /PATH/FILENAME
sudo swapon /PATH/FILENAME

... mindezekhez kell a sudo a parancssorok elejére és egy szóköz a sudo után..

Melyik volt az első parancssor, amit használtál és ezek után az ls nem látja? A fallocate vagy a dd. A sudo-t használtad?
Ide kéne másolni. Kimenet volt a parancssor futtatásakor, és mi? Ha volt.

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#7
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo fallocate -l 9G /swapfile  
[sudo] tibi jelszava:  
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo chmod 600 /swapfile
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo mkswap /swapfile
mkswap: /swapfile: warning: wiping old swap signature.
Setting up swapspace version 1, size = 9 GiB (9663672320 bytes)
no label, UUID=326f8402-e085-4c8d-9c41-f93802deba72
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo swapon /swapfile
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ ls
lost+found  timeshift  virtual_os
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$

Mindenhol hibaüzenet nélkül visszatért a prompt.
Lehet hogy létrejött, csak abszolút láthatatlan...? 
Ezt nem tudom.
 

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#8 Hm.

tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo swapon --show
NAME      TYPE SIZE USED PRIO
/swapfile file   9G   0B   -2
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo free -h
             total        used        free      shared  buff/cache   available
Mem:          7,7Gi       1,6Gi       4,2Gi       419Mi       1,9Gi       5,4Gi
Swap:         9,0Gi          0B       9,0Gi
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$

Lássuk alapon végigcsináltam mindent, és működik..? Konzol szerint igen. 

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#9
Működik mert egy reboot után megjelent a Munkamenet gombnál a hibernálás.
És ez eddig nem volt.
Most kipróbálom. 

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#10 Hát nem működik.
Rányomok hogy Hibernálás, a szokásosnál sokkal hosszabb ideig áll le, közben olyat csinál amit eddig nem, gondolom így írja ki a ramot a swapba.
Majd szépen kikapcsol a pc.
Megnyomom a power gombot és teljesen szabályos rendszerindítás következik.
Lekérdezve a swapot, a tartalma nulla, üres teljesen.
Hol lehet a bibi?

Értékelés: 

0
Még nincs értékelve
kimarite képe

A jó javaslat

#3 #8 #9 Mmm, a rendszer gyökerében hoztad, hoztátok létre a swap fájlt, persze, az én javaslatomra. Elnézést.

A rendszer könyvtárad ( a / alatt. Listázás --> ls -lh /) alatt véletlen létrehozott swap fájlt előbb kapcsoljátok ki, majd töröljétek.Aztán jöhet a következő módszer, mármint az elképzelt könyvtárban létrehozás.

Nézzünk egy nálam meglévő partíciót, melynek elérési útja ez:

/media/debkim/ADAT/

... a példában ezzel fogok dolgozni.

Nem kell belépni egy könyvtárba sem...

Viszont, ha kell az elérési út másolva, akkor érdemes belépni:

-- lépj be abba a könyvtárba (cd), ahol létrehozod a swap fájlt. Én most ide:

cd /media/debkim/ADAT/

-- megnézem, hol vagyok (pwd):

pwd
/media/debkim/ADAT

... a kimenet az az elérési út, amit használni fogok a következő lépésekben (példa!).

A swap fájl létrehozása

-- fallocate: fájl létrehozáse

sudo fallocate -l 9G /media/debkim/ADAT/swapfile

-- listázás, jelenlegi jogosultságok

ls -lh /media/debkim/ADAT/swapfile
-rw-r--r-- 1 root root 9,0G máj   18 22:42 /media/debkim/ADAT/swapfile

-- jogosultságok megadása (chmod)

sudo chmod 600 /media/debkim/ADAT/swapfile

-- listázás, jelenlegi jogosutságok

ls -lh /media/debkim/ADAT/swapfile
-rw------- 1 root root 9,0G máj   18 22:42 /media/debkim/ADAT/swapfile

-- formázás

sudo mkswap /media/debkim/ADAT/swapfile
Setting up swapspace version 1, size = 9 GiB (9663672320 bytes)
no label, UUID=e2bbd72f-acf0-4650-a81c-860df263f21e

-- a swap fájl bekapcsolása

sudo swapon /media/debkim/ADAT/swapfile

-- az eredmény

sudo swapon --show
NAME                        TYPE      SIZE   USED PRIO
/dev/sda2                   partition 9,5G 118,2M   -2
/media/debkim/ADAT/swapfile file        9G     0B   -3

-- az összes swap és RAM (human readable format)

free -h
              total        used        free      shared  buff/cache   available
Mem:          7,7Gi       2,6Gi       3,7Gi       278Mi       1,4Gi       4,5Gi
Swap:          18Gi       118Mi        18Gi

A swap fájl kikapcsolása

... ha már nem kell.

sudo swapoff /media/debkim/ADAT/swapfile

-- az eredmény

sudo swapon --show
NAME      TYPE      SIZE   USED PRIO
/dev/sda2 partition 9,5G 117,1M   -2

És ezek után kell betenni az etc könyvtár alatt található fstab fájlba, majd a rendszert újraindítva, használatba venni. Szerkeszteni kell az fstab fájlt.

A swap fájl törlése (az előbbi után)

-- törlés (vigyázat, az elgépelés törölhet más fájlt!)

sudo rm -f /media/debkim/ADAT/swapfile

-- tényleg töröltem? Igen:

file /media/debkim/ADAT/swapfile
/media/debkim/ADAT/swapfile: cannot open `/media/debkim/ADAT/swapfile' (No such file or directory)

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#11 Nincs benne az fstab fájlban. Ez lesz az utolsó lépés.
Előbb olvasd el, amit írtam:
https://linuxmint.hu/comment/37402#comment-37402

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#13   Az fstab bejegyzés a példámban említett elérési úttal:

-- új sorba, a meglévő szöveg után:

# swap file
/media/debkim/ADAT/swapfile    none    swap    defaults    0  0

Ha az fstabban benne van, akkor a rendszer indításakor a partíciónak automatikusan befűzve kel lennie!
Az elérési utat helyettesítsd be azzal, ami a te rendszerednek megfelelő.

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#13 De benne van az fstabbba, csak azt elfelejtettem leírni.
Tényleg a gyökérbe hozta létre pedig én a háttér hdd sdb4 partícióm gyökerébe imdítottam a terminált és végig abba dolgoztam.

tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo fallocate -l 9G /swapfile  
[sudo] tibi jelszava:  
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo chmod 600 /swapfile
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo mkswap /swapfile
mkswap: /swapfile: warning: wiping old swap signature.
Setting up swapspace version 1, size = 9 GiB (9663672320 bytes)
no label, UUID=326f8402-e085-4c8d-9c41-f93802deba72
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ sudo swapon /swapfile
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$ ls
lost+found  timeshift  virtual_os
tibi@444tibi-debian:/mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505$

Végig írja is hogy 
mnt/69e3c6b5-9ed5-47f8-9ca4-d9bbc07a6505 

Ez az sdb4 partícióm, ez nem a / . És mégis a / alatt hozta létre. Meg is találtam, ott van.
Mindegy, még jobb helyen is van egyelőre, de nem ez a gond hanem nem hibenál, illetve igen de visszetérésnél nem a hibernálásból áll fel a gép hanem egy teljesen szabályos rendszerindítás lesz.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#15 Ez az sdb4 partícióm, ez nem a / . És mégis a / alatt hozta létre. Meg is találtam, ott van.

Ácsi. Az előbb írtam le, miért ott hoztad létre. Leírod te is? :)
Azt is leírtam, hogyan hozd létre, ott ahol kell.
Az fstabban a / szerepel vagy a „hosszabb” elérési út?

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#16 Logikus, hogy a telepített rendszer fájlrendszerének gyökerében hozta létre a fallocate a swap fájlt (bármelyik könyvtárban állunk), mert azt az elérési utat adtuk meg a létrehozás helyének. Legalább az alkalmazásnak megvan a magához való esze. :)

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#16
Ácsi. Úgy csináltam ahogyan leírtad. Ha a terminált a HDD vinyóm sdb4 gpartíciójának a gyökerébe indítottam el. és végig OTT csináltam mindent, akkor hogyan lett swapfájlom az SSD vinyó sda4 Debian partíción ...?
Az fstabba nem a hosszabb hanem a / elérési út van.
De mindegy, megvan a swapfájl. Még jobb is tesztelni mert ott van ahol ideális, a Debian gyökerébe.
De nem működik a hibernálás. Ez a nagyobb baj.
Most midegy hol a swap, a lényeg hogy hibernálásra nyomva biztosan hibernál mert nem úgy áll le ahogy eddig, látom a gépen hogy tényleg hibernál de nem tud belőle vsszajönni hanem simán úgy indul mint amikor normál indítás van.

Értékelés: 

0
Még nincs értékelve

A swappiness értéket nem

#17 Te írtad feljebb hogy ha máshol nyitok terminált akkor ott hozza létre.

"Be kell lépni a másik meghajtó egyik könyvtárába vagy közvetlenül a befűzés helye alá, ha másik meghajtóra szánod a swap fájlt."

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hibernálás swap fájlba

#15 4 URL a hozzászólás végén: az egyiken írt powerdev szerkesztés szerintem nem szükséges.

Documentation used: https://askubuntu.com/a/1132154

Ha nem hibernálásra kell, vannak még más módszerek, tömörítési eljárást használó swap megoldások: zswap, zram.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#19 Te írtad feljebb hogy ha máshol nyitok terminált akkor ott hozza létre.

"Be kell lépni a másik meghajtó egyik könyvtárába vagy közvetlenül a befűzés helye alá, ha másik meghajtóra szánod a swap fájlt."

Igen. Értelek. Volt ilyen is.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A swappiness értéket nem

#18 Azóta megírtam, jól hogyan kell.

Értékelés: 

0
Még nincs értékelve

Summázva.

Summázva.
Mindegy hogyan bénáztam össze de létrejött a swapfile.
Fstabba benne van, a rendszer felismeri, kilistázza, használja.
Viszont mindezek ellenére a Debian képtelen hibernálni, pontosabban abból visszatölteni magát.

Éjjel volt időm ezzel bíbelődni.
Végignéztem a BIOS beállításokat, minden ok.
Beboooltam a Windows10-be, engedélyeztem a hibenálást (a Fast Startupot, Gyors rendszerindítást nem, csak  a hibernálást).
A Win jól csinálja a dolgát hibernál és fel is áll belőlee.
Ezt azért teszteltem le hogy kiderüljön az esetleges BIOS vagy ACPI beállítási vagy egyéb hiba.de azok akkor jól vannak beállítva.

"Ha nem hibernálásra kell, vannak még más módszerek, tömörítési eljárást használó swap megoldások: zswap, zram."
Ezaz hogy pont nem nem a swappolás miatt hoztam létre (8g ram mellett eddig se volt rá szükség),  hanem pont azért hogy tudjak hibernálni.
De az meg nem működik sajnos.

Értékelés: 

0
Még nincs értékelve
tresor képe

Summázva.

#23 Secure Boot be van-e kapcsolva a biosban?
Itt van egy Reddit-es szál, e szerint off Secure Boot opcióval ment a hibernálás.

https://www.reddit.com/r/debian/comments/ceaj4f/hibernation_doesnt_work_anymore_in_buster_with/

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Summázva.

#23 A swap fájlba lehet hibernálni. Nem automatikus, be kell állítani.
Az elméleti módszert írtam itt: https://linuxmint.hu/comment/37411#comment-37411
A módszert nézegesd, délután jövök.

Értékelés: 

0
Még nincs értékelve

Summázva.

#26 A második parancsnál számomr leküzdhetetlen problémába ütköztem:

tibi@444tibi-debian:~$ sudo swapoff /swapfile
[sudo] tibi jelszava:  
tibi@444tibi-debian:~$ sudo dd if=/dev/zero of=/swapfile bs=$(cat /proc/meminfo | grep MemTotal
| grep -oh '[0-9]*') count=1024 conv=notrun
dd: érvénytelen átalakítás: ”notrun”
További információkért adja ki a(z) „dd --help” parancsot.
 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Summázva.

#27 A linkelt leírásban lemaradt a notrunc kifejezés végéről a c karakter. A hibát jelző parancssor vége. Kézikönyv súgott:

https://linux.die.net/man/1/dd

Értékelés: 

0
Még nincs értékelve

Summázva.

#28 Hát hallod... Kb. 50  percig pötyörésztem meg másol, beilleszt, uuid-t copiz-beilleszt, grubot-systemd-t vagy mit meg initramfs-t szerkeszt meg updatel.

Működik a hibernálás.
Viszont nem tudom van-e értelme használni mindig, csak akkor látom értelmét ha sos-be össze kell kapnom a gépet és nyakig benne vagyok valamibe, hogy onnan folytassam később.
Nagyon lassan tér magához a gép. Nem méricskélek de érzésre annyi vagy hosszabb mint ha rendes indítást használnék.
Vitathatatlan előnye hogy onnan folytatja ahol abbahagyta.

Köszönöm a részletes magyarázatot, még egyszer biztos hogy nem vágok neki, pláne hogy áthelyezzem a másik partícióra a swapfájlt, brrr......
Tényleg nem azért mert, de ez Win alatt parancssorban ennyi:
powercfg -h on
És van hibernálás. Értelemszerűen -h off és kikapcsolja a hibernálást.
Gui alatt meg 6 kattintás.

Amúgy paráztam rendesen miközbe csináltam mert pl. Grub szerkeszés közben nem jó ómen benézni egy szóközt vagy az uuid esetleg rövidebb egy számmal... :-) 

Értékelés: 

0
Még nincs értékelve

Summázva.

#29 Ha jól sejtem ez egy PC - ha nem jellemző azon a területen ahol laksz a feszültségkimaradás, akkor nem jobb lenne a hibernálás helyett a felfüggesztés ?
Csak a RAM-ban lévő adatokat frissíti minimális teljesítmény-felvétellel.
És indítás után 1.5-2 másodperccel használható a rendszer.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Summázva.

#29 Működik a hibernálás.

Jó hír!

Viszont nem tudom van-e értelme használni mindig, csak akkor látom értelmét ha sos-be össze kell kapnom a gépet és nyakig benne vagyok valamibe, hogy onnan folytassam később.

Összakapásra, félbehagyásra jó...

Nagyon lassan tér magához a gép. Nem méricskélek de érzésre annyi vagy hosszabb mint ha rendes indítást használnék.
Vitathatatlan előnye hogy onnan folytatja ahol abbahagyta.

Nem használom. A LibreOffice is automatikusan menti a doksit, és be lehet állítani az időtartamát is.

Köszönöm a részletes magyarázatot, még egyszer biztos hogy nem vágok neki, pláne hogy áthelyezzem a másik partícióra a swapfájlt, brrr......
Tényleg nem azért mert, de ez Win alatt parancssorban ennyi:
powercfg -h on
És van hibernálás. Értelemszerűen -h off és kikapcsolja a hibernálást.
Gui alatt meg 6 kattintás.

Ezt nem tudom. Igazából azt sem, hogy van-e Windows alatt swap, úgy, mint fájl. De lehet (van?), mert ráálltak erre a hibernálásra, mert „megmutatjuk, a mi rendszerünk a leggyorsabb”. Csak szerintem sokan nem tudják, hogy miért. :)
Azt tudom, hogy a saját alkalmazásaik némelyike nem működik, például a webinar alkalmazás. Ha nem működik, nem sokat tudsz csinálni, amit igen, az nehezebb,mint Linux alatt, és igen kevés leírás van a megoldásról amott. A Linuxos Skype-ot sem tudják úgy összerakni, hogy ne fejjel lefelé legyen a kép. (majd este mondok egy „Üdvözlégy, Mária, kegyelemmel teljes„-t ..., hisz' szeretjük egymást. Ez a szóbeszéd. A változás nem túl gyors.)

Amúgy paráztam rendesen miközbe csináltam mert pl. Grub szerkeszés közben nem jó ómen benézni egy szóközt vagy az uuid esetleg rövidebb egy számmal... :-) 

Az nem jó :). De ott a chroot, mint lehetőség. (ezért kell tartalékba egy Live rendszer pendrive-on, amit csak erre használsz).
Technikai: mostanában próbálkozom a Raspbian telepítővel, a host a Debian. Virtualbox nem szereti az ARM-et, a QEMU elindította, de fekete képernyővel és egy nagy, fehér törzsfőnök villogó kurzor jellel (kis felbontásban). Nem jut eszembe, hogyan, mivel tudnám futtatni. Gondolkozom.

Értékelés: 

0
Még nincs értékelve

Summázva.

#29 Nem tudom, a Debian 10-es alapú Bunsenlabs-on nagyon jól müködik a hybrid-sleep a laptopon. Ha fedelet lehajtok akkor 2-3 másodperc alatt felélbred, ha netán tökéletesen lemerül, akkor pedig a hibernált állapotból visszahozza magát. Nem kell sokat bajlódni a beálltással sem, nem túl bonyolult.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Summázva.

#32 Azt gondolom, ez hardver függő. A fedél lehajtása és felnyitása az én noteszgépemen is működik, de ugyanaz a Debian 10, mint 444tibinek. Mondjuk, neki KDE, nekem Xfce az asztali környezet.
Itt egy új dolog jött képbe, a swapfile-ba hibernálás. Nekem swap partícióm van.

Értékelés: 

0
Még nincs értékelve

Summázva.

#31
Van Win alatt is swap, ezt nem tudom mire való mert külön van a pagefile.sys, ez a lapozófájl, vagyis a swap komkrétan.
És van külön hiberfil.sys, abba hibernál, külön van a kettő.
$Recycle.Bin
Documents\ and\ Settings
hiberfil.sys
Intel
pagefile.sys
PerfLogs
ProgramData
Program\ Files
Program\ Files\ (x86)
Recovery
swapfile.sys
System\ Volume\ Information
Users
Windows

Tudom hogy annak a rendszernek is van bőven baja, nem is ezért írtam amit írtam és nem célzattal írtam.
Csak megjegyeztem hogy 1000x egyszerűbb ezt a konkrét hibernálást ki-be kapcsolni.
A saját appjait a Microsoftnak én speciel nem használom, számomra a Windows Store nem létezik mert az appok erősen fapadosak és a konfigurálási lehetőségük a nullához konvergál, valamint az egésznek olyan érthetetlen zagyva knézete és hangvétele van.
Te is írtad hogy a Microsoft saját applilációi nem működnek a saját OS alatt normálisan.
Ebben egyetértünk, én ezért (is) használok külső, jól bevált, évek óta működő szoftvereket.
Amelyek között is előfordulnak enyhe bugok, tökéletes operációs rendszer és program nem létezik.

Értékelés: 

0
Még nincs értékelve

Summázva.

#30 "nem jobb lenne a hibernálás helyett a felfüggesztés ?"

Nem, legalábbis nekem 2 okból  sem jó a felfüggesztés.
Az egyik, épp ezért bíbelődtem a hibernálással, ami nekem van az gyakorlatilag egy asztali mini PC, de rá van applikálva usb hubostul tápegységestől mindenestől egy 22" monitor hátuljára. Gyakorlatilag egy 22 collos laptop, mert naponta hurcibálom az otthon és a munkahelyeim között. Működik 12 voltos akkuról is, kocsiba, kinnt terepen, mobil a cucc.
Kollégák már megszokták, Jön a Tibi, kilóg a hóna alól a "laptopja".
A másik, nyomós okom hogy nem tudok felfüggeszteni. Ha alvóba küldöm a gépet, visszatérésnél nincs kép. Ez biztosan valami videodriver gond de nem működik az alvás.
Minden visszajön, bill. világít, egér éled, háttér hdd felpörög, ha épp ment a zenelejátszás akkor az is szól de a monitor sötét marad.
Nem is próbálkozok vele mert ilyenkor mivel nem látok semmit, marad a főkapcsoló, azt meg nem szeretem. Kirántani az os lába alól a talajt, nem jó.

Valaki említette a hibrid alvást. Ez jó lenne nekem nagyon, ezt hogyan kell?

Értékelés: 

0
Még nincs értékelve

Summázva.

#35 Ez nem ajánlás, - csak egy keresés eredménye: https://www.maketecheasier.com/enable-hybrid-suspend-in-ubuntu/

Értékelés: 

0
Még nincs értékelve

Summázva.

#35 Próbáld terminálban:

systemctl hybrid-sleep

Remélhetőleg, ha már ment a hibernálás, nem is kell bűvészkedned tovább.

Értékelés: 

0
Még nincs értékelve

Summázva.

#37   
Működik a hibrid alvás, de ittt ugynaz van mint sima alvásnál, a visszatérésnél sötét marad a képernyő.
Ha ilyenkor kilvöm a bekapcsoló gombbal akkor indításkor betölti az állapotot vagyis valóban alszik is meg hibernál is.
Arra van valami megoldás hogy altatásból visszajövet legyen kép? Hibernálásból visszajön, jó,  sleep-- nincs kép.

Erről ezt találtam, segítene valaki értelmetni?
https://wiki.debian.org/Suspend#Fixing_corrupted_video_on_resume

Értékelés: 

0
Még nincs értékelve

Summázva.

#38 Gondolom már leírtad, de nem találtam, hogy milyen videokártyád van, valószínüleg arrafelé kell keresni a hibát. Sajnos ez elég gyakori hiba, volt néhány eset, amelyet nem is sikerült azon a gépen megoldani.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Summázva.

#38 Felbontás, háttérvilágítás, energiakezelés (képernyővédő)... ezek lehetnek az okok.

Pasztázni kéne a kimenetet, innen kiderülhet:

dmesg

Videókártya, driver:

inxi -G

Az acpi_backlight=vendor kernel paramétert kipróbálnám.
A linken is szerepel, de „backlight”-tal lehet gond. A dmesg mutathat mást is. A Xorg.0.log hasonlóan mutatja.
https://ubuntu-mate.community/t/suspend-black-screen/10563

A GRUB_CMDLINE_LINUX_DEFAULT sorban, a korábbi telepítésnél én is beállítottam a paramétert, most nem, de „cserébe” a noteszgép gyorsbillentyű vezérlése nem is működik. Nincs most erre szükségem.
A paraméter beállítása egyszeri indításhoz a GRUB menüben a legújabb kernel sor E-s szerkesztésével (quiet-nél), majd F10 az indítás. Maradandóan így: https://linuxmint.hu/blog/2018/03/kernel-kapcsolok-alkalmazasa-a-grub-fajl-szerkesztesevel
Utána suspend és visszatérés. A próba.

A visszatéréskor halványan látod esetleg az Asztal elemeit? Ha gyorsbillentyűvel világosítani próbálsz?

Értékelés: 

0
Még nincs értékelve

Summázva.

#40 Dmesg:
https://paste.ubuntu.com/p/3dn33kBH8y/

tibi@444tibi-debian:~$ inxi -G
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated  
          Graphics  
          driver: i915 v: kernel  
          Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa  
          resolution: 1920x1080~60Hz  
          OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) v: 4.5 Mesa 18.3.6

Meg fogom nézni a monitort este, van-e kép, arra gondolsz csak a háttérvilágítást nem teszi vissza sleep után?
Ezekkel a grub acpi backlight nemtudommikkel már szórakoztam a Mint és a Manjaro alatt is de nem vezetett eredményre.

A hibernálás nagyon szuperül működik, ma délelőtt hibernáltam a melóhelyen, itthon indít és a wifin kívül minden jól visszajött.
Azon homokórázott 2 percig majd meguntam és manuálisan rányomva átállt az otthoni routeremre.

Értékelés: 

0
Még nincs értékelve