Sharp MX-2651 működtetése Linux Minttel

Fórum: 

Sziasztok!

A címben említett multifunkciós készüléket szeretném működésre bírni Linux Mint 20 Ulyana alatt.

Egy középiskola rendszergazdája vagyok, ahol - eddig - három Windows 2008 R2-es szerver, és az arra csatlakozó Fujitsu-Siemens Futro S400-as kliensek szolgálták ki a tantestületet. Ezt szeretnénk lecserélni egy (vagy több) Linux alapú virtuális szerverre. A Linux Mint, vagy az Ubuntu Mate jött szóba erre a célra. Eddig úgy tűnt, minden tökéletesen halad, egy hónapja teszteljük páran, és úgy tűnt, működőképes a terv. Viszont a mai napon kaptunk két Sharp MX-2651 multifunkciós készüléket. A hivatalos oldalukról ( https://www.sharp.hu/cps/rde/xchg/hu/hs.xsl/-/html/product-details-offic... ) letöltöttem a "PS/PPD driver for Linux, version 1.1" nevű drivercsomagot, és a megfelelő .ppd segítségével, a "Nyomtatók" nevű alkalmazásban (system-config-printer) megpróbáltam hozzáadni a nyomtatót. Létszólag hozzá is adta, viszont egyszerűen nem tudok nyomtatni vele. Szívesen fogadnék minden javaslatot, ötletet, hogy egyáltalán hogy induljak el. Nem lennék felelőtlenül boldog, ha emiatt kellene dobnunk az egész átállást.
A /var/log/cups/access_log szerint nincs hiba, a nyomtatás kezdeményezésekor Print-job successful-ok bejegyzés keletkezik, csak éppen nem nyomtat... Windowsból viszont a nyomtatás rendesen működik.
Előre is köszönöm a segítséget!

tresor képe

Driver telepítés előtt nézted

Driver telepítés előtt nézted, hogy mit ismer fel a rendszer?

Driver telepítés után restart volt?

Csoport tagság?

Tagja vagy az lp és scanner csoportnak?

groups kimenet mit mutat?

 

Értékelés: 

0
Még nincs értékelve

Nyomtató IP címe fix-e?

Ilyen elő szokott fordulni attól is, ha a nyomató DHCP kiszolgálótól folyton megújúló IP címet kap.

Be kellene állítani egy FIX IP címet neki.

Illetve tűzfalat is megsasolni, nem blokkol-e valamit, pl. Kim által említett CUPS-t, 631-637 portokon.

Milyen gazdagépen fut a virtuális Linux? (bekavarhat még a Samba is)

Értékelés: 

0
Még nincs értékelve

Driver telepítés előtt nézted

#1 Látta a nyomtatót, de azt a típust nem támogatta (nem volt ott a listában), ezért próbáltam hozzá a drivert letölteni.

Újraindítás volt, de semmi változás. A csoporttagságokat most beállítottam (nem voltam tagja az lp-nek és a scannernek), de szintén semmi. A groups csak a saját csoportomat írta ki, illetve most már az lp-t és a scannert is.

Értékelés: 

0
Még nincs értékelve

Nyomtató IP címe fix-e?

#3 Az IP fix, DHCP szerver ugyan van, de a nyomtatók, hálózati eszközök és szerverek mind fix IP-t kapnak.
A virtuális Linux egy Debian 9-es gazdagépen fut.

Értékelés: 

0
Még nincs értékelve

Félsiker. :)

Lehet, hogy megtaláltam a megoldást. A driver kiválasztásakor a "Geenric (javasol)"-ban a PCL6-tal működik. (A PCL3-at javasolja, de azzal csak szemetet nyomtat.) Most már csak a színes nyomtatásra kell valahogy rájönnöm.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Félsiker. :)

#7 Azt írja a leírás is:

Alapkiépítésben PCL 6 emuláció, opcionális Adobe® PostScript® 3™

https://en.wikipedia.org/wiki/Printer_Command_Language

A FAQ ezt mondja:

„[Szín]” értékre van állítva a színes
mód?

A színes módhoz válassza ki az „Auto” vagy a „Szín” beállítást.
Windows:
A beállítást a nyomtató-illesztőprogram [Fő] lapján választhatja ki.
Mac OS:
A színes mód beállítást a nyomtatási ablak [Color] menüjében konfigurálhatja.
Windows rendszer esetén a beállítást a nyomtató-illesztőprogram [Minőség]
lapján is konfigurálhatja.

Nyilván a nyomtatás összes beállítását megnézted a LInux rendszeren is.
Megnéztem a PPD-t (egyszerű szöveges fájl), a CMYK beállítások benne vannak.

Értékelés: 

0
Még nincs értékelve

Újabb probléma

Köszönöm mindenkinek a segítséget! Igazából a megoldás itt volt végig az orrom előtt: a Generic / PCL Color Laser driverrel kitűnően nyomtat színesen. :) Régi rossz berögződés - látszik, hogy sokáig másik rendszerhez voltam szokva -, hogy az általános driverteket első körben meg sem néztem, közben meg kifogástalanul megy az "általános" driverrel.

Még egy dolog van, amivel viszont nem boldogulok: szükség lenne a felhasználókat kóddal, és ezzel együtt korláttal ellátni. Ezt a nyomtató admin felületében be is állítottam, viszont a nyomtató tulajdonságainál (mármint az oprendszerben, nem a nyomtató felületén) nem tudom beállítani a felhasználói számot. Erre esetleg tudtok valami megoldást? Netes keresés révén a Pykota-hoz jutottam, de az meg nem igazán akar működni a gépen található Pythonnal. Sem a 2-es, sem a 3-as verzióval.

Értékelés: 

0
Még nincs értékelve
kimarite képe

prqt | print quota enforcement daemon

#9 Alapvetően mintha arról.lenne szó, felhasználónként nincs limit/kvóta, de a beállításokban mégis ott. Nem ismerem közelebbről. A kézikönyve: https://linux.die.net/man/1/prqd

Értékelés: 

0
Még nincs értékelve
kimarite képe

PyKota

#9 Netes keresés révén a Pykota-hoz jutottam, de az meg nem igazán akar működni a gépen található Pythonnal. Sem a 2-es, sem a 3-as verzióval.

Nem arról van szó inkább, hogy nem a CUPS/Samba párossal házasítod össze a PyKota alkalmazást?
https://lists.debian.org/debian-user/2006/01/msg00990.html
Mi nem működik?

Így telepítetted?
http://www.pykota.com/software/pykota/download/

Videón: egy régebbi verzió:
This 6.7 MB screencast will show you how to install the latest stable release of PyKota on a Debian box with an existing an working CUPS setup, in less than 10 minutes (9'40").

Systemd van már a Debian 9 Stretch rendszeren a Sysvinit helyett (szolgáltatások újraindítása), de a leírás jó:
https://www.brennan.id.au/18-Samba.html
https://www.brennan.id.au/15-System_Printing.html

Értékelés: 

0
Még nincs értékelve

PyKota

#11 Úgy próbáltam telepíteni, ahogy a hivatalos oldalukon írták, amit linkeltél. A következőket kaptam:
 

root@vvtsrv6:/tmp/pykota-1.26_fixes_official# python checkdeps.py
bash: python: parancs nem található

root@vvtsrv6:/tmp/pykota-1.26_fixes_official# python3 checkdeps.py
  File "checkdeps.py", line 33
    exec "import %s" % module
         ^
SyntaxError: Missing parentheses in call to 'exec'
root@vvtsrv6:/tmp/pykota-1.26_fixes_official# python2 checkdeps.py
Checking PyKota dependencies...
Checking for Python-PygreSQL availability : NO.
ERROR : Python-PygreSQL not available !

Az első hiba érthető, nem találja a Python értelmezőt, holott az telepítve van, csak mint python2, vagy python3 kell hivatkozni rá. Ki is próbáltam következő lépésben, Itt szintaktikai hibára panaszkodik, gondolom, mert Python2-ben készült, és nem 3-ban. Python2-ben futtatva meg ad egy halom hibát (csak az elejét másoltam be), nem találja a PygreSQL-t. Ami viszont csak Python3-hoz érhető el, legalábbis a repóból.

Értékelés: 

0
Még nincs értékelve
kimarite képe

PyKota

#12 A függőségeket fel lehet tenni a PIP csomagkezelővel is. Talán lehetne egyértelműbb leírás ehhez. A másik történet: Alapértelmezett Python interpreter beállítása (modulok telepítése)

Értékelés: 

0
Még nincs értékelve