Nyomtató telepítése

Fórum: 

 Követem a http://hplipopensource.com/hplip-web/install/install/index.html varázslót. Odáig már eljutottam, hogy van egy letöltött hplip-3.17.4.run.asc filem, ezt próbálom telepíteni. A terminál azt mondta, hogy cd Desktop parancs nincs, erre áttetem a filt a Letöltések közül az Asztalra, cd Asztal már elfogadva, de hiába: ivan@ivan-Aspire-5535 ~/Asztal $ hplip-3.17.4.run
hplip-3.17.4.run: a parancs nem található.

Hogy tudom folytathatni a telepítst?

kimarite képe

RE: Nyomtató telepítése

@Hymer A hplip csomagok a Linux Mint tárolóiból is elérhetőek. Keresd a csomagok között: hplip
Wiki: https://wiki.ubuntuusers.de/HPLIP/

A másik csomagnál -telepítés- lemaradt az 'sh'.

A tárolóból elérhető frissülni fog, stb.:
https://askubuntu.com/questions/10082/which-is-the-best-way-to-install-n...

Értékelés: 

3
Átlag: 3 (1 szavazat)

Gimppel nem működik

Sikerült a hplip automatikus telepítése és a LibreOffice-szal működik is. De a Gimp még nem akarja elfogadni. Rákattintok a Fájl-ban Scan as layer-re vagy a Scan...-ra, akkor egy pillanatra megjelenik Scan dialógus három füllel, de ez nagyon hamar el is tünik. Az a furcsa, hogy mielőtt a hplip-et telepítettem, ebben a dialógusban néhány másodperc múlva a Files alatt megjelent a Scan is, aztán úgy nézett ki, mintha minden működne, még a szkennerem is pásztázott, csak éppen kép nem jött. 

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Gimppel nem működik

#2 Próbáld meg a gimp-gutenprint csomag telepítése után,
https://ubuntuforums.org/archive/index.php/t-825577.html
vagy Postscript (PS) formátumba
http://hplipopensource.com/node/325
elmenteni a nyomtatandót, majd azt megpróbálni kinyomtatni. Mindkét lehetőséget.

Milyen nyomtatód van?
https://wiki.ubuntuusers.de/HPLIP/

hp-info

Értékelés: 

0
Még nincs értékelve

HP Deskjet F4180, All-in-one

HP Deskjet F4180, All-in-one szkenner/nyomtató. Most nem a nyomtatás, hanem a szkenner a probléma, az működik nagyon szépen a LibreOfficeban, egyáltalán nem a Gimpben és félig a HP Device Managerben a fent látható módon. A gimp-gutenprintet telepítettem, de semmit sem segített. Ahogy írtam, a Scan dialógus néhány másodpercig megjelenik, abban látszik, hogy nem találta a szkennert, aztán eltünik, mielőtt bármit csinálhatnék. A nyomtatás funkció működik.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:HP Deskjet F4180, All-in-one

#5 Három megoldás kínálkozik, ma csak linkelni tudom ezeket:
http://publications.lexmark.com/publications/pdfs/network_scan_drivers/e...
http://smallbusiness.chron.com/gimp-recognize-scanner-58544.html

A szimbolikus link készítésébe akkor fogj bele, ha az előzőek nem hoztak sikert és tudod, mit kell pontosan csinálnod:
http://www.xsane.org/doc/sane-xsane-gimp-doc.html

Úgy értelmezem, szkenner plugin nincs a GIMP-hez, egy külső alkalmazást kell 'meghívni' ehhez a GIMP-ből, nevezetesen ez az XSane.

Értékelés: 

0
Még nincs értékelve

Az XSane-nel van baj: képszélesség

 Tulajdonképpen nem is a hp-val van hiba, hanem az XSane-nel. Úgy csinál. mintha szkennelne, szépen beolvas, aztán megjelenik az üres kép. Az nem jó támpont a hibakereséshez, hogy a LibreOffice-szal működik? Persze lehet, hogy az a Simple Scan-t használja? Mindenesetre az XSane nem működik, se önmagában, se a Gimppel.

SZERKESZTVE:  Legalul az a méret látszik, hogy 0,00 cm x 15,92 cm és valóban a képben egy függőleges halvány vonal jelenik meg. Ezt viszont nem tudom átállítani. Azt hogy kell?

MÉG VALAMI: Amikor beindul a szkennelés:  "Error during CMS conversion:

Could not open scanner ICM profile."

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Az XSane-nel van baj: képszélesség

#7 A hiba üzenetre:
https://linuxforums.org.uk/index.php?topic=10200.0

Mark Greaves (PCNetSpec)
I take it Xsane still starts/works ?

If so (and you don't use colour profiling) .. have you tried unchecking Preferences > Enable colour management

If you do use colour profiling, see here:
http://www.xsane.org/doc/sane-xsane-setup-color-management-doc.html
and maybe:
http://ubuntuforums.org/showthread.php?t=870424

donwatson
Thanks Mark,
I unchecked Preferences>Enable colour management and it now works.

Ugyanezt írják itt is:
https://answers.launchpad.net/ubuntu/+source/xsane/+question/65736

Értékelés: 

5
Átlag: 5 (1 szavazat)

[Megoldva!] Működik!

 Köszönöm kimarite! rm ~/.sane/xsane/*.drc volt a megoldás! Működik!

Értékelés: 

0
Még nincs értékelve
fecameca képe

HPLIP egy nagy rakás trágya

HPLIP egy nagy rakás trágya az egész. Miután feltelepítettem a gépemre a Linux Mint-et gyönyörűen működött a nyomtató is valamilyen nyílt forráskódú akármivel. De a HPLIP-pel csak a baj van. Nincs meg hozzá a HP deskjet 5150 inkjet-hez ppd fájl. Régebben még meg lehetett oldani a CUPS nevezetű akármilyen program ami a HPLIP- hez tartozik valahogy, eltávolításával, és újratelepítésével felrakott valami gutenprint nevű akármit. A nyomtatóm valamiért most is megadta magát, ezért eltávolítottam, és újra akartam telepíteni, de előjött megint, hogy nincs ppd fájl ehhez a nyomtatóhoz. Csak csupa laserjet van benne.  A CUPS pedig nem volt hajlandó települni, mert azt írta ki, valamilyen sérült csomagokat fogott vissza. Sajnos ez miatt teljesen úlra kellett telepítenem a rendszert, mert sehol senki nem tud ebben segíteni.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:HPLIP egy nagy rakás trágya

#12 Itt az ellenvélemény:
https://linuxmint.hu/comment/11328#comment-11328
A HPLIP egy nagyon jó alkalmazás, a gyártó is támogatja, az állításod nem igaz. Bizonyos esetekben utána kell járni (esetleg) a dolgoknak, de legtöbbször nem - de ez csak reflexió/válasz neked, fogalmam sincs, hol kérdeztél, és mi mit javasoltunk. Még az sem biztos, hogy van olyan HP, ahol nem működik, reagáltam neked.

'Sajnos ez miatt teljesen úlra kellett telepítenem a rendszert, mert sehol senki nem tud ebben segíteni.'
-- megpróbáltál itt kérdezni? Hol? Linkeld légy szíves. (' A CUPS pedig nem volt hajlandó települni, mert azt írta ki, valamilyen sérült csomagokat fogott vissza.' - ez egyértelműen megoldható, én vállalom a garanciát ;) pl. erre..., ha kiderül, mi a 'valamilyen' csomag. Tehát a konkrétumok segítenek, vagyis csak azok)
-- amúgy elég türelmesek és elég kitartóak vagyunk, hogy segítsünk, sokszor inkább a kérdező adja fel. Nyugodtan kérdezz..
-- én például Windows alatt találkoztam sok dologgal, amit nem tudtam megoldani, ...
-- igaz, Linux-szot használva is van sok kérdésem, de igyekszem keresni a megoldást: most is van például egy megoldásra váró dolog, de hamarosan 'fogom magam' és belépek a VLC fórumra, rákérdezek (magam még nem jöttem rá a megoldásra, egy bizonyos időbélyeg módosítására a televízió műsorok műsorújsága tekintetében).

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:HPLIP egy nagy rakás trágya

#13 Körvonalakban úgy tűnik a hplip által tényleg nem támogatott ez a printer. Ha tényleg frissítik az Ubuntu Wiki-t,
https://wiki.ubuntu.com/HardwareSupportComponentsPrintersHp
mert nem mindig. Itt most nem tudtam ránézni, mert valamiért nem tölt be az oldal: http://hplipopensource.com/hplip-web/supported_devices/index.html

Viszont a foomatic alkalmazással megoldható a HP Deskjet 5140 Inkjet működtetése, valahogy így: https://bbs.archlinux.org/viewtopic.php?id=219792
Ez egy lehetőség.

Akkor most az van, hogy látatlanban megoldottam neked, azt, amiben sehol senki nem segített. Ennyi.
(jav.: a 'sehol senki' a CUPS törésére vonatkozott, de szerintem az is megoldható. A csomag törések javíthatóak, persze, a stabil rendszert használva ... .)

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE: HP DeskJet 5150

#13 Itt mondjuk, azt írják szuper ..

HP DeskJet 5150
Color inkjet printer, max. 4800x1200 dpi, works Perfectly

Forrás:
https://www.openprinting.org/printer/HP/HP-DeskJet_5150

Értékelés: 

0
Még nincs értékelve
fecameca képe

Abban az egyben igazad van,

Abban az egyben igazad van, hogy itt még nem kérdeztem. De csak azért, mert nem is reméltem, hogy tud valahol bárki is segíteni, mert próbáltam keresgélni az ubuntus fórumokon, végignéztem az összes találatot, amit a google kereső a ppd-vel kapcsolatban behozott, és elolvastam azt is, amit te utoljára ide belinkeltél. Csakhogy abból semmi nem derül ki, hogyan csinálta és mit csinált?  Az előző egy archlinuxos fórum oldal, abból sem derül ki,honnan lett neki ppd, de nekem is volt, mint írtam (Vagy még nem?) valamikori régebbi CUPS még tudta ezt a nyomtatót, aztán valamelyik frissítés elfújta belőle. Így ha feltelepítem, még az sem garancia arra, hogy egy hónap múlva is tudom használni ezt a nyomtatót. Szerintem meg az történt, hogy a régebbi inkjetek támogatottsága megszűnt, és azért tűntek el azok a fájlok a HPLIP-ből. 2. Nem tudom, ha a Linux Mintet csak úgy simán feltelepítem, akkor az mit használ nyomtatóvezérlőnek, de ha egyszer elindítom a HPLIP-et akkor azt nem tudom többé visszahozni. A HPLIP már több géppel és többféle ubuntu és Linux Mint telepítése után kész kínlódás volt mindig. A legtöbször ezt a hiányzó ppd-t emlegette, a cups újrarakása néha segített, de ez a legutóbbi a Linux Mint xfce olyat produkált, amit még nem tapasztaltam: Íme az idézetek:

1: Error: No PPD found for model deskjet_5100 using old algorythm. Error.No appropriate print PPD file found for model deskjet_5100 2.: „Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy lehetetlen állapotot kért, vagy ha az unstable disztribúciót használja, akkor néhány igényelt csomag még nem készült el, vagy ki lett mozdítva az Incoming-ból. Az alábbi információk segíthetnek megoldani a problémát: cups : Függ ettől: libcups2 (=2.1.3-4) de csak 2.1.3-4ubuntu0.2 telepíthető < nem javítható, sérült csomagokat fogott vissza.”

Ekkor már elegem lett az xfce-ből, mert olyat is csinált, hogy automatikus beléptetéskor visszaszámlált 10-ről, és amikor elért 0-ig akkor újra kezdte az egészet elölről 30 ról. Úgy összevissza váltogatta, mindig oda ugrott, időben, ami neki tetszik.

 

Értékelés: 

0
Még nincs értékelve
fecameca képe

Most feltelepítettem rá a

Most feltelepítettem rá a Linux Mint 18.1 MATE változatát. Minimálisan több memóriaigény fejében egy sokkal stabilabb rendszer, és olyan menü, amit én megszoktam (Kár volt kísérletezni xfce-vel, kevesebb az előnye, mint haszna) Főleg azért, mert jól emlékeztem, a nyomtató jól működött HPLIP nélkül, nincs félórás feldolgozás, meg elakadt nyomtatási parancsok. Egyáltalán azt nem tudom, mi előnye van a HPLIP telepítésének, azon kívűl, hogy a nyomtató általában mindig a legváratlanabbkor, amikor a legnagyobb szükség lenne rá, meghal, és nem is hozható helyre a vele való kommunikáció. Valószínű, hogy nem is fogom akarni erőltetni a HPLIP-et, mivel van is egy tartalék lemezem is, amin még működik, de arra nincs garancia, hogy frissítéskor nem is megy tönkre.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Abban az egyben igazad van,

#16 Vélhetően valami bug-ról van szó, hogy ott a driver, de nem az lesz kiválasztva. Tesztelés és időm hiányában perpill nem tudok erre válaszolni. A  fo2zjs csomaggal megoldható az üzemeltetés, azaz ennek behelyettesítése az alábbi három csomag (a csomag már nem elérhetó fo2zjs néven a tárolókból. A Debian Wheezy alatt volt utoljára, de behelyettesíthető az alábbiakkal a Debian, az Ubuntu, a Linux Mint, stb. rendszereket használva)

sudo apt-get install hannah-foo2zjs printer-driver-foo2zjs printer-driver-foo2zjs-common

A következő csomag készíti az XML-ből a PPD-t (a linkelt Arch fórumon írják). Telepítése:

sudo apt-get install foomatic-db

Ha új topikot nyitsz (fórum), úgy bővebben foglalkozunk ezzel ...

Tájékoztató leírások (általában):
https://wiki.linuxfoundation.org/openprinting/database/foomatic
http://distro.ibiblio.org/smeserver/contribs/rvandenaker/testing/smeserver-cups/documentation/howtos/foomatic-ppds.html

Egy Linux kiadást (verzió: pl. Linux Mint 17, 18) bármely asztali környezettel (pl. Xfce, MATE, Cinnamon) használod, úgy ugyanazt a CUPS-ot, HPlip-et, SANE-t kapod, legfeljebb a működésükben fordulhatnak elő eltérések, amiket javítani kell(het) és ez lehetséges bizonyára. Most kifogtál egy ilyet.

Értékelés: 

0
Még nincs értékelve
fecameca képe

RE:RE:Abban az egyben igazad van,

Köszönöm a segítséget. Még alszom rá, mert azt a rendszert, ami a bajt produkálta, eltávolítottam.  Azt a foomatic dolgot még el kell olvasnom, akarjam-e? Nekem meg itt a másik gépem, meg ezen a másik lemezen működő HPLIP. Csak éppen: a Linux telepítése: kb 10 perc, negyed óra lehetett, a HPLIPmeg azt csinálja, hogyha elindítod \,/,\,/, ez a ferde vonal forog a terminálban kb fél óráig miután a kérdésekre megválaszoltál. Kérdezi hogy LinuxMint18 a rendszerem? Rákérdez a nyomtató típusára is, mégse azt telepíti fel,  ezért most nem kapkodom el. Ha belevágok,és kipróbálom egyszer azt a foomatic-et, akkor lehet, hogy arról új témát indítok, ha valami felmerül.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:Abban az egyben igazad van,

#19 Az alábbi első telepítés és a második telepítés is is felveszi a hplip-et. Live rendszeren is ki tudod próbálni a működést. Igazából ehhez kell 'sok' RAM. Először kell egy általános frissítés: a rendszer naprakészre frissítése. A frissítés a RAM-ba megy, ha ott 'elfér', akkor sikerül. A Live rendszer a saját működéséhez az elérhető RAM méretének felét használja, és a másik felével tudsz gazdálkodni.

Majd megpróbálod ezt,

sudo apt-get install hannah-foo2zjs printer-driver-foo2zjs printer-driver-foo2zjs-common

ha így sem talája meg a HPlip (vagy a CUPS) a nyomtatót, akkor generálhatod a PPD-t, és ehhez ez a csomag kell legyen telepítve.

sudo apt-get install foomatic-db

-----

Ha forgatnád, (nem hiszem, hogy szükséges / a tárolók használatát kéne 'erőltetni')
https://web.archive.org/web/20161029204107/http://hplipopensource.com:80/hplip-web/install/manual/distros/linuxmint.html
akkor a

--disable-foomatic-ppd-install

sort cserélni kell a

--enable-foomatic-ppd-install

sorra.

De van még pár kapcsoló, amit ki kéne cserélni innen
(példa a 64 bit-es módszerből)

./configure --libdir=/usr/lib64 --prefix=/usr --disable-qt4 --disable-qt5 --enable-doc-build --enable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-udev_sysfs_rules --disable-policykit --disable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build

'Enable' HPIJS (ezzel működött a te tipusod), CUPS, HPCUPS (a CUPS használatához) ... és a párat át kéne gondolni. Ha ezen leírás szerint telepítetted, úgy ez a logikus válasz, miért nem működött.

Majd két lehetőséged van az eszköz beállítására:

-- a HPLIP
https://web.archive.org/web/20161017083230/http://hplipopensource.com:80/hplip-web/install/manual/hp_setup.html

-- a CUPS - ha a csatlakoztatás módja
a) lokális/közvetlen (USB):
https://web.archive.org/web/20161019025827/http://hplipopensource.com:80/hplip-web/install/step4/cups/local.html
b) hálózat (pl. Samba):
https://web.archive.org/web/20161014021736/http://hplipopensource.com:80/hplip-web/install/step4/cups/net.html
( https://web.archive.org/web/20161017084222/http://hplipopensource.com:80/hplip-web/install/step4/cups/index.html )

:::::

Foomatic tutorial
-- HTML
http://www.openprinting.org/kpfeifle/LinuxKongress2002/Tutorial/II.Foomatic-User/II.tutorial-handout-foomatic-user.html
-- PDF
http://www.openprinting.org/kpfeifle/LinuxKongress2002/Tutorial/II.Foomatic-User/II.Foomatic-User.pdf
( https://wiki.linuxfoundation.org/openprinting/database/foomatic )

Értékelés: 

0
Még nincs értékelve

Kétoldalas nyomtatás nincs

 Megint itt vagyok a HP Deskjet f4160-nal. Most már csak egy hiba van. A kétoldalas nyomtatást hiába jelölöm be, akkor is csak egyoldalast kapok. Az windowsban a gép eredeti programjában ez úgy működött, hogy kinyomtatott minden második oldalt, aztán megállt a nyomtatás és egy ábra mutatta, hogy meg kell fordítani a papírköteget.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Kétoldalas nyomtatás nincs

#21 Mit mutat az alábbi parancs?

lpoptions -l

A kétoldalast nyomtatást kéne nézni, de jöhet az egész tartalom akár (paste ubuntu oldalra, ha hosszú).

Forrás
https://askubuntu.com/questions/4934/hp-laserjet-printer-doesnt-have-2-s...

Parancs kézikönyv
https://linux.die.net/man/1/lpoptions
https://www.cups.org/doc/options.html
...

A forrás oldal javaslata

In the output of lpoptions -l, you should see a line that says:

HPOption_Duplexer/Duplex Unit: True *False

You can change this to True via lpoptions -o HPOption_Duplexer=True, and then your print dialog should allow you to print double-sided.

If you don't even have the "HPOption_Duplexer" option (e.g., lpoptions -l | fgrep -c Duplexer prints 0), then:

1) either you have the incorrect printer description file configured (the so-called PPD),
2) or you didn't check the "Duplex printing" option in the printer capabilities section.

To solve 1., the quickest path is probably to re-install the printer and choose the correct make/model combination.

To address 2., just open System -> Administration -> Printers, right-click on your printer and choose "Properties", then click on "Installed options" in the left pane and finally check the "Duplex printing" box on the right.

Értékelés: 

0
Még nincs értékelve

 $ lpoptions -lPageSize/Media

 $ lpoptions -l
PageSize/Media Size: Card3x5 Hagaki Hagaki.FB Photo4x6 Photo4x6.FB A6 Photo5x7 Card5x8 Oufuku A5 B5 JB5 Executive 16k Letter *A4 ExecutiveJIS FLSA Legal EnvA2 EnvC6 EnvChou4 EnvMonarch EnvDL Env10 EnvChou3 EnvC5 EnvB5 Custom.WIDTHxHEIGHT
Duplex/Double-Sided Printing: DuplexNoTumble DuplexTumble *None
InputSlot/Media Source: *Auto PhotoTray Upper Lower Envelope LargeCapacity Manual MPTray
MediaType/Media Type: *Plain Glossy
OutputMode/Print Quality: *NormalRGB NormalGray DraftRGB DraftGray Photo
InstalledCartridge/Installed Cartridges: BlackColorOnly TriColorOnly PhotoColorOnly *BlackAndTriColor PhotoAndColor
OptionDuplex/Duplexer Installed: *False True

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE: $ lpoptions -lPageSize/Media

#23 Add ki ezt a parancsot:

lpoptions -o HPOption_Duplexer=True

Először érdemes ellenőrizni a hatást az előbbi parancssal, mielőtt tényleges nyomtatási próbát teszel.

lpoptions -l

Ez csak a CUPS -ra lesz hatással. ... mellesleg eleve nincs ilyen opció. De:

-o option[=value]

Specifies a new option for the named destination.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE: $ lpoptions -lPageSize/Media

#24 Igazából a nyomtatóra jellemző PPD fájl (is) tartalmaz sok beállítást. Azt most -csak később- tudom megmondani, hogy egy ilyesféle
https://stackoverflow.com/questions/19026172/how-to-enable-duplex-printi...
beállítások hozzáadása (hogy pontosan mit kéne), eredményes-e, pontosabban követendő lenne-e. De nyilván innen 'vette' a válaszoló a beállítási lehetőségeket.
https://opensource.apple.com/source/cups/cups-136/cups/doc/help/spec-ppd...

Az előző hsz-ben szereplő javaslatomat megpróbálhatod, legfeljebb később False-ra vesszük a változó értékét vagy töröljük.

-- a CUPS-on keresztül tudsz nyomtatni?
-- eddig rendben volt a két oldalas nyomtatás, mikor változott meg?

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE: $ lpoptions -lPageSize/Media

#25 Amúgy eleddig nem árultad el, hogy a '"sudo apt-get install hplip' parancs volt tette volna működőképessé a nyomtatót a korábbi nehézségek után, (vagy) pontosan milyen történet van itt. :-)

Például kérdés, hogy korábban említve lett két csomag, telepítve vannak?

apt-cache policy printer-driver-hpijs hpijs-ppds

-- a CUPS és használata
http://printersquestions.com/How-to-install-Hewlett-Packard-HP-DeskJet-F...

Értékelés: 

5
Átlag: 5 (1 szavazat)