Monitor bekapcsol kikapcsolás után

Fórum: 

Sziasztok!

 

Frissen telepített Linux Mint (Edge) rendszeren a monitor kikapcsolásával kapcsolatban szeretnék segítséget kérni.

 

inxi -F kimenete: https://pastebin.com/uJg6tSPF

 

Az energiagazdálkodási beállításoknál bármilyen értéket állítok be, a monitor kikapcsol a beállított tétlenségi idő után, de rögtön visszakapcsol és utána többé nem kapcsol ki, tehát nem kezdi újra a tétlenségi időmérést. A számítógépre két monitor van csatlakoztatva, a második monitor ritkán van használva, de a probléma akkor is fennáll, ha a második monitort nem csak szoftveresen, hanem fizikailag csatlakoztatom le. A hiba a képernyőkímélő be, ill. kikapcsolt állapotában is, továbbá zárolt képernyőnél is előjön.

 

A monitor a következő parancsok kiadása után is ugyanúgy visszakapcsol, mintha az Energiagazdálkodási beállítás hatására kapcsolt volna ki:

sleep 1 && xset dpms force standby

xset dpms force off

 

Továbbá a DPMS konzolos beállítása után is megmarad a probléma, tehát visszakapcsol a monitor lekapcsolás után.

Példák a tesztelt értékekre:

xset dpms 0 0 10

xset dpms 10 10 10

xset dpms 600 600 600

 

Teszt céljából kipróbáltam más rendszereket:

  • live EndeavourOS (KDE) → fennáll a probléma
  • live Linux Mint 22 Beta (Cinnamon) → fennáll a probléma

 

Korábbi tapasztalatok:

  • telepített Windows 10 és Windows 11 → sosem volt ilyen probléma

Az elvárt viselkedés az lenne, hogy a tétlenségi idő letelte után minden monitor kapcsoljon ki és csak aktivitás hatására kapcsolódjanak be újra.

Egér?

Ugyan csak az inxi eleje érhető el, feltételezem van egér a géphez csatlakoztatva. Nekem az lenne az első számú gyanúsított, pl. ha a kábele szakadozott, vagy, ha Genius.

Ha ki van húzva, akkor is jelentkezik a probléma?

Egy dmesg riportot is jó lenne pasztázni

Értékelés: 

0
Még nincs értékelve

Egér? Egér?

#1

#1  Igen, van csatlakoztatva. Kihúztam az egeret és kipróbáltam úgy is, de így is visszakapcsol a monitor. Azért gyanakszom szoftveres hibára, mert Windows alatt sosem volt ilyen, és bár esküdni nem mernék rá, de mikor korábban rövid ideig próbáltam Fedora-t telepítve, annál nem tapasztaltam ilyen hibát és habár nem értek igazán hozzá, de olvastam, hogy az a rendszer X11 helyett Wayland-et használ. Lehet, hogy az X-nél van probléma.

Később tesztelem Ubuntu Gnome live alatt is, hogy jelentkezik-e a hiba.

Itt a dmesg kimenete: https://pastebin.com/gM1gQD7w

Értékelés: 

0
Még nincs értékelve

Egér? Egér? Egér? Egér?

#1.1

#1.1  

Következő rendszereket teszteltem még live módban:

  • Ubuntu 24.04 (Gnome)
  • Fedora 40 (Gnome)
  • Fedora 40 (KDE)

Az első kettő alatt szintén fennállt a hiba, tehát az idő letelte után lekapcsoltak a monitorok, majd azonnal újra be és utána többet nem álltak le. A Fedora KDE annyiban különbözött, hogy ott mindig elkezdte újraszámolni a beállított egy percet, tehát percenként lekapcsolta a monitorokat.
Ezek szerint nem biztos, hogy az X11-gyel van a probléma, mert mindhárom tesztelt rendszer Wayland-et használ.

Értékelés: 

0
Még nincs értékelve

Nem egér, hanem CPU / BIOS

#1.1 Van nekem is hasonló lapom, de Ryzen 7 procim van hozzá, csak még nem raktam össze, és nem is tudom mikor fogok vele foglalkozni, így nem tudtam kipróbálni,  amiket írok:

Dmesg-ben sok probléma nem látszik, de ami igen, az pont lehet hogy a jelenség oka:

PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug

Ez mondjuk egy javaslat, arról szól, hogy ha problémát tapasztalsz, add hozzá a kernelkapcsolókhoz a pci=nocrs beállítást. Egyelőre még ne tedd, nem biztos hogy ez segít a problémán, de ha minden tipp elfogy, akkor ki lehet próbálni.

AMD Zen1 DIV0 bug detected. Disable SMT for full protection.

Keress ilyen lehetőséget a BIOS felületen (SMT), próbáld meg kikapcsolni. Lehet némi lassulás ettől, de nem biztos hogy érezhető. Ha zavaró, kapcsold vissza. Lehet, hogy későbbi kernel frissítés után erre nem lesz szükség.

És akkor itt az, ami szerintem a lényeg:

[    2.136393] clocksource: timekeeping watchdog on CPU3: Marking clocksource 'tsc' as unstable because the skew is too large:
[    2.136404] clocksource:                       'hpet' wd_nsec: 511161264 wd_now: 1d4ffb3 wd_last: 1655240 mask: ffffffff
[    2.136410] clocksource:                       'tsc' cs_nsec: 512040511 cs_now: af093bf60 cs_last: a82b4a360 mask: ffffffffffffffff
[    2.136414] clocksource:                       Clocksource 'tsc' skewed 879247 ns (0 ms) over watchdog 'hpet' interval of 511161264 ns (511 ms)
[    2.136419] clocksource:                       'tsc' is current clocksource.
[    2.136427] tsc: Marking TSC unstable due to clocksource watchdog
[    2.136462] TSC found unstable after boot, most likely due to broken BIOS. Use 'tsc=unstable'.
[    2.136464] sched_clock: Marking unstable (2136118359, 342036)<-(2237052880, -100592329)
[    2.136649] clocksource: Checking clocksource tsc synchronization from CPU 3 to CPUs 0.

Szerintem először próbálj meg BIOS-t frissíteni. Hátha attól megjavul. Ha nem, lehet későbbi kernel frissítés megoldja. Vagy mikrokód frissítés. Lehetne kernelt foltozgatni is ez ügyben, de az a következő frissítéskor úgyis felül íródik. Itt arról van szó, hogy az időzítés labilis, mert a CPU magok kiegyenlített terhelése mellett a 3-as mag valamiért elhúz.

Szerintem ezek miatt nem érdemes rendszereket próbálgatni, nem is azon múlik, hogy X vagy Wayland, hanem hogy milyen kernel. Hamarosan itt lesz a Linux Mint 22, 6.8-as kernellel. De BIOS-t frissíts, nem írták, hogy mit javítottak benne, csak annyit, hogy "improve system stability" -ez már az ötödik BIOS kiadás ahhoz képest, ami a gépeden van.

Értékelés: 

0
Még nincs értékelve

Nem egér, hanem CPU / BIOS Nem egér, hanem CPU / BIOS

#1.1.2

#1.1.2

Köszönöm a tippeket! A BIOS frissítést megcsináltam, sajnos nem volt változás a hibával kapcsolatban. Kikapcsoltam az SMT-t a BIOS-ban, de sajnos az sem hozott eredményt, így újra engedélyeztem.

 

Ez az új, BIOS frissítés utáni dmesg kimenete: https://pastebin.com/mzanEzch

 

Azért próbálkoztam más rendszerekkel, mert azokban talán más Kernel verzió van, talán javítva van bennük ez a hiba, de úgy tűnik nem.

Ezen a ponton érdemes kipróbálni a pci=nocrs kapcsolót? Legrosszabb esetben visszatérek Windows-ra, amíg kijön az új Mint, de jobb lenne, ha nem kéne :-)

Értékelés: 

0
Még nincs értékelve