[Megoldva]Firefox nem fogadja el a Google-t alapértelmezettnek

Fórum: 

Nem tudom beállítani a Google-t alapértelmezett keresőmotornak a Mintben. Módosítottam a keresőmotorokat a keresőablaknál kinyíló menüben, ott meg is jelenik a Google-keresés első helyen, mégis a Yahoo keres nekem, pedig az nem is szerepel a keresőmotorok között. A Beállításokban is a Google-t adtam meg és töröltem minden mást. Nem segít.
Úgy oldottam meg, hogy kezdőoldalnak megadtam a Google.hu-t, úgyhogy rákattintok a házikó-ikonra és akkor kereshetek vele. De persze eléggé irritáló, hogy ilyen egyszerű dolgot nem tudok beállítani. Ez valami bug vagy valami üzleti megállapodás a háttérben? Akármi, azért szeretném beállítani a Google-t.

RE: Firefox nem fogadja el a Google-t alapértelmezettnek

#1 Így van. Rá kell kattintani a Google ikonjára, aztán a Firefox „keresőmezőjében” a nagyítót ábrázoló ikonra és az így előbújó menü alsó részében ekkor hozzáadható a keresési szolgáltatásokhoz.
https://forums.linuxmint.com/viewtopic.php?t=237008#p1262113

Ezután a Szerkesztés/ Beállítások/ Keresés menüpontban a kérdező vélhetően már alapértelmezettnek fogja tudni kiválasztani a Google-t.

Értékelés: 

5
Átlag: 5 (1 szavazat)

Mindezt megtettem. A

Mindezt megtettem. A keresőmezőben a Google van legfelül, a Beállításokban azt állítottam be alapártelmezettnek, mégis, ha a keresőmezőbe vagy a címek helyére beírok valamit, a Yahoo keres. Pedig még csak nem is szerepel a Beállításokban a felsorolásban, ahol a Google van legfelül, mint alapértelmezett keresőszolgáltatás. 

Én vagyok az egyetlen ezzel a problémával?

Értékelés: 

0
Még nincs értékelve

 Ez véletlenül nem egy

 Ez véletlenül nem egy szinkronizált Firefox? Tud néha okozni gondot pláne ha egy Windows-os róka beleszól...Bár akkor lehet, hogy a Binget keresné..

Értékelés: 

0
Még nincs értékelve

Nem szinkronizált

Nem, én semmit nem csináltam vele, csak telepítettem a Sonyát és abban benne volt a Firefox.

Értékelés: 

0
Még nincs értékelve

Nem szinkronizált

#5 Feltettem virtuálisba egy ilyen fahéjjas Szonnyát, eszközöltem az összes jelenleg fellelhető frissítést, de az általad jelzett hibát nem tudtam reprodukálni, néhány másodperc alatt rávettem a Firefoxot, hogy alapértelmezetten a Google keressen nekem.

Próbálkozz meg a Firefox beállítókönyvtárának (~/.mozilla/firefox) átnevezésével, majd indísd el a Firefoxot és a kívánt keresési szolgáltatás hozzáadásának, alapértelmezetté tételének procedúráját kíséreld meg újra végigvinni.
Ha sikerrel jársz ebben a tekintetben, akkor a régi beállítókönyvtárból átmásolhatod az újba azt, amire szükséged van (például könyvjelzők).

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindezt megtettem. A

#3 Nálam a Google keres.
Nálad mi van ezen a két helyen?

Értékelés: 

0
Még nincs értékelve

Nem szinkronizált

#5  Sziasztok.

Ha még mindíg nem a google marad keresőnek amikor elintézted, hogy a beállításokban a google is látszik a többit távolítsd el majd a címsor mellett (ahol a www.... be írjuk) tehát jobbról mellette van egy másik kis rubrika is ahol szintén van legördülő és itt is állítsd google-re ezán maradni fog. Legalábbis nálam volt, hogy csak ezután maradt meg. 

Értékelés: 

0
Még nincs értékelve

Kimarite, a keresőmezőben

Kimarite, a keresőmezőben Yahoo van: https://www.dropbox.com/s/mb0gofp2exqgvyp/keresek.jpg?dl=0

zoli62, A kiegészítőt a ff nem telepíti, mert már megvan.

Most ujabban visszajött a yahoo az új fül megnyitásánál is, pedig az is be van állítva Google-ra és azzal is nyilt egy darabig.

Jó lenne, ha ott a legördülő menüben egyszerűen ki tudnám nyírni a Yahoot és betenni a Google-t. A legördulő menü is látszik a klippben, de nem tudom, hogy állítsam át Google-ra.

Talán az is segítene, ha űjra telepíteném a Firefoxot, de ez talán egyszerűbb.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Kimarite, a keresőmezőben

#10 Szia, ujmintes írta meg a jó választ:
https://linuxmint.hu/comment/13581#comment-13581
Az eltávolított kereső motorokat később visszatelepítheted, ezt írja a Mozilla webes súgója is.
Az 'about:config' beállítások engines kereső szavára is vannak találatok, de nálam is a Google jön be,
https://www.google.hu/search?q=keresek&ie=utf-8&oe=utf-8&client=firefox-b ...
de ez Debian (a korábban mutatott beállításokkal) és később tudok ránézni a Mint-re.

Értékelés: 

0
Még nincs értékelve

Továbbra is Yahoo

Nem, hiába, a Google nem akar alapértelmezett keresőm lenni, pedig már mindenütt beállítottam, az Ujmintes által javasolt menüben is. Ott legalul látszanak a keresőmotorok, és jobbkattintva lehet választani alapértelmezettet, ugye.

Telepítsem a Firefoxot megint?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Továbbra is Yahoo

#12 Teljes oldalas kép (akár az F11 segíttségével + Képernyőkép) kéne erről a látványról:

about:preferences#search

Ez egy URL: másold be és lépj rá.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Íme

#14 Ha az összeset eltávolítod (Eltávolítás)
és utána telepíted a Google-t innen (Commercial Engines)?
https://www.linuxmint.com/searchengines.php
'Bármire' lehet gyanakodni,
de én a Google Default-ra gyanakszom,
ha azt a kiegészító teszi oda.
 

Értékelés: 

0
Még nincs értékelve

Csakazértis Yahoo

Hiába szerepel Google mindenütt, a Yahoo vesz át minden keresést. Ráadásul az nem is látszik sehol a beállításokban. Hol lehetne azt kinyírni?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Csakazértis Yahoo

#16 Törölted a többit, ahogy kértem?

Értékelés: 

0
Még nincs értékelve

Igen

Igen. Töröltem a többit.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Igen

#18 Tudnál képet mellékelni erről?

És az

about:config

URL-en a

browser.search

(Keresés) találatokról is kéne kép.

Elég fura jelenség ez.

Értékelés: 

0
Még nincs értékelve

Off:"Firefox nem fogadja el a

Off:
"Firefox nem fogadja el a Google-t alapértelmezettnek"
Jól teszi.

On:

Egyszer én is jártam így. Nekem a dpkg-reconfigure firefox parancs megoldotta a problémát.

Értékelés: 

0
Még nincs értékelve

Yahoo kontra Google

user. Kösz, mindjárt kipróbálom, de először küldöm a képeket kimaritének. (Miért teszi jól, a Google elég jó nekem és ráadásul magyar eredményeket ad. Én a Google-hoz szoktam, mint a legtöbben a Földgolyón)

kimarite, Sok browsersearch van. Melyiket nyissam ki? https://www.dropbox.com/s/epecm59strh6am3/browsersearch.png?dl=0

Itt egyszerre látod a beálltást és a keresés eredményét. A Yahoot sokszor töröltem, mégis ott van. És hiába van a Google legfeljebb, a Yahoo keres. 

https://www.dropbox.com/s/g90k41g1mxcdphz/nemgugli.png?dl=0

Mindjárt kipróbálom user parancsát.

SZERKESZTVE. Beírtam, hogy sudo dpkg-reconfigure firefox, de nem segített.

Értékelés: 

0
Még nincs értékelve

Megérne egy külön topikot a

Megérne egy külön topikot a téma. Röviden, a Google-nek és a Yahoo-nak kétségtelenül jó szolgltatásaik vannak, de tisztességtelen cégek.
Érthető módon nem szokás ilyet tanácsolni, ám próbáltad már a böngészőt rootként elindítva lecserélni a keresőt?
Fut a gépeden apparmor vagy firejail?
Ha szeretnéd gyorsan megoldani a problémát, célszerübb teljesen eltávolítani a böngésződet majd újra feltelepíteni.
mv ~/.mozilla ~/mozilla-backup
sudo apt-get purge firefox*
sudo apt-get update -y
sudo apt-get purge firefox

Értékelés: 

0
Még nincs értékelve
kimarite képe

Yahoo kontra Google

#21 Szia. Arról kértem képet, hogy mindent töröltél

Ha az összeset eltávolítod (Eltávolítás) innen
https://www.linuxmint.com/searchengines.php

mert nem látszik, hogy töröltél volna bármit is.
Hiába mutatod állandóan azt a képet, hogy a Yahoo keres (az már eredmény), ha nem azt kértem, hanem mást (a tennivaló).

Elsőként változtasd meg ezt a karakterlánc beállítást:

-- browser.search.selectedEngine | a vége változzon erre: =Google

Értékelés: 

0
Még nincs értékelve
kimarite képe

Yahoo kontra Google

#23 Ui.: azt nem értem, hogy varázsoltál a böngészőbe Yahoo-t, és itt lehet a bibi. Tán a módszereddel, ahogy felvetted? Most nézem, nálam a Yahoo-nak nyoma sincsen. :-)

Értékelés: 

0
Még nincs értékelve

Yahoo vs Google

#22

Ezt is meg lehet tenni, de szerintem a kutya vagy a telepített kiegészítőkben, vagy bővítményekben van elásva.
A FF újratelepítése nincs hatással a telepített nyavalyákra.

Én először megpróbálnám letiltott kiegészítőkkel újraindítani a Tűzrókát.
Ha a bővítmények között van valami plusz, akkor azt is letiltanám.
Nálam csak ezek vannak:
OpenH264...
Widevine...
A Szolgáltatások lapon meg semmi sincs.

Ha ez nem segít, akkor egy új profilt készítenék.

Nincsenek csodák.

Értékelés: 

0
Még nincs értékelve

Yahoo vs Google

Keraform, de, csodák igenis vannak. Legalábbis itt. Megadtam kimarite parancsait, mire eltünt a Firefox, telepítettem, és azóta Google az alapértelmezett keresőm, juhé.

Értékelés: 

0
Még nincs értékelve

Yahoo vs Google

#26

Akkor próbáld ki, hogy visszaállítod a mozilla-backup mappa tartalmát, és majd meglátod, hogy nincsenek csodák.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Yahoo vs Google

#26 Az egyik kiegészítő a ludas, vélhetően előjöhet a probléma újra, amíg telepítve van (vagy nem, de nem tudjuk, mit csinál pontosan a kiegészítő). A kereső motorok törlése megoldást hozott, ez logikus vagy az 'about:config' átállítást is megcsináltad?

Illetve mit csináltál még ezeken kívül? ... pl átnevezted a 'mozilla' könyvtárat is?

A kiegészítők törlése nem törli a böngészőt, szép is lenne ... .

Értékelés: 

5
Átlag: 5 (1 szavazat)

Így

Az összes keresőmotort töröltem a beállításokban a Google-on kívül, az about.config-ot átírtam, ahogy írtad, Aztán amikor a parancsokat beírtam a terminálba, akkor teljesen eltünt a tűzróka, sőt, a Szoftverkezelőben is az jelent meg, hogy nincs telepítve. Telepítettem, beállítottam és most működik. Ezentúl mindig tesztelem, ha új kiegészítőt telepítek. Kösz a segítséget.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Így

#30 Így már érhető a böngésző eltűnése.

A parancsok ezek voltak # a magyarázat

Ha szeretnéd gyorsan megoldani a problémát, célszerübb teljesen eltávolítani a böngésződet majd újra feltelepíteni.
mv ~/.mozilla ~/mozilla-backup # személyes böngésző (Firefox) könyvtár átnevezése
sudo apt-get purge firefox* # a firefox és függőségeinek törlése a beállításaival együtt
sudo apt-get update -y # rendszer update: a csomag információk frissítése
sudo apt-get purge firefox # a firefox még egyszeri törlése a beállításainak törlése nélkül (egyszer elég)

Három különböző dolgot javasoltunk (c/1 és c/2 összefügg, hasonló):

a) a böngésző eltávolítása és újra telepítése
b) a személyes beállításokat tartalmazó könyvtár átnevezése (így nem használja, hanem alapértelmezett beállításokkal indul ..., új könyvtár jön létre)
c/1) a keresőmotorok törlése
c/2) a keresőmotorok átállítása az about:config -ban

Ha mindhármat megcsináltad egyszerre, nem tudni, melyik vált be.

Szívesen.

Értékelés: 

0
Még nincs értékelve