[MEGOLDVA] VLC player - webm fájl lejátszási gondok

IG képe

Fórum: 

Sziasztok!

A firefoxon be van állítva, hogy amikor csak lehet html5-ben jelenítse meg a videókat a flash helyett (youtube).
Mikor letöltöm a videót, akkor a VLC nem játsza le az adott fájlt, melynek kiterjesztése: webm.

A hibaüzenet ez:
Nincs megfelelő dekódoló modul:
A VLC nem támogatja a(z) „VP90” hang- vagy videoformátumot. Sajnos nem tehet semmit ennek kijavításáért.

Nincs megfelelő dekódoló modul:

A VLC nem támogatja a(z) „undf” hang- vagy videoformátumot. Sajnos nem tehet semmit ennek kijavításáért.

 

  • Ez alapján állítottam be a firefoxot:
  • Minden VLC plugin telepítve a hivatalos tárolóból.
  • Telepítettem a vlc-plugin-libde265 plugint is külső tárolóból, de nem oldotta meg a problémát.
  • Az ubuntu-restricted-addons és az ubuntu-restricted-extras is telepítve.
  • Érdekesség, hogy a Videók alkalmazás pedig lejátsza a webm formátumot, de nem szeretnék két alkalmazást használni.

 

Rendszer: LM 17.3 x64 Cinnamon. VLC: 2.1.6

 

Ötletek?
 

 

kimarite képe

RE:RE:Milyen csomagok vannak telepítve a VLC-ből?

#2 Köszi. A VLC-dnek már külön alkalmazás, plugin nélkül is képesnek kell lenni a 2.1.2 változat óta

Experimental VP9 decode support was added to VLC in version 2.1.2.

     -- http://www.webmproject.org/vp9/

Restricted csomag nem kell ehhez, valamint a h.265
http://addons.videolan.org/content/show.php/vlc-libde265?content=169475
nem webm.

Nem tudom pontosan mi a hiba nálad, visszatérünk erre holnap, de megpróbálhatnád a terminálból futtatást így (behelyettesítve a fájl nevét és elérési útját - vagy terminál nyitása a fájkezelődben ahol a fájl van),

vlc -vv *.webm

vagy

cvlc -vv *webm

és a kimenetek kellenének. Tehát le kéne játszania külsö csomagok nélkül. A böngészős leírás jó, de nincs kapcsolódási pont a VLC-vel, sőt a WEBM-mel sem.

Nem kell telepíteni, de ennek a két parancsnak mi a kimenete?

dpkg --get-selections | grep libav-tools
dpkg --get-selections | grep ffmpeg

És, ha telepíted a Sytemback alkalmazást, készítesz vele egy visszaállítási pontot, akkor -utána- megkísérelheted a VLC egy másik példányát telepíteni, ezen leírás alapján (de holnap el is magyarázhatom, ha nem egészen érthető);
https://jxself.org/webm/
Mert lehet, valami bug, nem tudom. Talán valaki más tudja. Nálam lejátssza a VLC a WEBM fájlokat, de nem Linux Mint-tet (és nem Ubuntu-t) használok, hanem Debian-t. És azt hiszem, a WEBM-et forrásból telepítettem .., nem emlékszem, de majd utána járok .

dpkg -l vlc* libvlc*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Név                       Verzió            Architecture       Leírás
+++-==========================-==================-==================-=========================================================
ii  libvlc5                    1:2.0.6-dmo3       i386               multimedia player and streamer library
ii  libvlccore5                1:2.0.6-dmo3       i386               base library for VLC and its modules
ii  vlc                        1:2.0.6-dmo3       i386               multimedia player and streamer
ii  vlc-data                   1:2.0.6-dmo3       all                Common data for VLC
ii  vlc-nox                    1:2.0.6-dmo3       i386               multimedia player and streamer (without X support)
ii  vlc-plugin-notify          1:2.0.6-dmo3       i386               LibNotify plugin for VLC
ii  vlc-plugin-pulse           1:2.0.6-dmo3       i386               PulseAudio plugin for VLC

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:Milyen csomagok vannak telepítve a VLC-ből?

#3 Pont a te verziódban van egy bug (WEBM-re), itt van erről szó
https://askubuntu.com/questions/534387/how-to-play-webm-using-the-vp9-co...
és ez lenne a megoldás
http://askubuntu.com/questions/34372/how-to-play-a-webm-video-file
csakhogy a PPA már nem létezik ...

Értékelés: 

0
Még nincs értékelve

RE: VLC player - webm fájl lejátszási gondok

@#0 Szia !

Nálam a VLC 2.2.1-es van fent, mely probéma nélkül lejátssza a webm fájlokat.

Az mc3man......PPA felvételével jutottam hozzá.

https://launchpad.net/%7Emc3man/+archive/ubuntu/trusty-media

https://i.imgur.com/anSe3Hm.png

 

De ha megvárod a Mint 18 kiadását, abban már valószínű a legújabb 2.2.3-as VLC lessz bent.

Értékelés: 

5
Átlag: 5 (1 szavazat)

RE:RE:RE:Milyen csomagok vannak telepítve a VLC-ből?

#3

A vlc -vv kimenete ez (brutál):
https://paste.ubuntu.com/16242696/

A cvlc --vv kimenete ez (brutal2.0):
https://paste.ubuntu.com/16242755/

A dpkg --get-selections | grep libav-tools kimenete:
libav-tools                    install
 
A dpkg --get-selections | grep ffmpeg kimenete:
chromium-codecs-ffmpeg-extra            install
ffmpeg2theora                    install
gstreamer0.10-ffmpeg:amd64            install
libffmpegthumbnailer4                install
nepomuk-core-ffmpegextractor            install

Megtaláltam én is a liinket a nem élő tárolóról. :( Systembackem van, mentési pontom is.
Próbálkozok egy teljes vlc eltávolítással és újrainstallal, majd jöhetnek a bonyolultabb dolgok.

Értékelés: 

0
Még nincs értékelve

RE:RE: VLC player - webm fájl lejátszási gondok

#5

Köszi megnézem ezt is.

Megnéztem- Működik a VLC 2.2.1-el a webm lejátszás!! :)

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install vlc

És frissíti a meglévőt vlc-t a 2.2.1-re, ami már lejátsza a webm-et. :)

Köszönöm mindeninek! :)

Értékelés: 

0
Még nincs értékelve