[Megoldva] Update Manager ikon nem jelez

Fórum: 

Környezet: Linux Mint 18.3 "Sylvia" - Cinnamon (64-bit))

Felraktam a panelra az Update Manager ikonját, és ha elindítom, akkor van is már 2-es szintű security update, de az ikon mindig csak egy fehér üres pajzs. Sem zöld pipa, sem felkiáltójel.

Update Manager ikon nem jelez

@#0 Nyisd meg a frissítéskezelőt (az ikonra kattintva) -> Frissítés (Update) - lefut hibaüzenet nélkül ?
A fehér üres pajzs, egyébként vagy azt jelenti hogy "Elfoglalt", vagy azt hogy "Ismeretlen állapot".
https://imgur.com/AUMgaMh

Értékelés: 

0
Még nincs értékelve

Kedves lala, most nem ülök a

Kedves lala, most nem ülök a gép előtt, de egyébként igen, tudok frissíteni, nincs hibaüzenet. A felajánlott proxy szervereket is beállítottam, a legyorsabbakat kiválasztva. És valóban frissített, mert már több dolgot jelez mint pár nappal ezelőtt. De az ikon nem csinál semmit.

Az általad linkelt oldalon mit kéne látnom? Három böngészővel is megpróbáltam, de csak törött ikont vagy homokórát látok.

Értékelés: 

0
Még nincs értékelve

Kedves lala, most nem ülök a

#2 Nem böngészővel kell nézni. :) Hanem nyisd meg a frissítéskezelőt - fent bal oldalt ->
"Szerkesztés" -> "Beállítások" -> "Ikonok" (fül)
Itt tájékoztat a lehetséges állapotokról. (Hogy milyen esetben, mit mutat az ikon.)

Egyébként, meg kéne ismerned a rendszer beállítási lehetőségeit - hogy ha szükség lesz rá,
tudd hogy mit hol érsz el. ... Nem kell változtatni semmit, csak ha olyanra bukkansz amit
számodra hasznosnak vélsz.
Ha bizonytalan vagy a változtatásokal kapcsolatban, inkább előtte kérdezz !

Értékelés: 

0
Még nincs értékelve

Windows XP

Rendben, köszönöm, majd este kipróbálom, most egy Windows XP-n dolgozom gőzerővel :-) 

Értékelés: 

0
Még nincs értékelve

Nálam nincsen Ikonok fül

#3

Hát a képet, amit linkeltél, csak böngészővel kell nézni. Napközben nem tudtam megnézni, egyik böngészővel sem jött be, de most látom.

Nos, nálam nincs Ikonok fül egyáltalán csak Options, Levels, Auto-refresk és Blacklist, tehát az első négy van, az ötödik nincs.

A Synaptic szerint a legfrissebb verzió van meg, az 5.3.2.3-as.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Update Manager ikon nem jelez

@#0 Bezárod az ikont, aztán terminálban indítva figyeled és ide másolod, hogy mit mutat az indítási parancs:

mintupdate

Milyen ikon és rendszer témát használsz? Eltér a rendszer alapértelmezettől?

Értékelés: 

0
Még nincs értékelve

Nálam nincsen Ikonok fül

#5 Igazad van ! A 18.3-ban tényleg nincs Ikonok fül. A képet egy régebbi (17.3) kiadás
alól küldtem - azon még van Ikonok fül.

Szándékosan használsz angol nyelvű menüt ?

Értékelés: 

0
Még nincs értékelve

Update Manager ikon nem jelez

#6

A mintupdate parancs nem ír ki semmit, csak elindítja az Update Managert.

Téma és ikon téren nem nyúltam semmihez, az alapértelmezett beállításokat használom.

Értékelés: 

0
Még nincs értékelve

Nálam nincsen Ikonok fül

#7

Igen, szándékosan használok angol nyelvű verziót a Linuxból.

Értékelés: 

0
Még nincs értékelve

Megjavult!

Na most ráértem egy kicsit próbálgatni és tesztelni.

Annyit pontosítok, hogy nem volt nálam minden dolog default. A tálcát szeretem felülre tenni, és mivel túl kicsi volt minden, ezért a Panel magaságát is megnöveltem.

***

Ezt kipróbáltam:

https://forums.linuxmint.com/viewtopic.php?t=247414

Right click panel->troubleshoot->restore all settings to default

Fenti utasítás hatására nem tudom, hogy rögtön megoldódott-e a probléma, (később leírom, hogy miért), de miután nem láttam semmit, ismét visszatettem a tálcát felülre, majd megint megnöveltem kissé a magasságát. Ekkor vettem észre, hogy a jobb oldalon megjelent egy új pajzs ikon, rajta egy i betűvel. Én eddig azt hittem, hogy az ikon a bal oldalon fog változni, ahol indítom a programot!

Rájöttem, hogy a jobb oldalon levő ikonnal is elindul a program, így a bal oldalit leszedtem.

Azt nem tudom, hogy az i betű jó-e, mert van ugyan 1-es szintű frissítés, de kimarite supportos kolléga zöld pipáról vagy kék felkiáltójelről írt. ?

Az egyik 1-es szintű Chromium, ami nekem nincs is fenn, a másik Thunderbird, ami ugyan fenn van, de nem használom. Ilyenkor feleslegesnek gondolom a frissítést, de hogyan tudom száműzni a listából ezeket?

Értékelés: 

0
Még nincs értékelve
tresor képe

Megjavult!

#10  

A Cinnamon részhez nem tudok mit hozzátenni, mivel nem használom. Viszont, ha van olyan program amit nem használsz, akkor azt inkább távolítsd el. Mintsem kizárva a frissítési listából (amit megtehetsz), ott csücsüljön a rendszeredben frissítetlenül. Vagy frissítessz mindent, amit a frissítéskezelő ajánl. Függetlenül attól, hogy használod vagy nem.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Megjavult!

#10 zöld pipa = minden frissítve (a beállítások szerint)
kék felkiáltójel = frissíthető csomagok (a beállítások szerint)
Valami ilyesmire 'emlékszem'. ;)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Megjavult!

#10 i betű?
A jobb oldalon jelenik meg a Frissítéskezelő ikon. A panel magassága talán befolyásolja a megjelenést, az 'Egyéni panelméret' beállítást talán próbáld kikapcsolni. (https://www.youtube.com/watch?v=iLkqtb_AVjQ)

Értékelés: 

0
Még nincs értékelve

i betű

#13

Az egyéni panelméret mellett is működik most már a kijelzés, a troubleshoot->restore all settings to default parancs után nem jött vissza a probléma. Halványan úgy emlékszem, hogy telepítés után is itt volt ez az izé, lehet, hogy kitöröltem (nem tudtam, mire jó).

Igen, a kijelzés nálam i betű, és tetszőlegesen magas panelméret esetén is jó a kijelzése.

Ha nálatok más van, az esetleg függhet attól, hogy nálam angol nyelvű a Linux, az i betű talán az information kezdőbetűje. Én nem tudok módosítani a beállításokon, mert nálam nincs Ikonok fül.

Érdekes, hogy az angol nyelvű User Guide még ír az Ikonok fülről, de már ott is hiányzik a képről (ellentmondás), míg a magyar nyelvűben már a szövegből is kivették.

Értékelés: 

0
Még nincs értékelve

Megjavult!

#11

Köszönöm a tippeket. Bár nem értem, hogy ha a Chromium nincs telepítve, akkor ahhoz miért ajánlott fel frissítést? Ezen az alapon, ha leszedem a Thunderbirdöt, akkor ahhoz is ajánlhat még később frissítést?

Ja, most megnéztem újra, szóval: Chromium nincs telepítve, de a chromium-codecs-ffmpeg-extra igen, ehhez jött most frissítés. Akkor ezt leszedhetem?

Értékelés: 

0
Még nincs értékelve
tresor képe

Megjavult!

#15 Chromiumot nem használom én sem, de ugyanez a csomag nálam is megjött, mint frissítendő. Érdemes frissíteni, mert más is használhatja azt a csomagot.

Értékelés: 

0
Még nincs értékelve
kimarite képe

i betű

#14 Az i betű stimmel.
Itt vannak a rendszer ikonok:

/usr/share/icons/

Az alkalmazás neve: mintupdate

dpkg -L mintupdate | grep icons

(rákeresés: dpkg -L csomag = egy telepített alkalmazás rendszer fájljainak listázása.
szűkítés az eredményben: grep és a keresett kifejezés
a két parancsot egy csővezeték köti össze: | )

És ez az ikon (megnézed) elérési úttal, az egyik méretben:

xdg-open /usr/share/icons/hicolor/96x96/status/mintupdate-updates-available.svg

Tényleg „i”. :)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Chromium: chromium-codecs-ffmpeg-extra

#16 Más csomagok függősége a telepített Chromium összetevő:

dpkg -l *chromium* | grep ii
ii  chromium-codecs-ffmpeg-extra 66.0.3359.181-0ubuntu0.18.04.1 amd64        Extra ffmpeg codecs for the Chromium Browser

Ezeknek (ezen csomagoknak kell):

apt-cache rdepends chromium-codecs-ffmpeg-extra
chromium-codecs-ffmpeg-extra
Reverse Depends:
 |chromium-browser
  chromium-codecs-ffmpeg
  chromium-codecs-ffmpeg
 |chromium-browser
  ubuntu-restricted-addons <-- multimédiás dolgokhoz jó,
  az ubuntu-restricted-extras csomag része, telepíthető (érdemes),
  nem ingyenes és nem nyílt forráskódú csomagokat tartalmaz (kodek)
  kubuntu-restricted-addons <-- multimédiás dolgokhoz jó,
  a kubuntu-restricted-extras csomag része, telepíthető (érdemes),
  nem ingyenes és nem nyílt forráskódú csomagokat tartalmaz (kodek)
  chromium-codecs-ffmpeg
  chromium-codecs-ffmpeg
  mint-meta-codecs <-- a rendszer része, alapértelmezetten telepítve van

-----

A csomagnak nem kell semmi:
(nincs függősége, mármint általában véve)

apt-cache depends chromium-codecs-ffmpeg-extra
chromium-codecs-ffmpeg-extra
  Függ ettől (előfüggés): dpkg
    dpkg:i386
  Függ ettől: libc6
  Ütközik: chromium-browser
  Ütközik: chromium-codecs-ffmpeg
  Kicseréli: chromium-browser
  Kicseréli: chromium-codecs-ffmpeg

Remélem, segítettem sötétet oszlatni. :)

Értékelés: 

0
Még nincs értékelve

Zöld pipa

Megnéztem én is az ikonokat. Double Commanderből is megy, az Xviewer-t tölti be hozzá.

Leszedtem a Thunderbirdöt, erre megszűnt az UM-ben a hozzá tartozó frissítés. Telepítettem az 1-es és 2-es szintű frissítéseket, beleértve a Chromium mpeg csomaghoz tartozót.

Megmaradt pár 4-es szintű frissítés, de csak akkor kaptam meg a zöld pipát, azaz akkor ürült ki a lista, ha beállítottam, hogy ne mindig mutassa a security update-ket. Úgy látszik ez az opció erősebb, mint amit Level szinten beállítottam (ott csak az első kettő van engedélyezve láthatóság és kiválasztás szempontból). Az Update Policyt az elsőre állítottam (kezdő felhasználó).

Az a baj, hogyha átállítom az Update Policyt az első vagy második lehetőségre, akkor az felülírja a Level szintű láthatóságot és kijelölést, így a pipa helyett megint i betű lesz. Úgy látom, hogy a legerősebb opció az Update Policy, utána a Preferences-Options, majd a Levels, és ez egyben beállítási sorrend is, mert ha nem ebben a sorban állítom be, akkor az elrontja a többit. Szóval jobb nem piszkálni az Update Policy-t, mert kezdhetem elölről a beállításokat.

Amikor először használtam, korábban lehet, hogy telepítettem 4-es és 5-ös szintű frissítést, mert azt hittem, akkor minden jó lesz. Meg lehet ezt utólag nézni, hogy volt-e ilyen és melyek ezek, és főleg el lehet távolítani?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Zöld pipa

#19 A szintek itt vannak rögzítve:

xdg-open /usr/lib/linuxmint/mintUpdate/rules

Bármivel megnyithatod, de xdg-open mindenhol van. ;)

Egyes csomagok tekintetében (példa):

-- telepített alkalmazás keresése a csomag neve alapján
(merítve a rules fájlból, különös tekintettel a kezdő és a záró * karakterre)

dpkg -l *xorg* | grep ii

-- telepített alkalmazás elérhető verzióinak keresése
(valamelyik -egyetlen egy csomag vizsgálata!- telepített csomag vizsgálata a korábbi parancsból):

apt-cache policy xorg

De ugyanezt a Synaptic csomagkezelőben is ellenőrizheted, és -'találat' esetén- a korábbi verzióra kényszeríted a csomagot. Ha nem megy, a segítségedre az aptitude lesz.
Előfordulhat, hogy valamely csomagból csak egy verzió érhető el, de vélhetően több csomag egynél több verzióban is a rendelkezésedre áll.

-----

A Frissítéskezelő beállítása a régebbi megjelenésre, működésre:
https://linuxmint.hu/blog/2018/03/a-frissiteskezelo-ikon-mukodese-a-linu...
Mostanában nem változik a frissítéssel a szöveges fájl.

Értékelés: 

0
Még nincs értékelve

Zöld pipa

#20

Ez rendben van, de honnan tudom, mi az a csomag, amire keresnem kell? Van-e olyan csomagom, amihez telepítettem 4-es vagy 5-ös szintű frissítést? Ezt valahonnan tudnom kell előbb.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Zöld pipa

#21Ez rendben van,
-- nincs megértve szerintem. :)

de honnan tudom, mi az a csomag, amire keresnem kell?
Saccperkábé:
-- a rules fájlban megkeresed a 4-es és az 5-szintű csomagok általános neveit és rákeresel (a * a név kiegészítés) a telepítettekre:
dpkg -l *xorg* | grep ii
-- kiválasztasz egy telepített fájlt és megnézed, egy vagy több változatban érhető el:
apt-cache policy xorg
... de több (telepített) csomagot is vizsgálhatsz, viszont mindenképpen pontos név szerint érdemes.
-- (az utóbbi parancs kimenetéből) kilesed a régebbi tároló szerver nevét (lövésem sincs, melyek azok az egyes csomagok tekintetében ... pontosan), és azt véve forrásnak, újratelepíted a csomagokat (példa):
sudo apt-get -t xenial install --reinstall csomag01 csomag02 (stb.)
(https://wiki.ubuntuusers.de/Apt-Pinning/)
... ekkor a csomag, vagy a telepítési parancsban szerelő csomagokat újratelepíted, és az újabb csomagot a másik tárolóból szedi le a csomagkezelő., amit aztán megfogsz ezen állapotban a Frissítéskezelő 1-es + 2-es + Biztonsági frissítések ( + esetleg 3-as) beállításaival
Elárulom, hogy nálam jelenleg a szintek ki vannak iktatva, pontosabban én mindent telepítek (kijelölöm a frissítésre nem kijelölt csomagokat is). Ennek az eredménye -egy ideje- az izgága viselkedés: ha az egér jobb klikkes menüvel nyitnék meg egy hivatkozást egy új lapon, úgy az esemény-választó menüt nem tudom elérni, a menüben legfelső választási lehetőség lesz kiválasztva, vagy a NoScript menüje nyílik meg. Nyomni kell folyamatosan az egér jobb gombját (menü elérése), és így tudom kiválasztani, hogy 'Megnyitás új lapon' vagy bármit egyáltalán ... . No, ilyen hibák miatt vannak a szintek. 

Van-e olyan csomagom, amihez telepítettem 4-es vagy 5-ös szintű frissítést? Ezt valahonnan tudnom kell előbb.
-- fentebb most és korábban is írtam. 'Visszafelé' nincs egyszerű módszer. Mármint egy lenne (az apt-pinning), de az sem egyszerűbb, mint amit most is leírtam ;). Vagy egy script. Érdemesebb a telepítést újrakezdeni talán.

(off: lassan húzzam ? :) megpróbáltam ;))

Értékelés: 

0
Még nincs értékelve

Aha, tényleg nem volt

Aha, tényleg nem volt megértve. Arra gontoltam, hogy a rules fájlt azért írod, hogy ott is beállíthatom, karbantarthatom az UM láthatósági szinteket, de ez egészen más.

Akkor ezeket kell majd végigkeresnem, ugye?

# Level 4
4|acpid|*
4|*lightdm|*
4|*slick-greeter|*
4|*linux-|*
4|*mdm|*
4|*nvidia|*
4|*xorg|*
4|bcmwl|*
4|ndiswrapper|*
4|grub2|*
4|grub|*
4|linux|*
4|mesa|*
4|plymouth|*
4|systemd|*
4|ubuntu-drivers-common|*
4|upstart|*

Lehet, hogy most nem esek neki, ezzel el lehet pepecselni egy darabig... Meg talán túl bonyolult is lesz. Majd megpróbálom.

Illetve ezt nem tudom, ezzel kezdődik a fájl:

# built against the LTS Vivid Xorg/MESA stack. Upgrading it removes virtualbox-guest-x11. Reinstalling the package breaks Xorg.
5|virtualbox|5.0.4-dfsg-2

Ez most 5-ös szintű volna?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Aha, tényleg nem volt

#23 Fordítás itt.

A # karakterrel kezdő sorok megjegyzések, tájékoztatások.

Értékelés: 

0
Még nincs értékelve

acpid próba

A Synaptic Package Mangerben az acpidhoz nem engedi a Force version parancsot futtatni.

Marad a parancsor.

Idáig jutottam el:

$ dpkg -l *acpid* | grep ii
ii  acpid          1:2.0.26-1ubuntu2 amd64        Advanced Configuration and Power Interface event daemon

$ apt-cache policy acpid
acpid:
  Installed: 1:2.0.26-1ubuntu2
  Candidate: 1:2.0.26-1ubuntu2
  Version table:
 *** 1:2.0.26-1ubuntu2 500
        500 http://ftp.freepark.org/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
 

Most mit kéne beírnom?

Értékelés: 

0
Még nincs értékelve
kimarite képe

acpid próba

#25 Itt semmit, egy verzió érhető el a csomagból. Talán kezesebb a Synaptic a keresésre: begépeled a fő csomag nevét, megnyomod a második táblázat fejlécet (ekkor a telepített csomagok sorakoznak majd felül a keresett szóra), és egyenként kiválasztva a csomagokat, ránézel a forrás fül tartalmára, hogy egy vagy több verzió érhető el, és azok mik pontosan.

Mert pl. (ez egy példa) a Firefox böngészőből több verzió érhető el, azaz több csomagforrása létezik:

apt-cache policy firefox
firefox:
  Telepítve: 60.0.1+linuxmint1+tara
  Jelölt:    60.0.1+linuxmint1+tara
  Verziótáblázat:
 *** 60.0.1+linuxmint1+tara 700 <-- első verzió
        700 http://ftp.energotel.sk/pub/linux/linuxmint-packages tara/upstream amd64 Packages
        100 /var/lib/dpkg/status
     60.0.1+build2-0ubuntu0.18.04.1 500 <-- második verzió
        500 http://mirror.vnet.sk/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     59.0.2+build1-0ubuntu1 500 <-- harmadik verzió
        500 http://mirror.vnet.sk/ubuntu bionic/main amd64 Packages

A verziók (a t kapcsolóhoz az újratelepítős parancsban): tara, bionic és a harmadik, a bionic-updates azonos a bionic-security verzióval (nálad ezek még xenial néven lesznek). A *** jelzésű, a tara verzió van nálam jelenleg telepítve. Ha ezt újratelepíteném (erre: binonic-security), akkor nemcsak a böngészőt kéne, hanem a magyar nyelvi környezetet, stb., mindazon csomagokat, amelyek a Firefox-hoz kötődnek és jelenleg tara verziójúak. Mert különben ütközés lép fel.

Értékelés: 

0
Még nincs értékelve

downgrade

A Synapticcal sikerült downgradelni a lightdm-ből mindkét tételt, és ezzel a Update Managerbe vissza is került a hozzá tartozó 4-es szintű frissítés. Jópofa dolog, majd eljátszok vele...

Bár azt hittem, ezek után a /usr/lib/linuxmint/mintUpdate/rules fájlból is eltűnik majd a 4-es lightdm, de benne maradt.

Értékelés: 

0
Még nincs értékelve
kimarite képe

downgrade

#27 A rules fájl egy beállítófájl, azt a Linux Mint készítői azért hozták létre, mert innen kukkol a Frissítéskezelő, azaz innen csak olvas és nem ír. A lib könyvtárakra ez a jellemző ;). Az etc könyvtár a beállítások helye.

Értékelés: 

0
Még nincs értékelve