[Megoldva] Nincs hang a jack kimeneten az Audacity használat, bezárás után

Fórum: 

 Sziasztok.

Lelkes kezdő vagyok, aki szereti megkeresni a megoldást, de most valahogy nem boldogulok. Persze biztos vagyok benne, hogy létezik a megoldás leírása, és én azt meg is találtam, de begyepesedett az agyam a keresésbe és átfutottam rajta. :(

A rendszerem:

intel core i5-ös dell vostro laptop SSD+HDD meghajtókkal Intel Device 9d71 hangkártyával. Linux mint 18.3 op. és 4.15.0-13 kernel.

Problémám:

Alap telepítés után minden működött ami nekem kell. (Audacious, apache2, mysql, phpmyadmin, php) Aztán használni akartam az Audacity-t és elment minden hang a jack kimeneten. A belső hangszóró működik, de fejhalgatót csatlakoztatva semmi hang. Próbáltam ALSA-t felrakni (Eredetileg PulseAudio volt) de semmi hatás.

Valaki tud nekem segíteni? Nem megy a munka zene nélkül. :(

Info:

System:    Host: boros-laptop Kernel: 4.15.0-13-generic x86_64 (64 bit gcc: 5.4.0)

            Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm

           Distro: Linux Mint 18.3 Sylvia

Machine:   System: Dell (portable) product: Vostro 15-3568 Chassis: type: 9

           Mobo: Dell model: 06XGVW v: A00

           Bios: Dell v: 2.0.4 date: 11/13/2017

CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB

           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848

           clock speeds: min/max: 400/3100 MHz 1: 800 MHz 2: 800 MHz

           3: 800 MHz 4: 800 MHz

Graphics:  Card-1: Intel Device 5916 bus-ID: 00:02.0 chip-ID: 8086:5916

           Card-2: Advanced Micro Devices [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230]

           bus-ID: 01:00.0 chip-ID: 1002:666f

           Display Server: X.Org 1.18.4 drivers: ati,radeon,intel (unloaded: fbdev,vesa)

           Resolution: 1920x1080@60.01hz, 1280x1024@60.02hz

           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)

           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes

Audio:     Card Intel Device 9d71

           driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d71

           Sound: Advanced Linux Sound Architecture v: k4.15.0-13-generic

Network:   Card-1: Qualcomm Atheros Device 0042

           driver: ath10k_pci bus-ID: 02:00.0 chip-ID: 168c:0042

           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: 9c:30:5b:17:85:a9

           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

           driver: r8169 v: 2.3LK-NAPI port: d000

           bus-ID: 03:00.0 chip-ID: 10ec:8168

           IF: enp3s0 state: up speed: 100 Mbps duplex: full

           mac: 58:8a:5a:23:aa:db

           Card-3: Atheros usb-ID: 001-005 chip-ID: 0cf3:e009

           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A

Drives:    HDD Total Size: 1120.2GB (55.2% used)

           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB serial: X7AUTUNDT

           ID-2: /dev/sdb model: KINGSTON_SV300S3 size: 120.0GB serial: 50026B774303F851

Partition: ID-1: / size: 103G used: 9.5G (10%) fs: ext4 dev: /dev/sdb5

           ID-2: /home size: 917G used: 560G (65%) fs: ext4 dev: /dev/sda1

           ID-3: swap-1 size: 8.44GB used: 0.00GB (0%) fs: swap dev: /dev/sdb1

RAID:      System: supported: N/A

           No RAID devices: /proc/mdstat, md_mod kernel module present

           Unused Devices: none

Sensors:   System Temperatures: cpu: 46.0C mobo: N/A gpu: 34.0

           Fan Speeds (in rpm): cpu: N/A

Info:      Processes: 230 Uptime: 17 min Memory: 1338.3/7758.3MB

           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0

 

AlsaMixer

Terminálból indíts egy AlsaMixer-t:

alsamixer

Itt ellenőrizd, hogy a Headphone rész nincs-e lenémítva. A föl-le gombokkal állítod a hangerőt. Az M betűvel lehet némítani illetve levenni a némítást.

Értékelés: 

0
Még nincs értékelve

Alsamixer

 Köszönöm. Nem írtam, de ezen túl vagyok már. :(

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nincs hang a jack kimeneten audacity futtatása óta

@Sirmax Próbáld ezt (alap beállításokra állít vissza minden hang beállítást)

alsactl init

esetleg (nem hátrány)

sudo alsactl init

Az mtimea javaslatához.
Az alsamixer az alsa-utils csomagban van. Telepítsd:

sudo apt-get install alsa-utils

Majd (terminál)

alsamixer

Kiválasztod a hangkártyát (ha egyáltalán kell, néha nem), és így látod a hangszabályozókat már.

M billentyű --> Mute, Unmute (némítás [NN], némítás kikapcsolása [BB])

!A kurzor nyilakkal lépkedsz jobbra és balra (kiválasztás), le és fel a kiválasztott szabályozó szabályozása.

Némi tájékoztató szöveget is látsz az ablakban fenn.

Kilépés: Esc (billentyű)

Értékelés: 

5
Átlag: 5 (1 szavazat)

Nincs hang a jack kimeneten audacity futtatása óta

 Elkiabáltam a dolgot.

Ha az audacity-t indítom mindíg elnémul, de ha futtatom az alsactl init-et, megjavul. Nem túl gyakran kell az audacity, de azért izgat, hogy mit állíthat el. Ez viszont már egy másik téma. 

Mégegyszer köszönöm. :)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nincs hang a jack kimeneten audacity futtatása óta

#6 Az Audacity hang beállításai környékén vizsgálódj. Én most nem használom, de ezt tenném. És használni fogom. ;)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nincs hang a jack kimeneten audacity futtatása óta

#7 Telepítettem, megnyitottam, bezártam (másra most nem volt idő). Semmi gond nem volt.
Próbáld a Felvevőeszköz lenyíló menüben a pulse beállítást.
A jack (fülhallgató) kimeneten kívül, még milyen kimenetek vannak. Pl. HDMI? És?
Valami olyasmi ok lehet, hogy használja a kimenetet az Audacious, és nem engedi el. De például indíthatod terminálból. Az látom, hogy az ALSA hangrendszert használja, efelett fut mostanában a Pulse hangrendszer. Az ALSA nem igazán tudott kiszolgálni egyszerre két alkalmazást ... alapvetően, de rá lehetett venni. :)
GyIK: https://manual.audacityteam.org/man/faq.html (nincs benne)

Értékelés: 

5
Átlag: 5 (1 szavazat)

Én sem tudtam reprodukálni a

Én sem tudtam reprodukálni a hibát, de askubuntu-n van bejegyzés hasonló problémáról, ami érinti a 2.1.2-es verziót is: https://askubuntu.com/questions/386869/headphone-jack-port-stopped-working-after-opening-audacity

Azt írják a mikrofonbemenet átállítása "sysdefault: Headphone Mic:0"-ról "sysdefault: Internal Mic:0"-ra megoldja a problémát. Vagy, ahogy fent is írva vagyon:

sudo alsactl init

Alternatívaként felrakhatod az Audacity-t flatpack csomagként (Szoftverkezelő, Flatpack fül, elég lassan települ...). Ott már a 2.2.1-es verzió elérhető. (Vagy megvárod a Linux Mint 19-et, ahol szintén 2.2.1-et fogjuk megkapni.)

 

Értékelés: 

5
Átlag: 5 (2 szavazat)
kimarite képe

megoldva úgy tűnik

#10 Amit én is elfelejtettem, hogy az Audacity nálam újabb, mert a Linux Mint 19 szintű rendszert használom.
Másik megoldásként javasolják ezt a PPA-t:
https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity
Ez esetben nem kell amikrofont átállítanod.
A PPA-t is felvettem valamiért, már nem tudom, melyik csomag miatt.

Értékelés: 

0
Még nincs értékelve