[Megoldva] Linux Mint 19 és a Wine

Xifoman képe

Fórum: 

Üdvözlök Mindenkit!

Eddig a Linux Mint 18 (Sara) rendszert használtam, és át szeretnék nyergelni az új 19-es változatra, de bele futottam egy olyan dologba a Wine programmal kapcsolatban, amit nem tudok megoldani. A gondom a következő: Linux Mint 18 alatt miután feltelepítem a Terminálban a Wine (verzió: 3.0.1) programot, majd utána ugyanitt a Winetricks-et simán gond nélkül telepíteni tudok Windows programot. Mivel  a program .exe fájlt el tudom indítani  (jobb egérgombot használva) a menüben található "Wine Windows Program Loader" alkalmazással. Amikor mindent feltelepítek a Linux Mint 19-ben (Wine 3.0.1. és a Winetricks) akkor hiába szeretnék bárminemű Windows telepítést végrehajtani semmit nem tudok tenni, mert a jobb egérgombos menüben sehol sincs a Wine Windows Program Loader, sőt még csak ki se tudom a többi program közül választani, mert nem szerepel a listában. Kérdésem: Valamilyen módon elő lehetne ugrasztani ezt a Wine Windows Program Loader-t? Ha mégsem megy a dolog akkor inkább maradok a jól működő "Sara"-nál. :D Előre is köszönöm a segítséget.

Wine Windows Program Loader

#1 Én azt hiszem úgy gondolja, hogy exe fájlra kattintva jobb egérgombbal nem tudja kiválasztani a wine-t. A megoldás pedig nekem az volt, hogy kézi beállitás és bepötyögni: wine %F

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine Windows Program Loader

#3 Ez is jó lehet:

Vagy a fájltársítás.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine Windows Program Loader

#3 Ja igen, a képen látható Tulajdonságok menüben is be lehet állítani a fájl tipusra vonatkozó fájltársítást. Erre gondoltál.

Értékelés: 

0
Még nincs értékelve
Xifoman képe

Wine Windows Program Loader

Igen erre gondoltam, de nem található meg a listában. Mert a Sara-ban bent van a listában tehát társítani tudom vele az exe fájlt Mivel ki tudom választani a listából a Wine Windows Program Loader-t. Ha 2-xer kattintok rá simán... vagy ezerszer... akkor sem történik semmi, ez olyan mintha a Wine-t fel sem telepítettem volna a 19-ben. Ugyanígy jártam amikor próbaképpen felhajítottam a gépemre az Elementary OS 5.0-át. Ott sem volt a listában a társításhoz, ráadásul már a rendszer telepítéskor felrakta nekem a Wine 3.0-át.

Értékelés: 

0
Még nincs értékelve
Xifoman képe

Wine Windows Program Loader

#3 Ezt hol kell "bepötyögni", a Terminálban?.. gondolom én. :)

Ezt a kézi beállítást meglesem... 

Amúgy konkrétan a The Sims 4-et, és a SimCity (2013)-at akarom futtatni, mert simán gond nélkül mennek Wine 3.0.1 verzióval Linux Mint 18 alatt. Ha így nem menne a 19-nél akkor még ott a PlayOnLinux is... az alatt is gőzerővel játszottam a Sara-val velük. Csak simán telepíteni jobb, mint a POL-al. :D

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine változatok

Habár hibás a videó,
https://www.youtube.com/watch?v=FD7FkoCAej0
(feleslegesen vesz fel egy tükröt, a hiba látszik is, de a készítő nem foglalkozik vele,
A leírás
https://wiki.winehq.org/Ubuntu
írja is, hogy Ubuntu-ra. Lentebb a Mint leírás.)
próbáld ezt (ez a helyes módszer), mennie kell:

-- az alapértelmezett, azaz a Linux Mint 19 alatt a Bionic tükrökről telepített csomagok eltávolítása:

sudo apt-get purge wine* winetricks*

sudo apt-get update

-- ha a rendszered 64bit-es (nyilván az):

sudo dpkg --add-architecture i386

-- további lépések a Linux Mint 19 tekintetében (32bit/64bit)

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt-get update
sudo apt-get install --install-recommends winehq-stable

Aztán lehet, az aptitude alkalmazás kell majd a telepítéshez. Erről volt már szó. Nálam sosem jelentkezett ezen beállításokkal a frissítés tekintetében: frissítések a 2. szintig és a biztonsági frissítések is bármely szinten.

Most frissítettem (a kérdés miatt) egy virtuális Linux Mint 19 képet (Virtualbox), de közben rátaláltam a fenti videóra. Tehát nincs akadálya, hogy akár kipróbáljam.

Hogy' a te telepítési módszeredet próbáljam, az nehezebb talán, mert nem tudom, a 15GB szabad hely elég-e a Timeshift mentésnek, hogy visszalépjek az eredeti, Wine telepítés nélküli állapotra és a most javasoltat megcsináljam. Persze, ugyanazt (végül is) meg tudom csinálni, a „purgálással”. Próbáld ki a módszert, az újabb Wine telepítését. :)

Értékelés: 

0
Még nincs értékelve
Xifoman képe

Wine változatok

#9 És meg van! :D

Értékelés: 

0
Még nincs értékelve
Xifoman képe

Wine változatok

#10 Az volt a gond, hogy eddig a Wine letöltését a terminálon keresztül teljesen máshogy csináltam a WineHQ oldalon. De a leírásodat szem előtt tartva így már jó lett... végre sikerül a 19-en maradnom. Ezt a telepítési sorrendet el is mentem rögtön!! Köszönöm a segítséget! :)

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine változatok

#11 Szívesen. :)

Értékelés: 

0
Még nincs értékelve
Xifoman képe

Wine változatok

#10 No, már játszhatok is! :D

Értékelés: 

0
Még nincs értékelve

wine

Üdv. Mindenkinek!

Nekem is gond a LinuxMint 19 wine hiánya.

Végig csináltam amit 'kimarite' írt, 2018.11.24, és az utolsó sorba hibát hozott:

sudo apt-get install --install-recommends winehq-stable
Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
E: Ez a csomag nem található: winehq-stable

32-bites a rendszerem.

Mi lehet a gond?

Értékelés: 

0
Még nincs értékelve

Most ez a verzio van elvileg

Most ez a verzio van elvileg a gépen, de nem találom rajta.

laci@R61i:~$ wine --version
wine-3.0 (Ubuntu 3.0-1ubuntu1)
laci@R61i:~$

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Wine 32 bit

#15 Szia. Ha a rendszer 32bites, akkor ez a lépés nem kell. Kihagytad amúgy?

sudo dpkg --add-architecture i386

-----

Én látok 32 bites csomagokat itt:
https://dl.winehq.org/wine-builds/ubuntu/dists/bionic/main/binary-i386/
A telepítés félbeszakadását az okozza, hogy más a 32 bites csomag neve, mint a 64 bitesé.

Másold be a terminálba ezt a parancsot,

sudo apt install --install-recommends winehq-stable

majd nyomd meg kétszer a TAB billenytűt.

Meg fognak jelenni a telepíthető csomagok. Másold ide, mi jelenik meg, a szöveget.

A TAB egyszeri megnyomása kiegészíti a (lehetséges) kifejezéseket a teljes nevükre. Ha nem egy, hanem több lehetőség van, azokat a TAB kétszeri megnyomása listázza ki.

Értékelés: 

0
Még nincs értékelve
keraform képe

Most ez a verzio van elvileg

#16 A winehq-stable nem szükséges a Wine használatához, nálam sincs telepítve.
"Most ez a verzio van elvileg a gépen, de nem találom rajta."
Terminálba: locate wine
Így se találod?
Látni a menüben akkor fogod, ha legalább egy windowsos programot telepítesz hozzá.

Tesztelésképpen kattints a https://notepad-plus-plus.org/download/v7.6.4.html oldalon a "Notepad++ Installer 32-bit x86" linkre.

Meg kell jelennie egy ablaknak ezzel a szöveggel:
Open with Wine Windows Program Loader

Az OK gombra kattintás után települnie kell. Utána lesz a Menüben egy Wine almenü, és benne a Notepad++ program.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Most ez a verzio van elvileg

#16 Ez a rövidke szösszenet elkerülte a figyelmem.

Nem fontos megkeresned hol van a Wine, mert, ha egy alkalmazást sem telepítettél általa, akkor nem látszik a menüben. Erről régebben volt szó.

Az alkalmazások indítóit a which paranccsal keresheted meg.

Például:

which wine

Egyes alkalmazások így nem találhatóak meg (ritka eset, de pl. a LibreOffice ilyen is lehet), akkor a  csomag végét nyitva hagyjuk a csillaggal, azaz bármi lehet ott, rákeresünk.
(vagy a már megismert egy, illetve kettő TAB megnyomás)

which wine*

De ez csak a bináris fájl, azaz az indító, azaz a menü elem más. Említettem, alapból ilyen nincs a Winenak. És a binárist hiába indítanád, annak nincs olyan szerepe, hogy elindítsd és .. láss valamit.

Telepített alkalmazások fájlrendszerben történő rákeresésére az említett locate parancs, illetve a find parancs jó. A pontos találatok a dpkg csomagkezelő L kapcsolójával érhetőek el. Például:

dpkg -L wine

De -a Wine vonatkozásában- ezzel sem tudsz mit kezdeni. Azért, amit említettem, önmagában nem indítható. Vannak segédprogramok, mint például a winetricks ..., a konfiguráláshoz. Telepítve a Wine egyelőre lehetőség, azaz, ha lát egy Windowsos telepítőt, meg tudod vele nyitni.

Inkább derítsük ki, mit szeretnél a Winenal kezdeni. Játékokat, vagy más alkalmazást telepíteni? És pontosan mit, miket? Ha megvan az elképzelés, a módszer is világos lesz (akor, ha szükség valamilyen egyedi módszerre).

-----

A külső tükör felvételével és használatával egy „viszonylag” újabb Wine csomaghoz jutsz. A tükör használata itt is azt hozza magával, hogy a csomag frissülni fog. A rendszer tükrökről elérhető Winet is használhatod, tehát amit pl. a Synaptic csomagkezelőben találsz, vagy a Szoftverkezelőben. Igazából nagy különbség nincs a kettő között, azaz inkább azt mondanám, hogy a különbség, ha van, akkor a használat során derül ki. Mindkettő biztonságos és használható.

Te most a rendszerben alapértelmezetten  elérhető Wine-t telepítetted. Ellenőriztem a verziót:

apt-cache policy wine-stable
wine-stable:
  Telepítve: (nincs)
  Jelölt:    3.0-1ubuntu1
  Verziótáblázat:
     3.0-1ubuntu1 500
        500 http://mirror.vnet.sk/ubuntu bionic/universe amd64 Packages
        500 http://mirror.vnet.sk/ubuntu bionic/universe i386 Packages

Értékelés: 

0
Még nincs értékelve

wine megoldva

 Lett wine!! :))

A meg oldás ez volt:

sudo apt install --install-recommends winehq-stable

Köszönöm a segítséget!!

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

wine megoldva

#20 Szívesen.

Csak zárójelben: az az apt-get-tel is működik a parancsban szereplő install-recommends kapcsoló. Példa:

sudo apt-get install --install-recommends htop
Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
Az alábbi ÚJ csomagok lesznek telepítve:
  htop
0 frissített, 1 újonnan telepített, 0 eltávolítandó és 26 nem frissített.
Letöltendő adatmennyiség: 80,0 kB.
A művelet után 221 kB lemezterület kerül felhasználásra.
Letöltés:1 http://mirror.vnet.sk/ubuntu bionic/main amd64 htop amd64 2.1.0-3 [80,0 kB]
Letöltve 80,0 kB 0mp alatt (626 kB/s)
A korábban ki nem választott htop csomag kiválasztása.
(Adatbázis olvasása ... 255776 fájl és könyvtár van jelenleg telepítve.)
Kibontás előkészítése: .../htop_2.1.0-3_amd64.deb ...
Kibontás: htop (2.1.0-3) ...
Aktiválók feldolgozása: mime-support (3.60ubuntu1) ...
Aktiválók feldolgozása: desktop-file-utils (0.23+linuxmint4) ...
Aktiválók feldolgozása: man-db (2.8.3-2ubuntu0.1) ...
Aktiválók feldolgozása: gnome-menus (3.13.3-11ubuntu1.1) ...
Beállítás: htop (2.1.0-3) ...

(Linux Mint 19.1)

Értékelés: 

0
Még nincs értékelve