LM20.1 és a gnome-hearts_0.3-2.2_amd64.deb

kojak képe

Fórum: 

Üdv,

Feltelepítettem az LM20.1 Cinnamon-t, a játékokat újra pakolva sajnos a klasszikus fekete macska nem megy fel. 

A következő üzenetet adja:

https://drive.google.com/file/d/1KD_p9QWr8TboFLBmFsu2lW2asKKYt_2A/view?u...

Van valami lehetőség arra, hogy ezt a klasszikust használni tudjam?

Előtte az LM19.4 volt fent, azon rendesen működött...

kimarite képe

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

Terminálban!

Prioritás fájl elkészítése (ami elérhetetlen, mint „focal” csomag, az a „bionic” tükörről jön):

echo 'Package: gnome-hearts
Pin: release n=xenial
Pin-Priority: 1001

Package: libgnome2-0
Pin: release n=bionic
Pin-Priority: 1001

Package: libgnome2-common
Pin: release a=bionic
Pin-Priority: 1001

Package: libbonobo2-0
Pin: release n=bionic
Pin-Priority: 1001

Package: libbonobo2-common
Pin: release n=bionic
Pin-Priority: 1001

Package: liborbit-2-0
Pin: release n=bionic
Pin-Priority: 1001

Package: multiarch-support
Pin: release n=bionic-security
Pin-Priority: 1001
' |
sudo tee /etc/apt/preferences.d/gnome-hearts_xenial_bionic

Tükör lista készítése (ami elérhetetlen, mint „focal” csomag, az a „bionic” tükörről jön):

echo '#------------------------------------------------------------------------------#
#                            OFFICIAL UBUNTU REPOS                             #
#------------------------------------------------------------------------------#
### https://repogen.simplylinux.ch/

##### Gnome Hearts - Xenial
deb http://sk.archive.ubuntu.com/ubuntu xenial main universe

###### Ubuntu Main Repos
deb http://sk.archive.ubuntu.com/ubuntu/ bionic main universe

###### Ubuntu Update Repos
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-security main universe
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-updates main universe
' |
sudo tee /etc/apt/sources.list.d/gnome-hearts_xenial_bionic.list

Beállítások frissítése:

sudo apt-get update

Telepítés (csak a „xenial” tükörről érhető el a csomag):

sudo apt-get install gnome-hearts

Miután a telepítés megvan, jön egy újabb szerkesztés:

sudo nano /etc/apt/sources.list.d/gnome-hearts_xenial_bionic.list

A kiemelt sort kommenteld (#) így:

##### Gnome Hearts - Xenial
# deb http://sk.archive.ubuntu.com/ubuntu xenial main universe

Mentés, és kilépés a nano szövegszerkesztőből:

Ctrl + O, és Enter,
majd Ctrl + X

Beállítások frissítése:

sudo apt-get update

Ha nem teszed megjegyzésbe (komment) a Xenial tükröt, ezt a hibajelzést kapod:

Can not add an empty (zero-length) key to the cache

Egyébként a Xenial (Linux Mint 18.x) már nem támogatott, frissítés innen nem érkezik, a komment előtti állapot csak a csomag telepítéséhez kellett. A Focal kiadáson (Linux Mint 20.x) nem elérhető Gnome Hearts függőségek a Bionic kiadásból (Linux Mnt 19.3) érkeznek.

Értékelés: 

5
Átlag: 5 (1 szavazat)
kojak képe

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

#4 uhh, nekem ez kínai indecisionlegalább is az eleje a "beállítások frissítése"-ig... sose csináltam ilyet. emésztem még egy kicsit, hátha megértem.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

#5 Az echo a terminál kimenetre írja a macskakörmök között látható szöveget, és innen a tee alkalmazás beírja egy-egy szövegfájlba. Hasonló, mintha a nano alkalmazással szerkesztenéd a fájlt, csak itt egyetlen lépésben megléped az összes lépést.

Értékelés: 

0
Még nincs értékelve
kojak képe

Nekem működik

#6 ok, letöltöttem.

most ez van a fájlban:

https://drive.google.com/file/d/1KsKNZuqR2VRi6_W4z_fiwT9slzHnSsAo/view?u...

ezt másolja bele telepítés előtt?

# deb http://sk.archive.ubuntu.com/ubuntu xenial main universe

és utána futtatható a deb?

Értékelés: 

0
Még nincs értékelve
kimarite képe

forráslista | apt-pining

#8 Mm, két emberrel beszélgetsz, ami nem baj, Viszont én és mumorec is teljesen mást mond.
Linux Mint 20.1 rendszeren, csak a játék telepítőt letöltve, az teljesíthetetlen függőséget kér.
Én azt írtam le, hogy egyéni letöltés nélkül, csak tükrök használatával, hogy telepíted a játékot.
Ki is próbáltam, az én módszerem tökéletesen működik. De! A Linux Mint 20.x rendszerre jó a módszer. És ez volt a kérdésben is. Miért kevered a módszereket?

ezt másolja bele telepítés előtt?

# deb http://sk.archive.ubuntu.com/ubuntu xenial main universe

és utána futtatható a deb?

Nem másolja bele a sort (egyik forráslistába sem)!
Ez a DEB telepítő nem az a DEB telepítő, ami tükröket is intéz neked. :)
Ui.: a Linux Mint és az LMDE 4 nem a mutatott sources.list fájlban tárolja a tükröket!

Nézd meg, hol:

inxi -r

Értékelés: 

0
Még nincs értékelve
kojak képe

forráslista | apt-pining

#9

van dropboxom, csak a régi telepítésnél is használtam, így a mostanit már nem engedi a 3 gépes maximum miatt. nem találok benne olyan opciót a webes felületen, hogy a régi gépet töröljem.

ez a verzió van fent:

https://drive.google.com/file/d/1qq-5i4d3ZPfYE5wBo6Ek3UH74CFYYcKj/view?u...

ezek szerint a 20.1-n nem működik a mumorec által leírt telepítés....

megpróbálom megérteni, amiket írtál kimi smiley

 

Értékelés: 

0
Még nincs értékelve
kojak képe

forráslista | apt-pining

#9

Sikerült!!!!

Kimi a király smiley

Csak rájöttem, miket csináljak smiley

Köszönöm!!!!

Értékelés: 

0
Még nincs értékelve
kojak képe

forráslista | apt-pining

#9

Sikerült!!!!

Kimi a király smiley

Csak rájöttem, miket csináljak smiley

Köszönöm!!!!

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nekem működik | Unjuk már

#14 Ez melyik Linux? A 19-es sorozat egyike?

Nem derült ki.
A gnome-hearts függőségek a 19.x kiadásnál későbbi kiadáson nincsenek meg.
Itt lehet mögnézni: https://packages.ubuntu.com/
Az, hogy a segítőnél működik valami, a válasz egy részlete lehet csak, a többi a megoldás keresése. És, ha a segítő ugyanaz sulykolja mégis, arra mondják, és én is a te figyelmedbe: a kutya f....át sem érdekli. :)

Értékelés: 

0
Még nincs értékelve

Nekem működik | Unjuk már

#15 Szállj le a magas lóról. Már nekem is kezd tele lenni a hócipőm a nagyképüsködésedtől.

A csatolt linken lépésről lépésre bemutattam a telepítést. Ott mutattam képet a Mint verziójáról is.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nekem működik | Unjuk már

#17 Tudod, van a „magyar vagyok, nem turista” póló felirat. Én vagyok a magyar, te a turista. A te megoldásod nem működött... . A „PPA” ugye normálisan „telepítve” van? Nem. A képen látható PPA-s csomag:
https://ibb.co/L6sd2sR
Segítő lépéseid vezetni sem az én feladatom. Ennyit tudtam segíteni, mi a helyes módszer. És itt pont.
A kérdezőt győzd meg, hogyan csinálja! Nem engem kell meggyőznöd!

A Caps Lock-hoz hasonlóan udvariatlan a félkövér „erősítés” az érveléshez. Az a szokás, hogy udvariasan beszélgetünk szakmai dolgokról: a beszólogatást gyakorold még kicsit a tükör előtt, egyáltalán nem vagy meggyőző ebben sem :). Merthogy, én legfeljebb ironikus voltam, te meg, idézem ... : Bizonyára nem mindig értünk egyet, ám ez nem lehet mentség sem kellemetlen viselkedésre, sem durva stílusra. (*)
Itt nincsenek sem mesterek, sem szolgák. Sem fenyegetőzés, sem félés. És szemetelni sem illik.

Értékelés: 

0
Még nincs értékelve
kojak képe

Nekem működik | Unjuk már

#17

sajnos nekem úgy nem ment fel, ahogy mutattad, már az első képen, a csomag telepítése sem zöldült ki, nem tudtam tovább lépni a letöltött deb-l.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nekem működik | Unjuk már

#19 Alapvetően téves elképzelés mumorec részéről, hogy az egyik képen látható PPA-s csomagot neked/nekem értenünk kéne, hogy melyik PPA lenne az általa használt tükör. És ahelyett, hogy kibontaná az általa követett megoldás minden részletét, konokul ragaszkodik ahhoz, hogy ő mindent megmutatott. A lényeg, neki sikerült, a többi nem számít, azaz mindenki más hülye. Szerintem, ez nem a segítés helyes módszere, de hát ki-ki máshogy vélekedik oly sok dologról, úgyhogy ..., ennyi is :). Én elhiszem amúgy, hogy neki is sikerült a telepítés. Csak nem értem. Nem vagyok ezzel egyedül, mert te sem érted. Számít? ;)

Értékelés: 

0
Még nincs értékelve

Nekem működik | Unjuk már

#18 Hatalmas egód van, hogy bírod ki saját magadat? Szerintem beteg vagy.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nekem működik | Unjuk már

#22 A lényeg nem az, hogy orvosi diploma vélhetően sehol, de az viszont legalább tartja bennem a lelket, hogy te az ilyen helyzeteket csuklóból kezeled. :)

-- Hogy sikerült az IQ tesztje?
-- Szerencsére negatív!

Azért megnézném, hogy te a saját közösségedért mit tettél le. De tényleg...

Értékelés: 

0
Még nincs értékelve

Ezért működik

Csináltam egy új, friss Cinnamon 20.1 telepítést. Csak a frissítéseket telepítettem. Megpróbáltam a Fekete Macskát telepíteni. Függőségi hibákat jelzett.

Másik gépen, amelyiken telepíteni tudtam a Fekete Macskát, elkezdtem keresni az eltéréseket. Kiderült, hogy a gépre telepítettem a Shutter-t és ez tartalmazza a hiányzó részeket.

Próba a friss telepítésre, Shutter telepítése:

https://www.linuxuprising.com/2018/10/shutter-removed-from-ubuntu-1810-a...

Fekete Macska telepítése, működik.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

#24 A “Linux Uprising” team, Shutter PPA-ja tartalmazza a Gnome Hearts függőségeit,
https://launchpad.net/~linuxuprising/+archive/ubuntu/shutter
(https://launchpad.net/+search?field.text=ppa%3Alinuxuprising%2Fshutter)
ezeket: libgnome, libbonobo, orbit. A multiarch-support csomagot közvetve nem.
A játékot magát le kell tölteni.
Ki lehet váltani a régebbi kiadások forrás tükreit PPA-val is.

#4 A saját tükör használata előnyösebb megoldásnak látszik, olyan szempontból, hogy egy-egy PPA támogatottsága olykor megszűnik (előfordulhat ilyen is), a saját tükörről származó csomagok viszont értelemszerűen egészen biztosan frissülnek.
Köszönjük

Értékelés: 

0
Még nincs értékelve

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

#25 Jah, így könnyű, hogy megadtam a megfejtést :-).

Értékelés: 

0
Még nincs értékelve
kimarite képe

Gnome Hearts - Xenial | Függőségei - Bionic (Linux Mint 20.1)

#26 Tudomásunk lett arról, hogy a te PPA-val használt, azaz egyénileg konfigurált Linux Mint rendszereden hogyan történne a játék telepítése. Mindazonáltal, az okokat feltáró folyamatban te is jobban megismerted a csomag telepítés, a rendszer működését. Az egyik legnehezebb dolognak tartom megindokolni a tanácsainkat és kiállni azokért, de véleményem szerint ez éppen olyan fontos, mint maga a javasolt módszer.

Értékelés: 

0
Még nincs értékelve
kimarite képe

pysolfc | Pythonos játék gyűjtemény

Itt egy másik Passziánsz/Fekete macska. A *-cardsets a grafikus megjelenítéshez kell, amúgy nem (Synapticban meg tudod nézni a tulajdonságoknál a leírásokat). Az LMDE 4 kiadáshoz is elérhető.

apt-cache policy pysolfc pysolfc-cardsets
pysolfc:
  Telepítve: (nincs)
  Jelölt:    2.6.4-3
  Verziótáblázat:
     2.6.4-3 500
        500 http://ubuntu.inode.at/ubuntu focal/universe amd64 Packages
        500 http://ubuntu.inode.at/ubuntu focal/universe i386 Packages
     2.0-4 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
pysolfc-cardsets:
  Telepítve: (nincs)
  Jelölt:    2.0+dfsg2-2
  Verziótáblázat:
     2.0+dfsg2-2 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        500 http://ubuntu.inode.at/ubuntu focal/universe amd64 Packages
        500 http://ubuntu.inode.at/ubuntu focal/universe i386 Packages

Ami vicces, elnavígáltam a passziánszról, és nem emlékszem, mi a neve az alkalmazásban :) (én a Debian rendszeremen telepítettem, de ez nem annak a kimenete)

Értékelés: 

0
Még nincs értékelve
kimarite képe

pysolfc | Pythonos játék gyűjtemény

#28 Ami vicces, elnavígáltam a passziánszról, és nem emlékszem... (Klondike)

Értékelés: 

0
Még nincs értékelve
kami911 képe

Milyen játékokat szoktál

Milyen játékokat szoktál telepíteni? Addig egy jó pasziánsz?

https://wiki.gnome.org/Apps/Aisleriot

apt install aisleriot

Gnome körök játékai:
https://wiki.gnome.org/Apps#Games

A hearts sajnos tényleg nincsen új csomagban.

Innen talán letudod szedni:
https://packages.ubuntu.com/xenial/gnome-hearts
(amd64 jó eséllyel,d e nem tudom milyen géped van.
De lehet, hogy néhány függőséget is le kell szedned. Ha elakadsz szól, a függőségekkel meg csak óvatosan.

Értékelés: 

0
Még nincs értékelve
Koppány képe

Milyen játékokat szoktál

#32 Jut eszembe, a The Ace of Penguins csomagban is van egy rahedli kártyás játék, minden ismert linux verzión elérhető. :) Fent van az összes Mint tárolóban.

Értékelés: 

0
Még nincs értékelve