Kernel frissítés->Rendszerindítási probléma

Fórum: 

Üdvözletem mindenkinek!

Ahogy a tárgy mezőben röviden megfogalmaztam, kernel frissítést követően (4.15.0-47-ről 4.15.0-48-ra) rendszerbetöltési probléma jelentkezik az utóbbi időben, de nem minden indítás során, csak időnként. Gépindítást követően a folyamat nem jut el a Linux Mint logó megjelenéségi, hanem az azt megleőző fekete képernyőnél megakad, az egyhangú látványt csak egy (random elhelyezkedő) vízszintes vonal teszi hangulatosabbá. Ezt követően, szerencsés esetben, néhány perc után automatikusan újraindul a gép és feláll a rendszer, a szokott módon, esetenként csak a CTRL+ALT+ PRT SC+REISUB segít, ritkán pedig csak reset-eléssel tudom kierőszakolni az újraindulást.

Volt már hasonló korábban is (4.15.0-46 esetén), de akkor a Mint logó megjelenése után adta meg magát.

Azért merem azt gondolni, hogy a kernel lehet a probléma oka, mert a frissítés után jelent meg (4.15.0-47-ről 4.15.0-48-ra), illetve az után automatikusan megoldódott korábban (4.15.0-46-ról 4.15.0-47-re). Utánaolvastam egy kicsit a dolgoknak, és azt találtam, hogy a régebbi gépeknél jelentkezhetnek problémák újabb kernelek esetén, és bizony az én gépem már nem fiatal, belépett a tinédzerkorba.

Olvasgatás közben találtam megoldási lehetőségeket is, de a barkácsolás mikéntjével nem vagyok pontról-pontra tisztában, így nem fogtam bele. Ha jól sejtem, akkor a GRUB szerkesztésével megoldható, hogy ne a legújabb, hanem az azt megelőző (és jól működő 4.15.0-47-es) kernel legyen az alapértelmezett, illetve van mód arra is, hogy több kernel használatával is indítható legyen a rendszer (választási lehetőséget kínálva).

Ennek a két beállításnak a véghezviteléhez szeretnék most segítséget kérni (már ha ezek megoldják a problémámat), mely segítséget előre is köszönöm! Természetesen egyéb javaslatokra is nyitott vagyok.

Végezetül némi infó a jelen állapotról:

Rendszer: Linux Mint 19 32 bit XFCE

Indításkor nem jelenik meg automatikusan a GRUB menü, mivel más rendszer nincs telepítve a gépre, és tudtommal, csak a legfrissebb kernellel üzemel, így ebből kifolyólag sincs több választási opció, mely a megjelenését indokolná (ezen szeretnék változtatni, ahogy fentebb is írtam).

A gépen található kernelekről ezt tudom megosztani a nagyérdeművel:

norbi@norbi-M540R:~$ uname -r ##

4.15.0-48-generic

norbi@norbi-M540R:~$ sudo dpkg --list | grep linux-image ##

[sudo] norbi jelszava:

ii linux-image-4.15.0-20-generic 4.15.0-20.21 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-43-generic 4.15.0-43.46 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-44-generic 4.15.0-44.47 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-45-generic 4.15.0-45.48 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-46-generic 4.15.0-46.49 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-47-generic 4.15.0-47.50 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-4.15.0-48-generic 4.15.0-48.51 i386 Linux kernel image for version 4.15.0 on 32 bit x86 SMP

ii linux-image-generic 4.15.0.48.50 i386 Generic Linux kernel image

norbi@norbi-M540R:~$

 

A GRUB pedig a következőket tartalmazza jelenleg (,ha jól sejtem, akkor itt kell majd módosításokat végrehajtanom):

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

 

További szép napot mindenkinek!

Üdv mindenki!

Üdv mindenki!

A GRUB láthatóságát időközben sikerült megoldanom, az alábbi forrás felhasználásával, melyért hálás köszönetem: https://linuxmint.hu/blog/2017/10/a-grub-menu-lathatosaga

Esetemben az alábbi módosítás segített (talál érdekel másokat, bár az érdeklődés a téma iránt eddig meglehetősen visszafogott):

Eredeti GRUB fájl:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Jelenlegi, módosított, GRUB fájl:

GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Időközben történt egy kernelfrissítés is:

ii  linux-image-4.15.0-50-generic              4.15.0-50.54                        i386         Linux kernel image for version 4.15.0 on 32 bit x86 SMP

Sajnos ennél is ugyanaz a probléma, mint a 48-asnál, azzal a különbséggel, hogy itt már vastagabb a korábban említett csík, bár ez nem boldogít különösebben.

Az alapértelmezett kernel módosításával kapcsolatban még nem sikerült előrébb lépnem. Próbálkoztam a GRUB fájl GRUB_DEFAULT=0 sorában a 0 helyett másik szám megadásával, de sikertelenül, valamint találtam néhány témábavágó videót mely alapján kísérleteztem, eddig hiába. A későbbiekben, különösen, ha sikerül célt érnem, írok egy újabb bejegyzést, hátha hasznát veszi valaki az általam leírtaknak.

További szép napot!

Értékelés: 

0
Még nincs értékelve
kimarite képe

Üdv mindenki!

#1 A Plymouth alkalmazás csinálja a "csilivili" betöltêst. Esetleg e témakörben nézz körül, netán el is távolíthatod.

Gondolom, az automatikus bejelentkezés van beállítva, de ha a jelszó kérés mégis, akkor érdemes lehet telepíteni a SliM alkalmazást. A telepítés közben be kell állítani, hogy ez legyen használva a LighDM helyett. Kiválasztod.

A probléma lehet: kernel, Plymouth, LigtDM, valamilyen eszköz vagy rendszer szolgáltatás.

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

Üdvözöllek!

Jelszókérés van beállítva, bár nem hinném, hogy ehhez kapcsolódna a probléma, mert a bejelentkezési képernyő közelébe sem jut el a folyamat. Azután akad meg, miután túljut a BIOS-ba, F2-vel történő belépés lehetőségén, ezután jön egy fekete monitorkép és itt akad meg és csíkosodik be a kép. Ha minden flottul működne, akkor az előbbi feketeség után jönne a Mint logó és alatta az 5 villogó folyamatjelző fény, majd a bejelentkezési képernyő. A 48- as és a legújabb 50-es kernelnél már a Mint logó előtti, fekete képernyőnél letérdel, a 46-osnál pedig a Mint logo megjelenése után szokott megfáradni (kb. "lefagyni"), egyéb esetben (a többi kernelnél) minden flottul ment idáig. Így jelenleg nem nagyon piszkálnám a Plymouth-ot, illetve a LightDM-et, most a többi, gépen lévő, kernelt tesztelem, hogy megtudjam jelenleg melyik használható és melyik nem (sikerült a GRUB-ot megjelenésre bírnom, ahogy fentebb jeleztem, így most a Speciális beállításokon belül már tudok váltogatni).

Egyébként rákerestem a SLiM-re és ezt találtam: https://wiki.archlinux.org/index.php/SLiM_(Magyar)

Komolyabban nem szeretnék a rendszerbe belemászni, hozzáértés híján, egyelőre a default kernel megváltoztatása egy korábbi verzióra bőségesen komfortossá tenné számomra a Mint használatát.

Jelenleg ezt a videót találtam a témában, ami a legrészletesebbnek és számomra leghasználhatóbbnak tűnik (remélem az eltérő disztribúció nem jelent problémát jelen esetben), ez alapján próbálkozom még egy kicsit, mielőtt komolyabban fontolóra veszem a fenti módosítási javaslataidat: https://www.youtube.com/watch?v=1cCLa4qusFo

Kellemes hétvégét!

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#3 Rossz videót linkeltem be, a következő volna a számomra használható, ha jól sejtem: https://www.youtube.com/watch?v=prHDES9XmjU

Egyébként Terminálban jelenleg a következőket látom:

norbi@norbi-M540R:~$ sudo update-grub

[sudo] norbi jelszava:

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

 

Ha jól sejtem, akkor, ha a fent kiemelt sor helyett, a következő jelenne meg: Sourcing file `/etc/default/grub.d/47_linuxmint.cfg', akkor minden problémám megoldódna és az aláhúzott kernel lenne az alapértelmezett, valahogy ezt szeretném kierőszakolni, már ha egyáltalán lehetséges.

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#3 Szia !
Ha egy előző kernel verziót szeretnél visszaállítani, akkor a GRUB menüt kell előcsalogatni.
(A gép indítása után a bal Shift vagy az Esc bill. szorgos nyomogatásával.)
Valahogy így néz ki: https://ibb.co/XFmMGkQ
Találsz benne olyan opciót hogy:
- Speciális beállítások ehhez: Linux Mint xx.x xxxx xx-bit
vagy:
- Previous Linux versions
Erre kell lépkedned a navigáló billentyűk segítségével, és entert nyomni.
Ekkor megjelenik egy lista a teleített kernelekkel.
Itt kiválasztod a visszaállítani kívánt verziót, és entert nyomsz.
Ekkor ezzel a régebbi kernel verzióval indul a rendszer.

Figyelem ! Ennek a hatása 1 munkamenetig tart - egy új indítás, vagy újraindítás során a legmagasabb
verziószámú kernel fog betőltődni.
Hogy ezt elkerüld, törölni kéne a nem megfelelően működő kenel verziókat.
Vagy ha minden igaz, ennek a parancsnak a hatására az adott (jól működő) kernel verzió rögzítve lesz:

sudo apt-mark hold $(uname -r)

 

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#5

Üdvözöllek és köszönöm a hozzászólásodat!

Indításkor a GRUB menü már csalogatás nélkül is előjön, mert szerkesztettem az etc/default/grub fájlt korábban, ahogy azt a témafelvetést követő első hozzászólásomban leírtam, így ez már OK.

Korábbi kerneleket is tudok választani az általad leírt módon, így a jelenlegi probléma nem nagy érvágás számomra, viszont minden indításkor kell egy kicsit kattogtatnom, mert ahogy Te is írtad, tiszavirág életű ez a beállítás és minden indításkor meg kell tenni, és ez az amin változtatni szeretnék, ahogy azt Te is jól tudod.

Korábbi olvasgatásaimból az dereng, hogy a legfrissebb, így alapértelmezettként használt kernel törölgetése nem a legjobb húzás, de javíts ki, ha tévedek.

A javasolt paranccsal teszek egy próbát.

Még egyszer köszönöm!

Üdv, Norbi!

Értékelés: 

0
Még nincs értékelve

A belinkelt videó alapján ezt sikerült összehoznom.

norbi@norbi-M540R:~$ sudo grub-mkconfig -o /boot/grub/grub.cfg

[sudo] norbi jelszava:

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

norbi@norbi-M540R:~$ sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N

 

1 menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' 1 {

2 menuentry 'Ubuntu, Linux 4.15.0-50-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 2 .15.0-50-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

3 menuentry 'Ubuntu, with Linux 4.15.0-50-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 3 'gnulinux-4.15.0-50-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

4 menuentry 'Ubuntu, Linux 4.15.0-47-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 4 .15.0-47-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

5 menuentry 'Ubuntu, with Linux 4.15.0-47-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 5 'gnulinux-4.15.0-47-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

6 menuentry 'Ubuntu, Linux 4.15.0-46-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 6 .15.0-46-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

7 menuentry 'Ubuntu, with Linux 4.15.0-46-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 7 'gnulinux-4.15.0-46-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

8 menuentry 'Ubuntu, Linux 4.15.0-45-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 8 .15.0-45-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

9 menuentry 'Ubuntu, with Linux 4.15.0-45-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 9 'gnulinux-4.15.0-45-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

10 menuentry 'Ubuntu, Linux 4.15.0-44-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 10 .15.0-44-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

11 menuentry 'Ubuntu, with Linux 4.15.0-44-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 11 'gnulinux-4.15.0-44-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

12 menuentry 'Ubuntu, Linux 4.15.0-43-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 12 .15.0-43-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

13 menuentry 'Ubuntu, with Linux 4.15.0-43-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 13 'gnulinux-4.15.0-43-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

14 menuentry 'Ubuntu, Linux 4.15.0-20-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 14 .15.0-20-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

15 menuentry 'Ubuntu, with Linux 4.15.0-20-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 15 'gnulinux-4.15.0-20-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

16 menuentry 'Memory test (memtest86+)' {

17 menuentry 'Memory test (memtest86+, serial console 115200)' {

~

~

~

~

~

~

~

~

(END)

 

Esetemben a kiemelt kernel lenne a vágyott alapértelmezett indításkor, így a következőkkel folytatom:

norbi@norbi-M540R:~$ sudo nano /etc/default/grub

[sudo] norbi jelszava:

 

GNU nano 2.9.3 /etc/default/grub Módosítva

 

# If you change this file, run 'update-grub' afterwards to update

# /boot/grub/grub.cfg.

# For full documentation of the options in this file, see:

# info -f grub -n 'Simple configuration'

 

GRUB_DEFAULT=3

#GRUB_TIMEOUT_STYLE=hidden

GRUB_TIMEOUT=10

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

 

# Uncomment to enable BadRAM filtering, modify to suit your needs

# This works with Linux (no patch required) and with any kernel that obtains

# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

 

# Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

[ 33 sor beolvasva ]

^G Súgó ^O Kiírás ^W Keresés ^K Kivágás ^J Sorkizárás^C Pozíció

^X Kilépés ^R Beolvasás ^\ Csere ^U Beilleszté^T Helyes-e? ^_ Ugrás sorra

 

Elviekben a 3-as szám tartozik a fentebb kijelölt 4-es sorszámú választási lehetőséghez.

 

Ezután: Ctrl+o → ENTER → Ctrl+x

 

norbi@norbi-M540R:~$ sudo grub-mkconfig -o /boot/grub/grub.cfg

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

 

A biztonság kedvéért lefuttattam a következőt is:

 

norbi@norbi-M540R:~$ sudo update-grub

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

 

Mindkét parancs ugyanazt az eredményt adja és nem látok semmi változást a kiindulási ponthoz képest. Jól van ez így?

 

norbi@norbi-M540R:~$ uname -a

Linux norbi-M540R 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:15:38 UTC 2018 i686 i686 i686 GNU/Linux

norbi@norbi-M540R:~$ inxi -S

System: Host: norbi-M540R Kernel: 4.15.0-20-generic i686 bits: 32

Desktop: Xfce 4.12.3 Distro: Linux Mint 19 Tara

norbi@norbi-M540R:~$

 

Az utolsó két parancs ugyanazt a kiemelt kernelt adja ki, amit a rendszer indításakor a GRUB Speciális beállításai közül választottam ki. Tehát látható előrelépés nincs.

 

Az etc/default/grub/, mely jónak tűnik, a következőket mutatja:

 

GRUB_DEFAULT=3

#GRUB_TIMEOUT_STYLE=hidden

GRUB_TIMEOUT=10

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

 

A boot/grub/grub.cfg a következőket mutatja, itt is megjelenik a 3-as, mint kiválasztott opció, de semmi gyakorlati haszna nincs, legalábbis nekem úgy tűnik:

 

#

# DO NOT EDIT THIS FILE

#

# It is automatically generated by grub-mkconfig using templates

# from /etc/grub.d and settings from /etc/default/grub

#

 

### BEGIN /etc/grub.d/00_header ###

if [ -s $prefix/grubenv ]; then

set have_grubenv=true

load_env

fi

if [ "${next_entry}" ] ; then

set default="${next_entry}"

set next_entry=

save_env next_entry

set boot_once=true

else

set default="3"

 

Az egész fájlt nem másoltam be, mert marha hosszú és nem fárasztanám senki szemét sem feleslegesen.

Részemről mára ennyi. Búcsúzom.

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#5

Szia!

Megpróbáltam az általad javasolt paranccsal rögzíteni az indításkor kiválasztott kernelt:

norbi@norbi-M540R:~$ sudo apt-mark hold $(uname -r)

linux-headers-4.15.0-20-generic beállítva visszatartásra.

linux-image-4.15.0-20-generic beállítva visszatartásra.

linux-modules-extra-4.15.0-20-generic beállítva visszatartásra.

linux-cloud-tools-4.15.0-20-generic beállítva visszatartásra.

linux-modules-4.15.0-20-generic beállítva visszatartásra.

linux-tools-4.15.0-20-generic beállítva visszatartásra.

norbi@norbi-M540R:~$ sudo grub-mkconfig -o /boot/grub/grub.cfg

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

norbi@norbi-M540R:~$ sudo update-grub

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

norbi@norbi-M540R:~$

Ha az általad javasolt, sudo apt-mark hold $(uname -r) parancs jól működött volna, akkor már a sudo grub-mkconfig -o /boot/grub/grub.cfg vagy a sudo update-grub parancsok valamelyike után nem ennek kellett volna megjelennie a kiemelt sor helyén, abban az esetben, ha a rendszert a 4.15.0-20-generic kernelt kiválasztva indítottam el (és elvileg ez került volna rögzítésre): Sourcing file `/etc/default/grub.d/20_linuxmint.cfg'

Egyébként melyik paranccsal tudom kiíratni terminálban az alapértelmezetten használt kernelt?

Jelen esetben ezt dobja ki az alábbi parancsok használatával, csak azt nem tudom, hogy ez az indításkori választás eredménye és csak erre a munkamenetre vonatkozik, vagy sikeresnek bizonyult a sudo apt-mark hold $(uname -r) parancs és állandósul a 20-as végű kernel:

norbi@norbi-M540R:~$ uname -r

4.15.0-20-generic

norbi@norbi-M540R:~$ uname -a

Linux norbi-M540R 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:15:38 UTC 2018 i686 i686 i686 GNU/Linux

Sajnos erősen úgy tűnik, hogy nem jött be a javaslatod, mert újraindítás után az alábbi eredmény jött ki úgy, hogy indításkor a GRUB menüben nem a Speciális beállítások közül válogattam, hanem hagytam mindent automatikusan továbbmenni, így elviekben az alapértelmezett kernellel indult a rendszer:

norbi@norbi-M540R:~$ uname -r

4.15.0-50-generic

norbi@norbi-M540R:~$ uname -a

Linux norbi-M540R 4.15.0-50-generic #54-Ubuntu SMP Mon May 6 18:45:45 UTC 2019 i686 i686 i686 GNU/Linux

norbi@norbi-M540R:~$ sudo grub-mkconfig -o /boot/grub/grub.cfg

[sudo] norbi jelszava:

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

GRUB beállítófájl előállítása…

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic

Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic

Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic

Found memtest86+ image: /boot/memtest86+.elf

Found memtest86+ image: /boot/memtest86+.bin

kész

norbi@norbi-M540R:~$

Ha minden jól ment volna, akkor úgy sejtem, hogy a kiemelt soroknak valahogy így kellene kinézniük:

4.15.0-20-generic

Linux norbi-M540R 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:15:38 UTC 2018 i686 i686 i686 GNU/Linux

Sourcing file `/etc/default/grub.d/20_linuxmint.cfg'

Értékelés: 

0
Még nincs értékelve
kimarite képe

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#8 Ez nem lesz jó:

sudo grub-mkconfig -o /boot/grub/grub.cfg

... ha a rendszer (idézem):

Rendszer: Linux Mint 19 32 bit XFCE

Magyarázat: https://linuxmint.hu/comment/27042#comment-27042

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#8 Nézd ! Tudod hogy kell egy régebbi kernellel indítani a rendszert.
A telepített kernelek közül válaszd ki a legmagasabb verziószámút amelyikkel
még kifogástalanul működik a rendszer.
Az ennél magasabb verziószámúakat pedig töröld.
Természetesen az lenne az ideális, hogyha a legutolsó verzióval sem lenne semmi probléma.
De mit érsz az újabb verziókkal, ha azokkal nem megfelelően működik a rendszer ?
Csak megjegyzem hogy nálam Mint 18.3 Cinnamon alatt semmi gond a 4.15.0-50-es kernellel.
Az ezt megelőzőkkel sem volt.
Viszont, a régi 17.3 rendszeremhez kapott utolsó 5 kernelfrissítés használhatatlannak bizonyult.
Telepítettem őket, de egyszerűen nem indult velük a rendszer. (3.13.0-166, 167, 168, 169, 170)
Töröltem őket - igy gond nélkül működik a rendszer a 3.13.0-165-ös verzióval.

 

Értékelés: 

0
Még nincs értékelve

A belinkelt videó alapján ezt sikerült összehoznom.

#7

Üdv Mindenkinek!

Amikor korábban ezt írtam:

A boot/grub/grub.cfg a következőket mutatja, itt is megjelenik a 3-as, mint kiválasztott opció, de semmi gyakorlati haszna nincs, legalábbis nekem úgy tűnik:

 

#

# DO NOT EDIT THIS FILE

#

# It is automatically generated by grub-mkconfig using templates

# from /etc/grub.d and settings from /etc/default/grub

#

 

### BEGIN /etc/grub.d/00_header ###

if [ -s $prefix/grubenv ]; then

set have_grubenv=true

load_env

fi

if [ "${next_entry}" ] ; then

set default="${next_entry}"

set next_entry=

save_env next_entry

set boot_once=true

else

set default="3"

tévedtem, nem volt hatástalan a változtatás.

Azt vettem észre, hogy a 3-as szám nem a norbi@norbi-M540R:~$ sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N parancs kiadása utáni eredményben található 4. opcióra hivatkozik (n-1.)

1 menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' 1 {

2 menuentry 'Ubuntu, Linux 4.15.0-50-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 2 .15.0-50-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

3 menuentry 'Ubuntu, with Linux 4.15.0-50-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 3 'gnulinux-4.15.0-50-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

4 menuentry 'Ubuntu, Linux 4.15.0-47-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 4 .15.0-47-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

,hanem az indításkor megjelenő GRUB menü 4. (n-1.) sorára (lehet, hogy ez csak nekem újdonság és másnak nem???):

Linux Mint 19 Xfce

Speciális beállítások ehhez: Linux Mint 19 Xfce

Memory test (memorytest86+)

Memory test (memorytest86+, serial console 115200)

A fenti tapasztalatból azt szűrtem le, remélem nem hibásan, hogy ennek a hivatkozási hibának (, ha hiba egyáltalán) valószínűleg az lehet az oka, hogy a 4. (n-1.) sorszámú kernel és a többi is a Speciális beállítások… soron belül szerepel, mint almenü. Erre utal a boot/grub/grub.cfg fájlban szereplő kifejezés: submenu 'Speciális beállítások ehhez: Ubuntu' $menuentry_id_option 'gnulinux-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

Van egy olyan sejtésem, hogy ha a kerneleket almenü mivoltukból sikerülne „főmenü” státuszba helyezni, akkor már működne a dolog, de ehhez a boot/grub/grub.cfg fájlt kellene valamilyen úton (terminálban: sudo nano boot/grub/grub.cfg/ segítségével, vagy indításkor a GRUB szerkesztésével, e gomb megnyomásával), komolyabban szerkeszteni. Ha minden jól menne és jól is gondolom, akkor a GRUB menü ezután valahogy így nézne ki és már működnének a sorszámos hivatkozások is:

Linux Mint 19 Xfce

Linux Mint 19 Xfce, Linux 4.15.0-50-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-50-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-47-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-47-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-46-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-46-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-45-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-45-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-44-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-44-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-43-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-43-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-20-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-20-generic verzióval (recovery mode)

Memory test (memorytest86+)

Memory test (memorytest86+, serial console 115200)

Ebben az esetben, ha jól gondolom, akkor, ha ez lenne látható az etc/default/grub fájlban:

GRUB_DEFAULT=3

#GRUB_TIMEOUT_STYLE=hidden

GRUB_TIMEOUT=10

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

, akkor a GRUB kiemelt sora alapján indulna a rendszer. Azt is meg merem kockáztatni, hogy a második, Linux Mint 19 Xfce, Linux 4.15.0-50-generic verzióval, sor kilőhető lenne, mert a tartalma, gyanítom, megegyezik az első, Linux Mint 19 Xfce, soréval (a boot/grub/grub.cfg fájl alapján).

Volna elképzelésem is a módosításra vonatkozóan:

Ha a gondolatmenetem nem hibás, akkor a boot/grub/grub.cfg fájlban (csak a releváns részt másoltam be) a kiemelt sorokat kellene törölni, esetleg a jelenleg almenüben lévő kerneleknél a behúzásokat csökkenteni (a menuentry szavaknál elhelyezkedőkre gondolok), valamint a lezáró }-ek helyzete is jelentőséggel bírhat:

menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

recordfail

load_video

gfxmode $linux_gfx_mode

insmod gzio

if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi

insmod part_msdos

insmod lvm

insmod ext2

set root='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW'

if [ x$feature_platform_search_hint = xy ]; then

search --no-floppy --fs-uuid --set=root --hint='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW' 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

else

search --no-floppy --fs-uuid --set=root 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

fi

linux /boot/vmlinuz-4.15.0-50-generic root=/dev/mapper/mint--vg-root ro quiet splash $vt_handoff

initrd /boot/initrd.img-4.15.0-50-generic

}

submenu 'Speciális beállítások ehhez: Ubuntu' $menuentry_id_option 'gnulinux-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

menuentry 'Ubuntu, Linux 4.15.0-50-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-50-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

recordfail

load_video

gfxmode $linux_gfx_mode

insmod gzio

if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi

insmod part_msdos

insmod lvm

insmod ext2

set root='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW'

if [ x$feature_platform_search_hint = xy ]; then

search --no-floppy --fs-uuid --set=root --hint='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW' 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

else

search --no-floppy --fs-uuid --set=root 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

fi

echo 'Linux 4.15.0-50-generic betöltése…'

linux /boot/vmlinuz-4.15.0-50-generic root=/dev/mapper/mint--vg-root ro quiet splash $vt_handoff

echo 'Kiinduló ramdisk betöltése…'

initrd /boot/initrd.img-4.15.0-50-generic

}

menuentry 'Ubuntu, with Linux 4.15.0-50-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-50-generic-recovery-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

recordfail

load_video

insmod gzio

if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi

insmod part_msdos

insmod lvm

insmod ext2

set root='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW'

if [ x$feature_platform_search_hint = xy ]; then

search --no-floppy --fs-uuid --set=root --hint='lvmid/A7lLYA-Fmld-5KJm-FPHW-8r26-7k0D-GJXP1Z/B4v47y-363Y-THNj-73LD-0EBm-y43s-ZnqotW' 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

else

search --no-floppy --fs-uuid --set=root 4af8aa9c-95e7-422c-bfb7-f30380cfeaf6

fi

echo 'Linux 4.15.0-50-generic betöltése…'

linux /boot/vmlinuz-4.15.0-50-generic root=/dev/mapper/mint--vg-root ro recovery nomodeset

echo 'Kiinduló ramdisk betöltése…'

initrd /boot/initrd.img-4.15.0-50-generic

}

menuentry 'Ubuntu, Linux 4.15.0-47-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-47-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {

Ebben az esetben a GRUB így nézne ki:

Linux Mint 19 Xfce

Linux Mint 19 Xfce, Linux 4.15.0-50-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-47-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-47-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-46-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-46-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-45-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-45-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-44-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-44-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-43-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-43-generic verzióval (recovery mode)

Linux Mint 19 Xfce, Linux 4.15.0-20-generic verzióval

Linux Mint 19 Xfce, Linux 4.15.0-20-generic verzióval (recovery mode)

Memory test (memorytest86+)

Memory test (memorytest86+, serial console 115200)

és, ha a etc/default/grub fájlban ezt látnám:

GRUB_DEFAULT=2

#GRUB_TIMEOUT_STYLE=hidden

GRUB_TIMEOUT=10

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

, akkor a GRUB 3., Linux Mint 19 Xfce, Linux 4.15.0-47-generic verzióval, sorával indulna a rendszer.

Vélemény/hozzászólás???

Értékelés: 

0
Még nincs értékelve

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#9

Sajnos tényleg nem működött, ahogy fentebb jeleztem is, pedig bíztam benne (, amikor belinkeltem a videót, írtam is), hogy nem jelent problémát a disztribúció-eltérés. A magyarázatodat majd átnézem. Mi a véleményed a #7-ben írt módosítási ötletemről?

Értékelés: 

0
Még nincs értékelve

Üdvözöllek!

#10

Tisztában vagyok vele, hogy lehet kerneleket törölni (csináltam is már ilyet korábban Ubuntunál és Mintnél is), de eddig csak régebbieket (helyfelszabadítás miatt), abban nem voltam biztos, hogy a legújabbat is lehet büntetlenül törölni (már ha korábbi használatával fut a gép az adott pillanatban), de ha nálad korábban működött, akkor már én is merek tenni vele egy próbát.

Mi a véleményed a #7-ben leírt törlési megoldásomról (bár, az általad leírtak alapján, már lehet, hogy nem is annyira fontos ilyesmiken agyalnom, mert van egyszerűbb megoldás, de azért mégis kíváncsi lennék a véleményedre, hogy mennyire beteg a gondolatom)?

Értékelés: 

0
Még nincs értékelve
kimarite képe

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#9 A jó megoldás:

-- készíts biztonsági mentést

sudo cp /etc/default/grub /etc/default/grub.ORIG

--szerkesztés (a kurzor nyilakkal lépkedsz)

sudo nano /etc/default/grub

-- az eredeti, változtatást igénylő szövegtömb (nagyjából) így néz ki:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

-- kiemeltem a változtatást

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Mentés, és kilépés a nano szövegszerkesztőből

Ctrl + O, és Enter, majd
Ctrl + X

-- a változtatás érvényesítése

sudo update-grub

... mely a rendszer újraindításkor lép életbe.

De ezzel még nem végeztél, hiszen a változtatás azt jelenti, hogy az utoljára használt kernellel lép be mindig a rendszer. Tehát egyszer azt ki kell választanod, azaz a kívánt, „régebbi” kernelt. Mindezt a GRUB betöltésekor látható „Advanced options” menüre lépve (felülről a második sor szokott lenni), és azt az Enter leütésével megnyitva teheted meg, azaz indítod a kívánt kernelt (itt ne a Recovery kifejezést tartalmazó indítást használd).

-----

De a

GRUB_DEFAULT=0

értéket is meg lehet változtatni a 0-ról röptében, ha tudod, melyiket szeretnéd (1, 2, ...), azaz a saved értéket megváltoztatni így (a „2” példa)

sudo grub-set-default 2

Kézikönyv:

man grub-set-default

Tartalom részlet:

NAME
       grub-set-default - set the saved default boot entry for GRUB

SYNOPSIS
       grub-set-default [OPTION] MENU_ENTRY

DESCRIPTION
       Set  the  default  boot  menu  entry  for  GRUB.  This requires setting
       GRUB_DEFAULT=saved in /etc/default/grub.

De a röptében változtatás előzménye, hogy így kell beállítani a sort:

GRUB_DEFAULT=saved

Ahogy írja a manual (Kézikönyv) is.

Értékelés: 

0
Még nincs értékelve

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#14

Megpróbáltam az általad felvázolt módszert, de valami miatt nem a várt eredményt hozta:

A biztonsági mentés elkészítését most kihagytam, mert már korábban megtettem (az általad javasolt pranccsal), mielőtt bármit is piszkáltam volna, ami a /etc/default/grub fájlt érinti, így már van egy teljesen érintetlen /etc/default/grub.ORIG fájlom.

1. lépésként kiírattam az aktuálisan használatban lévő kernelt (igaz erre nem tettél javaslatot, de azért tettem, hogy látható legyen számodra is, hogy nem a legújjabb, és működésképtelen 4.15.0-50-generic van használatban):

norbi@norbi-M540R:~$ uname -r
4.15.0-43-generic

2. lépésben nekiálltam a GRUB szerkesztésének:

norbi@norbi-M540R:~$ sudo nano /etc/default/grub
[sudo] norbi jelszava:              

Kiindulási állapot:

GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Jelenlegi, módosított állapot:

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

3. lépésként jött az update:

norbi@norbi-M540R:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB beállítófájl előállítása…
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin

4. lépésként jött a reboot, majd hagytam a gépet elindulni minden GRUB menüben történő kattintgatás nélkül, abban bízva, hogy majd az 1. pontban kiíratott kernellel indul, mint új alapértelmezettel.
norbi@norbi-M540R:~$ reboot

Valamit félreértettem az általad leírtakból, mert nem így történt. Rendszerindítást követően a GRUB menü megjelenésekor az első, egyúttal alapesetben indításra kijelölt, Linux Mint 19 Xfce sort hagytam kijelöltként és nem csináltam semmit, csak vártam, hogy haladjon a folyamat. A GRUB eltűnése után a következő jelent meg a képernyőn, fekete háttérben:

Hiba: diskfilter writes are not supported.

Nyomjon meg egy billentyűt a folytatáshoz...

Ezen túlmenően semmi változás, ha megjelenik a vízszintes csík, a fenti sorokkal párhuzamosan, akkor automatikusan újraindul a gép, egy idő után (,ahogy a témafelvetésben, a legelején leírtakban szerepel), ha nem jelenik meg a csík, akkor megjelenik a Mint logó, a folyamatjelző fényekkel és minden megy a maga rendjén és feláll a rendszer (mintha minden hibátlan lenne), de továbbra is a 4.15.0-50-generic kernellel.

Ezt követően visszaállítottam mindent a kiindulási pontra és újra nekifutottam a lépéseknek, csak azzal a különbséggel, hogy a reboot után nem hagytam érintetlenül a folyamat haladását, hanem a GRUB menü Speciális beállítások ehhez: Linux Mint 19 Xfce opción belül a Linux Mint 19 Xfce, Linux 4.15.0-43-generic verzióval lehetőséget választottam, abban bízva, hogy ezáltal ez kerül majd rögzítésre a jövőbeli indításokra nézvést, nem így lett (, pedig azt hittem, hogy ezzel rontottam el az első próbálkozásnál). A GRUB eltűnése után a következő jelent meg a képernyőn, fekete háttérben:

Hiba: diskfilter writes are not supported.

Linux 4.15.0-43-generic betöltése...

Kiinduló ramdisc betöltése...

Nyomjon meg egy billentyűt a folytatáshoz...

Gombleütés után betöltődik a rendszer a 4.15.0-43-generic  kernel használatával.

Összegezve: valamilyen oknál fogva (megeshet, hogy bennem van a hiba), de előrelépés nem történt, így visszaállítottam mindent a kiindulási állapotra az /etc/default/grub fájlban és továbbra is kattintgatok indításkor a GRUB fájl opciói között válogatva, ahogy eddig is.

A "röptében" történő változtatással most nem próbálkoztam, mivel erre már tettem korábban kísérletet, igaz nem az általad javasolt paranccsal (sudo grub-set-default 2), hanem a sudo nano /etc/default/grub parancs kiadásakor szerkesztettem a GRUB_DEFAULT=0 sort, eredménytelenül (,vagyis nem a kívánt eredménnyel, ugyanis nem a megfelelő sorra hivatkozott az adott sorszám az esetemben, a részleteket ebben a bejegyzésemben láthatod: A belinkelt videó alapján ezt sikerült összehoznom. Beküldte Norbi6891 - 2019. máj. 19. 17:08), van egy olyan sejtésem, hogy ez a parancs is ugyanezzel az "eredménnyel" járna (,mivel nem tudtam eddig sem a megfelelő sorra hivatkozni, a megfelelőnek tűnő sorszámmal), de ha tévedek, akkor kérlek szólj.

Értékelés: 

0
Még nincs értékelve

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#15 Nem akartam okoskodni, de az én feljegyzéseimben az /etc/default/grub fájl
ilyetén való szerkesztése:
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
Nem a betöltött kernelt, hanem az aktuálisan indított operációs rendszer indulását
"rögzíti" - elsődlegesként - multiboot rendszerek esetén.

Értékelés: 

0
Még nincs értékelve

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#16

Érdemben nem tudok hozzászólni a felvetésedhet (csak Mint van a gépemen, így még kipróbálni sem tudom ilyen tekintetben), de az tény, hogy nálam nem a várt eredményt hozta, ahogy írtam is.

Értékelés: 

0
Még nincs értékelve
kimarite képe

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#15 Ezt a fájlt megnyitva.

xdg-open /etc/grub.d/10_linux

nálad itt mi szerepel?

prefix="/usr"
exec_prefix="/usr"
datarootdir="/usr/share"
ubuntu_recovery="0"
quiet_boot="0"
quick_boot="0"
gfxpayload_dynamic="0"
vt_handoff="0"

Forrás: https://askubuntu.com/questions/468466/diskfilter-writes-are-not-support...

-----

https://youtu.be/rk8bEbmwOh0?t=2181

Értékelés: 

0
Még nincs értékelve
Salabakter képe

Szezont a fazonnal ?!?

Már ne haragudj, Norbi !

 

De minek bonyolítod konzolban a dolgot, ha van grafikus,  azaz pofon-egyszerű (pár klikkeléses) megoldás ?
Ha még nem vagy elég jártas a Linux és a bash shell mélyebb lelkivilágában, ne akarj egyszerre a mélyére szállni. Ha az a cél, hogy a problémára megoldást találj, akkor elég a megfelelő (és legegyszerűbb) megoldást megtalálni !  Nem szégyen, még egy profinak sem grafikus felületen megoldani a komolyabb rendszer-problémákat. Elvégre ezzel időt, energiát (és sok-sok hajszálat) spórolhatunk meg magunknak...

Hogy miért írtam, hogy kevered a szezont a fazonnal ?!?
Már csak azért is, mert te a /boot/grub/grub.cfg fájlt hiába szerkeszted, mert azt eleve a rendszer hozza létre az /etc/default/grub fájlból. Tehát neked ez utóbbit kell(ene) szerkesztened,  már ha feltétlenül buherálni (azaz ugyanazt 20-szor annyi melóval elérni, kvázni szívni) van kedved. Az ezt követő parancsok (pl.  sudo grub-mkconfig -o /boot/grub/grub.cfg ) pont az /etc/default/grub  fájlból generálják le a /boot/grub/grub.cfg állományt, aminek már az első pár sorában ott kiabál nagy betűkkel, hogy   #  DO NOT EDIT THIS FILE # . . .  :-(

Olvasni is kellene ezeket a kikommentezett (# elejű, esetleg # végű) szövegeket, mert nem dísznek teszik oda !!!

De  a lényeg.... Épp az előbb csináltam meg egy hasonló kernelt-törlést, mert nekem egy újabb volt aktív, és én is egy régebbit (pontosan én is a 4.15.0-50-generic kernelt) akartam meghagyni, mivel az én gépem sem éppen egymai darab, és semmi szükségem olyan kernelre, amibe bele van gyúrva egy csomó mai vas driver-e. Másrészt ez a kernel 2023. áprilisig támogatott lesz (tehát LTS /Long Term Supported = Hosszú Időtartamra Támogatott/ típusú), ellentétben a korábban aktívként használt 4.18.0-20-szal (ami csak 2019 augusztusáig).

A csere menete a következő volt:

1) A Grub menüjében a Speciális indítást választottam, majd a második (al-) menüben a 4.15.0-50 -es kernelt (minden kernelhez három típusú indítás van,  és legegyszerűbbet /legrövidebb szövegűt/ választottam).

2) A Linux Mint  (19.1) elindulása után elindítottam a Szoftverfrissítés programot (vagy konzolban sudo joggal a mintupdate -et kell futtatni).

3) Majd a megjelent ablakban a Nézet menüben a Linux kernelek   sorra kattintva elindítottam a "Kernel-varázslót"  (hehe... hogy "windózosan" fejezzem ki magam), majd a felugró ablak bal sávjában kiválasztom a kernel-családot , majd a jobb oldali, nagyobb ablakrészben megkerestem a családon belüli, konkrét számú kernelt, ami telepítve volt (elé volt írva, hogy Telepítve), majd rá klikkelve lenyílt az adott számú kernel, és a megjelenő opciók közül kiválasztottam kernel törlését.  Ekkor nyílik egy konzol, és látható, hogy lefut  egy sereg parancs. (Ezeket spóroltam meg a grafikus megoldással. És a tévedés lehetőségét is kizártam, mert ezeket helyes sorrendben elvégzi az a program, amit nálam sokkal okosabb kódolók írtak meg, majd ellenőriztek le.)

4) Nálam csak ez az egy kernel volt fölöslegben (ez volt tehát a korábban alapértelmezetten aktív). Ha a többi felesleges kerneltől is meg akarsz szabadulni, akkor a következőket tedd.

a) A 3) pont alatti törlési műveletet egyenként kell elvégezned azokkal a kernelekkel, amelyek a 4.15.0-50 utáni számozásúak. Mindegyiknél nyílik majd a konzol, és lefutnak a megfelelő utasítások.

b) Ha a 4.15.0-50 előtti (=régebbi) kerneleket is törölni akarod, akkor pedig a Kernel-ek nevű ablakban alul válaszd a Régi kernelek eltávolítása... gombot. Ekkor a megjelenő konzolban nem egy, de az összes régebbi kernelt kitörli a program. Csak az aktuális kernel marad (tehát amit a Grub-ban kiválasztottál).

 

És "voálá", így született meg Chocapic  a regebbi kerneles Linux Mint. ... Tádáááám  !  :-)
(Az egész 10 perc sem volt. És nem szenvedtem a netet bújva, esetleg a rossz angol tudásom miatt a szöveget félreértve. És még véletlenül sem cseszem szét a rendszerem a parancssor nem megfelelő alkalmazása miatt... Ne értsd félre, kérlek, mert nem azt akarom mondani, hogy a konzol az ördögtől való, kerülendő dolog. Sőt, nagyon is jó az. . . . Annak aki, türelemmel, lassacskán halad, és nem öles ugrásokkal rohan ! Legyenek erős alapok, aztán majd mehet a CLI-betyárkodás, meg a bash-scripting is, legalábbis idővel...).

Na,  minden jót,  azaz:

békesség,  "tesvírem" !  ;-)

UI.:

1) Nem árt utána egy rendszer-takarítást végeztetni pl. a Bleachbit programmal (óvatosan a használatával !),  mert elég sok felesleges fájlt benn hagy a Mint a kerneltörlések után, illetve a Szoftverfrissítés indításával is letöltődik egy csomó felesleges állomány, és ez az óvatos használatnál igen hasznol rendszer-pucoló azokat is eltávolítja.

2) Ha nem Linux Mint-et használnál (mert nekem gyanús ez a sok Ubuntus fájlnév),  akkor nem biztos, hogy a grafikus megoldás játszik majd nálad, mert ha jól tudom, ezek a Mint saját fejlesztései.

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default

#15 Még egyszer mert egyszer már leírtam.

Beállítod ezt (grub fájl):

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

Természetesen kell egy mentés:

sudo update-grub

Aztán beállítod, amelyik kernelt, azaz menü elemet szeretnéd (ez egy parancs):

sudo grub-set-default 3

Persze, kell egy rendszer újraindítás (mert logikus, hogy ekkor tudja betölteni a beállítást, röptében nem fogja):

sudo systemctl reboot

Elméletileg a 4-es menüvel, kernellel indul a rendszer.

Ellenőrzése:

uname -r

-----

Egy próbát megér így is:

GRUB_DEFAULT=saved
#GRUB_SAVEDEFAULT=true

... utána minden ugyanaz.

Értékelés: 

0
Még nincs értékelve
Salabakter képe

Még annyit, hogy ....

Még annyit, hogy előző hozzászólásommal nem a megmondóember képében akartam tetszelegni... (A hup.hu -n ennél sokkal durvább a hangnem, és kicsit ahhoz vagyok szokva, sajna. Sorry.)

A Linuxot felhasználóbaráttá tették a grafikus megoldások (legalábbis az Ubuntu és Mint vonalon).  Akkor éljünk hát velük !  Hiszen  pontosan értünk, miattunk  lettek ezek elkészítve.

Sok évnyi "win-dose"-fogyasztás után keveseknek vált a vérévé a parancssor használat, és nem bash-scriptekkel kelnek és fekszenek.
Az XP-n, Vista-n, W7-, W8- és W10-en "szocializálódott" embereknek a grafikus megoldásokkal kellene előbb tisztába kerülni, és majd csak ezt követően, apránként rákapni a konzolos megoldásokra.
Előző hozzászólásomat nyilván segíteni akarás motiválta, és nem a kritizálás.  (Ezért is írtam le pontokba szedve, részletesen, az általam használt, és nálam bevált megoldást.)

(Viszont talán kicsit  karcos lett a szövegem eleje, de ez nem neked szántam, Norbi.  Magával a konzol-használat erőltetésének jelenségével van bajom.)
Szóval senkit nem akartam megbántani, kioktatni, csesztetni. wink
Béláim az Úrban,  menjetek hát békével !  smiley

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Szezont a fazonnal ?!?

#19 (vagy konzolban sudo joggal a mintupdate -et kell futtatni).

Legközelebb próbáld meg, hogy csak így indítod:

mintupdate

és akkor bekéri a jelszót egy ablakban. Menni fog. :-)
Tán bennem van a hiba, de grafikus alkalmazást eszembe nem jutna sudo-val indítani. Amikor erre kerül a sor, lefagy a kezem. A megfogalmazás kicsit téves, nem sudo jog, hanem admin jog. Aki kezdő, nem tud még mindent. De amikor egy gyakran ismételt szót hall, nem gondolkodik: - aham, a sudo, ezt már ismerem, mindenre jó, a segítő is ezt írja, hogy használjam. És kész ...

Sok évnyi "win-dose"-fogyasztás után keveseknek vált a vérévé a parancssor használat, és nem bash-scriptekkel kelnek és fekszenek.
Az XP-n, Vista-n, W7-, W8- és W10-en "szocializálódott" embereknek a grafikus megoldásokkal kellene előbb tisztába kerülni, és majd csak ezt követően, apránként rákapni a konzolos megoldásokra.
Előző hozzászólásomat nyilván segíteni akarás motiválta, és nem a kritizálás.

A kérdező indult el a konzolban, mi mentünk utána. Az is látható, hogy grafikus megoldást is javasoltunk, de amit kihagytunk, az a Synaptic csomagkezelő :-). Az „update-grub” fogalmat mindenképpen tisztázni kellett. A segítőknek két lehetősége van. Kérdez, de olykor sok lenne egyszerre a kérdések sora, feldolgozhatatlan a kérdezőnek, így inkább vár, amíg valami megvalósul a válaszokban. És akkor továbblép a következő kérdésre. Néha az van, hogy a segítő vár valamire, egy (fontos) részletre, hátha elárulja magától a kérdező, és nem kell kitalálni. Olykor a várakozás csak remény marad ... . Különben viszonylag nehéz kérdezni, alapvető kérdésekre (nagyon ritkán) is megsértődik, bedurcul a kérdező, mit képzelünk, ezt ő már tudja. Volt olyan is, aki közölte 22 éve rendszergazda. Csak nem látszott :-). De aki rég segít fórumon, vagy netán oktatott valamilyen tantárgyat (a felnőttképzésben, ahol sok az ismeretlen ember, nem tudni az előéletüket), az tudja, az első lépés mindig a tanuló (kérdező) felkészültségének felmérése ..., mely amúgy egy jó társalgás szintjén kell történjen, mint amikor két ember barátkozik, beszélget. Van, aki gyors választ szeretne, és van aki nem gyorsat, hanem társalogna előtte, közben ... tanulna. Ezt érdemes kitalálni.

Most nézem, grafikus megoldást nem ajánlottunk, pedig a hold (csomag visszatartás) a Linux Mint Frissítéskezelőjének egyik szolgáltatása. Ez egy másik szálon ment.

-----

A kérdezőnek:

1) Arra is rá kéne nézni, hogy a visszatartott kernel mennyire biztonságos, azaz érkezett-e rá biztonsági frissítés. Ha érkezett, akkor a kiválasztott régebbi kernel használata nem ajánlott. A Frissítéskezelő vagy a Synaptic segítségével rá lehet nézni a kernel állapotára.

2) Ez (és amit még hozzátettem) nem biztos, hogy működni fog. Egy-egy fórumon olvastam hogy nem mindig működik (például Arch Linux fórum). A teljesség kedvéért az egész javaslatom bemásolom ismét. A teszt mutatja meg, hogy működik (én nem tudom kipróbálni, egy kernelt használok):

Beállítod ezt (grub fájl):

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

Természetesen kell egy mentés:

sudo update-grub

Aztán beállítod, amelyik kernelt, azaz menü elemet szeretnéd (ez egy parancs):

sudo grub-set-default 3

Persze, kell egy rendszer újraindítás (mert logikus, hogy ekkor tudja betölteni a beállítást, röptében nem fogja):

sudo systemctl reboot

Elméletileg a 4-es menüvel, kernellel indul a rendszer.

Ellenőrzése:

uname -r

-----

Egy próbát megér így is:

GRUB_DEFAULT=saved
#GRUB_SAVEDEFAULT=true

... utána minden ugyanaz.

Értékelés: 

0
Még nincs értékelve

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#18

prefix="/usr"
exec_prefix="/usr"
datarootdir="/usr/share"
ubuntu_recovery="1"
quiet_boot="1"
quick_boot="1"
gfxpayload_dynamic="1"
vt_handoff="1"

Értékelés: 

0
Még nincs értékelve
kimarite képe

!#sudo grub-mkconfig -o /boot/grub/grub.cfg

#23 Ez egy tapogatózás volt ... pár napja. Már nem lényeges igazán.

Megnézheted újra, ha megcsináltad ezt,
https://linuxmint.hu/comment/29148#comment-29148
akkor mire változik a jelenlegi tartalom.

Értékelés: 

0
Még nincs értékelve

Szezont a fazonnal ?!?

#19

Messze nem vagyok szakértője a Linuxnak és úgy általában az informatikának, hidd el nem fétisem az, hogy a lehető legbonyolultabb módon oldjam meg az e témakört érintő problémákat.

Teljes mértékben nyitott vagyok a különféle megoldási javaslatokra, azt pedig örömmel olvasom soraid közt, hogy van grafikus felületen is megoldás (eddig nem tudtam).

Lalának is volt már fentebb egy, véleményem szerint, a tiedével egyező tartalmú megoldása (https://linuxmint.hu/comment/29016#comment-29016), ami a nem megfelelő kernelek törlésére vonatkozik. Ahogy azt korábban (lala felvetésére) írtam, nem jelent problémát számomra a művelet kivitelezése, terminál használatával sem (életem már vele korábban, helyfelszabadítás miatt, de csak régebbi kernelek esetén, a legújabb, alapértelmezetten használt, meghagyása mellett: http://ubuntu.hu/node/34916#comment-402045), de abban nem voltam biztos, hogy a rendszer nem fog-e megborulni, ha a legújabb kernelt törlöm (nem tudom, hogy egy adott kernel telepítése során milyen függőségi kapcsolatok jönnek létre és milyen egyéb rendszerelemeket érintő változások mennek végbe és, hogy ezekre milyen hatással van/ van-e egyáltalán az adott kernel későbbi törlése).

Korábban Lala is megnyugtatott, hogy járható ez az út (neki bevált), most Te is megerősítetted, így egyre jobban hajlok az alkalmazására és hagyom a kínlódást (bár szívesen próbálkoztam, talán ragadt is rám valami közben és egy kicsit jobban megismertem a Linux világát), esetleg még náhány próba belefér, a javaslataitok alapján.

Egyébként esetemben Linux Mint 19 Xfce-ről van szó, mely tudtommal közeli rokonságban van az Ubuntuval (korábban Ubuntu 14.04 LTS volt a gépen és ezt váltotta le).

Béke!

Értékelés: 

0
Még nincs értékelve

grub-set-default

#20

Megpróbálom a javaslatodat, de még mielőtt megtenném, rákérdeznék a következőre.

Ahogy már korábban is jeleztem (https://linuxmint.hu/comment/29017#comment-29017), vannak problémáim azzal kapcsolatban, hogy a GRUB_DEFAULT= sorban az = után írt szám nem a kívánt eredményt hozza, a megoldásodban szereplő sudo grub-set-default 3 sorban nem állna fenn ugyanez a probléma??? Csak azért kérdezem, mert ha igazam van és itt is ugyanazt az eredményt hozná, akkor esetemben a Linux 4.15.0-47-generic helyett a Memory test (memorytest86+, serial console 115200) lenne a kiválasztott opció, ami nem igazán mondanám, hogy kívánatos számomra.

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#26 n - 1 a sorszám (*.cfg), amit kiválasztasz. A *.cfg-s sorszám, minusz 1. Ha a *.cfg-s sorszám 4, akkor 3.
Akárhol alkalmazod. A grub fájlban vagy a parancsban.

Amit te elképzelsz annak ez a beállítása (részlet):

GRUB_DEFAULT=3
#GRUB_SAVEDEFAULT=true

-----

Ez az én elképzelésem, ne keverd a másikkal, a tieddel

a megoldásodban szereplő sudo grub-set-default 3 sorban nem állna fenn ugyanez a probléma

Kicsit gondolkozz! Ez egy konzolban futtatandó parancs. Én nem sort írtam, azt is persze, a fenti parancshoz tartozó beállításokat ..., stb.. A beállítások a parancs előzménye! És ezen parancs előtt van az update-grub parancs. Nem szoktál jegyzetelni, mondjuk *.txt fájlba?
Nem tudom, mi történne a te elképzelésednél és az enyémnél. Pár perc kipróbálni egyiket és a másikat is.
Egyelőre máshol járunk. Tekintve, hogy a kernel paramétereket nem sikerül alkalmazni. ;-)

Megpróbálom a javaslatodat

Amit én elképzelek, azt már háromszor-négyszer leírtam. Íme, még egyszer:

Beállítod ezt (grub fájl):

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

Természetesen kell egy mentés:

sudo update-grub

Aztán beállítod, amelyik kernelt, azaz menü elemet szeretnéd (ez egy parancs):

sudo grub-set-default 3

Persze, kell egy rendszer újraindítás (mert logikus, hogy ekkor tudja betölteni a beállítást, röptében nem fogja):

sudo systemctl reboot

Elméletileg a 4-es menüvel, kernellel indul a rendszer.

Ellenőrzése:

uname -r

Még valami

Egy próbát megér így is:

GRUB_DEFAULT=saved
#GRUB_SAVEDEFAULT=true

... utána minden (teendő) ugyanaz.

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

Vakon követtem az általad leírtakat, remélem nem hibáztam el semmit és mindent a kívánt módon tettem.

Íme az eredmény részleteiben:

norbi@norbi-M540R:~$ sudo nano /etc/default/grub
[sudo] norbi jelszava:   

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

           
norbi@norbi-M540R:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB beállítófájl előállítása…
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
kész
norbi@norbi-M540R:~$ sudo grub-set-default 3
norbi@norbi-M540R:~$ sudo systemctl reboot

Gyönyörűen lefutott a Memory test, ahogy azt korábban sejtettem (https://linuxmint.hu/comment/29179#comment-29179), mindazonáltal nem vonom kétségbe a gondolatmeneted helyességét (biztos vagyok benne, hogy sokkalta jártasabb vagy a témában, mint én, ezt bizony nem nehéz, a tudásomat ismerve), de a gyakorlati eredmények valahogy mintha engem igazolnának jelen esetben, már ha jól látom.

Vélemény?

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#27

Megpróbáltam a másik módszert is, az alábbiaktól eltekintve minden ugyanúgy csináltam, mint a másik lehetőségnél, így a többit nem másolom be újra:

GRUB_DEFAULT=saved
#GRUB_SAVEDEFAULT=true
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Sajnos a végeredmény ugyanaz.

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#28 Értem. Hát nem minden esetben működik, ezzel nem tudunk mit tenni. Akkor marad ez a lehetőség:

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

A grub fájl szerkesztése és mentése után:

sudo update-grub
sudo systemctl reboot

Majd az indításnál, a GRUB megjelenésekor kiválasztod a neked tetsző kernelt, azzal belépsz a rendszerbe. A továbbiakban, minden indításnál mindig ez a kernel lesz használva, ezzel lép be a rendszer. Mármint, ha valamikor az időben más kernellel lépsz be, az lesz az alapértelmezett.

Az ellenőrzés:

uname -a

#29 Sajnos a végeredmény ugyanaz.

Elég furán fogalmazol, nem látom a sort ahol beírtad volna a 3-as számot. De elhiszem.

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#30

Üdv!

Az alábbiakat sikerült összehoznom, a legutóbbi javaslatod alapján:

norbi@norbi-M540R:~$ sudo nano /etc/default/grub
[sudo] norbi jelszava:  

GRUB_DEFAULT=saved
GRUB_DEFAULT=true

#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Ctrl+o Enter Ctrl+x

norbi@norbi-M540R:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB beállítófájl előállítása…
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
kész
norbi@norbi-M540R:~$ sudo systemctl reboot

Újraindul a gép és megjelenik a GRUB, itt:

Speciális beállítások ehhez: Linux Mint 19 Xfce

, majd:

Linux Mint 19 Xfce, Linux 4.15.0-44-generic verzióval

Feláll a rendszer, ezután Terminál ismét:

norbi@norbi-M540R:~$ uname -a
Linux norbi-M540R 4.15.0-44-generic #47-Ubuntu SMP Mon Jan 14 11:29:30 UTC 2019 i686 i686 i686 GNU/Linux

norbi@norbi-M540R:~$ reboot

Újraindul a gép és megjelenik a GRUB, itt nem nyomkodok semmit, csak hagyom, hogy minden menjen a maga útján:

Linux Mint 19 Xfce

Feláll a rendszer, ezután Terminál ismét:

norbi@norbi-M540R:~$ uname -a
Linux norbi-M540R 4.15.0-50-generic #54-Ubuntu SMP Mon May 6 18:45:45 UTC 2019 i686 i686 i686 GNU/Linux

Valahogy még mindig nem az igazi, remélem nem én hibáztam.

 

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#31 Ez akkor azt jelenti hogy a legújabb 4.15.0-50-generic kernellel is feláll a rendszer - és minden OK ?

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#30

A hozzászólásomat (https://linuxmint.hu/comment/29199#comment-29199) nem akartam túlnyújtani feleslegesen, mert Te is azt írtad, hogy "... utána minden (teendő) ugyanaz" (https://linuxmint.hu/comment/29180#comment-29180), így én sem akartam mindent megismételni, de akkor most megteszem, és leírom, hogy mit tettem (remélem jól értelmeztem az instrukciókat és nem hibáztam) pontról-pontra:

norbi@norbi-M540R:~$ sudo nano /etc/default/grub
[sudo] norbi jelszava:              
GRUB_DEFAULT=saved
#GRUB_DEFAULT=true

#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Ctrl+o Enter Ctrl+x

norbi@norbi-M540R:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB beállítófájl előállítása…
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
kész
norbi@norbi-M540R:~$ sudo grub-set-default 3
norbi@norbi-M540R:~$ sudo systemctl reboot

Újraindul a gép és megjelenik a GRUB, de sajna már itt látom, hogy nem lesz jó, mert a 4., Memory test (memorytest86+, serial console 115200) sor van kiemelve, jelezve, hogy ő kerül indításra, ha nem avatkozom be.

Összegezve ebből is kiderül, hogy nem a 3-as a szerencseszámom, mivel ebben az esetben is a sudo grub-set-default 3 sorban a 3-as nem a korábban használt (https://linuxmint.hu/comment/29005#comment-29005sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N  parancs (számomra érdekes módon most már nem dob ki semmilyen eredményt, csak ezt látom a Terminálban: sudo grep 'menuentry '" /boot/grub/grub.cfg | less-N
>) kimenetében szereplő 4. (4 menuentry 'Ubuntu, Linux 4.15.0-47-generic verzióval' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4 4 .15.0-47-generic-advanced-4af8aa9c-95e7-422c-bfb7-f30380cfeaf6' {) sorra hivatkozik az én esetmeben, hanem a GRUB 4., , Memory test (memorytest86+, serial console 115200) sorára, ahogy ezt már korábban is jeleztem.

 

 

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#32

Sajnos nem.

Legalábbis nem hiszem, hogy csoda történt volna (most csak 1x indítottam újra), mivel eddig is szeszélyes volt a lelkem (, ahogy a témaindítóban is írtam a 4.15.0-48-ra, illetve itt: https://linuxmint.hu/comment/28976#comment-28976 a 4.15.0-50-re vonatkozóan), ha úgy tartotta a kedve, akkor hibátlanul indult (ez volt a legritkább), többnyire csak feketeség volt az említett vízszintes csíkkal, melyet, szerencsés esetben, egy automatikus újraindulást követő rendszerfelállás vagy egy újabb csíkos feketeség követett és még egy újraindulás és harmadjára már általában OK volt, vagy rosszabb esetben erőszakoskodnom kellett már az első feketeség-csík kombónál (mivel nem történt semmi, automatikus újraindulás sem) és CTRL+ALT+ PRT SC+REISUB-ot nyomnom, nem ritkán resetet.

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#31 Mi most ennek a parancsnak a kimenete?

cat /etc/default/grub | grep GRUB

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#33 Összegezzünk. De inkább jól, mint rosszul.

Összegezve ebből is kiderül, hogy nem a 3-as a szerencseszámom, mivel ebben az esetben is a sudo grub-set-default 3 sorban a 3-as nem a korábban használt (https://linuxmint.hu/comment/29005#comment-29005)

Hiba: sudo grub-set-default 3 sorban

Felejtsd már el, hogy „sor”. Nem sor, hanem parancs. Írtam már. Aki nézi az írásaid, és csinálná ugyanezt ... jól bekevered.

sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N  parancs (számomra érdekes módon most már nem dob ki semmilyen eredményt, csak ezt látom a Terminálban: sudo grep 'menuentry '" /boot/grub/grub.cfg | less-N

Vajon miért nem jó ez a parancs?

sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N

Valamikor mentetted az egész mondatot, de csak nem ezt futtatod, az biztos. Mert hibás. Ezt kapod, ha futtatod:

>

... kacsacsőr.

Több helyen is láttam már tőled.

Rövid magyarázatokkal a hibákról:

-- Első ránézésre: hiányzik egy macskaköröm. Második ránézés: sok, azaz macskaköröm halmozás. Ez (itt, ebben a parancsban) nem kell: ". Csak a keresendő kifejezés után van, de pótolja ez a '. Úgyhogy, felesleges a ", és halmozásról beszélünk.

sudo grep 'menuentry '" /boot/grub/grub.cfg | less -N

... van macskád? :-)

-- leszedve a felesleget, a következő a felesleges szóköz a menuentry után, a macskarészecske előtt

sudo grep 'menuentry ' /boot/grub/grub.cfg | less -N

-- leszedve a felesleget, minek neked a találatok visszafelé történő felsorolása? A less parancs N kapcsolója ezt csinálja (kézikönyv: man less).

sudo grep 'menuentry' /boot/grub/grub.cfg | less -N

-----

-- leszedve a felesleget, marad a használandó parancs. Íme:

sudo grep 'menuentry' /boot/grub/grub.cfg | less

Egyébként egy macskaalkatrész (' vagy ") sem kell, mert azt, a miaumiau-kat csak akkor érdemes használni, ha a keresett kifejezés szóközt tartalmaz. A menuentry nem tartalmaz szóközt. Akkor a ' nélkül:

sudo grep menuentry /boot/grub/grub.cfg | less

A less parancs a lapozhatósághoz kell (kilépés a szöveg végére érve: Q).
Ha nem lapoznál, hanem egészben néznéd ( keresés találatait):

sudo grep menuentry /boot/grub/grub.cfg

Értékelés: 

0
Még nincs értékelve
Salabakter képe

Kimarite-nek és Norbinak.

@kimarite

Igen, a mintupdate-et akár hol indítjuk is el (menüből vagy konzolból), egy kis felugró ablakocskában bekéri az admin jelszót. És ugyanazt a megoldást adja, mint a sudo mintupdate parancs konzolból, csak nyilván annyi a difi, hogy nekem a konzolban kell megadjam a jelszót, és ezt követően jelenik meg a Szoftverfrissítés (alias mintupdate) ablaka. Ez csak ízlés kérdése, tehát teljesen mindegy, hogy ki melyiket alkalmazza. Én eleve a konzolban szoktam lenni, mert több mindent használok ott, pl. az mc-t. Akkor meg miért ne használlam a sudo-t ? 

Igen a hivatalos megfogalmazás az emelt szintű futtatásra az admin jogosultság, viszont a sudo, csoport név is, ami jól körülhatárolható (default) jogokkal rendelkezik, tehát ha a sodu jogot említenek, akkor talán -- ha nem is a leghelyesebb a szóhasználat -- a tartalmi része teljesen releváns, azaz tökéletesen megfelel az admin / rendszergazdai jogosultság kifejezésére. (Általános használatra én sem javasolnám, de ha gy fogalmaz valaki, azzal sosem vittek vakvágányra.) ... Ha meg valaki nincs tisztában az egyes csoportok jogosultságával, akkor meg érdemes  kicsit utánaolvasni, mert csinálhat nagy gebaszokat. (A hup.hu van egy srác, akinek az aláírása valami ilyesmi, erősen szabadon idézve:  "A Linux nem ingyenes, meg kell fizetni a tanulópénzt /a hibáinkon keresztül/.".  Na, ezt fizetik meg a túl türelmetlen, csak Ctrl+C majd Ctrl+V -vel a konzolban operáló kezdők. És pont ezért rtam, hogy a grafikus megoldást javaslom, mert bár abból valóban nem tanul semmit a rendszer mélyebb működéséből, viszont elrontani sem lehet vele, mert /ha csak nem hibás az oprendszer idevonatkozó kódr-részlete, ami azért eléggé ritka/ az automatikusan kezeli a függőségeket, ütközéseket, és mindent az adott rendszerre optimalizál általában.

És azért is ezt javaslom, mert az embereknek ritkán van idejük a rendszer mélyén turkászva naphosszat fórumokból kiszedni a lényeges infókat, majd azokat még kipróbálni, esetleg ha nem jó újra próbálkozni, ha mégannál is rosszab az eredmény, akkor meg helyrehozni a hibát... A legtöbben csak használni akarják probléma-mentesen a Mintet (vagy más disztrót), és nem igazán érteni, vagy saját megoldásokkal a mélységeit is átszabni. A legtöbben megelégszenek a felhasználói fiók kinézetének ésalapviselkedésének a beállításaival, és úgy hiszem ez így is van jól. A grafikus beállítás során elég nehéz hazavágni a rendszert...
Természetesen érthető, hogy ha a kérdező (Norbi) konzolos/parancssoros megoldásra kérdezett rá, akkor ott próbál a fórum segteni.

Kb. 15 éve kezdtem Linuxot használni, de csak az utóbbi 6-8 éveben kezdtem magam beásni kicsit  mélyebbre, viszont most sem erőltetm a konzolos megoldásokat. Főleg ott, ahol a célprogramok pofonegyszerű grafikus felületen is használhatók. Szeretem a gyors, de használható megoldásokat. (Na, meg ha valamihez nem értek eléggé, és hát elég sok ilyen akad, ráadásul épp időm sincs komolyabban utánaolvasni, akkor megváltás a grafikus felületes megoldás.)

@ Norbi

OK, a te döntésed, melyiket használod. Egyik sem jobb vagy rosszabb, mint a másik, csak másabb. Az általam javasolttal nem fogsz tanulni, és megérteni sem fogod a Linux vagy a Mint mélyebb működésének idevonatkozó részét. De gyorsan és problémamentesen jutsz megoldáshoz. Ha viszont az eredeti elképzelésed mellett döntesz, akkor ahogy eddig is, veszed a fáradtságot, és több megoldást kipróbálsz /természetesen csak előzetes rendszermentés után/. Az így szerzett tudást később is hasznosíthatod majd, akár még te is segíthetsz majd vele másoknak. Viszont ez az "ösvény" jóval nehezebb, és szokszor a "szopó-faktor" sem elhanyagolható mértékű.

 

Értékelés: 

0
Még nincs értékelve
keraform képe

Ezért!

#37 "Akkor meg miért ne használlam a sudo-t ?"
Ha majd egyszer úgy jársz, hogy bejelentkezéskor, miután beírtad a jelszavadat, ahelyett, hogy elfogadná a rendszered, visszadob a bejelentkezési ablakba, akkor jusson eszedbe ez a figyelmeztetés: grafikus (ablakkal rendelkező) alkalmazást soha nem indítunk sudo-val. Keress rá a login loop, és az Xauthority kifejezésekre.
De hogy ne kelljen keresned: http://ubuntu.hu/node/41576

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#35

norbi@norbi-M540R:~$ cat /etc/default/grub | grep GRUB
GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
#GRUB_TERMINAL=console
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true
#GRUB_DISABLE_RECOVERY="true"
#GRUB_INIT_TUNE="480 440 1"
norbi@norbi-M540R:~$

 

Értékelés: 

0
Még nincs értékelve

Ezért!

#38 Szerencsésebb lenne a pkexec használata

Értékelés: 

0
Még nincs értékelve
keraform képe

Ezért!

#40
Igen, én most nem is a gksu-t ajánlottam, csak egy esetleírást. Volt egy ilyen blogom: https://linuxmint.hu/blog/2018/06/gksu-helyett-pkexec-helyett-gksu

Amúgy én igazából nem használom egyiket sem. Én alapvetően grafikusan oldok meg mindent, amit csak lehet.
Jobb-klikk az etc mappán > Megnyitás rendszergazdaként, és már szerkeszthető is az fstab.
Ez sokkal gyorsabb is mint terminált nyitni, meg gépelni.

Értékelés: 

0
Még nincs értékelve

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#36

Bocs a helytelen szóhasználatért, gondolom, hogy aki járatosabb eme témában, annak piszkosul zavaró (és rávágna a kezemre, mikor bepötyögöm), de én még messze nem értem el ezt a szintet (ez szerintem eddig is meglehetősen nyilvánvaló volt), így nekem fel sem tűnik ez a halálos bűn. Azt nem ígérem meg, hogy többé nem fordul elő, de igyekszem mellőzni, ha mégis kiszúrnád a jövőben, úgy vállalom a jogos kokikat és körmösöket.
Egyébként a parancssorról, esetleg karaktersorról mi a véleményed (nem a hangulatot akarom fokozni, csak úgy poénból kérdezem), az helyénvaló lenne ez esetben (talán kiegyezhetnénk egy döntetlenben, Te az elejét, én a végét tenném hozzá és félúton találkoznánk, kezdetnek ez is elég jónak tűnik).

Azoknak akik figyelemmel kísérik a témához kapcsolódó társalgást és ennek hatására változtatni kívánnak a saját rendszerükön:

Nyomatékosan megkérek mindenkit, amikor az én soraimat olvassa (és itt tényleg a sorokról van szó, melyek nyomokban parancsokat is tartalmaznak), soha senki ne az én irományaim alapján próbálkozzon, csak és kizárólag az azokra érkezett válaszokra, hozzászólásokra hagyatkozzon. Én a mindent kipróbáló, felelőtlen, de lelkes és szorgalmas Hülyegyerek (gyilkos kombináció) szerepét töltöm be itt és nem a dörzsölt, tapasztalt rókákét, akiket követni érdemes.

Ami a problémás parancsot illeti, tényleg rosszul sikerült kiadnom és macskaköröm-probléma áll a háttérben, ahogy leírtad.
Helyesen így nézett ki és működött is korábban:
sudo grep "menuentry '" /boot/grub/grub.cfg | less -N

Alig észrevehető (egy hozzám hasonló, tapasztalatlan emberke számára egyáltalán nem szembetűnő) az eltérés ('/"), de a kacsa, vagy inkább a pingvin csőre tátva maradt tőle.
Egyébként nem magamtól fabrikáltam a parancsot (, ilyen gaztettre nem vetemednék), hanem innen lestem: https://www.youtube.com/watch?v=prHDES9XmjU
, ahogy azt korábban már megosztottam a nagyérdeművel, ebből kifolyólag a tartalmáért és a hosszáért felelőssége nem vállalok, viszont köszönöm, hogy ilyen részletesen kifejetted, hogy mi micsoda, ennyivel is okosabb lettem.

Kipróbáltam a sudo grep menuentry /boot/grub/grub.cfg parancsot és működik, mondjuk annyi eltérést elsőre is észrevettem, hogy a menuentry-ket nem sorszámozza be, ilyesmiről Te is írtál (-N kapcsoló), de ha így írom be: sudo grep menuentry /boot/grub/grub.cfg | less -N , akkor már számozza is őket, praktikus lehet, ha valaki nem akar számolgatni, amikor a sudo grub-set-default X parancsot kívánja kiadni és az X helyére keresi a megfelelő számot, akkor könnyebb dolga lehet (csak egyet kell belőlük kivonni és már meg is van az X értéke, pl. 4-1=3), de ugyanígy használható a sudo nano /etc/default/grub parancs kiadását követően a GRUB_DEFAULT=X sorban az X helyén lévő megfelelő sorszám megtalálására. (Ezek a sorok nem igazán Neked szólnak, inkább azoknak, akik hozzám hasonló problémával küzdenek és ennek megoldása céljából bönkészik a fórum sorait. Remélem egyértelműen fogalmaztam, nem vezetem senkit félre és a szóhasználat is OK.)

Ami a macskákat illeti: van kettő állandó jelleggel, az udvaron, néha 1-2 kóbor pormacska feltűnik a házban, de őket kiebrudalom, ami a szobacicákat illeti... (inkább befejezem, mert nagyon beteg kezd lenni).

Értékelés: 

0
Még nincs értékelve

Kimarite-nek és Norbinak.

#37

Az első hozzászólásodra (https://linuxmint.hu/comment/29147#comment-29147) küldött reagálásomból kimaradt:

Teljesen igazad van, hiányosan fogalmaztam, amikor a /boot/grub/grub.cfg fálj "szerkesztéséről" írtam, én is valamilyen közvetett módszerre gondoltam és nem direktre. A kikommentezett sorokat is elolvastam (ennyi még nem fogott ki az angoltudásomon, mert olyan sok IT-s szakszó nem volt benne), így tudom, hogy egy generált fájl volt előttem, melyet nem ajánlott szerkeszteni, de ez még nem tántorított el attól, hogy a fenti gondolatot megszüljem (mondhatom azt is, hogy az elméleti tudás hiánya határtalansággal lát el az eszementebbnél eszementebb gondolatok megalkotása terén), de azért rákérdeztem az életképességére, ez azért értékelendő szerintem.

A 2. hozzászólásodra (https://linuxmint.hu/comment/29149#comment-29149):

Bocs a megkésett válaszért, nem azért csúsztam ennyit, mert megharagudtam (bírom a strapát, nyugi).

Ahogy már kifejtettem, nekem sem létfontosságú, hogy paracsok gépelgetésével oldjam meg a problémát, egyelőre úgy gondolom, hogy még pár napot (amig ki nem derítem pontosan, hogy melyik kernel életképes, 3-4 napot használom őket egymás után, sorban haladva) "eljátszadozgatok" így, és ha addig nem sikerül zöldágra vergődni, akkor a Te, vagy egy ahhoz nagyon hasonló megoldás (írta róla) alapján járok el, aztán lesz, ami lesz.

A 3. kommentedre (https://linuxmint.hu/comment/29246#comment-29246):

Ahogy írtam, némi szopókázás most belefér, egy kicsit kínzom magam, attól meg nagyon nem félek, hogy nagyon megborítok valamit, mert a helyzet az, hogy simán belefér akár egy totális legyalulás és újratelepítés, ezt is megengedhetem magamnak (sokan nincsenek ilyen "szerencsés" helyzetben).

 

Béke!

Értékelés: 

0
Még nincs értékelve

Szezont a fazonnal ?!?

#22

Ezzel még "adós voltam" korábbról.

Csekkoltam a kerneleket az eredmény a következő:

Frissítéskezelő esetén (Frissítéskezelő->Nézet->Linux kernelek->Folytatás):

Minden telepítettnél (4.15.0-20, 4.15.0-43, 4.15.0-44, 4.15.0-45, 4.15.0-46, 4.15.0-47) a Superseded szó szerepel (, ha jól sejtem ez OK, mivel egyikük sem a legújabb és ez erre utal), kivéve a legújabb 4.15.0-50-est, amely 2023 áprilisig támogatott.

Synaptic esetén (Synaptic->Keresés mezőbe beríom: 4.15.0->1. Á feliratú oszlopnál az Á-ra katt, így a telepítetek kerülnek felülre /zöld négyzet):

A Telepített verzió és a Legfrissebb verzió oszlopokban a telepített kernelek mellett ugyanazt a verziószámot látom mendenütt (4.15.0-20, 4.15.0-43, 4.15.0-44, 4.15.0-45, 4.15.0-46, 4.15.0-47, 4.15.0-48, 4.15.0-50), így OK-nak tűnik minden.

Egy gyors kérdést azért feltennék, az hogy lehet, hogy itt (Synaptic) szerepel a 4.15.0-48-as, amitől már korábban megváltam (ily módon: http://ubuntu.hu/node/34916#comment-402045), viszont a Frissítéskezelőben nem szerepel telepítettként és amikor korábban (az eltávolítását követően bármikor) kiadtam a sudo-update-grub parancsot akkor sem tűnt fel a kimenetében:

norbi@norbi-M540R:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB beállítófájl előállítása…
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-50-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-50-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-47-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-47-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-46-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-46-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-45-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-45-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-44-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-44-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-43-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-43-generic
Megtalált linux lemezkép: /boot/vmlinuz-4.15.0-20-generic
Megtalált initrd lemezkép: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
kész

Értékelés: 

0
Még nincs értékelve

Szezont a fazonnal ?!?.

#44 Ha eltávolítasz a rendszerből programot / csomagot akkor érdemes kiadni utánna a:
sudo apt autoremove
parancsot. Ez eltávolít(hat) olyan függőségeket is, amelyeket a remove, purge bent hagy.
Add ki a parancsot, - és valószínű az 4.15.0-48-as, kernel maradékát is eltávolítja.
Ha a Frissítéskezelő -> Nézet -> Linux kernelek grafikus felületen távolítasz el kernelt,
az eltávolítja maradéktalanul.

Értékelés: 

0
Még nincs értékelve

Szezont a fazonnal ?!?.

#45

Köszönöm!

Kipróbáltam a parancsot (pontosabban csak elkezdtem és megszakítottam a végén):

norbi@norbi-M540R:~$ sudo apt autoremove
[sudo] norbi jelszava:              
Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
Az alábbi csomagok el lesznek TÁVOLÍTVA:
  linux-headers-4.15.0-43 linux-headers-4.15.0-43-generic
  linux-headers-4.15.0-44 linux-headers-4.15.0-44-generic
  linux-headers-4.15.0-45 linux-headers-4.15.0-45-generic
  linux-headers-4.15.0-46 linux-headers-4.15.0-46-generic
  linux-image-4.15.0-43-generic linux-image-4.15.0-44-generic
  linux-image-4.15.0-45-generic linux-image-4.15.0-46-generic
  linux-modules-4.15.0-43-generic linux-modules-4.15.0-44-generic
  linux-modules-4.15.0-45-generic linux-modules-4.15.0-46-generic
  linux-modules-extra-4.15.0-43-generic linux-modules-extra-4.15.0-44-generic
  linux-modules-extra-4.15.0-45-generic linux-modules-extra-4.15.0-46-generic
0 frissített, 0 újonnan telepített, 20 eltávolítandó és 0 nem frissített.
A művelet után 1.013 MB lemezterület szabadul fel.

Számomra úgy tűnt, hogy nem csak a 4.15.0-48-ast, vagy inkább pont azt nem, távolítaná el, hanem a számomra hasznos és jelenleg is használt (épp a 4.15.0-44-essel használom a gépet) kerneleket (4.15.0-43, 4.15.0-44, 4.15.0-45, 4.15.0-46) vagy legalábbis azok egyes elemeit, így az n billentyűt választottam végül az y helyett.

Nem kellene valamilyen formában az adott kernelre hivatkoznom a parancs kiadása során (, bár akkor miért auto az automemove, ebben az esetben, paraszti ésszel /IT-s fejjel még nem megy/ gondolkodva valahogy így kellene kinéznie: sudo apt remove 4.15.0-48 vagy valami hasonló - ezt nehogy kipróbálja valaki, ez csak az én beteg elmém szüleménye!!!).

Majd a Frissítéskezelőt használom (, de még várok, mert lesz több is: 4.15.0-50-es biztos, de ha jól emlékszem a 4.15.0-46-os is gázos volt korábban), ha úgy adódik.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Kimarite-nek és Norbinak.

#37 Írtam korábbab bővebb választ, de meg kellett szakítanom az elküldését.
A többiek írták a veszélyeket, és most röviden fogalmazva és ezzel is egyetértve,

"A Linux nem ingyenes, meg kell fizetni a tanulópénzt /a hibáinkon keresztül/."

így fogalmazom meg (a többiek után szabadon) az intelmet:

  •     grafikus alkalmazások indításánál a sudo használata veszélyes is lehet.

Tehát nem biztos hogy tégla esik a fejedre az életben valaha is. De, ha én olyan tanácsot adok neked, hogy megnő ennek az esélye, akkor nyilván én leszek a hibás, ha egyszer mégis bekövetkezik a baleset. Te most olyan tanácsot adtál, ami akár kellemetlen következménnyel is járhat. Én pedig ajánlottam egy hasonlóan egyszerűt, veszélytelent, és sudo nélkülit.

Értékelés: 

0
Még nincs értékelve
keraform képe

apt-get

apt-get autoremove
apt-get clean
apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get autoremove --purge <package_name>
apt-get update && apt-get dist-upgrade -yqq
stb.
Na, most tegye fel a kezét, aki tudja, hogy mit ebédelt. Mert én már nem emlékszem. Már elmúlt 19 óra.
Arra meg pláne nem emlékszem, hogy a fentiek közül melyik mit csinál. De nem is érdekel. Az nem normális, hogy ilyen sormintákat kelljen bemagolnia, és begépelnie az embernek, hogy üzemeltesse a számítógépét.
Nem szeretnék senkit megbántani, de aki a fentieket érti, az nem normális!
A normális ember ugyanis nem érti ezeket. Én legalább is nem ismerek egyetlen embert sem személyesen, akinek csak halvány sejtelme is lenne ezekről. Kimarite biztosan tudja, de őt meg nem ismerem. laugh

És azt látom a különböző fórumokon, hogy egyes emberek teli tüdővel ajánlják egyik, vagy másik parancsot, azután másvalakik kijavítják őket. Én nem szívesen használom ezeket, mert nem tudom pontosan, hogy melyik mit csinál. Néha van olyan, hogy egy terminálból történő telepítéskor megkér arra a terminál, hogy adjam ki az apt-get autoremove parancsot, ezt meg szoktam tenni neki. De nem értem, miért nem teszi meg "ő".
Ha régi kernelt akarok eltávolítani, (nem szoktam, elfér) akkor a Frissítéskezelő segítségét kérem ehhez. Ha telepítek, vagy eltávolítok, arra meg a Synapticot kérem meg.
Minden tiszteletem azoké, akik most hülyének tartanak.

Értékelés: 

0
Még nincs értékelve

Szezont a fazonnal ?!?.

#46 Háát, - nem tudom - de ezek szerint valami nem kerek nálad a kernelekkel.
Én nyugodtan kiadhatom az autoremove parancsot - nálam nem akar kernelt eltávolítani.
Esetleg csak abban az esetben, ha a kernel valamelyik összetevője már előzőleg
eltávolításra került,
A régebbi kernelek - a 4.15-ös is - 3 összetevőből állnak: (Az újabbak már 4-ből)
- Linux-heaers-4.15.x-xxx
- Linux-heaers-4.15.x-xxx-generic
- Linux-image-4.15.x-xxx-generic
Nézd meg a Synaptic-ban hogy az autoremove által eltávolításra felsorólt kerneleknek
megvan-e ez a 3 összetevője !?

Értékelés: 

0
Még nincs értékelve
kimarite képe

grub-set-default 3 | GRUB_DEFAULT=3 (nem ugyanaz)

#28 Most kéne egy új (az N paraméter sorszámoz valóban):

sudo grep "menuentry '" /boot/grub/grub.cfg | less -N

Ha az általad használt parancs fut le, az első sor is beleszámíthat a menübe természetesen:

      1 menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-75b      1 066d4-ffa5-4e5c-a77b-cee151ac284f' {

De nem teljes a kimeneted. Ez meglehetősen gyér (régebbi):
https://linuxmint.hu/comment/29017#comment-29017

Nálam most ilyen a kimenet:

      1 menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-75b      1 066d4-ffa5-4e5c-a77b-cee151ac284f' {
      2         menuentry 'Debian GNU/Linux, Linux 5.0.0-19.1-liquorix-amd64 verzióval' --class debian --class gnu-linux --class gnu -      2 -class os $menuentry_id_option 'gnulinux-5.0.0-19.1-liquorix-amd64-advanced-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      3         menuentry 'Debian GNU/Linux, with Linux 5.0.0-19.1-liquorix-amd64 (recovery mode)' --class debian --class gnu-linux --      3 class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-19.1-liquorix-amd64-recovery-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      4         menuentry 'Debian GNU/Linux, Linux 5.0.0-18.1-liquorix-amd64 verzióval' --class debian --class gnu-linux --class gnu -      4 -class os $menuentry_id_option 'gnulinux-5.0.0-18.1-liquorix-amd64-advanced-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      5         menuentry 'Debian GNU/Linux, with Linux 5.0.0-18.1-liquorix-amd64 (recovery mode)' --class debian --class gnu-linux --      5 class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-18.1-liquorix-amd64-recovery-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      6         menuentry 'Debian GNU/Linux, Linux 4.19.0-0.bpo.5-rt-amd64 verzióval' --class debian --class gnu-linux --class gnu --c      6 lass os $menuentry_id_option 'gnulinux-4.19.0-0.bpo.5-rt-amd64-advanced-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      7         menuentry 'Debian GNU/Linux, with Linux 4.19.0-0.bpo.5-rt-amd64 (recovery mode)' --class debian --class gnu-linux --cl      7 ass gnu --class os $menuentry_id_option 'gnulinux-4.19.0-0.bpo.5-rt-amd64-recovery-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      8         menuentry 'Debian GNU/Linux, Linux 4.9.0-9-rt-amd64 verzióval' --class debian --class gnu-linux --class gnu --class os      8  $menuentry_id_option 'gnulinux-4.9.0-9-rt-amd64-advanced-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
      9         menuentry 'Debian GNU/Linux, with Linux 4.9.0-9-rt-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu      9  --class os $menuentry_id_option 'gnulinux-4.9.0-9-rt-amd64-recovery-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
     10         menuentry 'Debian GNU/Linux, Linux 4.9.0-9-amd64 verzióval' --class debian --class gnu-linux --class gnu --class os $m     10 enuentry_id_option 'gnulinux-4.9.0-9-amd64-advanced-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {
     11         menuentry 'Debian GNU/Linux, with Linux 4.9.0-9-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --     11 class os $menuentry_id_option 'gnulinux-4.9.0-9-amd64-recovery-75b066d4-ffa5-4e5c-a77b-cee151ac284f' {

Tehát, ha a grub fáljban ez a beállítás

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

és a Debian alapértelmezett kernelét szeretném mindig (amely a 10-es), akkor ez a parancs:

sudo grub-set-default 10

A kézikönyv:

man grub-set-default

Idézet:

       MENU_ENTRY is a number, a menu item title or a menu item identifier.

-----

Amúgy te már mindenfélét variáltál, ahány kernellel beléptél, mindegyikre legyártottál egy-egy *.cfg fájlt

Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'

Sourcing file `/etc/default/grub.d/20_linuxmint.cfg'

Innen nézem: https://linuxmint.hu/comment/29013#comment-29013

Tehát ezen sem lehet nagyon csodálkozni:

Linux norbi-M540R 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:15:38 UTC 2018 i686 i686 i686 GNU/Linux

Eléggé megkeverted.

A Debian-alapú rendszereknél nem az mkconfig a grub beállítás frissítése, nem jól mutatja a videó: https://www.youtube.com/watch?v=prHDES9XmjU

Értékelés: 

0
Még nincs értékelve

Oldalak