Jelszó kérése hordozható eszközök csatlakoztatásakor

Fórum: 

Linux Mint Tessán hogyan lehet beállítani hogy root vagy sudoer jelszót kérjen külső eszközök csatlakoztatásakor? Szeretném beállítani hogy ha bárki bármilyen külső adathordozót szerente csatlakoztatni akkor mountolás előtt kérjen jelszót. Google-ben próbáltam rákeresni de csak az elfelejtett jelszó resetelésére adott találatokat.

A Lemezek megvan viszont nem

A Lemezek megvan viszont nem találok benne ilyen beállítást/opciót hogy csatlakozáskor/csatlakoztatáskor jelszó kérése. Ja lehet rosszul fogalmaztam de nem csak 1 adott adathordozót szeretnék lekódolni, hanem bárminek a csatlakoztatásakor kérjen jelszót. Pendrive, cd, HDD, SSD

Értékelés: 

0
Még nincs értékelve
kimarite képe

A Lemezek megvan viszont nem

#2 Előszöri kell választani a kötetet (partíciónak ismeri sok mindenki), amit ...
... a kiválasztás (ráböksz az egérmutatóval) után megnyomod a fogaskerék ikont a beállításokhoz.

Értékelés: 

0
Még nincs értékelve

Igen ki volt választva a

Igen ki volt választva a pendrive is meg a DVD meghajtóval is kipróbáltam. Az egyetlen ide kapcsolódó menüpont a csatolási beállítások szerkesztése volt. Ott megpróbáltam kipipálni a "További hitelesítés megkövetelése csatoláskor" opciót, de nem történt semmi. Ugyan úgy csatlakoztatható jelszó nélkül.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Igen ki volt választva a

#4 megpróbáltam kipipálni

És ment a pipálás .. vagy az se?

Értékelés: 

0
Még nincs értékelve

Igen ki volt választva a

#5 Az ment. Kipipáltam, de mint ha ott sem lenne.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Bocsi az előző kép nem volt

#12 Kapcsold ki a Lemezkezelőben a hitelesítést (úgy tűnik, ki kell kapcsolni, de ellenőrizd, és jelezz vissza az eredménnyel) és zárd be az alkalmazást.

Nyiss egy terminált, készíts egy PolicyKit szabályt

sudo nano /etc/polkit-1/localauthority/90-mandatory.d/external_mnt.pkla

Ezt másold bele:

[external mount pass]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks2.filesystem-mount
ResultActive=auth_admin_keep

Mentsd el a fájlt, és zárd be a nano szövegszerkesztőt

Ctrl + O, és Enter, majd
Ctrl + X

Legfeljebb 15 perc múlva működni fog a dolog, ugyanis a jelszót ennyi ideig jegyzi meg a rendszer egy alkalmazásban (fájlkezelő).

A forrás: https://forums.linuxmint.com/viewtopic.php?t=232159

Ellenőriztem:

pkaction | grep filesystem-mount
org.freedesktop.udisks2.filesystem-mount
org.freedesktop.udisks2.filesystem-mount-other-seat
org.freedesktop.udisks2.filesystem-mount-system

A másik megoldás (Lemezkezelő) nem tudom, miért nem működik. Emez egy általános megoldás.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Bocsi az előző kép nem volt

#13 De itt az ellenkezője:
https://unix.stackexchange.com/questions/96625/how-to-allow-non-superuse...
-----
https://wiki.archlinux.org/index.php/Polkit
https://wiki.archlinux.org/index.php/Udisks

Save the code below to /etc/polkit-1/rules.d/50-udisks.rules

polkit.addRule(function(action, subject) {
  var YES = polkit.Result.YES;
  var permission = {
    // only required for udisks1:
    "org.freedesktop.udisks.filesystem-mount": YES,
    "org.freedesktop.udisks.filesystem-mount-system-internal": YES,
    "org.freedesktop.udisks.luks-unlock": YES,
    "org.freedesktop.udisks.drive-eject": YES,
    "org.freedesktop.udisks.drive-detach": YES,
    // only required for udisks2:
    "org.freedesktop.udisks2.filesystem-mount": YES,
    "org.freedesktop.udisks2.filesystem-mount-system": YES,
    "org.freedesktop.udisks2.encrypted-unlock": YES,
    "org.freedesktop.udisks2.eject-media": YES,
    "org.freedesktop.udisks2.power-off-drive": YES,
    // required for udisks2 if using udiskie from another seat (e.g. systemd):
    "org.freedesktop.udisks2.filesystem-mount-other-seat": YES,
    "org.freedesktop.udisks2.encrypted-unlock-other-seat": YES,
    "org.freedesktop.udisks2.eject-media-other-seat": YES,
    "org.freedesktop.udisks2.power-off-drive-other-seat": YES
  };
  if (subject.isInGroup("users")) {
    return permission[action.id];
  }
});

Assume you are in the "users" group, using the following command to mount a partition (no need sudo).

# udisks2
udisksctl mount --block-device /dev/sda1

# udisks
udisks --mount /dev/sda1

Értékelés: 

0
Még nincs értékelve
keraform képe

Jelszó kérés

Én Linux Mint 18.3 Cinnamont, és az ESET NOD32 Antivírust használom.

Ez utóbbiban van egy beállítási lehetőség, amivel külön-külön blokkolható a CD-ROM, Floppy, FireWire, USB, HotPlug, Other.

De, ha engedélyezni akarom, szürkék maradnak a jelölőnégyzetek, és ez az üzenet olvasható:

Removable media blocking allows you to disable acces to removable media volumes.
Note that this distribution of Linux does not support blocking individual media types.
A computer restart is required for the changes to take effect.

A cserélhető adathordozó-blokkolás lehetővé teszi a cserélhető adathordozó kötetek elérésének letiltását.
Ne feledje, hogy ez a Linux disztribúció nem támogatja az egyes médiatípusok blokkolását.
A módosítások hatályba lépéséhez számítógép újraindítása szükséges.

Vagyis ez legalábbis nálam nem működik. De ezt találtam:
How can I make ubuntu ask for my password before mounting usb-drives?
https://askubuntu.com/questions/389974/how-can-i-make-ubuntu-ask-for-my-...

Itt a válaszban leírt megoldás után ez áll:
This should ask a password when an external device is mounted, but shouldn't ask when an internal is mounted.

Külső (eltávolítható) eszköz esetén jelszót kér, de belső eszközök esetén nem kér.

Értékelés: 

0
Még nincs értékelve
kimarite képe

external_mnt.pkla

#13 Ha ehelyett

[external mount pass]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks2.filesystem-mount
ResultActive=auth_admin_keep

ezt a szöveget teszed a pkla fájlba

[external mount pass]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks2.filesystem-mount
ResultActive=auth_admin

akkor minden befűzéskor jelszót kér ... nincs a sudo 15 perces jelszó megjegyzése.

A leválasztás kicsit nehezebb, nincs is megoldva az UDisk2-vel, de az Udiskie sem működik jól:
https://github.com/coldfix/udiskie/wiki/Permissions
Az Udiskie a storege csoporttal oldaná meg (jelszó kérést írtam bele),
-- de ezt ne csináld meg!

[udisks1]
Identity=unix-group:storage
Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.luks-unlock;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-detach
ResultAny=auth_admin

[udisks2]
Identity=unix-group:storage
Action=org.freedesktop.udisks2.filesystem-mount;org.freedesktop.udisks2.encrypted-unlock;org.freedesktop.udisks2.eject-media;org.freedesktop.udisks2.power-off-drive
ResultAny=auth_admin

[udisks2-other-seat]
Identity=unix-group:storage
Action=org.freedesktop.udisks2.filesystem-mount-other-seat;org.freedesktop.udisks2.filesystem-unmount-others;org.freedesktop.udisks2.encrypted-unlock-other-seat;org.freedesktop.udisks2.eject-media-other-seat;org.freedesktop.udisks2.power-off-drive-other-seat
ResultAny=auth_admin

Azonban ez így nem működik (az udiskie nincs telepítve).
Ez a megoldás viszont működik:
-- megcsinálhatod

sudo nano /etc/polkit-1/localauthority/50-local.d/10-udisks.pkla

Tartalom:

[udisks1]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.luks-unlock;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-detach
ResultAny=auth_admin
ResultInactive=auth_admin
ResultActive=auth_admin

[udisks2]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks2.filesystem-mount;org.freedesktop.udisks2.encrypted-unlock;org.freedesktop.udisks2.eject-media;org.freedesktop.udisks2.power-off-drive
ResultAny=auth_admin
ResultInactive=auth_admin
ResultActive=auth_admin

[udisks2-other-seat]
Identity=unix-group:admin;unix-group:sudo
Action=org.freedesktop.udisks2.filesystem-mount-other-seat;org.freedesktop.udisks2.filesystem-unmount-others;org.freedesktop.udisks2.encrypted-unlock-other-seat;org.freedesktop.udisks2.eject-media-other-seat;org.freedesktop.udisks2.power-off-drive-other-seat
ResultAny=auth_admin
ResultInactive=auth_admin
ResultActive=auth_admin

De csak a csatolásnál. Azaz ezt tudom megcsinálni jelenleg.
És ez egy elegánsabb megoldás, mint a korábbi. Ha emezt használod, a másik fájlt töröld:

sudo rm -f /etc/polkit-1/localauthority/90-mandatory.d/external_mnt.pkla

Teszt, beállítások megtekintése:

pkaction --verbose

Jegyzet: https://www.hogarthuk.com/?q=node/10

Értékelés: 

0
Még nincs értékelve