Gnome terminál

Fórum: 

Sziasztok

Csináltam egy hülyeséget. Gnome terminálban az egyéni parancs futtatása indításkor résznél bejelöltem, hogy amikor végez, akkor lépjen ki automatikusan. A kérdésem az lenne, hogy ezt hogyan lehetne visszaállítani. Már kerestem mindenhol megoldást, de nem találtam rá. Köszi előre is.

Valószinūleg a ,local/share

Valószinūleg a ,local/share/applications mappában van, ha nem ott akkor talán /usr mappák valamelyikében. Attól függ hogy hol van.

Értékelés: 

0
Még nincs értékelve

Valószinūleg a ,local/share

#5 Megpróbálom

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#4 A dpkg -L gnome-terminal parancsor kimenete mutatja, hol lakik az alkalmazás. Illetve, ez a rendszer elhelyezkedést mutatja.
A .config vagy a .local könyvtár esélyesebb, vagyis a saját beállításaidnál kéne beállítani valamit.
Listázásuk (inkább a .config esélyes):

ls ~/.config
ls ~/.local

De nézzük meg, így is kilép-e:

gnome-terminal --command="sudo apt-get update ; bash"

A parancssor futtatásához az XTerm terminált használd.
Esetleg „Futtatás” ablak, ami a: Alt + F2

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#7 (kifuttottam a szerkesztési időből - folytatom)
De nézzük meg inkább, így is kilép-e a Gnome Terminál:

gnome-terminal --command="sudo apt-get update ; bash"

A parancssor futtatásához az XTerm terminált használhatod.
Esetleg „Futtatás” ablakot is, ami a: Alt + F2

Esetleg az említet indítóban, ami desktop fájl, és annak Exec sora az indítás -> Fájlkezelő -> /usr/share/applications/ -> Gnome Terminál -> Megnyitás Xed-del (Cinnamonnál eza  szövegszerkesztő). MI az Exec sor?

A DConf alkalmazásban is benne lehet a beállítás megváltoztatása.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#8 Én Xfce Terminált használok. Nekem a .config alatt látható Xfce Terminál beállítás:

~/.config/xfce4/terminal/

Nézegesd a szöveges beállításokat, ahol gnome-terminal könyvtárat látsz (saját könyvtár/.config).
Ahol szerepel az egyéni indítás, azt kéne törölni. De előbb mutasd meg, mi az.

Itt is lehet:

  1. ~/.bash_profile
  2. ~/.profile
  3. ~/.bashrc

Ezt is próbálhatod(nem a command paraméter, hanem más... a bash biztosítaná, hogy nyitva maradjon)

gnome-terminal -e "bash -c cd ; bash"\

...és itt Entert ütsz.

vagy

gnome-terminal -- cd

vagy

gnome-terminal -e 'sh -c "echo test; sleep 180"'

... 180 másodpercig nyitva marad az ablak. A beállításokhoz, visszaállításhoz elegendő.

A parancssorokat az XTerm vagy a Futtatás alkalmazásokkal tudod futtatni,

Értékelés: 

0
Még nincs értékelve

Jó-jó, de melyik rendszer?

#9 köszi. Sikerült egy újratelepítéssel synaptic csomagkezelőben. De majd kipróbálom

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#10 Az is egyféle megoldás. Terminálban így néz ki (reinstall):

sudo apt-get install --reinstall gnome-terminal

Értékelés: 

0
Még nincs értékelve

Jó-jó, de melyik rendszer?

#9

gnome-terminal -e 'sh -c "echo test; sleep 180"'

Kipróbáltam ezt is. Működik :-)

Köszi

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#12 Önmagában biztos. Akkor próbáltad, amikor be van állítva, hogy fusson le egy parancssor, és utána záródjon be a terminál?

Az Xfce terminálnak van a preferences paramétere, ami a beállításokat nyitja azonnal. :)

xfce4-terminal --preferences

A súgó, a help segített az Xfce-nél. A Gnome Terminálnál a súgó:

gnome-terminal --help

... a Súgó - érdekes módon - nem ugyanaz, mint a Kézikönyv (man): man gnome-terminal

Van preferences?

Értékelés: 

0
Még nincs értékelve

Jó-jó, de melyik rendszer?

#14 igen, beállítottam újból, és úgy működött

Értékelés: 

0
Még nincs értékelve

Jó-jó, de melyik rendszer?

Ezen kívül, még kimarite megoldása is működik. Nyitsz egy másik terminált, és oda beírod a következőt:

gnome-terminal --preferences

Megnyílik a gnome terminal beállító ablaka, ahol vissza lehet állítani mindent.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Jó-jó, de melyik rendszer?

#16 A GNOME asztali környezet fejlesztői úgy gondolják, a felhasználó úgysem ront el semmit. Különben megoldhatnák egy másik menüvel, a beállítások tekintetében. Például az SMPlayer-nek van menüje a lejátszólistába bevitelhez (alapértelmezetten nem jelenik meg a menüben, de a menüszerkesztővel megjeleníthető)

Értékelés: 

5
Átlag: 5 (1 szavazat)