Frissítési kérdés (linux-libc-dev, kernel ...)

Fórum: 

 Sziasztok!

Mint 18 majd 18.1 és most 18.2-et használok folyamatos verzióváltással. Az első telepítés még 4.4-s kernelt használt (18 és 18.1). Mikor frissítettem 18.2-re akkor olvastam, hogy ez alapból 4.8-st használ ha újként telepítem. Mivel én frissítettem ezért utólag telepítettem fel ezt a kernel verziót. Azt szeretném megkérdezni, hogy a linux-libc-dev 4.4.0-89.112 csomagot most fel kell tenni, vagy sem? A frissítéskezelő mindíg pipát rak elé. Nem tudom, hogy szükséges-e a rendszernek. Az összes 4.4 kernelt eltávolítottam a kernel verzió kezelőnél, hátha akkor nem kéri, de akkor is alapból megjelenik. Aktívként 4.8-s kernelt jelöl meg a gép. Érdesem egy 6-7 éves Celeronra 4.10 kernelt felrakni? Van előnye? Ha új kernelt rekok fel érdemes törölni a régit? Mintha lassúlna a gép indulása a sok fent lévő kernel miatt. Ez abból vonta le, hogy mióta töröltem a régebbi kerneleket, minta gyorsabban indulna a gép.

Segítséget előre is köszönöm!

kimarite képe

linux-libc-dev

Csomag: Linux Kernel Headers for development
Ha csomagot fejlesztesz (forgatsz), akkor kellhet. A kernel header csomag függősége, melyre nincs feltétlen szüksége az átlag felhasználónak (a kernel az *-image nevű). A *-dev kifejezés véggel végződő csomagok szintén a fejlesztéshez szükségesek, más esetben nem használod.
Frissíthető -és nem szimplán telepíthető- lenne, de a biztonsági szint hatálya alá esik, be lett sorolva.

Az

apt-cache rdepends linux-libc-dev

parancs megmutatja, hogy a csomagra mely csomagokra van feltétlen szüksége (pl. nvidia). És valamelyik ilyen csomag is a biztonsági szint alá eshet. ... nincs leírás a biztonsági szintekbe kerülésről, gondolom, ez a csomagok bug gyakoriság dönti el.

A régebbi kernelek törlése nem szokott gyorsulást okozni, de az lehetséges, nem volt meg az 5% szabad helye a rendszernek, ezért volt lassabb.

Értékelés: 

0
Még nincs értékelve

 Az általad leírt parancs

 Az általad leírt parancs kimenete a következő:

hodi@hodi-RV510 ~ $ apt-cache rdepends linux-libc-dev

linux-libc-devReverse Depends:  nvidia-340  blktap-dkms  nvidia-375  nvidia-340  nvidia-304  bcmwl-kernel-source  libklibc-dev  libc6-dev  vdr-dev  rtl8812au-dkms  librsbac-dev  blktap-dkms  nvidia-361  nvidia-340  nvidia-304-updates  nvidia-304  bcmwl-kernel-source  gcc-multilib  libklibc-dev  libc6-dev  iptables-devhodi@hodi-RV510 ~ $  Ahogy elnézem sok dev és sok grafikus kártya meghajtó van köztük. Ezek alapján szükséges ezt frissíteni? Engem a fejlesztés ténye nem fenyeget!Az 5% + hely bőven megvolt. 30 Gb/250 Gb az arány. Érdemes egy 6-7 éves Celeronra 4.10 kernelt felrakni? Előre is köszönöm a válaszod! 

 

Értékelés: 

0
Még nincs értékelve

 Az általad leírt parancs

#2 " Érdemes egy 6-7 éves Celeronra 4.10 kernelt felrakni?"

Van olyan hardvare-ed amely nem vagy nem megfelelően működik ?

Mert ha nincs, akkor szerintem felesleges az újabb/legújabb kerneleket hajkurászni.

Majd ha hozzájutsz egy olyan hardware-hez (pl. egy új USB-s WiFi adapter) amelyikkel gond lesz,

akkor lehet hogy egy újabb kernel telepítése megoldja a gondot.

(Kíváncsiságból feltettem a Mint 18-ra (mely alapból a 4.4-es kernellel jött ki) a 3.13-as kernelt

azzal is ugyanúgy működött a rendszerem mint a 4.4-es kernellel...de ugyanúgy az akkoriban

legújabb 4.9.x-es (LTS) kernellel sem volt semmi gondja.)

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Az általad leírt parancs

#2 A kimenetet én is ismerem. :-)
Nem kell frissítened, mert 4-es biztonsági fokozat van a csomagra érvényben. Majd utána nézek, miért van mindig automatikusan bejelölve, de mintha régebben lett volna szó erről. Nálam is így van.

Az új kernel-t telepítheted, azaz kipróbálhatod, a hasznossága hardvereidtől függ, de nem tudom előre megjósolni, gyorsabb, jobb, stb. vagy esetleg az ellenkezője lesz. A régi kernel-t használhatod az új kernel telepítése után is, ha nem törlöd az újat, akkor is. Általában az újabb kernelekben sokkal több minden, firmware-ek, eszközök támogatása, stb. van, ez a fejlesztés iránya, azonban egyes régi hardverek nem biztos, hogy úgy viselkednek az új kernellel, ahogy az elvárható lenne. De, ha mégsem úgy viselkednek, akkor egy következő kernelben javíthatják a viselkedést a régebbi hardverre.

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Az általad leírt parancs

#4 Egyébként a kernel(ek) üzenetei, melyek akár kisebb módosításokra utalhatnak a rendszeren és így meg is oldhatóak, a dmesg parancs kimenetében nagyjából megmutatkoznak. Ez egy terminálban futattott parancs, csak tesztel, azaz üzeneteket, logolást mutat meg. Jelentése: display/driver messages (megjelenítési és driver/modul üzenetek)

A parancsot egy megnyitott (elindított) terminálba másolod (kijelölés és Ctrl + C..., esetleg begépeled (négy karakter), majd az Enter leütésével indítod/futtatod.

A kimenet a megjelenő szöveg. A terminál alkalmazások lehetőséget adnak a teljes szöveg kijelőlésére, de egérrel is kijelölheted (laptopot használva ez nehezebb művelet). A másolás az egér jobb gombos menüjével a legegyszerűbb. Azonban lehetőség van a kimenet szöveges fájlba vezetésére, így:

dmesg 2&>1 | tee -a dmesg_01.txt

A parancsot ugyanúgy másolva tudod futtatni. A kimenet, a szöveges fájl (*.txt) bármilyen nevű lehet, én csak azért tettem a 01 számozással, mert a tee alkalmazás írja ki a szöveget, ... de az '-a' kapcsoló teszi lehetővé, hogy kétszer futtatva a parancsot -erre nincs szükség- a második kimenet hozzá lesz fűzve az első kimenethez a fájlban. A tee '-a' kapcsoló nélküli használata az új kimenet felülírja (törli) az első (korábbi) kimenete(ke)t. Másodszori futtatásra jó pl. a 02-es számozás (ha csináltál a kettő futtatás között valamit, de ez ízlés kérdése).
A 2&>1 biztosítja, hogy a fájlba írt kimenet megjelenjen a terminálban is.
A | (csővezeték) biztosítja, hogy az egyik parancs (dmesg) kimenete valahová továbbítódjon, a példában a tee bemenetére. Ez olyan mint egy tölcsér vagy egy cső, amit 'beöntesz' az egyik oldalon, az kijön a másikon.

Az 'xdg-open' parancs a fájl kiterjesztés (tartalom) szerint kapcsolt alkalmazásokkal van összefüggésben (MIME), tehát a 'txt' fájlt az alábbi parancs

xdg-open dmesg_01.txt

az alapértelmezett szövegszerkesztőddel nyitja meg (ablakban, mert az alapértelmezett szövegszerkesztő általában grafikus alkalmazás: pl. a Pluma), így a szövegszerlesztőben megjelenő szöveget könnyedén másolod (vs. terminál). Aztán a vágólapra másolt szöveget beilleszted a https://paste.ubuntu.com/ oldalon és a már itt többször leírt módon mented és a mentés után látható URL-t osztod meg velünk, hogy segítsünk kiértékelni a kimenetet (dmesg), mert magad azt valószínűleg nem tudod kiértékelni: az error, warning, fail szavak irány mutatóak, de van pár más jelenség is, melyekre érdemes (fel)figyelni. A 'dmesg (*.txt) kimenetét az első parancs a jelen esetben a saját könyvtáradba menti, ott is megtalálod (a fájlkezelővel)

A régebbi kernellel való belépéshez a számítógép bekapcsolásakor a Shift billentyűt kell nyomogatnod, ekkor -általában- megjelenik egy szöveges menü, a GRUB (boot loader), ebben legfelül a legújabb kernel van, lentebb egy másik menü, amire a LE kurzor nyíllal lépsz, majd Enter-t ütve kiválasztod (az Enter ennnyi mindenre jó). Itt ismét lefelé lépve kiválaszthatod a régebbi kernelt és azzal lépsz be. Ha nem jelenik meg a GRUB a Shift nyomogatásra, arra is van megoldás.

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Az általad leírt parancs

#7 Egy részletet másolhattál be, mert az egész kimenet csak az Universal Firewall működést mutatja. Ezt nem kívánom elemezni. :-) ;)
Amúgy egy -persze, a mostaninál normálisabb, megszokottabb- kimenetet előnyösebb csak akkor tanulmányozni, ha valami problémát észlelsz vagy kíváncsiságból.

Értékelés: 

0
Még nincs értékelve

 Az általad leírt parancs

Elvileg szerkeszt/összes kijelölését használtam direkt, mert múltkor írtad, hogy az xfce terminál csak azt jelöli ki ami éppen a képen látszik és így a sorok vége lemarad. 

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Az általad leírt parancs

#9 mert múltkor írtad, hogy az xfce terminál csak azt jelöli ki ami éppen a képen látszik
-- nem így van -nem ezt mondtam- hanem ezt: a terminálok többsége levágja a sorok végét. Kijelölésről szó sem volt.
és így a sorok vége lemarad.

Használd a gépet kicsit, majd megint dmesg.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A frissítéskezelő mindíg pipát rak elé: szükséges-e telepíteni?

@PG78 Magyarázat ('megtaláltam')
Igen, szükséges lehet, hiszen, ha az 'iksz' fölé viszed az egér mutatót, az mutatja: „Biztonsági frissítés”. Ezen kívül van a „Szoftver frissítés”, a „Kernel frissítés” ahol nincs 'iksz' és 4-es besorolásúak a csomagok például. A biztonsággal összefüggő csomagokat a frissítéskezelő mindig telepítésre vagy frissítésre jelöli: vélhetőleg nem csak  a 4-es, hanem az 5-ös besorolásnál is.

Értékelés: 

0
Még nincs értékelve