Clipit nem működik

Fórum: 

Környezet: Linux Mint 18.3 "Sylvia" - Cinnamon (64-bit)).

Sem SM-ből, sem parancssorból telepítve a Clipit nem csinál semmit, sem jobb gombra, sem bal gombra nem reagál. Indítópultba berakva sem indul el.

Telepítés után a rendszert kétszer újraindítottam.

Parancssorból indítva ezt írja ki:

** (clipit:2092): WARNING **: Binding '<Ctrl><Alt>H' failed!

** (clipit:2092): WARNING **: Binding '<Ctrl><Alt>A' failed!

** (clipit:2092): WARNING **: Binding '<Ctrl><Alt>P' failed!

** (clipit:2092): WARNING **: Binding '<Ctrl><Alt>F' failed!

** (clipit:2092): WARNING **: Binding '<Ctrl><Alt>O' failed!

(clipit:2092): GLib-CRITICAL **: g_variant_new_string: assertion 'g_utf8_validate (string, -1, NULL)' failed
 

kimarite képe

Clipit nem működik

#1 Még mindig nem jut eszembe, hogyan oldottam meg, de a Debian Stretch és majdan a Linux Mint 19 alatt már egy újabb verzió van, amely működik ..., bár az eredetit sajnos nem fejlesztik:
https://alternativeto.net/software/clipit/
https://alternativeto.net/software/clipit/?platform=linux

Próbáld a qlipper-t (teszt)

sudo apt-get install qlipper -s
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
Az alábbi ÚJ csomagok lesznek telepítve:
qlipper
0 frissített, 1 újonnan telepített, 0 eltávolítandó és 0 nem frissített.
Inst qlipper (1:5.1.1-2 Ubuntu:18.04/bionic [amd64])
Conf qlipper (1:5.1.1-2 Ubuntu:18.04/bionic [amd64])

Függőség semmi.

Tulajdonságai:

Lightweight and cross-platform clipboard history applet
A Lightweight and cross-platform clipboard history applet. It
provides the following features:
.
- saves clipboard history entries and restores them
- lightweight
- systray docking app
- few requirements
- can be used in GNOME and Windows (and more)

Mármint, a valós telepítése ez:

sudo apt-get install qlipper

Értékelés: 

0
Még nincs értékelve

Qlipper sem működik

Qlipper sem működik, újraindítás után sem.

Parancssorból indítva ezt a hibaüzenetet adja vissza:

Translator is not loaded "qlipper_en_US" "/usr/share/qlipper/translations"
 

Kipróbálok még pár vágólapkezelőt.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Qlipper sem működik

#3 Érdekes. A

locale

parancs kimenetét ide másolnád?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Clipit nem működik

#2 A Clipit-ből még nem sikerült Backports csomagot készítenem. ... ha ez egyáltalán lehetséges.

Értékelés: 

0
Még nincs értékelve

Qlipper sem működik

#4

Ez látszik:

$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=hu_HU.UTF-8
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=hu_HU.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=hu_HU.UTF-8
LC_NAME=hu_HU.UTF-8
LC_ADDRESS=hu_HU.UTF-8
LC_TELEPHONE=hu_HU.UTF-8
LC_MEASUREMENT=hu_HU.UTF-8
LC_IDENTIFICATION=hu_HU.UTF-8
LC_ALL=
 

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Qlipper sem működik

#6 Neked szándékosan ilyen kevert, mint amit látok?
Nálam ilyen:

locale
LANG=hu_HU.UTF-8
LANGUAGE=hu_HU
LC_CTYPE="hu_HU.UTF-8"
LC_NUMERIC=hu_HU.UTF-8
LC_TIME=hu_HU.UTF-8
LC_COLLATE="hu_HU.UTF-8"
LC_MONETARY=hu_HU.UTF-8
LC_MESSAGES="hu_HU.UTF-8"
LC_PAPER=hu_HU.UTF-8
LC_NAME=hu_HU.UTF-8
LC_ADDRESS=hu_HU.UTF-8
LC_TELEPHONE=hu_HU.UTF-8
LC_MEASUREMENT=hu_HU.UTF-8
LC_IDENTIFICATION=hu_HU.UTF-8
LC_ALL=

Értékelés: 

0
Még nincs értékelve
kimarite képe

Qlipper sem működik

#7 Próbáltál más alkalmazásokat is?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Clipit nem működik

#1 Azt hiszem leforgattam a csomagot:

git clone https://github.com/CristianHenzel/ClipIt.git
cd ClipIt/
./autogen.sh
./configure
make
sudo checkinstall

Forrás:
https://github.com/CristianHenzel/ClipIt
A fejlesztői csomagok telepítése szükséges, de csak, ha erőt érzel magadban a folyamathoz...

A ClipIt forrását adó Parcellite

sudo apt-get install parcellite

is ugyanolyan hibákat dob nálam, mint az általad elsőként közölt hibák.

Értékelés: 

0
Még nincs értékelve

local

#7

Nem szándékos, nem tudom melyiket, mi állítja be.

Az biztos, hogy telepítéskor általában angolra állítom be a nyelvet, de a helyi beállításokat magyarra, valószínűleg onnan ered.

Értékelés: 

0
Még nincs értékelve

Szinte egyik sem működik

#8

Igen, a legtöbb egyáltalán el sem indul. Ezeket találtam a SM-ben: pl. Clipman, Parcellite, Diodon sem működik, a Gpaste elindul, de az sem úgy működik, ahogy szeretném. Ha becsukom, nem figyel tovább, ha fut, akkor meg a futó programok között van. Továbbá csak az utolsó kettőt ajánlja fel.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Szinte egyik sem működik

#11 A ClipIt is csak akkor figyel, ha el van indítva (így logikus), de a telepítés után beteszi magát automatikusan induló alkalmazások közé. A ClipIt forgatásában tudok segíteni (magyarázatokkal).

Értékelés: 

0
Még nincs értékelve

Köszönöm a felajánlott

Köszönöm a felajánlott segítséget, de valami egyszerűbb dolgot keresek (nem érzek erőt :-). Otthoni körülmények között "kényelmes" vagyok.

Amúgy nyilván futnia kell a programnak, akkor működik, de a futó alkalmazást ebben az esetben úgy értem, hogy az ALT+TAB listán és a tálcán nem jelenik meg. Illetve a tálcán csak ikonként a jobb sarokban. Így működik az összes windowsos vágólap kezelő, amiket próbáltam

Lehet, hogy szenvedek még a Copyq-val, talán mégis be lehet konfigurálni valahogy normálisra.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Köszönöm a felajánlott

#13 Lehetséges, le tudok gyártani egy DEB csomagot, meglátom. 64bit-es a rendszered?
Nem tudom, mi van ezekkel a vágólapkezelőkkel, hogy egyik sem működik. :)

Értékelés: 

0
Még nincs értékelve

Köszönöm a felajánlott

#14

Igen, 64 bites.

Amúgy arra már rájöttem, hogy a Copyq-nak van egy kapcsolója, hogy Hide Main Window, ez éppen arra jó, hogy kiveszi a futó programok listájából. De a System Trayben (nem tudom, ennek mi a neve magyarul) nem jelenik meg, pedig meg kéne a leírás és a képek szerint linux alatt is. Gyorsgombra azért elő lehet hívni, de még mindig ott van a lassú működés, meg a kilépési probléma.

Értékelés: 

0
Még nincs értékelve

bug javítás

Még az is eszembe jutott, hogy ezeket a bugokat nem javítják?

Ha majd frissítem a linuxot, lehet, hogy majd működni fognak a programok?

Értékelés: 

0
Még nincs értékelve

Panel

Most jutott eszembe.

A panelelemekben szerepel az értesitési-terület plugin?

Értékelés: 

0
Még nincs értékelve

Panel

#17

Ha arra gondolsz, hogy a tálca jobb oldalán látszik-e a hangerő, az óra, a hálózati kapcsolat és a felhasználó ikon, akkor igen.

A Settings alatt van egy Notification, ahol a Display test notification is működik.

Értékelés: 

0
Még nincs értékelve
kimarite képe

bug javítás

#16 Nálam működik a ClipIt. :)

Értékelés: 

0
Még nincs értékelve

bug javítás

#19

Remek! De hogy lehet nálad már a 19-es Linux Mint?

Egyébként van valahol leírás, hogyan kell majd frissíteni?

Értékelés: 

0
Még nincs értékelve
kimarite képe

bug javítás

#20 Szia, én átírtam a frissítési forrásokat. Úgy kellett volna csinálnom, hogy először a Sylvia csomagokat felfrissítem az 5-ös szintig, majd ezután írom át a tárolókat:
-- sylvia --> tara
-- xenial --> bionic
A PPA-knál is (ha rendelkezel ilyekkel), bár azokat meg kell nézni van-e bionic megfelelőjük, azaz meg kellett volna nézni.

Majd

sudo apt-get update

és

sudo apt-get dist-upgrade

vagyis a második parancsnál jobb, ha az aptitude-ot használod

sudo aptitude full-upgrade

Ubuntu alatt ez a parancs:

update-manager -cd

Aztán pár dolgot helyre kellett rakni, de bíztam a dpkg és az aptitude alkalmazásokban. Ahonnan az Ubuntu építkezik a Debian Sid, és ezek az alkalmazások a Debian alatt is sokszor segítettek.

Ez nagyon nem hivatalos út, ugyanis a hivatalos frissítés alkalmával az upstart beállításaival törlődik, és van még néhány 'apróság', ami az új rendszer működését beállítja magától. Megint nagy ugrás történt, tehát érdemes megvárni a hivatalos lehetőséget a frissítésre, ami májusban, júniusban lesz. Most kivezetésre került az upstart (nem választható), de korábban (Linux Mint 17.x > 18.x), a systemd került bevezetésre (a korábban kizárólagosan használt upstart mellé). Tehát, most a systemd van kizárólagosan használva (rendszer összetevő). Ezek a változások nagy mértékben befolyásolják a rendszer működését és nem a látható dolgok. A Cinnamon indulását egy bug befolyásolta, azt bizonyára javítják, míg erre rájöttem, addig LXDE asztali környezettel használtam a rendszert. A bug, egy alkalmazás beállítási bug, nem Cinnamon összetevő. Erről itt írtam meg a nemzetközi fórumon:
The problem is, that vino-3.14 (~amd64) and gnome-control-center-3.12 (stable) are not compatible, because the "enabled" key has been removed in 3.14.
https://forums.linuxmint.com/viewtopic.php?f=46&t=268704#p1464864

Várd meg a frissítést, vagy telepíts friss rendszert. :)
A közeljövőben több hasonló, rendszert ilyen erősen érintő változás vélhetően nem lesz, mármint a következő kiadásoknál. A hivatalos frissítési út még nem létezik, de mindezeket megoldja.

-----

Ráadásul én egy unstable Cinnamon PPA-t is felvettem, de készítek olykor mentéseket a rendszerről.

Értékelés: 

0
Még nincs értékelve

Linux Mint 19

Hú! Nem sokat értek azokból, amiket leírtál, de mindenképpen megvárom a hivatalosan verziót.

Köszönöm, hogy ennyi időt és energiát fordítottál erre, bár gondolom ez neked egyben hobbi is, ha ilyen szinten foglalkozol a dologgal.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Linux Mint 19

#22 Szeretek ilyen dolgokat kipróbálni. :)
https://www.youtube.com/watch?v=RbcMDsRd6H8

Értékelés: 

0
Még nincs értékelve