Canon MP 280 nyomtató probléma Linux Mint 18.1 alatt

Fórum: 

 Sziasztok!

A következő probléma keseríti meg az életemet. :)

Egy Canon MP280 nyomtatót szeretnék Linux Mint 18.1 alatt működésre bírni.

(Ugyanez a nyomtató egy másik régebbi gépen Linux Mint 17 alatt remekül működik.)

Az a probléma, hogy tesztoldal nyomtatásakor a nyomtatási sorban "visszatartott" lesz az állapot és

elakad a nyomtatás. Próbáltam a Canon oldaláról a 3.4 verziójú nyomtatódriver telepíteni, de függőségi problémák és 

libtiff4 csomag hiánya adódott. (a libtiff5 viszont telepítve a gépen)

Kérlek segítsetek. Köszönöm

kimarite képe

RE: Canon MP 280 nyomtató problém Linux Mint 18.1 alatt

@Pooli Próbáld így:

-- PPA felvétele

sudo add-apt-repository ppa:inameiname/stable
sudo apt update

Igaz, hogy egy korábbi Ubuntu kiadásra készült a csomag, de a PPA csomagválasztás (Xenial Xerus / 16.04 = Linux Mint 18+) szerint jó neked is.

A telepítés folyamata
(a Synaptic csomagkezelő használatával)

-- kiválasztod a nyomtatónak megfelelő csomag verziókat (melyek nem a képeken láthatóak) és telepíted

-- végül újraindítod a rendszert

sudo reboot

-- és a nyomtatás tesztje következik

Forrás:
http://tipsonubuntu.com/2016/08/14/canon-printer-driver-scangear-mp-ubun...

A PPA:
https://launchpad.net/~inameiname/+archive/ubuntu/stable

Értékelés: 

0
Még nincs értékelve

Szia Kimarite!

Szia Kimarite!

Köszönöm a gyors választ, de a problémám sajnos még mindíg fennáll.

Felvettem a tárolót. A sudo apt-get update futtatásakor van egy "www.openingprint/download/printerdriver stb

kulcs aláírás gyenge kivonatoló algoritmust használ" hibaüzenetem. Nem tudom ez bekavarhat-e?

A synapticban telepítettem a cnijfilter-common és a cnijfilter-mp 280 nyomtató driverek 64bites verióit.

Újraindítás után a nyomtató csatlakoztatása után automatikusan elveszi a rendszer az általa ajánlott MP280 nyomtatót és

a tesztoldal nyomtatás közben ugyanúgy elakad. A nyomtatási sorban a státusz "visszatartott"-ra változik.

Segíts légyszíves mit rontok el?

Üdv: Pooli

 

 

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Szia Kimarite!

#2 Szia. Lehet, bennem a hiba, de el nem tudom képzelni, hogy ebben a mondatban
'a nyomtató csatlakoztatása után automatikusan elveszi a rendszer az általa ajánlott MP280 nyomtatót'
mit jelent az, hogy a rendszer elveszi a nyomtatót. Gondolom, nem házasodás céljából. ;)

Értékelés: 

0
Még nincs értékelve

 Szia!

 Szia!

Nem Benned,hanem bennem van a hiba.

Nem el, hanem fel. :)

Az történik, hogy újraindítást és a nyomtató usb kábelének csatlakoztatását követően megjelenik 

az új nyomtató MP 280 telepítése felírat a jobb felső sarokban, de a tesztoldal nyomtatása már elakad és

a nyomtatási sorban a státusz "visszatartott" lesz.

 

 

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

 Szia!

#4 Szia. Ahogy látom, vannak különbségek a telepítendő csomagoknál a 32 bit-es és a 64 bit-es rendszerek tekintetében. 32 bit-es csomagok tudsz telepíteni a 64 bit-es rendszerre, fordítva nem menne.

Ezt írod:
'A synapticban telepítettem a cnijfilter-common és a cnijfilter-mp 280 nyomtató driverek 64bites verióit.'

Ellenőrizzük a telepített csomagokat, .. és elhiszem, amit mondasz:

dpkg -l | egrep 'cndrvcups-common|cnijfilter|scangearmp'

A dpkg nálam a telepített csomagokat dobja ki (ii), szerintem nálad is így lesz.

Forrásul vettem (a csomagokat néztem):
https://launchpad.net/~inameiname/+archive/ubuntu/stable/+sourcepub/6728...
https://launchpad.net/~inameiname/+archive/ubuntu/stable/+sourcepub/6728...
https://launchpad.net/~inameiname/+archive/ubuntu/stable/+sourcepub/6728...

Úgy látom, létezik csomag 64 bit-re.

-----

Meg kéne nézni, ezeknek mi a kimenete, mi történik:
http://ubuntuhandbook.org/index.php/2014/12/canon-driver-scangear-mp-ubu...

sane-find-scanner
scanimage -L
scangearmp2
xsane

Ezek mutathatnak valami hibát, mert gondolom, a 17+ alatt is 64 bit-es rendszert használtál. Ugyanígy.
A visszatartott nyomtatás lehetséges, még a csomagok telepítése előtti időből származik? Ezeket nem tudnád pl. a 17+ alól törölni, és üresen indítani a feladatoknál?

------

Egy más megoldást tesz fel egy hozzászóló, a 32 bites scangear csomag tekintetében (egyelőre ezzel várjunk)
http://tipsonubuntu.com/2016/08/14/canon-printer-driver-scangear-mp-ubun...

sudo apt-get install ia32-libs libatk1.0-0:i386 libc6:i386 libcairo2:i386 libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386 libgtk2.0-0:i386 libpango1.0-0:i386 libx11-6:i386 libcanberra-gtk-module:i386

A csomagok verziószáma eltérhet a javaslatban szereplőtől.

-----

A ScanGear parancs- vagy/és menüikon létrejött amúgy?
https://unix.stackexchange.com/questions/257544/how-to-scan-with-canon-i...
De ez csak egy kérdés (az URL egy példa, az esetre, ha nem jött volna létre), a 'scangearmp' vagy a 'scangearmp2' parancs lenne a teszt.

Értékelés: 

0
Még nincs értékelve

Szia

Szia

Leszedtem minden korábban telepített 64 bites csomagot (cnijfilter-common, cnijfilter-mp280). 

Feltelepítettem a 32 bites változatokat:

kriszta@kriszta-SATELLITE-C55-A-1NU ~ $ dpkg -l | egrep 'cndrvcups-common|cnijfilter|scangearmp'
ii cndrvcups-common:i386 2.50-1-2~raring1 i386 Canon Printer Driver Common Modules
ii cnijfilter-common:i386 3.90-76~ubuntu14.04.1 i386 IJ Printer Driver for Linux.
ii cnijfilter-common-32 3.90-76~ubuntu14.04.1 amd64 IJ Printer Driver for Linux.
rc cnijfilter-common-64 3.90-76~ubuntu14.04.1 amd64 IJ Printer Driver for Linux.
ii cnijfilter-mp280series:i386 3.90-76~ubuntu14.04.1 i386 IJ Printer Driver for Linux.
ii cnijfilter-mp280series-32 3.90-76~ubuntu14.04.1 amd64 IJ Printer Driver for Linux.
ii scangearmp-common:i386 2.10-33~raring1 i386 ScanGear MP for Linux.
ii scangearmp-common-32 2.10-33~raring1 amd64 ScanGear MP for Linux.
ii scangearmp-mp280series:i386 2.10-33~raring1 i386 ScanGear MP for Linux.
ii scangearmp-mp280series-32 2.10-33~raring1 amd64 ScanGear MP for Linux.
kriszta@kriszta-SATELLITE-C55-A-1NU ~ $

Sajnos a probléma továbbra is megvan.

Az sane-find-scanner parancs kimenete szerint nincs csatlakoztatva USB scanner.

Azt írtad: "A visszatartott nyomtatás lehetséges, még a csomagok telepítése előtti időből származik? Ezeket nem tudnád pl. a 17+ alól törölni, és üresen indítani a feladatoknál?" Ezt hogyan kellene megtennem?

A scangear menüikon létrejött, de indítás után a hibaüzenet: Nem található lapolvasó.

Tanácstalan vagyok.

Üdv:Pooli

 

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Szia

#6 Hát a 32 bit-es csomagokra írtam megoldást (hogy mit kéne telepíteni azokhoz), azt csináld, ha már így lett ... . Tanácstalan ne legyél. ;)

Ezt írtam a 32 bit-es csomagokra: (egyelőre ezzel várjunk) :-)
Ez nem tudom, mennyire érthető félre ..., mennyire nem.
Tájékoztató jelleggel írtam, hogy valaki így csinálta, íme ..., mondjuk én nem értem, miért így, hogy mi annak az értelme.
Mindenesetre csak kimeneteket kértem (két szövegblokkban), a telepítést nem. ;)

Értékelés: 

0
Még nincs értékelve