Az egérmutató eltünik, nem birom használni a rendszert.

Fórum: 

Sziasztok!

 

Kezdő vagyok! 3-4 éve csak linuxot használok

Feltelepítem a Mint 20 x64 Xfce verzióját (a 19.3- nál is ugyan ez a helyzet, telepítés után frissítem a rendszert, működik rendesen. Aztán elindítom a böngészőt (Firefox), ekkor eltünik az egérmutató, és így nem bírom használni a rendszert. Aztán rezet gomb vagy tápegység kikapcsol, ujra indul a rendszer, működik, egészen addig még el nem indítom a Firefoxot. Kezdődik minden előröl. Gondoltam nem jó az iso. Letöltöttem a Mintet, több forrásból is. Mindel így jártam. Ugyan így jártam ezekel is:

Robo Linux x64,

Ubuntu Mate x64,

Zorin OS Core x64.

 

Amik viszont hibátlanul működnek:

LMDE-4 x64

Mageia x64

MX Linux x64

Peppermint x64

SolydX x64

Sparky x64

Ufficio Zero Siena x86

Voyager x64

Zorin OS Lite x86 és x64 mid két verzió

 

Három különböző gépen próbáltam ki ezeket. Régi AM3-as alaplapok, AMD Athlon II X4 640, Phnom II X2 550. Ram: Egyik gépben 8 GB, másik gépben 4 GB, harmadik gépben 5 GB memória van.

 

Most lehetne azt mondani, hogy használjam azt amelyik működik. De akkor miért is tértem át linuxra?

 

Ebben szertertnék segítséget kérni! Köszönöm!

 

Üdv: Zsolt

kimarite képe

Nyiss egy terminált,

Nyiss egy terminált, egyenként illeszd be a parancssorokat, majd szintén egyenként üss Entert (ez egy parancs futtatása) ... először az első parancssort futtasd, aztán a másodikat, majd a harmadikat. Nem javítanak, de sok információt tudunk meg velük.
A kimenetek megosztásának módszerére ez a leírás nyújt segítséget:
A honlap működése 7. rész: Ubuntu Pastebin | szöveg megosztása

A parancssorok:

inxi -Fzxxx
apt-cache policy firefox
dmesg

A parancssorok terminál ablakba illesztése menüből is történhet vagy a környezeti menüvel (egér jobb gombos menü). Tedd nagyra a terminál ablakot, mielőtt futtatod a parancssorokat. Figyelj, mert egyes kimenetek nagyon hosszúak, azaz, nem elegendő azt másolni, amit az ablakban látsz. Mindent egyben is másolhatsz, menüből megoldható a másolás szintén.

Értékelés: 

0
Még nincs értékelve

Ne így

Az egerhez nem tudok hozzászólni de ne így állítsd le. Super (Windows) gomb, bejön a helyi menü es ott a fel le bal jobb gombokkal el tudsz navigálni a szabályos leállítashoz, es enter. Vagy gyorsgombozd ki, nekem alt+ctrl+ num0 de azthiszem van erre dedikált bill.parancs de most nem jut eszembe.   Valamint, mivel régebben sok usb gondom volt, az energia fülön beállítottam hogy a főkapcsoló megnyomására Leállítás. Ilyenkor rákérdez, és mégegy power gombnyomásra szépen leáll, szabályosan.

Értékelés: 

0
Még nincs értékelve

Mindhárom gépen u.a. egér?

Írod, három gépen is próbáltad. Mindegyiken ugyanazzal az egérrel?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nyiss egy terminált, (ui.)

#1 Elegendő az egyik gépet tesztelni, csak ezt az információt  (három gép), már nem olvastam, mert egy frissítés alkalmazása miatt ki szerettem volna lépni mihamarabb. És az is kérdés, tényleg, hogy: ugyanaz az egér mutatja ezeket a dolgokat, vagy más és más egeret hasznász a gépekhez?

Értékelés: 

0
Még nincs értékelve

Nyiss egy terminált,

#1 https://paste.ubuntu.com/p/vmcd2jZQrb/

Értékelés: 

0
Még nincs értékelve

Ne így

#2 Köszönöm, megfogadom a leállítási tanácsodat.

Üdv: Zsolt

Értékelés: 

0
Még nincs értékelve

Mindhárom gépen u.a. egér?

#3 Probáltam usb egérrel, meg PS/2 egérrel is, a végeredmény mindig ugya az lett.

Üdv: Zsolt

Értékelés: 

0
Még nincs értékelve

Nyiss egy terminált, (ui.)

#4 Igen, próbáltam másik egérrel is, a végeredmény mindig ugyan az.

Üdv: Zsolt

Értékelés: 

0
Még nincs értékelve

Mindhárom gépen u.a. egér?

#7 Csak megjegyzésként írom, nekem a Genius egerek szoktak vacakolni, a vadi újak is, ezért lehetőleg nem ilyent használok Linuxhoz. Mondjuk el nem tudom képzelni, hogy mit tudnak egy egérrel tenni, de tény, hogy szakadozik, ugrál, stb. Ami nem jelenti azt, hogy nálad is ez a gond.

Szerintem nagy valószínűséggel a hardveres gyorsítás lehet a hunyó. Ill. a videokari képességei.

Létre kellene hozni egy xorg.conf nevű fájlt a /etc/X11/ mappába.

ezt kell beleírni:

Section "Device"
Identifier "Card0"
Driver "radeon"
Option "SWCursor" "true"
EndSection

Újraindítás / próba cseresznye. De én azért néznék egy combosabb videokártyát ebbe a gépbe.

Ez most arra az egy gépre igaz, amelyikről a riportok készültek.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Nyiss egy terminált,

#5 Van egy hiba:

[    0.092004] mem auto-init: stack:off, heap alloc:on, heap free:off
[    0.105138] AGP: Checking aperture...
[    0.110896] AGP: No AGP bridge found
[    0.110899] AGP: Node 0: aperture [bus addr 0xe3e000000-0xe3fffffff] (32MB)
[    0.110899] Aperture beyond 4GB. Ignoring.
[    0.110900] AGP: Your BIOS doesn't leave an aperture memory hole
[    0.110901] AGP: Please enable the IOMMU option in the BIOS setup
[    0.110901] AGP: This costs you 64MB of RAM
[    0.110904] AGP: Mapping aperture over RAM [mem 0xc4000000-0xc7ffffff] (65536KB)
[    0.110906] PM: Registered nosave memory: [mem 0xc4000000-0xc7ffffff]
[    0.143485] Memory: 7991360K/8387036K available (14339K kernel code, 2400K rwdata, 5008K rodata, 2736K init, 4964K bss, 395676K reserved, 0K cma-reserved)

A 8 GB RAM-ot nem érzékeli a kernel.

Na most erre (please enable/kérlek, engedélyezd) az egyik megoldás a BIOS. Két beállítás.
Engedélyezned kell az IOMMU-t. Kb. így néz ki, hogy mit és hogyan:
https://us.informatiweb.net/tutorials/it/bios/enable-iommu-or-vt-d-in-your-bios.html

Engedélyezd a virtualizációs technológiát is (Enable) a CPU tekintetében (AMD). Fentebb is láthatod a linken. És itt is: Enable virtualization (Intel VT-x / AMD-V)

Mindezek után újabb dmesg kiment kéne, ellenőrizni, van-e korábbi üzenet az IOMMU-ra vagy mi sikerült, ez is egy üzenet lesz. Szóval, megnézzük az újabb dmesg kimenet, és utána döntünk.

Ami utána jöhet (majd), az egy kernel kapcsoló:
https://maidavale.org/blog/amd-enabling-soft-iommu/

iommu=soft

Esetleg:
https://www.cyberciti.biz/tips/howto-turn-on-linux-software-iommu-support.html

iommu=calgary

Vagy ezek valamelyike:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/271070

1) iommu=noaperture,memaper=3
2) maxcpus=1
3) iommu=noaperture,memaper=3 maxcpus=1

némi „magyarázat”, mi vált be:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/203537

- iommu=noagp NO success
- iommu=noaperture SUCCESS (seems similar to =soft according to dmesg output)
- iommu=memaper1,2,3 NO success

Mindez nagyon izgalmas egyes régi AMD lapoknál, tudom, mert nekem is van egy ilyenem. :)
Ezek a kernel kapcsolók néha változnak, egyeseket kivezetik, azt majd megnézem, melyik használható még. És a linkelt oldalak nagyon régi leírások, mint a lapjaid. A gyakorlat: Kernel kapcsolók alkalmazása a grub fájl szerkesztésével

Szóval én Johnny Mnemonicos  „szivárgásra” gyanakszom, azaz elfogy a RAM, mikor egy viszonylag nagy erőforrásigényű alkalmazást indítasz, mely a böngésző. Ennek lehet következménye az egér fura viselkedése. Volt ilyen, gyakori eset. Csak a Firefox csinálja? A Frissítéskezelő, miközben frissíteni próbálsz (Frissítés elem), nem? Aztán, lehet másféle gon. Az is igaz, a PS2 csatlakoztatás be szokott válni, de most nem. Nézz rá erre is a BIOS-ban, hátha van valami tiltás. A régebbi hardvereken a BIOS nehezebben engedi vezérelni magát a kernel által.

Nézem még a dmesg kimenetet, hátha találok mást is.
De egyelőre az említett kettő BIOS beállítás, próba azzal. És maradjunk ennél a gépnél. Ja, és USB-s kábelt próbálj.

Egyes Linuxok beleírják ezeket a kernel parancssori kapcsolókhoz..., ez lehet a magyarázat, hogy hol működik, hol nem. Vagy más beálításokat alkalmaznak, de ez egyértelmű a viselkedési különbségek alapján..

Értékelés: 

0
Még nincs értékelve
kimarite képe

EDAC amd64: ECC disabled in the BIOS

#10 A virtualizáció biztosan ki van kapcsolva:

[   13.881333] kvm: disabled by bios
[   13.922428] kvm: disabled by bios
[   13.958421] kvm: disabled by bios
[   13.994429] kvm: disabled by bios

Ezzel kéne még valamit kezdeni majd:

[   14.115153] EDAC amd64: Node 0: DRAM ECC disabled.
[   14.115156] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)

Újabb kernelt, kapcsolót illetve modult tiltást is javasolnak (két utóbbi ugyanaz, csak más a módszer) .., ami aztán mégsem válik be:
https://bugzilla.kernel.org/show_bug.cgi?id=210593
https://askubuntu.com/questions/1264469/ecc-disabled-in-the-bios-or-no-ecc-capability-module-will-not-load
https://bbs.archlinux.org/viewtopic.php?id=252195
BIOS-ban kéne megnézi, támogatja-e, ha igen, be van-e kapcsolva, és bekapcsolni. Majd megint dmesg.

Kimenet?

sudo dmidecode --type memory

Ez a két beállítás fontos (az én gépemnél, ahol semmi ilyesmi nincsen, vagy nem kapcsoltam be esetleg):

Error Correction Type: None
Maximum Capacity: 16 GB
Error Information Handle: Not Provided

Ez ilyen, kutatós dolog a régi alaplapoknál, de nem mindig.
Nem hiszem, hogy köze van az egérhez, de biztos, ami biztos.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Mindhárom gépen u.a. egér?

#9 Azt is meg lehet nézni, itt van-e már kész beállítófájl (AMD videókártya),

file /etc/X11/xorg.conf.d/20-radeon.conf

és mi a tartalma?

cat /etc/X11/xorg.conf.d/20-radeon.conf

... látnunk kéne itt a tartalmat.

Ha létezik, akkor ezt lehetne szerkeszteni. Az eredeti mentése után:

sudo mv/etc/X11/xorg.conf.d/20-radeon.conf /etc/X11/xorg.conf.d/20-radeon.conf.ORIG

A xorg.conf helyett használják manapság, tartalma hasonló (példa, nem javaslat):
https://gist.github.com/ivan/27d3f473b1851da031c3806ea3970fd4

Értékelés: 

0
Még nincs értékelve

Köszönöm szépen a

Köszönöm szépen a segítségeteket! "Megoldodott" a problémám. Letöröltem a Firefoxot, és feltelepítettem a Firefox ESR-t. Ezzel már nincs semmi probléma, nem tünik el az egérmutató.

Üdv: Zsolt

Értékelés: 

0
Még nincs értékelve
kimarite képe

Köszönöm szépen a

#13 Snap csomag?

Értékelés: 

0
Még nincs értékelve