19.2 felébredés + initramfs

Fórum: 

Sziasztok!

Sokáig húztam a 18.3 verzióval. Végül tegnapelőtt felraktam a 19.2-t. Nagyon dizájnos, meg egy csomó mindent úgy tűnik jobban kezel alapból, viszont dualboot rendszerem van, tegnap már beleszaladtam egy initramfs-be, amit a sudo e2fsck -f -y -v /dev/sdxy paranccsal helyre tudtam hozni. Nem örülök nek, de eddig OK.

Monitort és vezeték nélküli egér/klaviatura kombót használok a laptophoz, így a laptop fedele mindig le van csukva, de a gép szinte sosincs kikapcsolva. Eddig 18.3 alatt hozzáértem a vezeték nélküli billentyűzethez és már írhattam is a jelszavamat a képernyő feloldáshoz, a 19.2 nem hajandó felébredni. Az új procedura "Laptop kinyit, bekapcs gomb megnom, laptop lezár." Mit kellene beállítsak ahhoz, hogy ez is "érintésre" ébredjen?

Előre is köszönök minden előrevivő gondolatot!

kimarite képe

A sikeres indítás után

A sikeres indítás után futtatott

dmesg

és az

inxi -Fz

parancsok kimenete kéne.

A hardver (inxi kimenet) milyensége lényeges dolog.

A Paste Ubuntu segítségével linkelve.
https://paste.ubuntu.com/

(Kérdeztem,
https://linuxmint.hu/comment/32942#comment-32942 ,
de ide kéne a válasz.)

Az altatáskor vélhetően a WiFi-s dolgok tényleg altatva lesznek, és nincsenek használatban ...

Értékelés: 

0
Még nincs értékelve

A sikeres indítás után

#1 Bocs. Oda írtam. Írom ide is.

Igazából a Win10-et elindítottam, egy nagyobb frissítés ment le rajta, majd amikor újra a Mint-et akartam indítani, a Busy és initramfs feliratok jöttek elő. Szerencsére találtam rá megoldást (lásd fentebb) azóta még nem Win-eztem. Tudom, majd a secure boot-jára rá kell nézzek. Most ezt egylőre nem forszírozom, most abban a tudatban vagyok, hogy a boottal nem lehet gond, hiszen évekig használtam ezzel a Winnel közös SSD-n a Mint 18.3-at, amivel egyszer, a telepítés után volt ilyen gondom. Akkor a Win be lett állítva, és azóta semmi gond nem volt. Most csak simán feltelepítettem a 18.3 helyére a 19.2-t, és egyszer valamiért átléptem Winbe, és következő Mint indításnál már jött is a hiba.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A sikeres indítás után

#2 A következő kernel paramétert kéne próbálni:

psmouse.synaptics_intertouch=1

A próba dönti el, beválik-e.
A módszer (példa): https://linuxmint.hu/blog/2018/03/kernel-kapcsolok-alkalmazasa-a-grub-fa...
Figyelmesen olvasd el, és használd átgondoltan.

Mert úgy látom, nem a libinput van használatban, hanem a xorg synaptics ...

Itt a javaslat (https://paste.ubuntu.com/p/zkG99nN4Mb/ ):

[    2.979426] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4648]
[    2.991204] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    3.005677] psmouse serio1: synaptics: queried min coordinates: x [1278..], y [1206..]
[    3.005682] psmouse serio1: synaptics: Your touchpad (PNP: DLLb6b2 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
[    3.057287] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00323/0x840300/0x12e800/0x0, board id: 3014, fw id: 1832337
[    3.089758] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6

Magyarázat:
https://lkml.org/lkml/2019/1/11/1320
https://patchwork.kernel.org/patch/9880743/
https://ask.fedoraproject.org/t/synaptic-touchpad-stopped-working-after-...
https://forums.lenovo.com/t5/Other-Linux-Discussions/Thinkpad-X1-Carbon-...
https://bbs.archlinux.org/viewtopic.php?pid=1781984#p1781984 (https://bbs.archlinux.org/viewtopic.php?id=236367 )

Amúgy a suspend után működik a touchpad / trackpad?

És ez is mutatja, mi a probléma:

[ 2494.727379] PM: Syncing filesystems ... done.
[ 2494.733774] Freezing user space processes ... (elapsed 0.006 seconds) done.
[ 2494.740021] OOM killer disabled.
[ 2494.740021] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 2494.741354] Suspending console(s) (use no_console_suspend to debug)
[ 2494.912072] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 2494.913669] sd 0:0:0:0: [sda] Stopping disk
[ 2495.100056] psmouse serio1: Failed to disable mouse on isa0060/serio1

Ha szükséges lesz, tovább vizsgálódunk.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A sikeres indítás után

#3 A Windows Secure Boot be van kapcsolva, az látszik is a bepasztázott dmesg kimenetben.
(https://linuxmint.hu/comment/32944#comment-32944 )

A másik helyen én töröltem ugyanezt (a dupla hozzászólást).

Értékelés: 

0
Még nincs értékelve

A sikeres indítás után

#4 A secure nem tudom hogy aktiválta magát, de köszönöm, kilövöm.

Viszont. Illesztőprogram kezelőnél "a tároló információk betöltése meghiúsult."

 

Értékelés: 

0
Még nincs értékelve

A sikeres indítás után

#4 igen, működik az egér és mnden más (a touchpad-et letiltottam), de csak a be/ki kapcsoló gombbal tudom újraéleszteni.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#6 A

sudo apt-get update

parancs kimenete kéne (a hiány, vagyis az üzenet másolhatósága miatt)..., de nem kell, mert így tudod felvenni a WineHQ tükör nyilvános GPG kulcsát (a Linux Mint terjesztésre):

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-get update

Forrás: https://wiki.winehq.org/Ubuntu

Értékelés: 

0
Még nincs értékelve
kimarite képe

A sikeres indítás után

#7 igen, működik az egér és mnden más (a touchpad-et letiltottam),

Értem. Milyen módszerrel tiltottad le a touchpadot?

de csak a be/ki kapcsoló gombbal tudom újraéleszteni.

Gondolom, a kijelentésed a rendszerre vonatkozik. Szerintem megértettük ezt elsőre is. ;-)

Akkor most jöhet a kernel kapcsoló próbája.

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#8

Közben megnéztem a secure boot-ot. Az alaplapon "disabled" van.

sudo apt-get update

https://paste.ubuntu.com/p/gYxTSScCrB/

wget -nc https://dl.winehq.org/wine-builds/winehq.key
--2019-11-30 14:23:43--  https://dl.winehq.org/wine-builds/winehq.key
dl.winehq.org (dl.winehq.org) feloldása… 151.101.194.217, 151.101.130.217, 151.101.66.217, ...
Csatlakozás a következőhöz: dl.winehq.org (dl.winehq.org)[151.101.194.217]:443… kapcsolódva.
HTTP kérés elküldve, várakozás válaszra… 200 OK
Hossz: 3220 (3,1K) [application/pgp-keys]
Mentés ide: „winehq.key”

winehq.key                                          100%[===================================================================================================================>]   3,14K  --.-KB/s    idő 0s     

2019-11-30 14:23:43 (9,03 MB/s) -- „winehq.key” mentve [3220/3220]

sudo apt-key add winehq.key
OK

sudo apt-get update
Találat:1 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu bionic InRelease
Találat:2 http://archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                              
Letöltés:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]                                                                                                         
Találat:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                                                             
Letöltés:5 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6.259 B]                                                                                                                  
Találat:6 http://archive.canonical.com/ubuntu bionic InRelease                                                                                                                                  
Letöltés:7 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                                                                   
Mellőz:8 http://packages.linuxmint.com tina InRelease                                                                       
Találat:9 http://packages.linuxmint.com tina Release                                                                        
Letöltés:10 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages [531 kB]
Letöltés:12 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 Packages [562 kB]
Letöltve 1.256 kB 1mp alatt (977 kB/s)                     
Csomaglisták olvasása... Kész

Touch pad letiltása egyszerűen "egér és érintőpárna " menüben lett letiltva, de most kifejezetten a további próbálkozások miatt engedélyeztem.

Illesztőprogram kezelő most lefutott hiba nélkül, de üres az ablak, "nincsenek használatban zárt illesztőprogramok"

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#10 Valami javult tehát.

Akkor most jöhet a kernel kapcsoló próbája.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#10 Touch pad letiltása egyszerűen "egér és érintőpárna " menüben lett letiltva, de most kifejezetten a további próbálkozások miatt engedélyeztem.

Ha a tiltás nélkül újraindítod a rendszert, majd teszteled az altatásből ébresztést, mit tapasztalsz?
Egyelőre a kernel paraméter nélkül ...

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#12

Negatív. :-(

Sajnos semmi változás. Frissítette a wine-t.

Van mégegy változás. A korábbi lépésben mikor a wine-t újratelepítettem, azóta az az alól futtatott Win-es Firefox (csak az alá tudok egy plugint telepíteni) nem mutatja a biztonsági kamerák képét.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#13 Negatív. :-(

Akkor most jöhet a kernel kapcsoló próbája.
Rendszer újraindítással nyilván (a paraméter bejegyzés szerinti beállítása után).

És imádkozzunk ... https://www.youtube.com/watch?v=TGW3jeZCFcQ :-)

-----

Van még egy változás. A korábbi lépésben, mikor a wine-t újratelepítettem, azóta az az alól futtatott Win-es Firefox (csak az alá tudok egy plugint telepíteni) nem mutatja a biztonsági kamerák képét.

Ez már nem ide tartozik. Más téma, más bejegyzés.

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#14 Újraindítás után műxik a wine és a portforwardolt kamerák.

Ezt a kernelkapcsolást légyszives pontosítsd nekem, túl sok volt az információ egyszerre. Melyik az a módszer? ;-)

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#14

https://linuxmint.hu/blog/2018/02/kernel-forgatas-4152  ?

Nem szeretnék kernelforgatással bajlódni. Azt sem tudom melyiket hová, minek? Mi az érteleme?

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#14 Itt ilyeneket is találtam:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="

A két # -es sor nincs is a Mint 19 GRUB-jában.

A leírásokban szereplő parancs nem futtatható: gksu geany /etc/default/grub felajánlja a ksu-t de azzal sem.

user:~$ psmouse.synaptics_intertouch=1
psmouse.synaptics_intertouch=1: a parancs nem található

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#17 Ezt linkeltem korábban,

https://linuxmint.hu/blog/2018/03/kernel-kapcsolok-alkalmazasa-a-grub-fa...

és én itt nemcsak a gksu-s parancsot látom, hanem amit használhatsz is, az a "sudo nano..."-s.

A kommentelt, azaz megjegyzésbe tett sorokkal nem kell foglalkoznod ..., de az is le van írva a bejegyzésemben, hogy mi a lényeg ..., és mi a példa.

Azt mondom most is, akkor fogj az egésznek, ha megértetted a leírtakat. A kérdéseidböl viszont az látszik, vélhetöen, még elolvasni sem volt idöd a leírtakat ... . Akkor kezdesz neki az olvasásnak, amikor akarsz. A szabadidöd nem osztom be.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#17 Még valami: egyetlen leírást linkeltem (korábban is), nem többet.

 

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#19 Ok. engem elvitt a leírásba beágyazott link ami a kernel fordítást mutatta be. Most már értem.

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#21 Yesss! :-)

Sajnos az ébresztés továbbra sem működik. Azt viszont nem értem, hogy mit csináltam ezzel?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#22 A rendszer újraindítás is megvolt?

Meg tudnád mutatni a kimeneteket?

cat /proc/cmdline
grep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

A kernel különböző paraméterekkel beállítható az alapértelmezettől eltérő viselkedésre is.
Itt az összes paraméter: https://www.kernel.org/doc/html/latest/admin-guide/kernel-parameters.html

És nézzünk rá, most mi a helyzet. Kifejezésekre szűkített keresés (altatás utáni állapotnál futtasd):

dmesg | egrep -i 'psmouse | synaptics'

-----

A kernelnek paraméterei vannak, de régebben ezeket kapcsolónak hittem, olvastam. Az eredeti bejegyzés be lehet linkelve néhány weboldalon. Ha megváltoztatnám a címét, akkor nem találnák meg.

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#23 Igen, újraindítottam.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Off: WineHQ repository key

#24 Az látszik a képen, hogy a megfelelő helyen nincs meg a paraméter:

psmouse.synaptics_intertouch=1

... így azt nem is tudtuk tesztelni, jó-e, rossz-e. ;-)

Ok lehet, hogy

-- nem mentetted el megfelelően a nano szövegszerkesztőben a változtatást.
    A mentés, kilépés folyamata:

Ctrl + O, és Enter,
majd Ctrl + X

-- vagy nem volt meg a GRUB frissítés (ez egy parancssor)

sudo update-grub

Nem tudom, hol hibázhattál ...

 

Értékelés: 

0
Még nincs értékelve

Off: WineHQ repository key

#25 Az nem egyértelmű számomra, hogy ezt hogyan és hová írjam be. A dmesg szépen kiír egy listát, de azt hogyan tudom szerkeszteni? Abba a file-be kell egyáltalán beleírni, vagy a GRUB-ba? Ez a leírások alapján számomra úgy tűnik hogy abba, amit a dmesg-el kiíratok, de mi az a file? Hol találom?

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub

#26 Szövegesen tedd ide a kimenetet:

grep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

És azon megmutatom...

https://www.youtube.com/watch?v=WYhPoLONqZg

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#27 Itt a bejegyzés (ismét linkelem):
https://linuxmint.hu/blog/2018/03/kernel-kapcsolok-alkalmazasa-a-grub-fa...
Az alábbiakban a már kész, azaz a fentebb linkelt bejegyzésemből másolok!
Kivéve a rendszer újraindításának parancssorát, mert az változott a systemd-vel, de a bejegyzésben említett is használható, működik.
Mindezt azért teszem, mert neked és csakis neked ezt kell tenned a kernel paraméter alkalmazásához. Másnak mást ...

-----

  • Világosan le van írva, melyik a szerkesztendő fájl

A beállító (konfigurációs) fájl helye, azaz elérési útja:

/etc/default/grub

A módosításoknak csak akkor fogj hozzá, ha már megértetted a folyamatot.

-----

  • A biztonsági másolat készítése

-- biztonsági mentést készítesz az eredeti fájlról:

sudo cp /etc/default/grub /etc/default/grub.ORIG

-----

  • A szerkesztés

Mutatom a használatot a nano [...] szövegszerkesztő tekintetében,

sudo nano /etc/default/grub

-----

  • Nem ugyanazt látod ..., mert ez egy példa

-- valami ilyesmi szövegtömböt keress:
(a nano alkalmazásban a kurzor nyilakkal tudsz lépkedni a szövegben)

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX=""

... nem ugyanezt látod majd,
https://linuxmint.hu/blog/2017/10/a-grub-menu-lathatosaga
mert a fenti az én beállításom.

-----

  • Ezt a sort keresd (a paraméter is példa)

-- ebbe a sorba kell bemásolnod majd az i8042.kbdreset=1 kapcsolót:
(jelen esetben, mert ez egy példa:
https://linuxmint.hu/comment/17508#comment-17508)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

------

  • A sor nálad eredetileg így néz ki (begépeltem - képen nem mutatunk szöveges információt!)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=1"

... nem tudom, minek gépeltél be még két paramétert. Miért? Példa ... !

    Biztonsági másolat készült a szerkesztés előtt még?

-----

  • Így kell kinéznie a sornak (nálad, mert más, és más lehet a Linux rendszerek paraméterezése):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=1 psmouse.synaptics_intertouch=1"

A szóközök és a " -be zárás számít!

-----

  • Mentés ...

-- mented a változtatásokat, és kilépsz a nano szövegszerkesztőből,

Ctrl + O, és Enter
Ctrl + X

------

  • A rendszer beállítások frissítése ...

-- frissíted a rendszer beállításokat,

sudo update-grub

------

  • A rendszer újraindítása

... a változtatás a rendszer első újraindításakor lép érvénybe.

-- újraindítod a rendszert, például így.

sudo systemctl reboot

-----

  • Teszt
dmesg | egrep -i 'psmouse | synaptics'

A kimenet kell!

     Javaslatokat örömmel fogadok, hogy miképpen lehetnék még egyértelműbb! Bátran mondd az ötleteket.

Esetleg szívj el egy cigarettát,
https://www.youtube.com/watch?v=MMErtAtAtBY
vagy más bevált dolgot csinálj ..., ha nem megy a figyelem.
:-)

Értékelés: 

0
Még nincs értékelve

Ilyen GRUBom

Már benne van az i8042.kbd... rész:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_blacklight=vendor i8042.kbdreset=1"
GRUB_CMDLINE_LINUX=""

 

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#28 dmesg | egrep -i 'psmouse | synaptics' -re a válasz:

[    3.268197] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4648]
[    3.294224] psmouse serio1: synaptics: queried min coordinates: x [1278..], y [1206..]
[    3.294225] psmouse serio1: synaptics: Trying to set up SMBus access
[    3.296582] psmouse serio1: synaptics: SMbus companion is not ready yet
[    3.347373] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00323/0x840300/0x12e800/0x0, board id: 3014, fw id: 1832337
[    3.379069] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6

Most várok, hogy leálljon és tesztelem az ébresztést.

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Ilyen GRUBom | jah, ez elég nagy baj

#30 Jó .. elárulok egy titkot, azt, hogy neked ez a két paraméter biztosan nem kell:

acpi_blacklight=vendor
i8042.kbdreset=1

Ezek példaként lettek említve. A példa olyan dolog, ami szemléltetés célra van, azaz valaminek a bemutatásában, megismertetésében a feladat (ismétlem) szemléltetésére szolgál általában. A példát szolgaian, azaz szóról szóra nem kell követni.

Mondom, pihenj rá az egészre, ha nem megy. Tényleg. Elsőre nem mindenkinek megy. De az előző hozzászólásomban, remélem, legalábbis nagyon egyértelműen fogalmaztam ..., sokat segíthet, ha elolvasod.

Törölni kéne ... és a neked ajánlott harmadikat betenni.

Ez az:

psmouse.synaptics_intertouch=1

Nemrég írtam erről elég hosszan.

-----

#31 Most hiába tesztelsz, azt is megírtam nemrég, hogy miért.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Ilyen GRUBom | jah, ez elég nagy baj

#32 Ezt is kérdeztem, azaz, hogy van-e biztonsági mentésed.

A teszt:

file /etc/default/grub.ORIG

Mi a kimenet? Másold ide.
Mást ne csinálj.

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#31 Teszteltem. Sajnos nem ez volt a hiba. Most így néz ki a GRUB:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=1 psmouse.synaptics_interto$
GRUB_CMDLINE_LINUX=""

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#34 Hát a végét elvitte a cica?

    psmouse.synaptics_interto$

Mert ezt lenne a paraméter:

psmouse.synaptics_intertouch=1

Tedd nagyra a terminál ablakot. Az egyáltalán nem szükséges $ karakter talán a kis ablak miatt látszik.

És a sor végén a " is fontos!

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#35 Ott van minden, csak valóban a terminal ablak mérete miatt nem volt látható. Kitallóztam, megnyitottam, így néz ki:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=1 psmouse.synaptics_intertouch=1"
GRUB_CMDLINE_LINUX=""

Most még nehezebben nyílik újra, amikor megnyomom a bekapcs gombot (továbbra is igényli) nem engedi beírni a jelszót. Új protokoll: gép kikapcs/bekapcs.

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#36 Jónak tűnik a paraméterezés. Én „mára” kifáradtam, azt hiszem, lefekszem. :-)

Értem, tehát a korábbi jelszóval belépés sem működik ... . Vagyis jelszóval nem is enged belépni a rendszer? Mármint az altatás után nem enged, ugye? És a gép bekapcsolása után beenged?

Nézzünk azért kimenetet, változott-e valami.

dmesg | egrep -i 'psmouse | synaptics'

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#37 Köszönöm az eddigieket!

Pontosítok. Akkor 1x valamiért nem engedte. Ütöttem a billentyűket, de a jelszó mezőben nem szaporodtak a jelek. Nem engedett beleklikkelni sem. Most újraindítás után engedi. De tovbábbra sem éled fel.

dmesg | egrep -i 'psmouse | synaptics'
[    2.892880] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4648]
[    2.918823] psmouse serio1: synaptics: queried min coordinates: x [1278..], y [1206..]
[    2.918825] psmouse serio1: synaptics: Trying to set up SMBus access
[    2.921104] psmouse serio1: synaptics: SMbus companion is not ready yet
[    2.972644] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00323/0x840300/0x12e800/0x0, board id: 3014, fw id: 1832337
[    3.004526] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6
[  745.193229] psmouse serio1: Failed to disable mouse on isa0060/serio1
[  748.336675] psmouse serio1: Failed to deactivate mouse on isa0060/serio1
[  749.156675] psmouse serio1: Failed to enable mouse on isa0060/serio1

Várj csak! Itt azt nézem, hogy a touchpad-et és az egeret izgatjuk. (igaz egérre sem éled) Nekem tökéletesen megfelel(ne) ha a vezeték nélküli klaviatura vagy egér fel tudná éleszteni.

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#38 A

sudo update-grub

parancs is megvolt a grub fájl szerkesztése után, a rendszer újraindítás

sudo systemctl reboot

előtt?

Mi most a kimenet?

grep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

-----

Várj csak! Itt azt nézem, hogy a touchpad-et és az egeret izgatjuk. (igaz egérre sem éled) Nekem tökéletesen megfelel(ne) ha a vezeték nélküli klaviatura vagy egér fel tudná éleszteni.

A további lehetséges összefüggésekre rákeresek.

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#39 Igen. GRUBhoz nem nyúlok úgy hogy ne update-eljem, jártam már pórul. Ez a kimenet.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=1 psmouse.synaptics_intertouch=1"

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#40 Gyakorlatilag nem tudjuk a megoldást, vizsgálódni kell, mely javaslat

synaptics: SMbus companion is not ready yet

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1791427

https://bbs.archlinux.org/viewtopic.php?id=236367

lehet eredményes.

A BIOS-ban, az USB beállítások az energiagazdálkodás beállításai milyen lehetöségeket mutatnak? Létezö beállítás lehet az altatásra, hibernálásra vonatkozó beállítás. Ennek lehetöségei érdekesek, és a jelenlegi beállítás.

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#41

Kimarite!

Köszönöm az eddigi áldozatos segítségedet. Egyszer már visszatértem 18.3 vezióra más okok miatt, most tettem egy újabb kísérletet, az SMbus-ra még ránézek, de nagyon meglepett, hogy 1,5 év alatt a Mint 19 cinnamon még nem jutott el odáig, hogy hibernációból vissza tudna jönni. Semmi olyat nem szerettem volna, amit a 18.3 ne tudna, ezért valószínűsítem hogy nem a BIOS beállításokban van a hiba.

Összességében tetszett, de sajnos emiatt visszatérek a régi bevált rendszerhez.

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#42 Bocs hogy belevauzok, de "nagyon meglepett, hogy 1,5 év alatt a Mint 19 cinnamon még nem jutott el odáig, hogy hibernációból vissza tudna jönni." Pedig visszajön, most próbáltam ki. 19.2 Mint Cinnamon...Sok mindent nem is kellett tenni.

############# Hibernálás menü megjelenitése, laptopfedél beállitás
sudo tee /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla <<'EOB'
[Enable hibernate]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes
EOB
###############################################################################

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#42 most tettem egy újabb kísérletet, az SMbus-ra még ránézek

Ezen én is gondolkodom ... . Meg azon, hogy miképpen tudunk tesztelni.

nagyon meglepett, hogy 1,5 év alatt a Mint 19 cinnamon még nem jutott el odáig, hogy hibernációból vissza tudna jönni.

Nem a Linux Mint nem tudja a hibernációt, hanem a kernel nem tudja, s mindez mindegyik Linux terjesztés alatt jelentkezik. A hibernálás nehéz ügy a kernel tekintetében.
De most a hibernálásról beszélsz, korábban az altatásról (mindvégig). Most melyikkel van gond?
A kettő nem ugyanaz: https://www.fosslinux.com/184/what-is-difference-between-suspend-and-hib...
Ha hibernálsz, akkor kikapcsol a rendszer, azaz biztosan nem tudod felébreszteni a WiFi egérrel.
A hibernáláshoz ugyanannyi hely kell, mint amit a rendszered foglal.

Semmi olyat nem szerettem volna, amit a 18.3 ne tudna

Hát ez lehet az újabb kernel miatt, és más dolgok miatt is.
Mint látod, foltozás van, azaz patchek készültek a hasonló problémára más Linux terjesztések alá is.
De a te gondod valahol a Power Management környékén lehet. Hogy mikor kap áramot, azaz vezérlést a WiFi, azaz az egér.
Aggasztó az is, hogy a Synaptics driver ki- vagy bekapcsolva is hibaüzenetet dobál. Ez megint más történet.

Most kicsit nehéz három napom lesz, de körbenézek. :-)

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#44 "A hibernáláshoz ugyanannyi hely kell, mint amit a rendszered foglal."

Szerintem csak annyi, amennyi a memória-méret.

Értékelés: 

0
Még nincs értékelve
kimarite képe

wake up

#44 Nézzük a kimeneteket.

cat /proc/acpi/wakeup
grep . /sys/bus/usb/devices/*/power/wakeup
grep . /sys/bus/usb/devices/*/product
lsusb
ls /etc/udev/rules.d/

A kimenetek mindenképpen kellenek.
Használatban kell lennie az USB-s, WiFi-s egér vezérlőnek a parancssorok futtatásakor.

  • Az egyik megoldás, hogy a megfelelő vezérlő ébresztését engedélyezed.

Nem ezzel a megoldással, amit itt javasolnak,
https://askubuntu.com/questions/848698/wake-up-from-suspend-using-wirele...
hanem hasonlóan. Tehát a linken leírtakat NE csináld meg, csak a kimenetek kellenek (a fenti öt).
    Fontos, hogy mindig ugyanoda dugd a WiFi-s eszköz csatlakozóját, ugyanott használd!

  • A  másik megoldás  egy szabály létrehozása (ebbe ne kezd bele amúgy még)

-- szerkeszted a „10-wakeup.rules” fájlt, vagy, ha még nem létezik, létrehozod

sudo nano /etc/udev/rules.d/10-wakeup.rules

-- bele egy ehhez hasonló tartalom, melyhez az lsusb kimenet szolgáltat adatokat (ez egy példa, ne másold):

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="062a", ATTRS{idProduct}=="4101" RUN+="/bin/sh -c 'echo enabled > /sys/bus/usb/devices/usb8/power/wakeup'"

Forrás: https://askubuntu.com/questions/848698/wake-up-from-suspend-using-wirele...

Állítólag az Ubuntu 18.04 és a Linux Mint kiadásokon és az ennél újabb rendszereken a második megoldás működőképes.

(Most így kerestem a megoldásokra: https://duckduckgo.com/?q=usb+wifi+mouse+suspend+linux&t=ffsb&atb=v191-1... )

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#45 Legalább akkora hely kell (a sikeres hibernáláshoz), mint a memória (RAM) mérete.

A hibernáláshoz használható a wap partíció vagy a swap fájl:

What happens if you try to hibernate Linux but the swap partition is smaller than RAM?

Nothing. After the kernel checks the size of the partition (or file or multiple which may be set as swap space) it chooses the one large enough to fit all of the RAM, at least what’s already saved to swap as well as all RAM in use (including the kernel itself and all its tools and libs).

If there isn’t any large enough it errors and stops the operation. I.e. nothing occurs.

To ensure you can hibernate in most cases, make the swap partition the same size as RAM. That should catch all situations where the RAM is large enough for all the programs you run. It still won’t hibernate if you’ve loaded more programs / data than you actually have RAM and the swap is not large enough to hold all at once.

There are alternatives to a swap partition. You could set a file as a swap destination as well, similar to how Windows uses a page file. But the default is a partition as this tends to have better performance overall.

The kernel function being called is swsusp, short for “swap suspend”. If you want more info you could follow through on that documentation.

https://www.quora.com/What-happens-if-you-try-to-hibernate-Linux-but-the...

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#43 Pech.

Pech, hogy előtte nem próbáltam ki, hogy a laptop saját billentyűzetéről éled-e a 19.2. most nyitva maradt a laptop fedele és miután a vezeték nélküli klaviatura meg se nyikkant, kipróbáltam a sajátját. Na arról elindult.

Ez fél siker, de nem ez a cél. A lapotot lecsukott fedéllel, külső monitorral használom. Így azt kellene megoldani, hogy a vezeték nélküli billentyűzet vagy egér is ébressze, mert most minden alkalommal nyitnom kell (már erre is elindul).

Ebben is tudsz segíteni?

Értékelés: 

0
Még nincs értékelve

/etc/default/grub | magyarázat

#48 holnap usb egérrel megpróbálom, kis türelmet kérek, ma nagyon strapás nap volt.

Értékelés: 

0
Még nincs értékelve
kimarite képe

/etc/default/grub | magyarázat

#43 WiFi-s egérrel nem jön vissza. ;-)

Pech, hogy előtte nem próbáltam ki, hogy a laptop saját billentyűzetéről éled-e a 19.2. most nyitva maradt a laptop fedele és miután a vezeték nélküli klaviatura meg se nyikkant, kipróbáltam a sajátját. Na arról elindult.

Értékelés: 

0
Még nincs értékelve

Oldalak