AMD (volt ATI) eszközmeghajtó illesztőprogramok telepítése

kami911 képe

Telepítés az Illesztőprogram-kezelővel

Az AMD (ATI) videokártyák eszközmeghajtó illesztőprogramjai elérhetőek nyílt forráskódú és zárt forráskódú változatban is. Amennyiben a zárt forráskódú verzió használata mellet döntünk, akkor a legegyszerűbben azt az Illesztőprogram-kezelővel telepíthetjük, amellyel pár kattintással üzembe állíthatjuk a kívánt illesztőprogramot. A hátránya lehet ennek a megoldásnak, hogy nem feltétlenül a legújabb illesztőprogram települ így a számítógépre. Amennyiben a gyártó weboldalán van újabb verzió is, úgy onnan is beszerezhetjük és telepíthetjük az illesztőprogramot.

Illesztőprogram beszerzése az AMD-től

Az AMD többféle illesztőprogram-csomagot készít, függően a használt videokártya típusától.

Figyelmeztetés: A X sorozatú kártyák zárt illesztőprogramja nem támogatott a Linux Mint 13-asnál újabb verzióival. A Linux Mint újabb verzióinál a nyílt forráskódú eszközmeghajtó illesztőprogramot kell használni.

Illesztőprogram telepítése terminálból, csomagkészítéssel.

Figyelmeztetés: A videokártya illesztőprogram a rendszer fontos része. A nem megfelelő telepítés problémát okozhat a grafikus környezet működésében vagy akár a rendszer elindulását is meghiúsíthatják. Csak akkor telepítse kézzel a videokártya illesztőprogramot, ha ért a Linux rendszermaghoz, eszközmeghajtókhoz, dkms rendszerhez és tudja hogyan állítson helyre egy nem induló rendszert.

Az elérési utak a letöltött csomag vezióival változik. Tömörítsük ki a letöltött tömörített állományt:

unzip ./amd-catalyst-omega-14.12-linux-run-installers.zip -d amd1412

Futtassuk a illesztőprogram telepítőprogramját és kérdezzük le milyen csomagokat képes készíteni:

cd amd1412/fglrx-14.501.1003/
./amd-driver-installer-14.501.1003-x86.x86_64.run --listpkg

Ekkor a telepítő kilistázza az elkészítheő telepítő csomagokat:

=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
 List of generatable packages:
  Package Maintainer(s): Aric Cyr <aric.cyr@gmail.com>                     
  Mario Limonciello <superm1@gmail.com>
 Status: *UNVERIFIED* Debian Packages:
     Debian/sid
     Debian/unstable

[...]

     Ubuntu/precise
     Ubuntu/quantal
     Ubuntu/raring
     Ubuntu/saucy
     Ubuntu/source
     Ubuntu/trusty
     Ubuntu/utopic
  For example, to build a Debian Etch package, run the following:
 % ./amd-driver-installer-<version>-<architecture>.run --buildpkg Debian/etch

Linux Mint esetén az Ubuntu csomagokat válasszuk, azon belül is az adott Linux Mint verzió alapjául szolgáló Ubuntu verziót.

Linux Mint 17 sorozat esetén a megfelelő parancssor:

./amd-driver-installer-14.501.1003-x86.x86_64.run --buildpkg Ubuntu/trusty

Linux Mint 13 esetén a megfelelő parancssor:

./amd-driver-installer-14.501.1003-x86.x86_64.run --buildpkg Ubuntu/precise

A telepítő a csomagok létrehozása során bekéri majd a rendszergazda jelszót.

Az elkészült csomagokat a következő módon telepíthetjük:

sudo dpkg -i fglrx*.deb

Illesztőprogram telepítése grafikus módban

Figyelmeztetés: A videokártya illesztőprogram a rendszer fontos része. A nem megfelelő telepítés problémát okozhat a grafikus környezet működésében vagy akár a rendszer elindulását is meghiúsíthatják. Csak akkor telepítse kézzel a videokártya illesztőprogramot, ha ért a Linux rendszermaghoz, eszközmeghajtókhoz, dkms rendszerhez és tudja hogyan állítson helyre egy nem induló rendszert.