Legyilkolhatja a laptopokat az Ubuntu 17.10

keraform képe

Itt egy igen kellemetlen hír, (más forrásból), az Ubuntu 17.10 verzió felhasználóinak, és az azt használó kernel esetén több más disztrónak is.
Ezek a laptopok biztosan érintettek:

  • Acer Aspire E5-771G
  • Acer Aspire ES1-111M-C1LE
  • Acer TravelMate B113
  • Lenovo B40-70
  • Lenovo B50-70
  • Lenovo B50-80
  • Lenovo Flex-3
  • Lenovo Flex-10
  • Lenovo G40-30
  • Lenovo G50-70
  • Lenovo G50-80
  • Lenovo S20-30
  • Lenovo U31-70
  • Lenovo Y50-70
  • Lenovo Y70-70
  • Lenovo Yoga Thinkpad (20C0)
  • Lenovo Yoga 2 11" - 20332
  • Lenovo Z50-70
  • Lenovo Z51-70
  • Lenovo ideapad 100-15IBY
  • Toshiba Satellite S55T-B523
  • Toshiba Satellite L50-B-1R7
  • Toshiba Satellite S50
  • B-13GDell Inspiron 15-3531Mediacom
  • Smartbook 14 Ultra M-SB14UC

A fenti laptopokon kívül érintettek lehetnek még olyan készülékek, amelyek a Insyde Software által szállított BIOS-sal kerültek forgalomba (például: InsydeH20) . Az Insyde tud a hibáról, bár részleteket nem közölt.

Úgy tűnik a hiba forrása a kernel Intel SPI illesztőprogramja, amely az Ubuntu 17.10-ben a Linux 4.13 kernel. Ez a verzió meváltoztatja a fenti gépekben található BIOS-t, amivel különféle a hibák jelentkeznek:

  • Nem menthető beállítások,
  • USB/DVD indítási lehetőség megszünése.

Az Intel SPI kernel illesztőprogramja felelős a SPI sorosvonali flashmemória írásáért. Az SPI flash memória tartalmazza a BIOS és egyéb platform specifikus adatokat. Ezeknek a területeknek alapértelmezetten csak olvashatónak kellene lennie, de úgy tűnik a Canonical által szállított Ubuntu 17.10 verzió 4.13-as kernelénél ez a feltételezés nem igaz.

Az Ubuntut-t készítő Canonical, visszahívta a telepítőket és egy olyan verziót készít, amelyben a kernelben az Intel SPI illesztőprogramja le van tiltva. Gyártói kiadási megjegyzések. Kapcoslódó hibajegy a hiba leírásával, érintett eszközökről, lehetséges elkerülő megoldásokról: 1734147. A Lenovo fórumán található egy átmeneti javítás a bootmeghajtó hibához.

A Linux Mint felhasználók a hibában nem érintettek, mert az alapértelmezésként szállított Linux kernel 4.10 verzió ezt a hibás illesztőprogramot nem tartalmazza.

Hozzászólások

hm

Mielőtt még ezt hallottam volna kipróbálásra feltettem én is.Azóta nem megy a WIFI a laptopon és USB-n keresztül sem tud netet fogadni . Fujitsu Amilo Pro V3505 .(Új WIFI panel,új HDD friss Mint telepítéssel,de a hiba megmaradt) Javítható valahogy?

Értékelés: 

0
Még nincs értékelve
kimarite képe

egyelőre ismeretlen tipusú wifi + Linux Mint 18+

#2 „az Ubuntu 17.10 verzió felhasználóinak, és az azt használó kernel esetén több más disztrónak is.”

A kernelt kell megnézned, nem hiszem, hogy annyira új lenne a Linux Mint 18.3 alatt.
A következő parancsok mutatják:

inxi -F
uname -a
lsb_release -a

Nálad mik a kimenetek?

Persze, ha, nem ugyanaz a kernel, akkor a Wifi eszközt megnézed (-zük) az első parancsból (F = full) vagy a (PCI eszköz)

sudo lspci -nnkv

és/vagy az (USB eszköz)

lsusb

kimenetekből. Aztán rákeresel itt a fórumon a hasonló problémára ..., vagy nyitsz a kérdésnek témát (fórum).

Lehet, csak hardveresen van blokkolva az eszköz. Megmutatja ez a parancs:

rfkill list all

Az eszköznek csatlakoztatva kell lennie a parancsok futtatásakor (pl. ha nem beépített, akkor).

Értékelés: 

0
Még nincs értékelve

Hát nem tudom. Per pillanat

Hát nem tudom. Per pillanat ez a fő rendszer a Samsung laptopon. Kernel 4.13.0.21. Gyakorlatilag júliusban a daily build felkerült a gépre, azóta szinte hibátlanul teszi a dolgát, számomra eddig ez az XFCE disztro a legkevesebb problémát okozó, a legjobban kézre álló kiadás. A még szintén ezen  a gépen levő ubuntu 18.04,  Archmerge valamint nem is beszélve windows 10-ről, sokkal több 'törödést' kíván. Csak szerencsém van? Igaz, 'legacy' telepítés volt.

Értékelés: 

0
Még nincs értékelve