20.2-re frissítés

Fórum: 

Néhány perccel ezelőtt frissült a Frissítéskezelő. Azzal járt, hogy -> "Szerkesztés" - megjelent benne a 20.2-re történő frissítés lehetősége. https://ibb.co/st2q4Q7 Ma már nem, de holnap elindítom - miután csináltam egy friss rendszer-visszaállítási pontot.

kimarite képe

A fő tükörkiszolgáló > minden tároló

#46 Igazság szernt, én nem a leírtak szerint frissítettem a 20.1 kiadásról a 20.2 kiadásra, hanem egészen mást, mindössze ezt csináltam:

sudo apt-get update
sudo apt-get full-upgrade

Hibáztam volna?

Nálam ez van:

Nem sikerült letölteni minden tároló indexfájlját

Lehetséges, hogy a tároló már nem létezik vagy hálózati problémák miatt nem érhető el. Ha a le nem tölthető indexnek elérhető egy régebbi verziója, az kerül felhasználásra. Egyébként a tároló mellőzve lesz. Ellenőrizze a hálózati kapcsolatát és győződjön meg róla, hogy a tároló címe helyes.

És ez az előző után:

Hiba történt

A következő részletek ismertek:

E: Érvénytelen rekord a tulajdonságfájlban, nincs csomagfejléc
E: Nem tudom a listakönyvtárat zárolni

Hm, el is felejtettem kutatni az okot, a témát.

Most ez történt: Karbantartás, csomagtárolók frissítése után.

Elérhető a Frissítéskezelő újabb verziója

Frissítés alkalmazása (megnyomtam)

A csomag: 5.7.7 > 5.7.8

A korábbi két jelzés megmaradt, viszont - ellentétben a kiinduló állapottól - most megjelent jó pár frissíthető csomag. Telepítem ezeket...

A teleptés megvolt, a korábbi két jelzés megmaradt.

Itt nem látok problémát, de visszatérek a megoldás megfejtésére.

inxi -r
Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/cappelikan-ppa-focal.list
  1: deb http://ppa.launchpad.net/cappelikan/ppa/ubuntu focal main
  2: deb-src http://ppa.launchpad.net/cappelikan/ppa/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://ftp.energotel.sk/pub/linux/linuxmint-packages uma main upstream import backport
  2: deb http://tux.rainside.sk/ubuntu focal main restricted universe multiverse
  3: deb http://tux.rainside.sk/ubuntu focal-updates main restricted universe multiverse
  4: deb http://tux.rainside.sk/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fő tükörkiszolgáló

#49 zoli62 megjavult már?

A fő tükörgiszolgáló lekérdezése sikertelen, váltson egy közelebbi kiszolgálóra.  Eddig nem volt ilyen hiba.

Válts másik tükörkiszolgálóra! Ezt próbáltad, és mi történt?
Itt egy bug: https://github.com/linuxmint/mintupdate/issues/689

Nálam nem javul a helyzet, vélhetően elbújt valahova, valami Python fájlba a régi tükör vagy ilyesmi. Hibát nem találok a listában és a preferences fájlokban sem.

#47 zoli62 és atime mutatnátok szöveges tartalmakat,

cat /etc/apt/sources.list.d/official-package-repositories.list
cat /etc/apt/preferences.d/nosnap.pref
cat /etc/apt/preferences.d/official-package-repositories.pref
cat /etc/apt/preferences.d/official-extra-repositories.pref

és listákat?

ls -la /etc/apt/preferences.d/
ls -la /etc/apt/sources.list.d/

Köszi.

Terminálos frissítés megy, de a Frissítéskezelő a korábbiakat mondja, amikor megnyomom a Frissítés elemet. Most angolul írom (LANG=C mintupdate):

E: Invalid record in the preferences file, no Package header E: Unable to lock the list directory

mintupdate If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

A Panel menüből frissítéskor mindez nem jelentkezik.

A PPA-t

http://ppa.launchpad.net/cappelikan/ppa/ubuntu focal main

és a MainLine alkalmazást töröltem, a Frissítéskezelőben végigmentem az összes Karbantartás elemen, nem segített. A rendszerem a Linux Mint 20 beta verzió telepítéséből frissül.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fő tükörkiszolgáló

#52 Mmm, a forráslista kézzel történő átírása után is megmaradt a két hibaüzenet.
Az átírás (grafikusan megjelenik ugyanez):

#deb http://packages.linuxmint.com uma main upstream import backport
deb https://mirrors.nic.cz/linuxmint-packages uma main upstream import backport

#deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse

deb http://mirror.dkm.cz/ubuntu focal main restricted universe multiverse
deb http://mirror.dkm.cz/ubuntu focal-updates main restricted universe multiverse
deb http://mirror.dkm.cz/ubuntu focal-backports main restricted universe multiverse

#deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ focal partner

deb http://mirror.dkm.cz/ubuntu focal-security main restricted universe multiverse

A Partner tükör megjegyzésbe (komment) tétele sem segített. Vissza az egész.

Forrás: https://www.addictivetips.com/ubuntu-linux-tips/switch-to-a-local-update-mirror-in-linux-mint/

Várok, mert frissül a Frissítéskezelővel, de a hibaüzeneteket nem tudom mire vélni.
Az imént a terminál megnyitásának időpotjában jött frissítés (frissülne grafikusan is):

sudo apt-get upgrade
Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
Frissítés kiszámítása... Kész
Az alábbi csomagok frissítve lesznek:
  gdebi gdebi-core synaptic
3 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.
Letöltendő adatmennyiség: 762 kB.
A művelet után 4.353 kB lemezterület szabadul fel.
Folytatni akarja? [I/n]
...

Jah, a Synaptic csomagkezelő, köszöni, jól van, nincs hibaüzenet.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fő tükörkiszolgáló

#53 Telepítettem a 20.2 rendszert. Frissen. Már a kernel headers-t csomagolja kifelé, de hibát nem látok. A tükörkiszolgálókat állítottam át gyorsabbra, minössze ennyit tettem. Tökéletesen működik a Frissítéskezelő. A Live rendszeren is csak a CD ROM-mal problémázott, de ez érthető, ott még be van kapcsolva, mint telepítési forrás, azaz a képfájl (ISO) maga.

Megoldottnak tekintem ... https://vimeo.com/117106976

Értékelés: 

0
Még nincs értékelve

mintinstall 8.0.8 kell

Az angol oldalon azt olvastam, a mintinstall 8.0.8 -ban ezt javították, amit a napokban kiadtak, bár azt még nem találtam meg, hogy ez hogyan frissül, ha nem működik a frissítés

Értékelés: 

0
Még nincs értékelve
kimarite képe

mintinstall 8.0.8 kell

#55 A frissen telepített 20.2 kiadásban a mintinstall 8.0.8 van benne.
A csomag maga a Szoftverkezelő. Ennek hibájára nem gyanakodtam, de nem is biztos, hogy összefügg. Nem tudhatom ... . Megkaphatnám a linket, ahol erről írnak?

MintInstall

Az első futtatás a kiemelt jelenséget hozza,

mintinstall
MintInstall: Detected system architecture: 'x86_64'
Installer: Flatpak remotes have changed, forcing a new cache.
Installer: Generating new pkgcache
Installer: flatpak - metadata for remote 'flathub' has been updated. Comparing appstream timestamps...
Installer: flatpak - no new appstream data for remote 'flathub', skipping download
Installer: Processing Flatpaks for cache took 1902.793 ms
'NoneType' object has no attribute 'summary'
Installer: Processing APT packages for cache took 4107.876 ms
Full installer startup took 6676.173 ms
MintInstall: Cannot open reviews cache: [Errno 2] Nincs ilyen fájl vagy könyvtár: '/home/cinkim/.cache/mintinstall/reviews.json'
MintInstall: Deleting old screenshots
MintInstall: Downloaded new reviews
Installer: Generating new pkgcache
Installer: flatpak - metadata for remote 'flathub' has been updated. Comparing appstream timestamps...
Installer: flatpak - no new appstream data for remote 'flathub', skipping download
Installer: Processing Flatpaks for cache took 1628.538 ms
'NoneType' object has no attribute 'summary'
Installer: Processing APT packages for cache took 2665.491 ms
Installer: User pkgcache is most recent, using it.
Full installer startup took 20688.452 ms
MintInstall: Deleting old screenshots
MintInstall: No new reviews

A második futtatás ezen „továbblép”:

mintinstall
MintInstall: Detected system architecture: 'x86_64'
Installer: User pkgcache is most recent, using it.
MintInstall: Deleting old screenshots
MintInstall: No new reviews

Először egy fájl (reviews.json) hiányára panaszkodik, melyet érzésem szerint, az első futtatás hoz létre.
Másodszor közli, nincs újdonság (No new reviews), azaz, nem érhető el frissítés éppen.
A Cinnamon Spices és Flatpak frissítés bekapcsolva.

Frissítés

A terminálból lehetett nálam frissíteni, csak Frissítéskezelő adott hibaüzeneteket. Először nem frissített, azaz nem mutatott frissítést sem. Aztán a Karbantartás ..., de inkább szerintem az én „egyéni” parancssoraim hatására javult.

Javítás

Sok mindent kipróbáltam, de a javítás mindössze ennyi lehetett igazság szerint:

sudo apt-get update
sudo apt-get upgrade

... azaz, naprakészre frissítettem a rendszert terminálban. Ezután a Karbantartás Külső csomagok eltávolítása, valamint a Visszafejleszthető külső csomagok keresés már nem talált egy alkalmazást sem, míg a frissítés előtt igen, rengeteget. És a Frissítéskezelő telepítette az újabb változatát is talán, de mindenképpen frissítettem egyszer a Frissítéskezelő segítségével.

Azaz, a mintinstall is egészen biztosan a legfrissebb verzióra frissült.

Hiba

Csak a két üzenet maradt meg. Nem érdemes ezeket vizsgálni, hiszen 20 Beta telepítést frissítettem, és azt is említettem, nem a megszokott módon, nem a Frissítéskezelő segítségével frissítettem legutóbb, azaz a 20.2 kiadásra, hanem így (nagyjából):

sudo apt-get update
sudo apt-get full-upgrade

Nem a hivatalos megoldással. Valami összegubancolódott :D. Nem kutatok, és 10 perce töröltem a Beta telepítést is a Virtualbox képekből, tehát lehetőségem sincs kutatásra már. :)

Jelzések

Két fórumtársunk jelzése:
-- atime: neki Wifi okozott problémát, azaz „hardveres” a történet, nem volt térerő... .
-- zoli62: ha átállítja a tükröket, többet nem jelenik meg a válts közelebbi tükörre üzenet. Így tettem én is. Az üzenet megjelenése logikus, hiszen ki ne váltana gyorsabb tükrökre, ha erre lehetőség van grafikusan? ;)

Fájlok és könyvtárak

A korábban kért forráslista és a pref (preferences) fájlok tartalmát szemrevételezéssel összehasonlítottam. Nem volt nehéz, sokat nézegettem. Ugyanazok. Más lehetett a probléma.

Összegzés

Semmi gond a Linux Mint 20.2 kiadással, minden a lehető legjobb módon működik.
A Hibajelentő a Timeshift elindítására (használatának szükségességére) figyelmeztett, mást nem jelez. És a megnézhetőek a rendszer információk is, nemcsak az inxi-vel terminálban (inxi -Fzxxx), hanem grafikusan is.

Értékelés: 

0
Még nincs értékelve

mintinstall 8.0.8 kell

#56 Csak megjegyzem: Én is 20 (naprakész) Beta kiadásról frissítettem közvetlenül 20.2-re.
A Frissítéskezelőben felajánlott egérkattintgatós módszerrel.
A frissítés után semmi probléma nem jelentkezett.

Értékelés: 

0
Még nincs értékelve

A fő tükörkiszolgáló

#52 Nem tudom, aktuális-e még:

andrea@andrea-mint-xfce:~$ cat /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com uma main upstream import backport 

deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ focal partner
andrea@andrea-mint-xfce:~$ cat /etc/apt/preferences.d/nosnap.pref
# To prevent repository packages from triggering the installation of Snap,
# this file forbids snapd from being installed by APT.
# For more information: https://linuxmint-user-guide.readthedocs.io/en/latest/snap.html

Package: snapd
Pin: release a=*
Pin-Priority: -10
andrea@andrea-mint-xfce:~$ cat /etc/apt/preferences.d/official-package-repositories.pref
Package: *
Pin: origin live.linuxmint.com
Pin-Priority: 750

Package: *
Pin: release o=linuxmint,c=upstream
Pin-Priority: 700

Package: *
Pin: release o=LP-PPA-linuxmint-daily-build-team-daily-builds
Pin-Priority: 700
andrea@andrea-mint-xfce:~$ cat /etc/apt/preferences.d/official-extra-repositories.pref
Package: *
Pin: origin "build.linuxmint.com"
Pin-Priority: 700
andrea@andrea-mint-xfce:~$ 
 

A listákat is küldöm, ha szükséges.

Értékelés: 

0
Még nincs értékelve
kimarite képe

A fő tükörkiszolgáló

#58 Ugyanezek. Módosítottam az előző hozzászólásom, leírtam ezt is. Valami más lehetett a probléma mögött, a rossz frissítési módszerem szerintem, vagy a 20-as Beta kiadásból maradt valami, de szerintem, én hibáztam. Nincs értelme pontos okot kutatni, felesleges időt pazarolni, hiszen csak nálam történt meg mindez, és a történtekből nyilvánvaló, hogy másnál nem fog.
Nem kellenek már a könyvtár listázások, mert töröltem a Virtualbox képet, újat telepítettem. Mindez is benne az előző hozzászólásomban.
Maradj még a Linux Minten, mármint a bekapcsolt rendszeren ... stabil, jó, és még annyi kiváló tulajdonsága van. ;) :) Köszi a segítséget.

Értékelés: 

0
Még nincs értékelve

mintinstall 8.0.8 kell

#56 -- atime: neki Wifi okozott problémát, azaz „hardveres” a történet, nem volt térerő... .

Nem, nem teljesen, nem volt hálózat, hogy az történetesen WIFI sem, az mellékes.VIszont újraiindtás megoldotta. 

Értékelés: 

0
Még nincs értékelve
kimarite képe

Frissítéskezelő | felajánlott egérkattintgatós módszer

#57 Én is 20 (naprakész) Beta kiadásról frissítettem közvetlenül 20.2-re.
A Frissítéskezelőben felajánlott egérkattintgatós módszerrel.
A frissítés után semmi probléma nem jelentkezett
.

Én beiktattam a 20.1-es kiadást is, és nem a Frissítéskezelős, ajánlott módszerrel frissítettem a 20.2 kiadásra frissítéskor. Belekezdtem, de ... huhh. :), mindent leírtam már erről az egészről korábban itt.

Ezért írtam ezt: Nincs értelme pontos okot kutatni, felesleges időt pazarolni, hiszen csak nálam történt meg mindez, és a történtekből nyilvánvaló, hogy másnál nem fog.

Azt hittem, javítható, ezért kérdeztem. Lehetséges, igen, azonban nem éri meg ennyire belemélyedni.

Értékelés: 

0
Még nincs értékelve
kimarite képe

nézelődtem, a WIFI ment el. Újraindítás megoldotta.

#60 Én csak arra támaszkodhatok, amit a fórumtárs ír. Korábban ez volt leírva: ;)

Ez nálam is kijött, nem is értettem. Aztán nézelődtem a WIFI ment el. Újrainditás megoldotta.

Lényeg, egy rendszer újraindítás helyrehozta a jelenséget. :)

Értékelés: 

0
Még nincs értékelve

nézelődtem, a WIFI ment el. Újraindítás megoldotta.

#62 Bocs a pontatlan megfogalmazásért. Valóban, a lényeg a lényeg...

Értékelés: 

0
Még nincs értékelve

mintinstall 8.0.8 kell

#56 . . Megkaphatnám a linket, ahol erről írnak?

már becsuktam az oldalt, de megpróbálom újra megtalálni. talán ez: https://blog.linuxmint.com/?p=4111#comment-213877

de tuti hogy több helyen is ez a válasz különféle frissítéskezelős hibákra. (azaz, nem csak 1 helyen olvastam)

Értékelés: 

0
Még nincs értékelve
kimarite képe

mintinstall 8.0.8 kell | Frissítéskezelő != Szoftverkezelő

#64 Eddig rendben és köszi, csak apró probléma, hogy nem az általad említett

Software Manager (mintinstall) / Szoftverkezelővel,

hanem a Frissítéskezelővel volt mindig is (most) gondom (mintupdate). ;)

Én meg nem nyitok soha Szoftverkezelőt, szívbajt kapok rögtön. :)
Az általad linkelt válasz a Szoftverkezelős hibára javasolja. Mondom, a csomag telepítve volt, és úgy is jött két üzenet. Ennek megoldását ejtettem... (friss telepítés -> minden rendben)

Értékelés: 

0
Még nincs értékelve

A fő tükörkiszolgáló

#52 Most úgy tűnik, magától megjavult.

Értékelés: 

0
Még nincs értékelve

Egy apró észrevétel a telepítővel kapcsolatban

Tegnap a húgoméknál voltam, és többek között felraktam a gépre a Mint 20.2-t, a 19.3 helyére. A telepítőt Ventoy alól indítottam, és valami ilyent tapsztaltam:

A telepítő észlelte a Mint 19.3-at gépen (több rendszer van több HDD-n amúgy), és felajánlotta annak a "frissítését", figyelmeztetett, hogy minden adat törlődni fog, stb. (volt mentés, no para). Megnyomtam, hogy rendben, erre szokásos lépések után feltelepült (ezelatt nem voltam a gép előtt, mást csináltam), majd ujraindítás... GRUB ERROR, unknown filesystem, vagy mi (valami fájlrendszer problémája volt, az tuti).

No, Live rendszer indít, nézem mi van, hát csinált a HDD elejére egy 200 MB FAT32 partíciót, utána volt egy nagy Ext4 partició, meg a régi Swap partició. Tökre úgy nézett ki, hogy UEFI módban akar települni (nem UEFI-s a gép). Töröltem minden partíciót a cél HDD-ről, majd a telepítést újra elindítottam, "valami más" opcióval, bepipáltam formázza a teljes HDD-t, ekkor szépen feltelepült, és csak egy partició van a HDD-n. És működik, bár a GRUB menüből eltűnt pl. a Memtest, amit UEFI módú telepítésre jellemző.

Nem tudom, hogy a Ventoy miatt van ez, vagy egyéb oka lehet, nem volt sok időm tesztelni, és nem tudom mikor megyek újra, hogy tovább vizsgálódjak, a lényeg, hogy most rendben van a rendszer, csak leírtam mit tapasztaltam.

Értékelés: 

0
Még nincs értékelve

Egy apró észrevétel a telepítővel kapcsolatban

#68 A telepítők, már elég régóta 2 féle "üzemmódban" indíthatóak.
Ezek az üzemmódok a gép indítása után előcsalogatott boot-választóban választhatók ki.
(Nálam PC-n, Gigabyte-os alaplappal, az F12 bill. nyomogatására jön elő a boot-választó)
Ebben, maga a telepítő eszköz (pendrive) 2 választható opcióban jelenik meg.
- UEFI; előtaggal -> (UEFI-s gpt/EFI módú telepítéshez)
- Előtag nélkül -> (Legacy-s msdos/BIOS módú telepítéshez)

Ha nem választod ki az üzemmódot, akkor megjósolhatatlanul vagy az egyikkel vagy a
másikkal fog indulni. (Ilyenkor érheti az embert az általad felvázolt meglepetés.)

Értékelés: 

0
Még nincs értékelve

Egy apró észrevétel a telepítővel kapcsolatban

#69 Én már elég sokat telepítettem Linux Mint-et, de még ilyenszerű működést nem tapasztaltam (hogy választani lehet UEFI meg Legacy mód között), én tapasztalatom az, hogy ha UEFI módban van gép, akkor automatikusan UEFI móban települ, ha meg Legacy, akkor úgy. A kettő között annyi eltérést találtam eddig, hogy UEFI móban pl. nem települ a Memtest..

Avagy talán úgy érted, hogy a gép bootolási módjai közt választasz? A kérdéses gép nem tud ilyent, bár tucat féle boot eszközt lehet válszatani, azokank nincs köze az UEFI-hez (USB boot "eszközöket" lehet választani, mint USB Floppy,  Iomega, Zip drive, USB Hdd, meg hasonlók)

Most elöször használtam Ventoy-os indítást, ezért ezt inkább ennek tudom be. (ugyanezt az ISO-t használtam több esetben, virtuális gépen, meg fizikain, ott mindig a könyv szerint működött.)

Értékelés: 

0
Még nincs értékelve

Egy apró észrevétel a telepítővel kapcsolatban

#70 "(USB boot "eszközöket" lehet választani, mint USB Floppy, Iomega, Zip drive, USB Hdd, meg hasonlók)"
Ezek a beállítási lehetőségek általában a BIOS beállításaiban vannak - amely, vagy valamelyik
Fx (F1, F2, F10, F11, F12) vagy a Delete bill. nyomogatására jön elő a gép indítása után.
A Boot-válaasztó képernyő/ablak valamelyik másik F bill. nyomogatására jön elő.
És ebben lehet választani hogy milyen módban induljon a telepítő.
Nálam, a BIOS(UEFI) beállításokat a "Delete" hozza elő.
A boot-választót, pedig az F12
Ahány gyártó/alaplap ez változhat.

Értékelés: 

0
Még nincs értékelve

Oldalak